Jump to content

Kerbal Space Program 1.12: "On Final Approach" Grand Discussion Thread


UomoCapra
 Share

Recommended Posts

On 6/28/2021 at 1:58 PM, herbal space program said:

Like you, I can make the new wheels work OK in the update by changing settings, but unfortunately it seems they've greased up all the landing legs too! Here' s a screenshot of my  Duna ore mining ship, which was perfectly stationary on around a 9-degree slope before the update, cutting loose and starting to slide so fast I couldn't time warp to stop it or switch away:

kT1udIM.png

Of course unlike wheels, the legs don't have any handy physics adjustment sliders, so  I had to wait about 20 minutes for it to travel to a spot that was flat enough to bring it to a halt. Luckily there were no bumps or steeper spots to flip it over on that that little journey!  Anyway, I don't know how the KSP community at large feels about these slippery landing legs, but I don't personally think that level of traction is acceptable.

Check this video. @Emperoreddy @herbal space program @lemming1 @Anth12

I edited the value in the landing legs .cfg file.
My suggestion is to make friction control options available for landing legs too.


Also i made this bug report: https://bugs.kerbalspaceprogram.com/issues/28141

Edited by Marlus
Link to comment
Share on other sites

We ask if you could raise a bug report on the tracker with your issues. Provide as much info as you can, such as what landing legs? on what celestial body? You're not using any mods?
Attaching craft files and save files will also assist in speeding up the bug triage process much more than bug reports with just words or attached videos.
https://bugs.kerbalspaceprogram.com
The same goes for reporting any bugs. It has a much better chance of being triaged and fixed if it's raised on the bug tracker.
And I'm not saying it will get fixed, just that posting it in a forum post saying, such and such is not working has to then:-
a) be noticed by a staff member. If ever.
b) be then reproduced by a QA staff member if possible with the little info we can gather. This can take some time.
before it even gets into the usual triage and possible bug fix list.
 

Link to comment
Share on other sites

I get up to level 6 on the tech tree and want to get Advanced Electronics. I have plenty of science and Electronics in Level 5 is activated. I get the message "can not research Technologies over 100 science at this level." This was no problem in Kerbal 190, but has the tech tree changed for 112? Do I have to active all the tech in level 5 before I can get a tech on level 6? I have no mods installed

Link to comment
Share on other sites

41 minutes ago, Shiva said:

I get up to level 6 on the tech tree and want to get Advanced Electronics. I have plenty of science and Electronics in Level 5 is activated. I get the message "can not research Technologies over 100 science at this level." This was no problem in Kerbal 190, but has the tech tree changed for 112? Do I have to active all the tech in level 5 before I can get a tech on level 6? I have no mods installed

Upgrade your R&D building

Link to comment
Share on other sites

Thank you man. That will do it. I think the error text could have been a bit more specific.  Funny I never noticed that in all the years I have played KSP.  Had about a year break playing Stationeers, so am a bit rusty. Thanks again.

Link to comment
Share on other sites

8 hours ago, JPLRepo said:

We ask if you could raise a bug report on the tracker with your issues. Provide as much info as you can, such as what landing legs? on what celestial body? You're not using any mods?
Attaching craft files and save files will also assist in speeding up the bug triage process much more than bug reports with just words or attached videos.
https://bugs.kerbalspaceprogram.com
The same goes for reporting any bugs. It has a much better chance of being triaged and fixed if it's raised on the bug tracker.
And I'm not saying it will get fixed, just that posting it in a forum post saying, such and such is not working has to then:-
a) be noticed by a staff member. If ever.
b) be then reproduced by a QA staff member if possible with the little info we can gather. This can take some time.
before it even gets into the usual triage and possible bug fix list.
 

1) If you're so keen on everybody using your bug tracker instead of discussing the issues they're having in the forum, why have you erected an additional wall of authentication between us and that process?  Why must we work so hard for the privilege of beta testing your already-released game? Maybe you could bring up that question at a meeting some time. Besides, It's sad to say, but often the really knowledgeable people in this forum are faster and more reliable at fixing the problems we find than Squad is, as we have just seen.

2) For my part, I'm not even sure this is something you would define as a bug. Somebody in your outfit must have decided what the value of that static friction coefficient, which is apparently very easy to find and edit, should be.  They seem to have chosen a number that causes the legs to slide all over the place in situations where they did not before.  I personally am playing on a generic PC/Windows platform, through Steam, with no mods other than KER and your DLC installed. That and the fact that 3-4 others are reporting the same thing in the last few days tells me this is not some platform-specific weirdness. You guys changed a number that was fine before and apparently didn't thoroughly investigate the effects of that decision on gameplay.  Meanwhile, some resourceful person in this forum has already found the offending number, and has not only told us we can fix the problem by editing it, but has even shown us exactly how to do it with a video! Based on your "I'm not saying it will get fixed, even if you jump through all our hoops" response,  it seems pretty clear I'm much more likely to get my problem solved by talking about it here than I am by doing it your way.  This is in fact the second time in as many months that this has happened for me, the last being the unfulfillable repair contract bug.  Just something to think about!

3) The person who already fixed the problem for us in the post immediately above yours also said in that post that they made a formal bug report, for whatever that is worth.

Link to comment
Share on other sites

42 minutes ago, herbal space program said:

why have you erected an additional wall of authentication between us and that process? 

Because the bug tracker is not a part of the forum software. The developers make the game, not the forum nor the bug tracker system. That's like saying "Why do I need a whole separate account to log into a Microsoft account? I already have an Apple one!"

Link to comment
Share on other sites

4 minutes ago, Deddly said:

Because the bug tracker is not a part of the forum software. The developers make the game, not the forum nor the bug tracker system. That's like saying "Why do I need a whole separate account to log into a Microsoft account? I already have an Apple one!"

I actually think it's more like asking "why does a Microsoft game require people to have an Apple account to report its bugs?",  but I can see just from the fact that I am  getting "moderated" over this post that I might as well argue with the wind.

Link to comment
Share on other sites

1 minute ago, herbal space program said:

I actually think it's more like asking "why does a Microsoft game require people to have an Apple account to report its bugs?",  but I can see just from the fact that I am  getting "moderated" over this post that I might as well argue with the wind.

I can't see any indication that your post has been moderated, but if you have any concerns, please reach out to me in a PM and I'll look into it.

Link to comment
Share on other sites

39 minutes ago, Deddly said:

I can't see any indication that your post has been moderated, but if you have any concerns, please reach out to me in a PM and I'll look into it.

All I meant is that the first response to what I said above was for a forum moderator to come and tell me I asked a dumb question, when I really don't think it was, as Take Two owns both this forum and KSP. Anyway, this is not worth debating anymore, especially since I now know how to solve my problem.

Link to comment
Share on other sites

2 hours ago, herbal space program said:

1) If you're so keen on everybody using your bug tracker instead of discussing the issues they're having in the forum, why have you erected an additional wall of authentication between us and that process?  Why must we work so hard for the privilege of beta testing your already-released game? Maybe you could bring up that question at a meeting some time. Besides, It's sad to say, but often the really knowledgeable people in this forum are faster and more reliable at fixing the problems we find than Squad is, as we have just seen.

2) For my part, I'm not even sure this is something you would define as a bug. Somebody in your outfit must have decided what the value of that static friction coefficient, which is apparently very easy to find and edit, should be.  They seem to have chosen a number that causes the legs to slide all over the place in situations where they did not before.  I personally am playing on a generic PC/Windows platform, through Steam, with no mods other than KER and your DLC installed. That and the fact that 3-4 others are reporting the same thing in the last few days tells me this is not some platform-specific weirdness. You guys changed a number that was fine before and apparently didn't thoroughly investigate the effects of that decision on gameplay.  Meanwhile, some resourceful person in this forum has already found the offending number, and has not only told us we can fix the problem by editing it, but has even shown us exactly how to do it with a video! Based on your "I'm not saying it will get fixed, even if you jump through all our hoops" response,  it seems pretty clear I'm much more likely to get my problem solved by talking about it here than I am by doing it your way.  This is in fact the second time in as many months that this has happened for me, the last being the unfulfillable repair contract bug.  Just something to think about!

3) The person who already fixed the problem for us in the post immediately above yours also said in that post that they made a formal bug report, for whatever that is worth.

- Player(s) report bug(s) in forum

- KSP team member asks to put bugs into separate bug tracker with details

- Player(s) complain bug tracker is separate and are annoyed about how convoluted the process is (it is convoluted) 

- KSP form moderator brings up the process is convoluted/separate, and provides a disclaimer that reporting doesn't mean things will get fixed (as they aren't in control of that)

- Player(s) complain process should be made not convoluted to make it easier to report bugs/get things fixed

 

So the actual person that will fix the problem isn't the same person who moderates the form. Yea its both Take Two + KSP forum... but it's not a faceless organization that fixes the problem, it's a person somewhere that probably isn't skimming through the forms 24/7 to find bug reports as they could spend that time fixing the reports that already exist within the bug report system.

Yea the process is convoluted, that's undisputable, and lowering the bar of entry to report bugs would improve the process of getting bugs reported. But, I'll be willing to bet that bug tracker is overflow with entries and noise of all kinds anyways so lowering the bar of entry might make things even worse in terms of fixing anything, which no one wants. 

There are multiple ways to improve the process for everyone... but the person that could actually fix that process isn't involved anymore, and probably will never be involved at all here, because changing how bugs are handled isn't something one does at the end of a game lifecycle. The process is convoluted, but not by choice, give everyone a break on this one.

Link to comment
Share on other sites

This is the final push guys to get bugs fixed.

We will definitely get a 1.12.2, but will we get a 1.12.3? or a 1.12.4?

The developers come and tell us the available tools that can help fix KSP and then we abuse them?

The developers we see here aren't Squad, they work for Squad. Killing the messenger is pointless.

The final push...I have at least 20 bug reports since 1.12 came out. I don't know how many more we have before KSP is abandoned so I am going to report a lot more

Tell me what bugs you have in 1.12 in a private message and I will investigate them and report them. I have put aside 2 weeks just for reporting bugs

@JPLRepohas given us the available tools, he didn't create the tools

Link to comment
Share on other sites

THANKS YOU @SQUAD!

nEZHg9K.png

BEST UPDATE EVER!

 

Now if we could only get a fix to the rather annoying bug that randomly resets the fireworks colors to either default or black (as in invisible) when reverting crafts...

Edited by panzer1b
Link to comment
Share on other sites

In career mode do you need to upgrade a building or something to get the maneuver tool app? i have the alarm clock so i know my game updated but i don't have the little asterisk looking app to make maneuver nodes? Thanks.

Link to comment
Share on other sites

 

1 hour ago, JSlone said:

In career mode do you need to upgrade a building or something to get the maneuver tool app? i have the alarm clock so i know my game updated but i don't have the little asterisk looking app to make maneuver nodes? Thanks.

You need to upgrade Mission Control and the Tracking Station to some degree for it to show itself

Link to comment
Share on other sites

The maneuver creator app is not working in my current save.

 

Things I've tried:

- Ran the game without mods

- Reverted back to 1.11 then updating again to 1.12

- Maneuver seems to work on other saves except my current 

 

All of my mods are installed in CKAN if that helps. Has anyone else experienced this issue? Would really appreciate any help! Thanks in advance!

Link to image.

Edited by Already_Dead
Link to comment
Share on other sites

44 minutes ago, MinimalMinmus said:

For some reasons since the update it's almost impossible to turn using wheels on Minmus. Is it possible to restore the old wheel model, or at least to fix the new one, in some way?

Right click the wheel and disable the steering aid

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...