Jump to content
  • 0

Full SAS controls available on any probe core (even though it should only have stability assist) ONLY in career mode


Krydax
 Share

Question

As mentioned via title, I have full SAS controls available on any craft I've launched so far. I'm doing a modded JNSQ career with probes before crew and lots of various QOL and parts mods, but I can't really understand what might be causing this. When I googled/searched the issue, it sounds like it was an issue at some point in 1.11 but didn't really hear of any fixes or why it was happening so I'm not sure where to start.

Here's a pic from my current career playthrough. Stayputnik has full controls with SAS: (i also tried starting a brand new career with default settings, and it still had full sas controls)

https://imgur.com/a/QDt1IHq

Here's a pic from a NEW sandbox save. Stayputnik does NOT have full controls with SAS:

https://imgur.com/a/MHm5fRm

 

What on earth? Why would it have full SAS hax on career but not sandbox?


I'm happy to share log files but honestly not sure what site is easy to upload them to, like an imgur for txt files?

Edited by Krydax
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Yep. That fixed it. Making Less History mod created this issue. Unfortunate. I actually like the mod enough that I'll continue playing with it, and just use self control to choose not to use any SAS modes that shouldn't be available to me.

Link to comment
Share on other sites

  • 0
25 minutes ago, peridoot said:

whats your diffculity settings?

screen shot of your game data folder?

https://imgur.com/a/r5Nxjzq

 

Not sure how difficulty settings are relevant. The sandbox game i just left on default normal settings and the SAS control stuff worked correctly, but the career game left on default settings has all the sas options enabled. So the difficulty settings for both of those pictures were exactly the same.

Link to comment
Share on other sites

  • 0

hmmm looking at the gamedata i cant find a mod that will cause this to my knowldege

do any of the mods directly affect how probecores work?

what about tech nodes?

Link to comment
Share on other sites

  • 0
27 minutes ago, peridoot said:

hmmm looking at the gamedata i cant find a mod that will cause this to my knowldege

do any of the mods directly affect how probecores work?

what about tech nodes?

I'd have thought maybe so. But that still doesn't do any explaining on why sandbox DOESNT have the issue and Career does. If anything you think it would be the other way around. Unless somehow unlocking a tech node FIXES the problem, and that's what's happening in sandbox. And removing probes before core, which would be the most likely thing to mess with probes, didn't fix it.


I also cheated some science in, unlocked command pods, and lvl 1 Jeb is even giving all the SAS controls, so it's not just a probe core thing

Link to comment
Share on other sites

  • 0
5 hours ago, Krydax said:

I have full SAS controls available on any craft I've launched so far.

This has been a problem with KSP since version 1.11.   

The bug goes away if you buy and install Making History

but other than that, no-one has reported any solution (other than stubbornly refusing to use the SAS options that should not be there)

 

Link to comment
Share on other sites

  • 0
13 minutes ago, OHara said:

This has been a problem with KSP since version 1.11.   

The bug goes away if you buy and install Making History

but other than that, no-one has reported any solution (other than stubbornly refusing to use the SAS options that should not be there)

 

https://imgur.com/a/Pt6ZhTJ

I got news for ya.... I already have it. Do you think, then, it could be the "making less history" mod? I really like that mod... It saves me loadtime and ram. But it disables some elements of making history and maybe that's why I'm seeing this bug? I'll test it out and get back to you.

Link to comment
Share on other sites

  • 0

Yes, as mentioned, this appeared to be a bug that was exclusive to 1.11 without DLCs.

I installed both DLCs (it was a good nudge to get them, I suppose), and this immediately rectified the issue. Whether it was the Breaking Ground or Making History DLC that fixed the issue (Or either. Or both) I don't know.

I do not use any mods at all, so cannot confirm whether your issue would be resolved if you removed the 'making less history' mod; but I'd suggest that would be a good place to start.

Edited by Chequers
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...