Jump to content
  • 0

Black instead of loading screen under linux (steam)


WebFerretNL
 Share

Question

I have recently performed a clean install of pop_os 21.04, and with that a clean installation of ksp. Since the last time I ran it, it updated to 1.12. I saw someone with the same problem on protondb, but I haven't seen a solution.

The problem in more detail: When I launch ksp through steam on a clean ksp install, it gives me a screen of black for a few seconds, then quits. Launching it again (and all subsequent launches), it gives me a black screen, but doesn't quit, it only quits when I give it the command to force-quit. However, when I try to launch it from the file manager itself, it launches without problem.

I have tried a plethora of (old) fixes from the web, but none worked, and I'm kinda at my wits end. (this is literally the first time I've had to made a forum post about a bug)

Thanks for your help in advance.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I had a similar issue with KSP v1.12.3 on Ubuntu 20.04.

The solution for me was to go the the "Additional Drivers" tool in Ubuntu and set the Nvidia graphics driver to "nvidia-driver-390 (proprietary)".  Note: the most recent proprietary driver didn't work.

Link to comment
Share on other sites

  • 0
7 hours ago, poopslayer78 said:

The solution for me was to go the the "Additional Drivers" tool in Ubuntu and set the Nvidia graphics driver to "nvidia-driver-390 (proprietary)".  Note: the most recent proprietary driver didn't work.

I have no such issues and I'm using the latest, "metapackage from nvidia-driver-510 (proprietary, tested)" .

Using a GTX-960 if there's any difference.

Link to comment
Share on other sites

  • 0
On 3/3/2022 at 5:50 AM, poopslayer78 said:

The solution for me was to go the the "Additional Drivers" tool in Ubuntu and set the Nvidia graphics driver to "nvidia-driver-390 (proprietary)".  Note: the most recent proprietary driver didn't work.

Have the problem too, do you know how to set a nvidia propritary driver that works (please)?

Link to comment
Share on other sites

  • 0
26 minutes ago, Nazalassa said:

do you know how to set a nvidia propritary driver that works (please)?

This is how you enable the proprietary Nvidia drivers in ubuntu 20.04:

  1. Search for "Software and Updates" tool or run "software-properties-gtk" from the command line
  2. In the "Ubuntu Software" tab, make sure that the "restricted" and "multiverse" boxes are checked (note: you may not actually need "multiverse", since the "nvidia-driver-390" package is part of "restricted").
  3. Run sudo apt-get -y update
  4. Close & re-open the "Software and Updates" tool
  5. Click on the "Additional Drivers" tab if it's not open already
  6. Select the desired driver.  For me nvidia-driver-390 worked while neither nouveau nor nvidia-driver-510 worked.
  7. If you still don't see nvidia-drover-390 as an option, try "sudo apt-get -y install nvidia-driver-390".  The proprietary drivers were always visible for me so I never needed to do this step manually.

jsUXIgK.png

Note: some other Ubuntu users have reported being able to use nvidia-driver-510 without issue, but it didn't work for me.

I'm using an Nvidia Geforce GTX 970 if that helps.

Link to comment
Share on other sites

  • 0
35 minutes ago, poopslayer78 said:

This is how you enable the proprietary Nvidia drivers in ubuntu 20.04:

  1. Search for "Software and Updates" tool or run "software-properties-gtk" from the command line
  2. In the "Ubuntu Software" tab, make sure that the "restricted" and "multiverse" boxes are checked (note: you may not actually need "multiverse", since the "nvidia-driver-390" package is part of "restricted").
  3. Run sudo apt-get -y update
  4. Close & re-open the "Software and Updates" tool
  5. Click on the "Additional Drivers" tab if it's not open already
  6. Select the desired driver.  For me nvidia-driver-390 worked while neither nouveau nor nvidia-driver-510 worked.
  7. If you still don't see nvidia-drover-390 as an option, try "sudo apt-get -y install nvidia-driver-390".  The proprietary drivers were always visible for me so I never needed to do this step manually.

jsUXIgK.png

Note: some other Ubuntu users have reported being able to use nvidia-driver-510 without issue, but it didn't work for me.

I'm using an Nvidia Geforce GTX 970 if that helps.

Does it work with nvidia 340-GeForce 8800?

Link to comment
Share on other sites

  • 0
1 hour ago, poopslayer78 said:

Note: some other Ubuntu users have reported being able to use nvidia-driver-510 without issue, but it didn't work for me.

I'm using an Nvidia Geforce GTX 970 if that helps.

Yeah, me for one.

I'm using 510  on 20.04 LTS with a GTX 960

Maybe OpenGL/Mesa is messing things up?

 

Link to comment
Share on other sites

  • 0
On 7/16/2021 at 2:02 PM, WebFerretNL said:

I have recently performed a clean install of pop_os 21.04, and with that a clean installation of ksp. Since the last time I ran it, it updated to 1.12. I saw someone with the same problem on protondb, but I haven't seen a solution.

Since you specifically mention protondb, I'm wondering.  Are you using the Linux version of KSP, or did you install the Windows version by forcing a compatibility layer?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...