Jump to content
  • 0

SAS seems to be non existent or broken since last update.


tiriss
 Share

Question

For about a month or more, I'm finding a lot of my rockets nearly un-flyable even though the pilots are level 2 or higher.  Even though they have SAS engaged, there is Constant Roll.... I've tried adding reaction wheels, level 3 pilots, using flight trim with Alt+Q/E to no avail.  SAS simply doesn't seem to work on ships I've been flying for 6 months in real time and years in Kerbal time.

Suddenly, I now have no functioning SAS when attempting to dock or maneuver.  I'm either rolling or it won't even hold a direction like prograde.
Is there something in the 10th anniversary patch/update that broke it?
 

I've checked reddit for Kerbal Space Academy and see no relevant information.  I'm Aithiopis there.

Edited by tiriss
additional reddit information
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I feel so stupid!!!!!!!!!!!!!!!!!!!!!  This is NOT a bug.  This is USER ERROR!  If you want to read the details I'll list them, but the bottom line is check your joystick and other controllers for proper calibration!

So a month ago when they opened up all the DLC for free for the 10th anniversary (I already had bought them), I also got some mission to fly an airplane and I think do some temp measurements around Kerbin.  After having difficulty (probably bad design, I don't have a lot of airplane tech) getting into flight using mouse and keyboard, I found a USB Joystick Attack 3 and boom wonder of wonders, I could fly pretty well with it.  It kept rolling it but I trimmed the issue out of existence for flying that particular plane.

The problem is, I never calibrated the joystick.  So from then on, every rocket I had made, and every ship in orbit, and every satellite from then on had a constant roll.  I tried to trim the issue thinking it was problem with the patch, it was NOT, it was the joystick.  When I launched a new satellite... on the launching pad SAS was suddenly in constant circular arrow icon rather than stable SAS icon, I began to realize I've got something giving input when I haven't touched a key on the launch pad!  Calibrated my joystick and the game is now back to the SAS you expect.  Point in a direction and it will stabilize using whatever reaction wheels and pilots or probes on board.

Sorry I raised the alarm but the bizarre coincidence led me to, and now I'll just unplug the joystick until I have another plane mission again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...