Jump to content

[1.8 - 1.12] KSPCommunityFixes - Bugfixes and QoL tweaks


Gotmachine
 Share

Recommended Posts

1 hour ago, BronzeShoe20968 said:

and now i dont have a wepon manager

missing BDARMORY tab after i dowload breaking ground now!

and now i dont have a wepon manager

missing BDARMORY tab after i dowload breaking ground now!

You have incompatible or incorrectly installed mods.  You'd need to post your log file somewhere for someone to diagnose it, or just use CKAN and don't install things for old versions.

Link to comment
Share on other sites

  • 2 weeks later...

@Gotmachine @NathanKell

QoL-Proposal: Offer an option to make the target time of the "skip to next morning"-button of Stock KSP adjustable. Reason: the most beautiful lighting happens way earlier than the button timecode targets. For me it's the sunrise (using Spectra & Scatterer). I think, the option to adjust the target time of the button would be a nice qol-feature for many people using visual mods for beautiful atmospherics effects. The stock skip to next morning button currently switches to a time at almost noon, lightingwise. Meeeeh... adustable would be perfect.

E.g. here:

IFRCalA.png

10 hours ago, jebycheek said:

OMG. my whole base just launching into the sky and fell down to pieces again during gamestart, do we have a fix for that? I heard it's a common problem.

Had this yesterday with one of my superheavy ore-transporters. It now krakenizes right on the launchpad reproduceable upon loading on the launchpad, which it did not, when I designed it - (1.11 before  KSPCF.... maybe some little tiny imperfection in the loading-kraken-fix

Edited by Rakete
Link to comment
Share on other sites

Addendum:

Here an examplecraft of a launchpad-Kraken. It desintegrates right after loading. Back in the day, when it was designed (To take Ore as a "universal fuel" ressource to a big refuelerstation) it did not explode on launchpad - back in the day somewhere along 1.11 and the release of KSP 1.12... where KSPCF wasn't a thing... So maybe the launchpad krakenfix of KSPCF has downsides too... This is for debugging/improvement for you, if you wish.

 

This craft is pure stock and comes from a pure stock playthrough (except waterfall then) and will be available for 7 days from now on:

https://www.filemail.com/d/nkrpjscnwdpxbnh

Edited by Rakete
Link to comment
Share on other sites

What are those (unlocked by StrategyDuration) numbers worth? Like

    minLeastDuration = 600
    maxLeastDuration = 600
    minLongestDuration = 1200
    maxLongestDuration = 1600

Are those minutes or something? I just tried it with a strategy (JNSQ's "Local Science") and the strategy was done after the blink of an eye while KCT timewarping to a few days later.

Edited by Gordon Dry
Link to comment
Share on other sites

Does KSPCF make any changes that would prevent me from being able to attach struts from a payload to the inside of a stock fairing in the editor?  (fairing expansion disabled). I've always been able to do this but now cannot.  Probably a glitch peculiar to this craft, but thought I'd check

Link to comment
Share on other sites

So with my heavy modded KSP install 1.12.3 I have noticed some thing.

I only seem to get a CTD if I by mistake prematurely tap or click a button while I am doing a scene transition. I am sure I read this somewhere else also.

I was wondering if you could implement a lock key state on scene transition I think this would also help a lot of others out who get to keen on tapping keys and dont realise that most of the crashes are being to eager to move the camera in the editor or dont give the scene enough time to load.

I mostly mean a key lock while the screen is black thats when I seem to notice it will crash if you hit keys to early.

 

Thanks :)

Link to comment
Share on other sites

I have a minor bug report that might be fixable. It has annoyed me a few times while e.g. building submarines that need a lot of ore in them:

When copying a fuel tank with alt-click, the fuel flow enabled button is reset to on, no matter what state it was in previously. ,

would that be fixable with mods?

Link to comment
Share on other sites

Hi.

Before 1.11.1 Kerbals would swim at a fixed height and  you could increase or decrease their weight to sink or make them neutrally buoyant, through a mod I made.

From 1.11.1 onward they follow the ground surface underneath and so if the ground slopes down then they swim down following it.

Do you think this is something that could be fixed?

Link to comment
Share on other sites

On 10/22/2022 at 11:25 PM, Rakete said:

QoL-Proposal: Offer an option to make the target time of the "skip to next morning"-button of Stock KSP adjustable.

Good idea. I don't have the time or motivation to implement this, but suggestions are welcome nevertheless :)

On 10/23/2022 at 3:43 PM, Rakete said:

Back in the day, when it was designed (To take Ore as a "universal fuel" ressource to a big refuelerstation) it did not explode on launchpad - back in the day somewhere along 1.11 and the release of KSP 1.12... where KSPCF wasn't a thing... So maybe the launchpad krakenfix of KSPCF has downsides too... This is for debugging/improvement for you, if you wish.

Well, don't have much time either. The few "kraken fighting" patches in KSPCF are far from a definitive or reliable fix. KSP will forever stay prone to such events, and there might be indeed corner cases where KSPCF is doing more harm than good.
This being said, if you can reliably reproduce a case where the same craft has issues when the PartStartStability patch is enabled, and is working fine when the patch is disabled, please provide the craft or save file.

On 11/1/2022 at 4:39 PM, stk2008 said:

I only seem to get a CTD if I by mistake prematurely tap or click a button while I am doing a scene transition.

Please try to reproduce this in a stock install. There is a large probability this is caused by a mod. And if you manage to reproduce it, please provide your Player.log file (see https://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/)

On 11/4/2022 at 1:05 PM, HB Stratos said:

When copying a fuel tank with alt-click, the fuel flow enabled button is reset to on, no matter what state it was in previously. ,

would that be fixable with mods?

It is fixable with a mod, but it would be a behavior change that has a significant chance to affect other mods in unexpected ways, so KSPCF isn't the right place for that.

1 hour ago, ColdJ said:

Before 1.11.1 Kerbals would swim at a fixed height and  you could increase or decrease their weight to sink or make them neutrally buoyant, through a mod I made.

From 1.11.1 onward they follow the ground surface underneath and so if the ground slopes down then they swim down following it.

Same response. KSPCF doesn't change stock behavior like this one to avoid messing with what other mods are expecting. This is something that you can and should handle from your own mod.

Link to comment
Share on other sites

1 hour ago, Gotmachine said:

Same response. KSPCF doesn't change stock behavior like this one to avoid messing with what other mods are expecting. This is something that you can and should handle from your own mod.

I don't make mods that add .dll  , Everything I do is designed to be used on a stock system.

Anyhow, got my answer. Can't be done.

Thank you.

Link to comment
Share on other sites

On 11/5/2022 at 3:00 PM, ColdJ said:

increase or decrease their weight

So you gave them snacks or put them on a diet? Poor Jeb. :D

 

On 11/5/2022 at 4:18 PM, Gotmachine said:

This being said, if you can reliably reproduce a case where the same craft has issues when the PartStartStability patch is enabled, and is working fine when the patch is disabled, please provide the craft or save file.

The craft linked down here for download reliably desintegrates on launchpad with stabilityfix engaged. You can download it from there. Please tell me, if you can't, then I will upload it again, as the filehoster is free of charge but hosts files only for a limited amount of time.

https://www.filemail.com/d/lywpqmojfmbmbtt

Edited by Rakete
Link to comment
Share on other sites

  • 2 weeks later...

@Gotmachine

I found a pretty severe bug with robotic drift fix. It resets the angle of locked robotic parts after a scene reload. 

How to reproduce: 

1. Put a robotic part on a vessel and launch it. 
2. Change the angle of the robotic part and then lock it. 
3. Reload the scene.

The angle of the locked robotic part will reset to its original position, but the part that's attached to the robotic part will not move with it, completely offsetting the hierarchy. Disabling the RoboticsDrift patch removes the issue. 

Game version: 1.10.1
Video of the bug: https://youtu.be/hBmhoqfY0K0
KSP.log: https://drive.google.com/file/d/1HR90rLVDlift4dV74Foz9e7lAXjSKuyf
Player.log: https://drive.google.com/file/d/1iGZ6bMPreWflWVdm4FL8Or7CV87HNjgJ

 

Link to comment
Share on other sites

Please could some one help

I have been getting this error started yesterday and I cant figure out whats causing it but I am pretty sure what ever adds this

TCfyvyH.jpeg

has caused the log spam or

[LOG 00:25:32.802] [PartSet]: Failed to add Resource -929029996 to Simulation PartSet:63 as corresponding Part Mk0 Liquid Fuel Fuselage-765077360 SimulationResource was not found.

here is my log reports :)

https://oshi.at/CksJ/KSPBugReport_2022-11-15_003203.zip

thanks in advance

 

adding things to stock tanks also gives me this error

lCMmLMQ.jpeg

i can add the fuel fine though but clicking the green F after is this normal?

 

Edited by stk2008
Link to comment
Share on other sites

8 hours ago, dok_377 said:

The angle of the locked robotic part will reset to its original position, but the part that's attached to the robotic part will not move with it, completely offsetting the hierarchy. Disabling the RoboticsDrift patch removes the issue. 

Game version: 1.10.1

Thanks for the report.
I managed to reproduce this on KSP 1.10, but not on 1.12, so this is caused by some differences in the stock robotic code between those versions.
The RoboticsDrift patch is developed against KSP 1.12, I have a few other robotics related issue reports lying around, and I suspect at least some of them are caused by minor differences between KSP versions.

I don't really have time (nor willingness) to investigate and fix such version-specific issues, so I will just disallow the patch to run on KSP versions prior to 1.12.

8 hours ago, stk2008 said:

I have been getting this error started yesterday and I cant figure out whats causing it but I am pretty sure what ever adds this

The error you're getting is indeed caused by some mod uncorrectly managing resources, so "whatever adds this" is indeed the likely culprit.
I would suggest finding which mod it is and asking on the forum thread for this mod, or to post in the "Technical Support (PC, modded installs)" forum, this has nothing to do with KSPCommunityFixes.

Link to comment
Share on other sites

3 hours ago, Gotmachine said:

I don't really have time (nor willingness) to investigate and fix such version-specific issues, so I will just disallow the patch to run on KSP versions prior to 1.12.

Well, great. :(

I'm not playing on newest versions for a reason. This is the reason:
6CZ0exe.jpg

It's not my computer, it's KSP being a piece of trash. :/

Edited by dok_377
Link to comment
Share on other sites

30 minutes ago, dok_377 said:

Well, great. :(

I'm not playing on newest versions for a reason. This is the reason:
6CZ0exe.jpg

It's not my computer, it's KSP being a piece of trash. :/

Is KSP Community Fixes installed in both of these cases?  Try turning on the CommNetThrottling patch, which is disabled by default.

Link to comment
Share on other sites

Just now, JonnyOThan said:

Er, what I was getting at is that KSPCF *fixes* a lot of the bad performance issues.

Yeah, I misinterpreted the message, sorry. Well, as I understand it, the throttling is supposed to help with save files that have a lot of active flights in them. This is not the case here. I exclusively created new save files in each version with only one vehicle (the one on the screenshot) to see the performance difference. KSPCF does a lot of nice stuff for the game, but I don't think it can save this particular case. 

Link to comment
Share on other sites

7 minutes ago, dok_377 said:

Yeah, I misinterpreted the message, sorry. Well, as I understand it, the throttling is supposed to help with save files that have a lot of active flights in them. This is not the case here. I exclusively created new save files in each version with only one vehicle (the one on the screenshot) to see the performance difference. KSPCF does a lot of nice stuff for the game, but I don't think it can save this particular case. 

You'd be surprised.  The other big performance issue is the progression system.  I don't know *when* these issues were introduced, but if they were sometime between 1.10 and 1.12 then that would explain it AND it would be fixed with KSPCF.

In any case it would be a great data point if you're willing to do the test.  If KSPCF doesn't make the two versions run the same speed, then there's some big optimization target we're missing and we can dig in further to see what the differences are.

Link to comment
Share on other sites

23 minutes ago, JonnyOThan said:

You'd be surprised.  The other big performance issue is the progression system.  I don't know *when* these issues were introduced, but if they were sometime between 1.10 and 1.12 then that would explain it AND it would be fixed with KSPCF.

In any case it would be a great data point if you're willing to do the test.  If KSPCF doesn't make the two versions run the same speed, then there's some big optimization target we're missing and we can dig in further to see what the differences are.

No luck. Just loaded the same craft file with the latest version of the game and KSPCF. It practically has the same performance as before. 

Link to comment
Share on other sites

3 minutes ago, JonnyOThan said:

Mind sharing the craft file?

Sure: https://drive.google.com/file/d/1cOWFf51z2MuGoLZ3ZKtDLslhdYZUVeKp

I'm pretty convinced it's not the craft file, as I have created this one from scratch specifically for this occasion. And I also checked my old save file with a bit of progress in it, it has the same performance problems. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...