Jump to content
  • 0

Modifying "scienceMultiplier" in mobile processing lab doesn't seem to work in 1.12



Hi everyone,

A couple years back, I posted this thread asking how to reduce the data to science conversion in the mobile processing lab. I got a great reply by @4x4cheesecake which worked perfectly on whatever version I was running at the time (~1.6?). Several years later, I've reinstalled KSP and attempted to carry out the same fix but can't seem to modify the conversion rate to anything other than 1 data > 5 science. 

Here's the relevant part of my current LargeCrewedLab.cfg (relevant line in bold)


        name = ModuleScienceConverter
        dataProcessingMultiplier = 0.5 // Multiplier to data processing rate and therefore science rate
        scientistBonus = 0.25    //Bonus per scientist star - need at least one! So 0.25x - 2.5x 
        researchTime = 7        //Larger = slower.  Exponential!
        scienceMultiplier = 1.5    //How much science does data turn into?
        scienceCap = 500        //How much science can we store before having to transmit?        
        powerRequirement = 5    //EC/Sec to research
        ConverterName = #autoLOC_502055 //#autoLOC_502055 = Research
        StartActionName = #autoLOC_502056 //#autoLOC_502056 = Start Research
        StopActionName = #autoLOC_502057 //#autoLOC_502057 = Stop Research

I suspect I'm probably just doing something really boneheaded like accidentally editing the file to a different modded install or similar, but after at least an hour of troubleshooting I haven't had any luck. Thought I'd ask on here to make sure there  wasn't some change between versions that make this step no longer work!


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

It should actually still work the same way as before. I did a quick test and it still works for me using either of both methods I've suggested the last time (direct file editing or Module Manager patch).

We might need some more insight here...

First of all: do you try to edit the file directly or do you use a MM patch?
If you try to use a MM patch, do you actually have MM installed?
Which value do you try to set?
And since you brought it up: You are really 100% sure edit the right file of the right game install? ;)

Link to comment
Share on other sites

  • 0

Solved! It appears that the scienceMultiplier value needs to be a whole integer. I tried it at 1, 1.5, and 2, and 1 and 2 worked fine while 1.5 reverted to the 5x amount. Would have done additional testing, but given that my KSP takes about 5 minutes to boot up after every file change, I decided to call it a day early! I wonder if there's something coded in to ensure only whole numbers of science get created. In any case, the problem seems to be solved for me for the time being. Thanks!

Link to comment
Share on other sites

  • 0
1 hour ago, GP_LeChuck said:

I wonder if there's something coded in to ensure only whole numbers of science get created.

Well, kinda...

If you look into the api documentation for the "ModuleScienceConverter" and check out the "Public Attributes", you will find the default scienceMultiplier value but also it's type, which is an integer in this case.


So when you try to use anything else than an integer, it will fall back to the default value.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...