Jump to content

[KSP 1.8+] Kerbal Konstructs (Continued)


NathanKell
 Share

Recommended Posts

I'm having a problem with sites of all kinds and ground stations closing themselves. Once in a while, some sites and openable buildings inside them just become closed. I am not able to reproduce it, as it happens once per few hours of gameplay. I suspect that this bug is occurring when the game is loaded, since it seems to happen particularly when I quicksave & load a lot. It is particularly annoying in career mode, since not only do I need to cheat some money, but also enable remote opening of bases to fix that. It also makes research and money generation buildings useless and extra ground stations unreliable. This problem probably persisted for quite a while, since I encountered it both now in KSP 1.12 and a few years ago in KSP 1.3.1.

Here are the logs:
https://www.dropbox.com/s/etag302uoajvcyx/Player.log?dl=0
https://www.dropbox.com/s/7i6chj14t21kin8/KSP.log?dl=0

One of bases that I opened for the first time and that closed itself in this single run was Dununda.

Is this a known issue? Are there any known workarounds?

Link to comment
Share on other sites

There are some KK errors relating to a conflict between RemoteTech and KK that may be a contributing factor as there are related to setting the open/closed state of facilities. 

The following are a sample. 

At line 55274  
[LOG 01:43:32.531] [RemoteTech] Removing Kerbin SouthReserch 
[ERR 01:43:32.539] Exception loading ScenarioModule KerbalKonstructsSettings: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
  at System.ThrowHelper.ThrowInvalidOperationException (System.ExceptionResource resource) [0x0000b] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Collections.Generic.List`1+Enumerator[T].MoveNextRare () [0x00013] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Collections.Generic.List`1+Enumerator[T].MoveNext () [0x0004a] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Linq.Enumerable+SelectListIterator`2[TSource,TResult].MoveNext () [0x00029] in <351e49e2a5bf4fd6beabb458ce2255f3>:0 
  at KerbalKonstructs.Addons.RemoteTechAddon.CloseAllStations () [0x00067] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.ConnectionManager.LoadGroundStations () [0x00040] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Career.KerbalKonstructsSettings.OnLoad (ConfigNode node) [0x000c2] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at ScenarioModule.Load (ConfigNode node) [0x0000e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at ScenarioRunner.AddModule (ConfigNode node) [0x0005e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 

At line 188364
[WRN 07:56:01.314] KK: [ConnectionManager] DetachGroundStation: Trying To close a GroundStation that was never opened by us: Kerbin_Cape Kerman:Cape Kerman_KSC_TrackingStation_level_3_0
[ERR 07:56:01.315] Exception loading ScenarioModule KerbalKonstructsSettings: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) [0x0001e] in <9577ac7a62ef43179789031239ba8798>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00037] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Career.KerbalKonstructsSettings.OnLoad (ConfigNode node) [0x00028] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at ScenarioModule.Load (ConfigNode node) [0x0000e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at ScenarioRunner.AddModule (ConfigNode node) [0x0005e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0   

Workarounds. 

  1.  In the KK settings under game difficulty you could deselect "Open Bases only when landed" option allowing base openings remotely. 
  2. In the same place under "cheats" you could enable "Open everything" and just proceed from there. (I typically make use of this in my career games, but I never user the funds or science farm features of KK in my games. Just the refueling options for aircraft) .

Depends on your playstyle. 

 

 

Link to comment
Share on other sites

4 hours ago, Caerfinon said:

There are some KK errors relating to a conflict between RemoteTech and KK that may be a contributing factor as there are related to setting the open/closed state of facilities. 

Thanks a lot for checking it out! I am not really keen to removing any of these mods, so I will try to fix this somehow or use the "open everything" option once I finish buying everything. I'll have to check if toggling the "additional ground stations" option in remotetech will fix anything, since these might be the stations that cause problems. If not, I'll check if "open everything" will apply to facilities too.

I already checked that research/business/barracks buildings somehow do work and keep assigned staff after this removal occurs (you still have to pay for the facility itself), so at least the amassed research/credits is not lost.

 

On a related note - I have 10 unassigned kerbals after hiring 40 in Dununda, but I only use 30 on them for business/research there. I am unable to hire them in other locations, such as Kermundsen's Research Station. Does that mean that the pool of kerbals to hire is tied to a specific base?

Link to comment
Share on other sites

47 minutes ago, Xilexio said:

Does that mean that the pool of kerbals to hire is tied to a specific base?

Yes.

Each base needs to have a barracks for local staff, not all the bases in Kerbin Side Remastered include these facilities.  They are fairly easy to add in KK. Just select a building that doesn't already have a facility attached to it, and add the barracks facility. A base can have more than one barracks if you need the staff. 

Link to comment
Share on other sites

3 hours ago, Caerfinon said:

Each base needs to have a barracks for local staff, not all the bases in Kerbin Side Remastered include these facilities.  They are fairly easy to add in KK. Just select a building that doesn't already have a facility attached to it, and add the barracks facility. A base can have more than one barracks if you need the staff. 

I see. I actually have KSR + KSR GAP Extras installed and:

$ grep -E -R 'FacilityType *= *(Barracks|Research|Business)' KerbinSideRemastered KerbinSideRemasteredGapExtras
KerbinSideRemastered/Statics/ExampleBases/Dununda/KSC_Administration_level_3-instances.cfg:                     FacilityType = Business
KerbinSideRemastered/Statics/ExampleBases/Dununda/KSC_AstronautComplex_level_3-instances.cfg:                   FacilityType = Barracks
KerbinSideRemastered/Statics/ExampleBases/Dununda/KSC_ResearchAndDevelopment_level_3-instances.cfg:                     FacilityType = Research
KerbinSideRemastered/Statics/ExampleBases/Harvester/KS_observatory1-instances.cfg:                      FacilityType = Research
KerbinSideRemastered/Statics/ExampleBases/NyeIsland/KS_observatory1-instances.cfg:                      FacilityType = Research
KerbinSideRemastered/Statics/ExampleBases/Polar_Alpha/KS_observatory1-instances.cfg:                    FacilityType = Research

It follows that Dununda is the only place in KSR where you can make use of Research or Business buildings.

Edited by Xilexio
Link to comment
Share on other sites

6 minutes ago, Xilexio said:

Dununda is the only place in KSR where you can make use of Research or Business buildings.

Yes,  I didn't add any facilities other than fuel at the KSR GAP extras sites. and while the KSR sites have  research and business facilities , they have no barracks. Up to the player to go there press CTL-K and add via the GUI, or if you know haw to edit the KK files you can do that and add the facilities before you start the game up.  

Edited by Caerfinon
Link to comment
Share on other sites

On 8/26/2022 at 4:36 AM, Caerfinon said:

There are some KK errors relating to a conflict between RemoteTech and KK that may be a contributing factor as there are related to setting the open/closed state of facilities. 

The following are a sample. 

At line 55274  
[LOG 01:43:32.531] [RemoteTech] Removing Kerbin SouthReserch 
[ERR 01:43:32.539] Exception loading ScenarioModule KerbalKonstructsSettings: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
  at System.ThrowHelper.ThrowInvalidOperationException (System.ExceptionResource resource) [0x0000b] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Collections.Generic.List`1+Enumerator[T].MoveNextRare () [0x00013] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Collections.Generic.List`1+Enumerator[T].MoveNext () [0x0004a] in <9577ac7a62ef43179789031239ba8798>:0 
  at System.Linq.Enumerable+SelectListIterator`2[TSource,TResult].MoveNext () [0x00029] in <351e49e2a5bf4fd6beabb458ce2255f3>:0 
  at KerbalKonstructs.Addons.RemoteTechAddon.CloseAllStations () [0x00067] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.ConnectionManager.LoadGroundStations () [0x00040] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Career.KerbalKonstructsSettings.OnLoad (ConfigNode node) [0x000c2] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at ScenarioModule.Load (ConfigNode node) [0x0000e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at ScenarioRunner.AddModule (ConfigNode node) [0x0005e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 

At line 188364
[WRN 07:56:01.314] KK: [ConnectionManager] DetachGroundStation: Trying To close a GroundStation that was never opened by us: Kerbin_Cape Kerman:Cape Kerman_KSC_TrackingStation_level_3_0
[ERR 07:56:01.315] Exception loading ScenarioModule KerbalKonstructsSettings: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) [0x0001e] in <9577ac7a62ef43179789031239ba8798>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00037] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at KerbalKonstructs.Career.KerbalKonstructsSettings.OnLoad (ConfigNode node) [0x00028] in <a5e296023c464add972f71a1e2dd6a8a>:0 
  at ScenarioModule.Load (ConfigNode node) [0x0000e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at ScenarioRunner.AddModule (ConfigNode node) [0x0005e] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0   

Workarounds. 

  1.  In the KK settings under game difficulty you could deselect "Open Bases only when landed" option allowing base openings remotely. 
  2. In the same place under "cheats" you could enable "Open everything" and just proceed from there. (I typically make use of this in my career games, but I never user the funds or science farm features of KK in my games. Just the refueling options for aircraft) .

Depends on your playstyle. 

 

 

I frankly don't understand how that code ever worked, since it's removing an item from a dictionary *and then getting the item from the dictionary*. Anyway, here's a dll to try @Xilexiohttps://github.com/KSP-RO/Kerbal-Konstructs/raw/master/GameData/KerbalKonstructs/KerbalKonstructs.dll

Link to comment
Share on other sites

1 hour ago, NathanKell said:

I frankly don't understand how that code ever worked, since it's removing an item from a dictionary *and then getting the item from the dictionary*. Anyway, here's a dll to try @Xilexiohttps://github.com/KSP-RO/Kerbal-Konstructs/raw/master/GameData/KerbalKonstructs/KerbalKonstructs.dll

Thank you for your work on this issue! I will test it for a few hours today while trying to visit different KK and stock ground stations to trigger all kinds of events.

Link to comment
Share on other sites

11 hours ago, NathanKell said:

I frankly don't understand how that code ever worked, since it's removing an item from a dictionary *and then getting the item from the dictionary*. Anyway, here's a dll to try @Xilexiohttps://github.com/KSP-RO/Kerbal-Konstructs/raw/master/GameData/KerbalKonstructs/KerbalKonstructs.dll

I finished my test (existing career mode only). The main fix was successful - I did not see any bases or facilities closing themselves. There was one error related to RT setup.

KK: [GroupCenter] SetInstancesEnabled: Setting Group SulinsOdyssey: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

KK: [GroupCenter] SetInstancesEnabled: Setting Group ValdrinsTriumph: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

KK: [GroupCenter] SetInstancesEnabled: Setting Group Woomerang: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Exception handling event onNewGameLevelLoadRequestWasSanctionedAndActioned in class KerbalKonstructs:System.NullReferenceException: Object reference not set to an instance of an object
  at KerbalKonstructs.KerbalKonstructs.get_enableRT () [0x0000c] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00012] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.KerbalKonstructs.OnLevelWasLoad (GameScenes data) [0x00201] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0  
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at KerbalKonstructs.KerbalKonstructs.get_enableRT () [0x0000c] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00012] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.KerbalKonstructs.OnLevelWasLoad (GameScenes data) [0x00201] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventData`1:Fire(GameScenes)
<FireLoadedEvent>d__46:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

Here is the full log: https://www.dropbox.com/s/uoph0fh3ppn3yxc/Player-TestKK.log?dl=0

 

Apart from that:
- Funds/research per day seem to be calculated incorrectly. Fully staffed Dununda's Administration Complex produces only 100 / Day, even though it has the following config:
 

Facility
{
	FacilityType = Business
	ProductionRateMax = 1000
	FundsOMax = 999999
	StaffMax = 10
	OpenCost = 250000
	CloseValue = 62500
	FacilityName = [email protected]_Administration_le
	OpenCloseState = Closed
}

Changing production rate in the editor does not change anything: https://pasteboard.co/xCwuoqSeNt1U.png . Same for a manually created one.


- Is there any reason why the limit on the amount of funds in a building is only 999999 (and research 999) and not some huge value or max float/int? In late game, these buildings are valuable mainly because even though production per day is small, it will add up during a journey to Eeloo or a star system from another mod.
- I'm not sure if the reason why I don't get additional RT ground stations from additional stock ground station isn't related to KK. That'd require a fresh RT + KK instance to test.
- There was an issue before that editing anything in KK caused everything to be closed. Probably for the same reason as random closures. It was fixed too.

Lastly, I'm curious, was the closing bases issue reported before? Is a KK + RT career run w/o everything unlocked so rare?

Link to comment
Share on other sites

16 hours ago, Xilexio said:

I finished my test (existing career mode only). The main fix was successful - I did not see any bases or facilities closing themselves. There was one error related to RT setup.

KK: [GroupCenter] SetInstancesEnabled: Setting Group SulinsOdyssey: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

KK: [GroupCenter] SetInstancesEnabled: Setting Group ValdrinsTriumph: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

KK: [GroupCenter] SetInstancesEnabled: Setting Group Woomerang: active state form: True to: False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Exception handling event onNewGameLevelLoadRequestWasSanctionedAndActioned in class KerbalKonstructs:System.NullReferenceException: Object reference not set to an instance of an object
  at KerbalKonstructs.KerbalKonstructs.get_enableRT () [0x0000c] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00012] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.KerbalKonstructs.OnLevelWasLoad (GameScenes data) [0x00201] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0  
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at KerbalKonstructs.KerbalKonstructs.get_enableRT () [0x0000c] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.ConnectionManager.DetachGroundStation (KerbalKonstructs.Core.StaticInstance instance) [0x00012] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.GroundStation.SetClosed () [0x00006] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.KKFacility.ResetToDefaultState () [0x0001b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.Modules.CareerState.ResetFacilitiesOpenState () [0x0002b] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at KerbalKonstructs.KerbalKonstructs.OnLevelWasLoad (GameScenes data) [0x00201] in <7ee0e42919ad47868a035e1b98d1fe68>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventData`1:Fire(GameScenes)
<FireLoadedEvent>d__46:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

Here is the full log: https://www.dropbox.com/s/uoph0fh3ppn3yxc/Player-TestKK.log?dl=0

 

Apart from that:
- Funds/research per day seem to be calculated incorrectly. Fully staffed Dununda's Administration Complex produces only 100 / Day, even though it has the following config:
 

Facility
{
	FacilityType = Business
	ProductionRateMax = 1000
	FundsOMax = 999999
	StaffMax = 10
	OpenCost = 250000
	CloseValue = 62500
	FacilityName = [email protected]_Administration_le
	OpenCloseState = Closed
}

Changing production rate in the editor does not change anything: https://pasteboard.co/xCwuoqSeNt1U.png . Same for a manually created one.


- Is there any reason why the limit on the amount of funds in a building is only 999999 (and research 999) and not some huge value or max float/int? In late game, these buildings are valuable mainly because even though production per day is small, it will add up during a journey to Eeloo or a star system from another mod.
- I'm not sure if the reason why I don't get additional RT ground stations from additional stock ground station isn't related to KK. That'd require a fresh RT + KK instance to test.
- There was an issue before that editing anything in KK caused everything to be closed. Probably for the same reason as random closures. It was fixed too.

Lastly, I'm curious, was the closing bases issue reported before? Is a KK + RT career run w/o everything unlocked so rare?

I'll fix that last exception when I have a sec and release (if there hasn't been a KK release by the middle of the weekend, ping me! Currently busy shipping things at work...) 
As to the facility stuff...I don't know anything about the econ side of KK, do other bits of that work? We just use it for making the Cape (or other launch sites) look pretty and, err, extra-launch-siteable. :]

My guess is the overlap between KK and RT folks is pretty minimal? I'd guess many RT folks who play stock-ish moved on to CommNet (and maybe Kerbalism?) But I'm really not plugged into the non-RO scene at all.

Link to comment
Share on other sites

is there any technical information for adding new models? the manual was very specific for the cfg but mentioned practically nothing at all on making new statics from the unity editor side of things. 

nvm. it worked when i moved my statics into the kk folder. i had it in its own folder with some map decals and other kk things i was messing around with. funny thing is the decals show up when placed in that folder but not the statics. 

Edited by Nuke
Link to comment
Share on other sites

Edit: Disregard. Reinstalling a second time fixed the issue? It's weird that the issue happened to me on two different clean installs of KSP. Third reinstall fixed everything somehow.

Spoiler

Do ground stations added with this mod have a hard coded cap on their distance? I've been trying to make a new space center, and I can't seem to get the ground station to have the correct distance. I want it to be the same distance as the default KSC distance (250Bm) but it seems to only be effective out to low Kerbin orbit. I made a separate install of the game with no extra mods and tried doing just a ground station at the desert airfield, and I got the same results. Pics and log: https://drive.google.com/drive/folders/1MLoasyiFzlunXagDCBvBbu97AT1maLwF?usp=sharing

You can see in the second picture that the craft can connect to the KSC no problem but not to my KK ground station.

When I created the ground station, the units were in meters. When viewing the ground station from tracking center or map view, the units are "tkm" but the digits I typed in are the same. I also tried adding way too many zeros but the results are the same.

I looked in all the KK files to see if there was a setting that may have been causing it, but I didn't see anything. Anyone know what's going on with this?

Edited by Micro753
Link to comment
Share on other sites

  • 1 month later...

@NathanKell

Hi. I am trying to make a Static that can be used as a Launch Site. I have given the static a launch transform and I can configure it in the KK window but it never shows up on the list of bases for me to open it. I have no problem putting other peoples premade launch site statics into the world and having them come up right.

I work in the Blender enviroment with the .mu plugin. The examples I have looked at seem to be all on layer 0 with no special attributes.

Is there something I am unaware of that needs to be done in the .mu model to enable it to be used correctly?

 

Update since I wrote this. It turns out the old static that I was trying to convert was the culprit. I have since made 2 simple statics with transforms as launch sites and they work as they should.

 

Edited by ColdJ
Link to comment
Share on other sites

33 minutes ago, Rutabaga22 said:

Is there a way to make Kerbal konstructs only have buildings on 1 save

No. The KK configs are common to all the saves in a particular game.

You could copy your Kerbal Space Program folder to another location on your disk and run a completely different game instance with the KK Statics set up the way you want.  I currently have 5 separate instances of KSP that have different KK set ups, and planet pack set ups depending on what I'm working on.   

Link to comment
Share on other sites

On 6/25/2022 at 10:51 PM, Thatguywholikesionengines said:

Made a decent custom launch center in KK, and all was well until i closed and re-opened the game. It completely disappeared past one or two buildings, and now, despite reinstalling the mod twice, the ctrl+k keybind doesn't work. I've asked around and couldn't find any solutions, to the disappearance issue or the ctrl+k issue. For the love of god, please help me.

Edit: if you manual installed, uninstall and re-instal via CKAN, that worked for me

Edited by GianFrank
Link to comment
Share on other sites

To add to what Linux said a few pages back I to am having issues with JNSQ,GPP and GEP. every thing works untill I add KK and its reqiured mod.

the game hangs at load memory goes through the roof till it crashes.

my combination of mods work great untill I add KK.

 

Did any one figure out the issue?

Thanks in advance :)

Link to comment
Share on other sites

On 10/17/2022 at 3:55 AM, stk2008 said:

To add to what Linux said a few pages back I to am having issues with JNSQ,GPP and GEP. every thing works untill I add KK and its reqiured mod.

the game hangs at load memory goes through the roof till it crashes.

my combination of mods work great untill I add KK.

 

Did any one figure out the issue?

Thanks in advance :)

Are those the only 4 mods you have installed? If not, try just with those 4.  (plus Module Manager, obviously) Scatterer may have interactions if it's not up to date. 

If that doesn't resolve it, try removing the JNSQ_Configs/KK folder and try again. If it doesn't hang with the KK folder removed, then it's possible the KK patches don't account for the most recent updates in KK. JNSQ hasn't been updated in a long time.

 

Link to comment
Share on other sites

I am currently just using KK with JNSQ which works so it must be GEP or GPP?.

Any ways I was wondering if KK allows me to build more transmitters around the planet I use Remotetech and once I get past the base HQ I loose connection.

Can I land at lets say other side of the world and use KK to build another transmitter?.

 

Thanks :)

Link to comment
Share on other sites

  • 2 weeks later...

Ok I am back but with some info that may help others :)

So I was building a craft and we have all had a craft spawn on runway or other places after building it in the editor and it suddenly jumps into the air (even in vanilla).

Spending so so much time trying to get my water plane to not jump into the sky after chooseing harbour spawn I remembered I had KK installed and pressed ALT+K chose the harbour spawn raised it a little and boom...or lack of.

It worked.
I had the same issue with the same plane on the runway but gave up...but now I am going to start the game again and see if the same fix for the water spawn also works on the runway.

I shall report back later :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...