Jump to content
  • 0

Seemingly Random Yaw Inputs


Nate F
 Share

Question

Running KSP 1.12.2, zero mods installed. I've noticed the last few weeks that I start getting random yaw inputs to the right. Like, I'll be in a stable orbit, with or without SAS engaged, and all the sudden my craft yaws to the right. And it's always to the right. No random pitch or roll, just yaw. The pitch/roll/yaw input display shows a sharp input, too. Doesn't matter if I have my hand on the joystick or not. I'm using a Thrustmaster T-Flight HOTAS X, but I have this issue in literally no other games. I even backed out and went to the Windows game controller setup, calibrated, and then just watched the input gauges on there to see if I could get it to replicate...no luck. It's entirely confined to KSP. It's SUPER annoying when setting up for precison burns and at T -2s your craft gets knocked off alignment because the gremlins decide to yaw you to the right.

I've done all the normal stuff, plug and unplug the controller, restart KSP, etc., but it keeps happening. My dead zones are appropriately set, too, so it's not like the controller is getting bumped.

Any ideas?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
8 hours ago, Nate F said:

Any ideas?

Just a detail, if you completely unplug the joystick does the input still happen?

Maybe re bind in kerbal's settings the inputs in case something is mixed up.

If you are on steam, go to big picture mode and see the joystick configuration, settings there, deadzones etc.

 

Link to comment
Share on other sites

  • 0
2 hours ago, Serenity said:

Just a detail, if you completely unplug the joystick does the input still happen?

Maybe re bind in kerbal's settings the inputs in case something is mixed up.

If you are on steam, go to big picture mode and see the joystick configuration, settings there, deadzones etc.

 

If I unplug the joystick it doesn't seem to happen anymore. Tried re-binding (a few times) but no luck. Steam doesn't give me any options in big picture mode for joystick dead zones, it seems...just options to set up a gamepad.

Has anyone else ever had this issue? It's so frustrating because it's difficult to replicate, it just happens at seemingly random times.

Link to comment
Share on other sites

  • 0
2 hours ago, Nate F said:

If I unplug the joystick it doesn't seem to happen anymore. Tried re-binding (a few times) but no luck. Steam doesn't give me any options in big picture mode for joystick dead zones, it seems...just options to set up a gamepad.

Has anyone else ever had this issue? It's so frustrating because it's difficult to replicate, it just happens at seemingly random times.

It doesn't show in Steam as a gamepad?

Does it happen when you change the throttle? Maybe there is some weirdness there?

Do you have your joystick connected to a usb hub? 

Its super rare but sometimes if it doesn't get enough power weird things can happen but  i don't know.

Some use 3rd party programs to fine adjust these things but i have no idea if its a good thing to do.

Edited by Serenity
Link to comment
Share on other sites

  • 0

Yeah, it's listed as a gamepad, but there aren't any options to adjust sensitivity or dead zones.

I did have it going through a hub, but switched it back down to one of the mother board USB inputs thinking that may have been the issue, but nope.

The weird thing is that this only happens in KSP, not anywhere else.

Not tried the 3rd party route yet...

Link to comment
Share on other sites

  • 0
50 minutes ago, Nate F said:

Yeah, it's listed as a gamepad, but there aren't any options to adjust sensitivity or dead zones.

I did have it going through a hub, but switched it back down to one of the mother board USB inputs thinking that may have been the issue, but nope.

The weird thing is that this only happens in KSP, not anywhere else.

Not tried the 3rd party route yet...

Check this post i found, far chance but:

You may be pressing Alt key for something during flight, which is used to trim the craft. Alt+X is default to reset trim.

If it's not the case, and you have joystick plugged in, try restarting the game without it and see if it was the problem.

Maybe a mod like this to help?

 

Edited by Serenity
Link to comment
Share on other sites

  • 0

Definitely not a trim issue. That was the first thing I checked and the only thing even remotely applicable after a dozen different Google searches. Oddly enough, I just spent an hour playing and it didn't happen a single time, but I've done literally nothing different since the last time. Honestly, I do wish KSP would have better native joystick support. It's like it was kind of an afterthought.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...