Jump to content

[1.12.2] S.A.V.E Resaved - Automatic Backup System


linuxgurugamer
 Share

Recommended Posts

Originally written by @Nereid, it was broken in 1.12.  I've tried to contact him, no response, so I've adopted this mod.  As usual, if he comes back, I'd be happy to return it to him.  Original thread is here: https://forum.kerbalspaceprogram.com/index.php?/topic/94997-1100-save-automatic-backup-system-1100-3173/

 

S.A.V.E

automatic backup system

Have you experienced some kind of major bug in a plugin? Did your save game got corrupt or have you lost all your ribbons in FinalFrontier, because of a single stupid mistake the developer (who is me unfortunately) has made? No? Well, you are lucky then. If you have experienced this, S.A.V.E may come to rescue. This plugin will handle automatic backups of your save games for you to prevent loss of data.

As most other software, this software comes with no warranty of any kind. If you use it, you do it at your own risk. :wink:

All releases until 0.9.11-319 will not backup your ship templates!

And a word of warning: I have tested this on Windows only. I do not know, if S.A.V.E works correctly on a MAC or on Linux.


Important! Please read!

This plugin will store the backups at the location on the file system that is set by the user! It may write on any location on the file system if the user changes the default location. Please keep this in mind, if you are setting S.A.V.E to a different backup location.

The default location for backups is: <KSP-HOME>/backup. There is a subfolder for each save game. Each backup is stored in a folder YYYYMMDD-HHMISS.

Folders containing a .nobackup file are not included in any backup. So if you do not want to backup a game or a subfolder of a game, just create a file of that name there.

Availability

CKAN soon

Adoption Changes

  • Adoption by Linuxgurugamer
  • Added variable positioning of the window
  • Converted from threads to CoRoutines
  • Fixed bug where trying to clone after doing a backup was returning a sharing violation (backup.ok wasn't being closed)
  • Removed asyncronous option

Features:

  • Completely automatic; it will create a backup after a save
  • Backups can be stored anywhere in the file system ("a king who must say 'I'm the king' is no real king" :wink: -a backup on the same hard disk is no real backup)
  • Configurable backup interval
  • Configurable minimal number of successful backups
  • Configurable maximal number of backups
  • Configurable time in days to keep backups
  • Backup of all games at once
  • Restore functionality
  • Automatic backup before a restore is done.
  • Compressed backups
  • Cloning a game from a backup

Screenshot:

S.A.V.E.jpg


Hints:

  • Setting "days to keep backups" to 0 will keep backups forever (as long other constraints are not violated).
  • Setting "max number backups" to 0 will keep an unlimited amount of backups (as long other constraints are not violated).
  • Setting both "days to keep backups" and "max number backups" to 0 will never delete any backup (not even failed ones).
  • The value of "min number of backups" determines the number of successful backups that have to be kept in any case.

 

Regarding the logging, if you already had SAVE installed, you will need to manually change the saved log level in the configuration.  At the MainMenu, follow these steps:

  1. Click the Configure button on the SAVE window
  2. On the first line below the word Configuration, click the log level you want.  Suggested (and default for new installs) is ERROR
  3. Click Save Config

 

Edited by linuxgurugamer
Link to comment
Share on other sites

@linuxgurugamer My S.A.V.E is filling my KSP.log with the following message:

Quote
[LOG 23:46:00.480S.A.V.E: stopping backup/restore threads
[LOG 23:46:00.480S.A.V.E: stopping backup/restore threads
[LOG 23:46:01.487S.A.V.E: stopping backup/restore threads
[LOG 23:46:01.487S.A.V.E: stopping backup/restore threads

Looks like it's logging that message twice every second. This is on 1.12.2 with all default mod settings.

Edited by jefferyharrell
Link to comment
Share on other sites

1 hour ago, jefferyharrell said:

@linuxgurugamer My S.A.V.E is filling my KSP.log with the following message:

Looks like it's logging that message twice every second. This is on 1.12.2 with all default mod settings.

You can ignore that, will be fixed in next release.  It's just a leftover message, doesn't mean anything anymore and doesn't impact the performance

Link to comment
Share on other sites

  • 4 weeks later...

New release, 1.11.0.1

  • Added AssemblyVersion.tt
  • Added InstallChecker
  • Changed default log level for  release to ERROR
  • Added AsemblyFileVersion
     

Regarding the logging, if you already had SAVE installed, you will need to manually change the saved log level in the configuration.  At the MainMenu, follow these steps:

  1. Click the Configure button on the SAVE window
  2. On the first line below the word Configuration, click the log level you want.  Suggested (and default for new installs) is ERROR
  3. Click Save Config

 

Link to comment
Share on other sites

  • 2 weeks later...
On 9/14/2021 at 8:48 AM, linuxgurugamer said:

New release, 1.11.0.1

  • Added AssemblyVersion.tt
  • Added InstallChecker
  • Changed default log level for  release to ERROR
  • Added AsemblyFileVersion
     

Regarding the logging, if you already had SAVE installed, you will need to manually change the saved log level in the configuration.  At the MainMenu, follow these steps:

  1. Click the Configure button on the SAVE window
  2. On the first line below the word Configuration, click the log level you want.  Suggested (and default for new installs) is ERROR
  3. Click Save Config

 

This release does not appear to actually have a release:
https://github.com/linuxgurugamer/S.A.V.E/releases

(There is source code downloads, but no compiled release.)

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
On 11/29/2021 at 11:27 PM, linuxgurugamer said:

New release, 1.11.0.2

  • Removed some log spam
     

Can you please remove the log spam for real?

It generates exactly 2 copied of the same message per second and that really disturbs debugging when you're trying to read the logs.

Nvm, I read the OP and found a way to disable the log spam. I assume it's disabled by default?

Edited by Krzeszny
Link to comment
Share on other sites

1 minute ago, Krzeszny said:

Can you please remove the log spam for real?

It generates exactly 2 copied of the same message per second and that really disturbs debugging when you're trying to read the logs.

You can do that by changing the log level in the configuration.

It defaults to INFO, but you can set it to anything you want.  I'd suggest either WARNING or ERROR

Link to comment
Share on other sites

Just now, linuxgurugamer said:

You can do that by changing the log level in the configuration.

It defaults to INFO, but you can set it to anything you want.  I'd suggest either WARNING or ERROR

I found it, thanks. I'd suggest WARNING or ERROR by default.

Link to comment
Share on other sites

  • 3 months later...
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...