Jump to content
  • 0

SAS not working



I can't turn on SAS even though my rocket has a Kerbal, I can only turn on SAS if I have a pilot Kerbal inside it and even then I can't use the maneuver, target and anti-target hold. It only seems to work on probes that have the ability to do all of those (the Probodobodyne HECS2) and on for example the Stayputnik probe core or  other probes I can't turn on SAS either.  This only seems to be a problem on my current save, but it has occurred a few times on my other saves as well. Is there any way I could fix this without starting a new save?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Is this a career save?

If so, this is all normal in a career save. Non pilot Kerbals don't have any piloting abilities. For pilot Kerbals, extra abilities like target hold are gained as the pilot gains "experience". You need a level 3 pilot for maneuver and target hold.


There is a game setting in the advanced section "enable Kerbal experience" that will disable this feature.



Link to comment
Share on other sites

  • 1

This is all working as intended.

You need either a probe core (that isn't a Stayputnik) or a Kerbal pilot on board to use SAS; engineers and scientists can't do it. There are different levels of SAS: level 0 is the basic SAS mode that tries to cancel rotation, level 1 adds pro/retrograde hold, level 2 adds radial and normal hold and level 3 gives you everything; this corresponds to the levels your pilots need to reach to be able to use these abilities, so a level 1 pilot can do pro/retrograde hold and a level 3 pilot can use any SAS mode they like. Reaching level 3 is relatively easy- just plant a flag on the Mun, plant a flag on Minmus and make a (very brief) trip outside Kerbin's SOI and that's enough XP for any Kerbal to reach level 3. Probe cores have fixed SAS abilities that depend on the part- the QBE and RoveMate have level 0 SAS, OKTO and HECS have level 1, OKTO2 has level 2 and HECS2 and RGUs have level 3, with the Stayputnik having no SAS at all; keep in mind that you also need reaction wheels (or RCS) to control your attitude and the RoveMate, QBE and Stayputnik have no built-in reaction wheels at all.

If you're in sandbox mode you can change the difficulty settings to enable SAS more widely- turn on "All SAS modes on all probes" and every probe core will have all the SAS modes. You can also disable Kerbal experience in every game mode (I think), in which case every Kerbal will be level 5 by default and all pilots will give you full SAS control.


Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...