Jump to content
  • 0

Loading screen stuck (NullReferenceException)


raize308
 Share

Question

I was just loading ksp and while loading the loading bar stopped. I checked the debug toolbar i think its called and it says "Exception: NullReferenceException: Object reference not set to an instance of an object" after loading some textures. Last time i was on ksp the game got stuck after pressing launch in the VAB but i dont know if thats related. Any help?

Link to comment
Share on other sites

15 answers to this question

Recommended Posts

  • 0
  1. Get your log files. The easy one is KSP.log, that’s right there inside the KSP root directory (if you downloaded KSP via Steam, just right click KSP in your Steam library and click “browse local files”; otherwise it’ll be wherever you told the installer to install it), the harder one is Player.log which is more detailed but buried in a folder tree behind a hidden folder- on Windows you’ll find it at C:/Users/(your username)/AppData/LocalLow/Squad/Kerbal Space Program, the AppData folder is hidden so you’ll need to turn on “show hidden folders” to see it.
  2. Put the logs on a file sharing site, preferably something easy to access and free from viruses like Dropbox or Google docs.
  3. Post a link to those log files here so people can look at them.

You’re in the unmodded support forums so I assume you have no mods installed? What KSP version are you using, any DLCs, OS and PC specs?

Link to comment
Share on other sites

  • 0

Ok, i might actually have plugins apparently ("Assembly-CSharp" "KSPSteamCtrlr"). Sorry, i play on my brothers account and he said there werent any.  I have both DLCs, version 1.12.2.3167, pc specs: OS: Windows 10  (10.0.0) 64bit, CPU: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz (4), RAM: 8090, GPU: NVIDIA GeForce 940M (2020MB). Player and output_log: https://drive.google.com/drive/folders/10jKg2H9NatAzTn-HM7J81lVCEaMRZMGC?usp=sharing hope its the right format

Link to comment
Share on other sites

  • 0
On 11/21/2021 at 1:17 PM, raize308 said:

Ok, i might actually have plugins apparently ("Assembly-CSharp" "KSPSteamCtrlr"). Sorry, i play on my brothers account and he said there werent any.  I have both DLCs, version 1.12.2.3167, pc specs: OS: Windows 10  (10.0.0) 64bit, CPU: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz (4), RAM: 8090, GPU: NVIDIA GeForce 940M (2020MB). Player and output_log: https://drive.google.com/drive/folders/10jKg2H9NatAzTn-HM7J81lVCEaMRZMGC?usp=sharing hope its the right format

I can't access that link, you need to make the files publicly viewable.

Link to comment
Share on other sites

  • 0
On 11/20/2021 at 7:04 PM, raize308 said:

I was just loading ksp and while loading the loading bar stopped. I checked the debug toolbar i think its called and it says "Exception: NullReferenceException: Object reference not set to an instance of an object" after loading some textures. Last time i was on ksp the game got stuck after pressing launch in the VAB but i dont know if thats related. Any help?

The only DLLs you have listed are the stock DLLs.

I assume you didn't install any mods other than the stock DLC?  Since this is a Steam install, try having Steam verify the files.

Your video board is adequate, how much memory do you have on the computer?

Link to comment
Share on other sites

  • 0
12 hours ago, linuxgurugamer said:

The only DLLs you have listed are the stock DLLs.

I assume you didn't install any mods other than the stock DLC?  Since this is a Steam install, try having Steam verify the files.

Your video board is adequate, how much memory do you have on the computer?

Ok so I just tried that and it replaced 182 files. I opened the game and it loaded slightly more but it's still stuck right now. Yeah, only the 2 DLCs. It's 8 gb ram. Should I just reinstall the game?

Link to comment
Share on other sites

  • 0

I second verifying the files through Steam- it’s very unusual to get a crash like this with stock KSP unless something has been corrupted in some way, which verifying the files should fix.

To verify the files: right click KSP in Steam > Properties > local files > verify integrity of game files. It might say some files need to be redownloaded so let it do that and see if the game loads properly after that.

If that doesn’t work, try uninstalling and reinstalling KSP completely, just remember to copy your save files (right click KSP in Steam > browse local files > go to saves folder > copy the folder with the name of any save(s) you want to keep > paste to desktop) before uninstalling and then put them back after reinstalling.

Link to comment
Share on other sites

  • 0
2 hours ago, raize308 said:

Ok so I just tried that and it replaced 182 files. I opened the game and it loaded slightly more but it's still stuck right now. Yeah, only the 2 DLCs. It's 8 gb ram. Should I just reinstall the game?

182 files is very suspicious.  I'd remove it, and then, before you reinstall, manually delete ALL files (except possibly the save files) from the install directory, then reinstall and try again

Link to comment
Share on other sites

  • 0

Yeah I tried again and it still gets stuck so I'm gonna reinstall the game.

5 minutes ago, linuxgurugamer said:

182 files is very suspicious.  I'd remove it, and then, before you reinstall, manually delete ALL files (except possibly the save files) from the install directory, then reinstall and try again

So delete everything, reinstall the game and only paste in my saves folder?

Link to comment
Share on other sites

  • 0
1 hour ago, raize308 said:

Maybe it has something to do with the bug I had last time I played before this happened. This post describes it perfectly: 

Perhaps it's not related but I'm bringing it up just in case it is

Ummm, that report is 5 years old, not really relevant to the current version.

 

Link to comment
Share on other sites

  • 0
14 minutes ago, linuxgurugamer said:

Ummm, that report is 5 years old, not really relevant to the current version.

True but maybe it can help narrow down the possibilities for my bug. I noticed that this only happens to old versions, which is suspicious since it happened to me too whilst using the newest version.

Link to comment
Share on other sites

  • 0

Problem fixed! I uninstalled the entire KSP folder, clicked on verify file integrity in properties and it reinstalled the game. After that I replaced the new saves folder with my old saves folder. Crashed a few times trying to load the DLCs but now it's working just fine! The other bug is gone too. Thank you all!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...