Jump to content
  • 0

did they change the reentry heat management? overheating inconsistency


king of nowhere
 Share

Question

I just brought my crew back to kerbin after a long mission. I used a well tested capsule design, whom I knew could survive reentry at over 8 km/s.

Imagine my surprise when I reentered at 4 km/s and almost burned anyway.

Here's the recent reentry. 40 km altitude, 4.2 km/s, it's only avoiding destruction by the thinnest margin

PSSUjl0.png

Here's the old reentry, dated last february. nearly twice as fast, already lower in the atmosphere, it's not even close to overheating. the limit to reentry speed was not heat, but acceleration - it killed my crew if i tried to go faster.

2A8K5XO.png

 

the capsule is basically the same. there are a couple rtg attached to it, not enough to make a real difference. So, what the hell? Why in the past I could pull that stunt and now I almost died at a much safer speed?

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Did you have *both* the same Ap and Pe as usual? Also an rtg might generates its own heat on top of being heavy. Normally would not be much, but at reentry much harder to dissipate. And there were updates lately, but did not hear anything specific to re-entry.

Link to comment
Share on other sites

  • 0

I know they messed with some of the nodes on the heatshield, so it might have something to do with that, but I think it's probably the trajectory. The more recent re-entry looks a lot shallower. The trick with heatshields is a steep, deep re-entry (see the link below). I'm a spaceplane guy, so I almost never play with the rocket parts--I think that pod could almost do the more recent re-entry without the shield.

 

Link to comment
Share on other sites

  • 0
16 minutes ago, FleshJeb said:

I know they messed with some of the nodes on the heatshield, so it might have something to do with that, but I think it's probably the trajectory.

I've done a lot of reentries and aerobrakes, and I can confidently say it's impossible that small differences in the trajectory would compensate a difference in speed of 4 km/s.

furthermore, i still had ablator on the shield after landing.

Link to comment
Share on other sites

  • 0
4 hours ago, king of nowhere said:

Imagine my surprise when I reentered at 4 km/s and almost burned anyway.

I have noticed this also.  Unfortunately I do not know what the cause is.  I suspect that heat is being transferred from the heat shield to adjacent parts quicker than it has in the past.

I also have not found a solution, except to accept the fact that heat shields now seem to have a limit to how much they protect the vessel.  This is probably more realistic, but like you I was surprised to find this out.

Link to comment
Share on other sites

  • 0
2 hours ago, OHara said:

I have old versions sitting around so I thought I would compare (Imgur album link) but I couldn't see any significant difference between versions.

Well, I do see a difference in your screenshots:

  • In the first two (1.3 & 1.7), the conductive flux for the command pod is negative, meaning it is conducting away more heat than it is receiving.  This is matched by the conductive flux of the shield (give or take).
  • In the last two (1.10 & 1.12), the conductive flux for the command pod is positive, indicating it is receiving more heat via conduction than it is shedding.

Edit- It also appears the radiated flux is lower in the last two screenshots.  To me, this would mean in addition to receiving more heat via conduction, it is also not shedding it as efficiently via radiation.   So given enough time the command pod is receiving more heat than before, and shedding it less via ratiation.  This kinda matches what I’ve been seeing, parts attached to heat shields are ending up with more heat than before.

Edited by 18Watt
Link to comment
Share on other sites

  • 0
17 hours ago, 18Watt said:

I do see a difference in your screenshots:

True, I wasn't quick enough to point the capsule retrograde, and the capsule interior reached 322K in version 1.3.1 and 344K in 1.7.3.  I should have set SAS retrograde just before entering the atmosphere, and made that the quicksave to try across versions. Having bit of recent practice, I did better and kept it to 318K in 1.10.1 and  314K in 1.12.1.  The pod stayed cooler in later versions, but only because of my different flying, which difference I wasn't considering significant.

I also forgot about the Mk1-2 getting auto-upgraded to Mk1-3 in version 1.4, which decreased its mass, and thus its thermal mass.  If the heat-shield weren't so well insulated, the Mk1-3 would heat up faster than the old pod of that size.   

All the images in the original post, though, show the Mk1-3 pod and version 1.11 or later, so maybe version 1.11 had a bug with heat. 

 

Off topic, in hindsight, I like the thermal model that KSP had before the ISRU and 'core heat'. 

Even the pre-core-heat model was a bit complicated a little mysterious to me as a new player.  If we had different temperature gauges showing which temperature is getting dangerous, maybe vertical thermometers for internal temperature, horizontal for skin temperature, that might have been enough to make it transparent.  The distinction between skin and internals, and different thermal conductivities, seems to be enough to make radiators do their special job.  Most parts have good insulation between skin and internals, except radiators have a good thermal link between skin, internals, and the internals of their parent part.  So maybe that was just complicated enough to enable all the interesting behaviour.

I never learned the rules about which parts are cooled by the various radiators, or about core heat regarding the ISRU system, so I ignored that part of the game.

Link to comment
Share on other sites

  • 0
4 hours ago, OHara said:

Off topic, in hindsight, I like the thermal model that KSP had before the ISRU and 'core heat'. 

They’re all mysterious to me.  While I was a little surprised at some of my entry vehicles getting hot faster, I do find the current system more realistic.  Deep-diving into the atmosphere at 8 km/s should be a very dangerous proposition.  No matter how good your shielding and insulation is, spend enough time at high speeds and eventually the vessel is going to get hot.

Players who find the thermal system too limiting can always just disable it.  I was happy to see @king of nowhere notice some differences too though- I actually thought it was just me (or my imagination) until he commented on it.

I’ve become used to the fact that anytime there is an update to KSP I really shouldn’t count on any of my vessels working like they used to.   I don’t think we’ve actually answered @king of nowhere’s original question though.  Other than to say, ‘Well, it looks like there may be some differences, but we’re not sure exactly what..’
 

Link to comment
Share on other sites

  • 0

The answer to the top-post question is, no, they did not change re-entry heat, anytime since 1.2.

At least not on purpose.  There was a bug in 1.8.0, for example, where lots of parts lost most of their drag, so different parts would overheat than before; they repaired that in 1.8.1.

cOuNf1m.jpgThe images in the top post show the stock cabinet icon, but not the alarm clock, so I guess those images are from version 1.11.  For me, in stock KSP, the heat shield barely survives a 7km/s re-entry of the 3-kerbal pod.  I don't use ablator because it doesn't help much; the T4 radiative cooling of a 3300K heatshield (hotter than incandescent light bulbs) is enough to cool it.  If you stay perfectly retrograde, the capsule is completely protected.

A small imbalance that tilts the craft would let a bit of the capsule feel compression heating, and in KSP if part of the skin overheats the whole part gets the warning thermometer and is destroyed.  The skin of the pod has a 2400K temperature limit.  

I posted a patch once to make the mk1-3 pod fit the other 1.25-m parts at its top node, and this patch causes some of the pod extend beyond the heat shield, and feel some heating.  Maybe some other mod does similarly.

Link to comment
Share on other sites

  • 0
1 hour ago, OHara said:

The answer to the top-post question is, no, they did not change re-entry heat, anytime since 1.2.

At least not on purpose.  There was a bug in 1.8.0, for example, where lots of parts lost most of their drag, so different parts would overheat than before; they repaired that in 1.8.1.

cOuNf1m.jpgThe images in the top post show the stock cabinet icon, but not the alarm clock, so I guess those images are from version 1.11.  For me, in stock KSP, the heat shield barely survives a 7km/s re-entry of the 3-kerbal pod.  I don't use ablator because it doesn't help much; the T4 radiative cooling of a 3300K heatshield (hotter than incandescent light bulbs) is enough to cool it.  If you stay perfectly retrograde, the capsule is completely protected.

A small imbalance that tilts the craft would let a bit of the capsule feel compression heating, and in KSP if part of the skin overheats the whole part gets the warning thermometer and is destroyed.  The skin of the pod has a 2400K temperature limit.  

I posted a patch once to make the mk1-3 pod fit the other 1.25-m parts at its top node, and this patch causes some of the pod extend beyond the heat shield, and feel some heating.  Maybe some other mod does similarly.

but then, why did i got overheating? you saw my screeenshot, it was 4 km/s, and it was perfectly retrograde

Link to comment
Share on other sites

  • 0
2 hours ago, king of nowhere said:

perfectly retrograde

I don't think this makes much difference in your case, but for the sake of accurate documentation: The atmosphere calcs happen in the Surface reference frame, so the Navball/SAS should be switched to Surface mode if you want to be retrograde relative to the air.

Link to comment
Share on other sites

  • 0
20 hours ago, king of nowhere said:

but then, why did i got overheating?

Don't ask me; I looked for an explanation but couldn't find any.  Since I get reasonable behaviour in 1.11.1 with a similar pod, maybe there is something special about yours that you can find,.

Maybe one of FleshJeb's ideas above leads you to  the cause.  The shield might be offset up so that the pod peeks through (KSP gives you some margin here).  Maybe you attached it inverted, and then rotated it, fooling simple KSP into thinking the pod is connected to the ablator side.  Maybe your later trajectory spends much longer in the upper atmosphere than I was able to do.

The Kerbalism mod has considered requiring a 0°-40° (270K--320K or so) for manned pod interiors, which would be difficult to maintain during re-entry, but I don't think they ever added this to the mod.

Maybe some mod (like my old mod that I linked above) has made the pod overhang the heat shield slightly.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...