Jump to content
  • 0

anyone having problems with vessels sliding down shallow slopes in 1.12.2? Here's a fix.


TimKerbin
 Share

Question

Ever since playing 1.12.2 I've noticed that vessels slide down slopes, even shallow gradients.  Whether it's a 5-man vessel or a 100-tonne mining ship it would slide down a slope at maybe 0.1, 0.2 m/s. Duna, Ike, Mun, Minmus, it didn't matter. It was like the legs had no friction. So I opened up the part file for the LT-2 landing legs and looked for anything friction related. I had no idea what I was doing. :lol:

I changed a few values (in bold) but the one that seemed to work was "autoFrictionAvailable = false".  If you set it to "True", a friction slider control becomes available for the legs on your vessel (I'm talking about the heavy LT-2 legs but the other legs might be the same).

I then tested a vessel by landing it on Minmus on a heavy slope. With the friction slider set to 0, the vessel kept sliding. With the slider set to 1, 1.5 or 2, the vessel eventually stopped completely.

FYI Here is the section where I made the edit/s.

MODULE
    {
        name = ModuleWheelBase
        
        wheelColliderTransformName = wheelCollider        
        useNewFrictionModel = true
        wheelType = LEG
        adherentStart = 0.01
        frictionAdherent = 0.5
        peakStart = 2
        frictionPeak = 1.0
        limitStart = 7.0
        frictionLimit = 1.5
        // setting this to true will override the radius and center parameters
        FitWheelColliderToMesh = False        
        radius = 0.12
        center = 0,0,0
        mass = 0.040
        autoFrictionAvailable = True
        clipObject = piston_collider
        TooltipTitle = #autoLOC_502076 //#autoLOC_502076 = Landing Leg
        TooltipPrimaryField = 
        
        groundHeightOffset = 1.37
    }
I was reading the patch notes for 1.12.2 and Squad claims they've finally fixed the landing legs. Well, they haven't. By fixing one thing they seem to have introduced another issue. In all my time playing KSP I've never had this persisent sliding problem until now. All they had to do was turn this value on by default and there wouldn't have been a problem. Yes I know this setting is meant for wheels but in the part file it treats wheels and legs the same. Both wheels and legs still need friction! In 1.12.2 they (at least the LT-2 legs) don't have friction!

Anyway I hope this helps anyone else having this issue.  

Come on Squad, add this part edit to the next final patch. Prettty please! &) Was this an oversight? Did you miss it? Did you intend to fix this and forgot?
    

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...