Jump to content

[1.12.x] Reviva - the IVA revival and editor/flight switcher. BDB 1.11 Compatible (0.7.7 - 22nd Oct 2022)


610yesnolovely
 Share

Recommended Posts

Posted (edited)

"In accepting this nomination, I'd like to thank my publicist @Stone Blue, without whom..." :D '

99% of the hard work is by others (I'm thinking @MOARdV and @blowfish), I'm merely an archivist making sure you can all find and use it, a bit easier. (Actually it started out as a very selfish "I want this" project, haha).

Edited by 610yesnolovely
Link to comment
Share on other sites

Does this mod/thread get an anthem if it becomes thread of the month? If so, might I suggest Destiny's Child's song "SurReviva"? :cool:

*starting to sing*

"I'm a surrevivor (what), I'm not gon' give up (what)
I'm not gon' stop (what), I'm gon' work harder (what)
I'm a surrevivor (what), I'm gonna make it (what)
I will surrevive (what), keep on surre
vivin' (what)"
Link to comment
Share on other sites

Posted (edited)

Big thanks to @theonegalen, @SkyKaptn, @Thilen123(hoping that's https://www.reddit.com/user/Thilen03/) and of course @blackheart612 (for Airplane Plus).

Release 0.7.5

Adds:

  • Support for Airplane Plus:
    • Warbirds (Bell Heli, Citation, Old Fighter Inline, X1 Supersonic, B29 Bomber)
    • Airplane Plus IVA Pack (Bell Heli, Bombardier Jet, Cessna, F-18 Fighter, Huey Heli)
    • Airplane Plus F-16
      • ASET/RPM for Falcon cockpit
      • Needs to be installed in GameData/AirplanePlusFalcon (otherwise it installs in AirplanePlus, not recommended, and won't work with Reviva).

Fixes:

  • Null exception on switching IVA, possibly only when both RPM and MAS (or just MAS) are installed. Would result in Kerbal portraits disappearing. If you see this again, switching to another craft and back should fix it. May be.

Big recommends for flying: Nav Utils, Rocket Sound Enhancements, Atmospheric Autopilot, Waypoint Manager, a decent Joystick and Throttle and TrackIR.

Check out these people's amazing IVAs!

AP-1.png?raw=true

AP-2.png

AP-3.png?raw=true

AP-4.png?raw=true

Edited by 610yesnolovely
Link to comment
Share on other sites

40 minutes ago, theonegalen said:

oh gosh, that B-29 IVA is so incomplete...

The other cockpits are very good though, up there with ASET, in my opinion. They're also super useful in early career, when paired with UKS, which is what I'm trying now with KSRSS and BDB.

Link to comment
Share on other sites

Posted (edited)

I noticed that there is a known issue posted on GitHub for the Warbirds Mk1 Inline IVA, with the SI edition, regarding the JSI Callback Animator error. I'd like to add that I noticed some other issues with the Warbirds Mk1 Inline SI edition:

* the Raster Prop Monitor MFD in the SI edition is the normal glass one, not the green CRT version which only has the Target management screen. To be honest I prefer this full-featured version, since having just 1 MFD greatly expands the IVA's utility, allowing it to be used for arbitrary space missions in a spaceplane. Maybe digital screens were just recently invented, so the cockpit manufacturer could only afford to install just one. :D

* if you look closely out the right window, you will see a small object off in the distance. This appears to be a side-view of the frame of a RasterPropMonitor MFD.

* the analog altitude dials are using the wrong needles. For instance, on the upper altitude one uses the thin needle for 10,000m increments, while the fat needle is used for 100m increments. I don't know why there's a duplicate altimeter above the brake force area, but its needles are also incorrect, but in a different way.

* the auto-pilot panel on the right (which I don't use since I don't have it installed) is simpler with the SI version.

* the text for the "Brake Force" selector switch is glitchy-looking, although this is the same for the Imperial unit one. Also the little book says "Take-Off Checklis" instead of "Checklist" but I think that's an ASET thing.

Edited by minkar81002
Link to comment
Share on other sites

Thanks again for the great detailed response! I've also noticed some issues with the Caged Inline Mk1 where some of the geometry overlaps the AG buttons on the right side.

With Reviva I'm initially doing the minimum amount of "fixing" IVA so they at least load, once I get through most of them, I'll try to go back to add or update any issues - but I'd probably do so by contacting the original authors and either passing them the fixes for their mod, or if they're not around either adopting them, or as last resort fixing it in Reviva.

The idea is Reviva is the switcher, and might provide it's own minor alterations - swapping out some MFD like you suggested is something I can do somewhat easily.

For these issues, let's see if @theonegalenhas time to take a look - I've seen him around. If you have GitHub, copy-paste the above into an issue on https://github.com/theonegalen/WarbirdCockpits - that way they don't get lost.

Link to comment
Share on other sites

  • 2 weeks later...

@610yesnolovely I have a very annoying problem that is ruining my IVA experience and I don't know where to turn, and I hope you could help me.

Here is the save file: https://www.dropbox.com/s/40hpb5uie7b4nsm/Happy Squid Mk1 Can Broken.sfs?dl=0

You can create a new test Career save and plop that save file in there, and load it up. You should load to the "Happy Squid" ship which has as its main cockpit the Mk1 Lander Can.

For some reason with that save, the ASET Mk1 Lander Can IVA keeps breaking. The left half of the IVA becomes completely non-interactable. I have pursued these following leads in trying to solve the issue, all in vain:

*I tried going to the Space Center and then back. Still broken.

* I tried uninstalling QuickIVA, thinking that it forced the view into the IVA before it was done loading properly. This fixed the situation I had when none of the props in the IVA were interactable, but eventually the left side stopped working too and I can't fix it.

* Looking at the log, there was a warning about the BoxColliders for "tggl_CM_EventTimer_UP_DOWN_RESET_T1-T" not supporting negative scale. I tried editing internal.cfg for the ASET Mk1 Lander Can replacement, removing the event timer props. This did not solve the problem.

* I tried removing Reviva, B9PartSwitch, and DE_IVAExtension (and also QuickIVA) to just have the ASET Mk1 Lander Can and that's it. But no, the Happy Squid ship's ASET Mk1 Lander Can IVA just seems irreparably broken.

* In addition to the above, I also removed the KSPCommunityFix and Harmony mods, in case there was some caching issue or something. No dice.

Thus I don't know whether this is an inherent problem with the ASET Mk1 Lander Can IVA Replacement, or RPM, or maybe Reviva or something broke the save file at some point. I really just don't understand how a save file could have a permanently broken IVA. Can the RPM "Computer" become corrupted? I looked at the RPM computer for the lander can in question (search "ba2386b7-6076-40af-923c-d6c2c03784cb" in the save file .sfs) and I don't know what I'm looking for tbh. Can something in there get corrupted?

Link to comment
Share on other sites

Reviva does do some weird stuff with RPM and MAS computers, so I'd not be super suprised if I broke something and it's getting saved. If building a completely new ship without any mods (except RPM and the IVA) shows the same behaviour then it'd be isolated to those things. I had a look at the sfs file, those numbers are uuid so the IVA and RPMComputer can match up - you have two IVA and both _seem_ to be present and correct with the right numbers matching up.

 

 

Link to comment
Share on other sites

Posted (edited)

@610yesnolovely  I'm at a loss. I've still been looking into this issue, and I've uninstalled the following mods to see if it made a difference: Reviva, B9PartSwitch, DE_IVAExtension, ThroughTheEyesOfAKerbal, KSPCommunityFixes, Harmony, and QuickIVA. So while this might not have anything to do with Reviva directly, I hope that you'd be interested in figuring out this issue for one of your fellow "23 IVA users" as you like to say :unsure:

I have located a save file wherein the Happy Squid IVA is working, and then did some tests to see if I could get the left side of the IVA to stop working. Here it is: https://www.dropbox.com/s/9i5u08rk2sh2sl2/Fragile Save File.zip?dl=0

Although the IVA kept breaking, I couldn't figure out a reliable series of steps to make it break:
 

Spoiler

* at first I thought that doing an EVA Construction Mode with an Engineer on the docked Lander at the bottom, and then returning to the Mk1 Lander Can IVA, would make the left side of the IVA unresponsive. Sometimes it this action broke the IVA, but sometimes it worked okay

* then I thought that maybe doing an EVA Construction Mode anywhere on the vessel would cause it. Sometimes yes, sometimes no

* while pressing in the IVA, I pressed the Prograde (SAS) button, which caused the left side of the IVA to lock up. But I couldn't replicate this. I will say that pressing the Maneuver (SAS) button similarly caused the IVA to break before, I'm pretty sure

* while pressing the Reserves switch cover over and over, one time that made the IVA break. I couldn't replicate this either.

It just seems to happen randomly by doing various things. I don't understand it. My best result was Broken2a.sfs which is not totally broken upon loading the file, but various actions can make it break: if you press the Reserves switch cover, the SAS on/off switch, or the resource monitor display selector dial a few times in various orders. Nothing shows up on the console when the left side of the IVA becomes unresponsive. Breaking the IVA in Broken2a.sfs yielded Broken2b.sfs. Comparing these two files, I don't notice a significant difference between the two save files, and yet the 2a temporarily works and 2b is broken.

Using Notepad++'s compare plugin to compare the save files, I noticed some things:
 

Spoiler

* the Working.sfs file has a module "UIRootManager" but the broken ones do not. But earlier working files don't have UIRootManager either.

* the broken .sfs files tend to have different orbital elements for some various flags planted on planets/moons

* broken 3 has a bunch of index files which were changed, but the other broken files don't seem to have this change.

As you can imagine, it's pretty frustrating to fly an IVA mission with an orbital-construction long-term ship, only to have the save file become permanently broken at some random, unpredictable point. You're an IVA master so I think you're my only hope to diagnose this issue. :wacko::unsure::(

 

Edited by minkar81002
Link to comment
Share on other sites

When I get the chance, I'll take a look, but I'd need a bit more info (since I'd have to clone your set up and try to load the save files):

  • A list of mods you have installed, if you use CKAN: File -> Save installed mod list... 
  • A list of any non-CKAN mods you've manually installed
  • A recent KSP.log (or Player.log, either is fine for me)

No promises I can help, or help quickly, as I tend only to get KSP play/modding time occasionally (though I'll read the forum in a break :-)). I've found diagnosing these kinda things can take quite a while. Usually my technique is a) Google/KSP Forum search for anything that seems involved to see if anyone else found the issue b) cloning the setup on a seperate build, trying to replicate with a completely new save and build of rockets with less mods, often removing most of the mods and slowly re-adding.

I've long ago made my KSP install completely automated (using ckan.exe and shell scripting), exactly because I've had issues that have taken weeks to figure out.

Link to comment
Share on other sites

  • 2 weeks later...

So, WC 0.4 is going to be very different than previous versions. No custom "feet" variables, installed in a different place, different and better names for the interior spaces. If I get it ready, I'll make and submit a pull request to fix Reviva integration. :)

Link to comment
Share on other sites

Hey, I was poking around some old mods and I noticed that Apex and Kermantech mk3 cockpits are not supported by Reviva.  Would you mind adding them?

This seemed to work for me:

		SUBTYPE:NEEDS[Apex]
		{
			name = Apex
			primaryColor = Red
			secondaryColor = Grey
			descriptionSummary = Apex IVA
			descriptionDetail = Apex IVA

			MODULE
			{
				IDENTIFIER
				{
					name = ModuleIVASwitch
				}
				DATA
				{
					internalName = MK3_ApexInternals
					RasterPropMonitorComputer
					{
						name = RasterPropMonitorComputer
						storedStrings =   v 0.2   |2016-04-28|    Mark 3 Pod    |ADVANCED LANDING CAPSULE|FOR    ORBITAL    RENDEZVOUS|SQD002002-A1|MK3|    SQUAD & A.S.E.T. & Apex
					}
				}
			}
		}

		SUBTYPE:NEEDS[KermanTech]
		{
			name = KermanTech
			primaryColor = Green
			secondaryColor = Grey
			descriptionSummary = KermanTech IVA
			descriptionDetail = KermanTech IVA

			MODULE
			{
				IDENTIFIER
				{
					name = ModuleIVASwitch
				}
				DATA
				{
					internalName = MK3_adv_Int
				}
			}
		}
	}

Kermantech: 

Apex:

 

Link to comment
Share on other sites

23 hours ago, JonnyOThan said:

Hey, I was poking around some old mods and I noticed that Apex and Kermantech mk3 cockpits are not supported by Reviva.  Would you mind adding them?

This seemed to work for me: [snip]

Niiice. Thank you very much. Those two were on the list to add support for, but you have indeed done the work. I shall add them and your other fix, perhaps today.

https://github.com/harveyt/reviva/issues/8

I've tried to make a list of every IVA I could find, and intend to go through them all eventually, or hope that the mod authors provide patches, list is here:

https://github.com/harveyt/reviva/blob/main/README.md#dependency-summary

If anyone wants to help like this, I am very very happy to accept patches to Reviva, or alternatively help mod authors. 

On 5/29/2022 at 4:59 PM, theonegalen said:

So, WC 0.4 is going to be very different than previous versions. No custom "feet" variables, installed in a different place, different and better names for the interior spaces. If I get it ready, I'll make and submit a pull request to fix Reviva integration. :)

I'm very happy to see you active, now that, I guess, school is out or nearly out for summer! Looking forward to some Warbird cockpit improvements - they are very cool indeed.

I'm still playing UKS with BDB, KSRSS - with patches I posted, a lot of fun. Though I spotted you thinking about using something other than UKS... :confused:

Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)

@JonnyOThanhas released KSA IVA pack with Reviva support in that mod itself, with quite a few IVA for stock:

 

Mod authors who want to provide ModuleManager patches for Reviva can check out the action here:

https://github.com/JonnyOThan/KSA-IVA-Upgrade/blob/main/GameData/KSA/IVAUpgrade/Patches/Mk1_Pod.cfg

Note that this works because Reviva already provides the MM patches to set up switching for stock parts, there would be more MM magic required if it were a new part or one without Reviva support already. I can certainly help figure it out.

Edited by 610yesnolovely
Link to comment
Share on other sites

  • 3 months later...

0.7.6 Release - Moar IVA and BDB (24th Sep 2022)

Adds:

  • Support for:
    • Starilex Intra-Vehicular Solutions - an excellent retro Mk1 pod. Available for Stock Mk1 and BDB Hermes / Mercury CM. Uses RPM.
    • Max-Ksp MAS IVA Pack - excellent retro Mk1-3 and MEM pods. Available for Stock Mk1-3, Making History MEM, BDB Kane / Apollo, Sina / LEM. Uses MAS.
    • SABS_IVA: MAS-enabled IVA - partial support (it provides a full set of Stock and Making History pods using MAS) for Mk1, Mk2, Mk1-3, MEM and BDB equivalents. Uses MAS. These are work-in-progress, I may add configs for everything else later.
    • Snakeru's Mk2 Pod IVA - excelent retro style Mk2. Available for Stock and BDB Vinci / Gemini. Note that this is a ZIP file in a GitHub issue and is Beta, but to me is the best retro MAS style IVA for the Mk2.

 

Here's some pictures of the reason why I made this release, some decent retro style Stock / BDB command modules.

HUGE THANKS to @Ailex@Max-Ksp, @SingABrightSong, and @snakeru who did all the hard work of building these amazing IVA.

Starilex Mk1 / Hermes / Mercury

Mk1-Mercury-Starilex.png?raw=true

Snakeru's Beta MAS Mk2 / Vinci / Gemini

Mk2-Gemini-Snakeru.png?raw=true

Max-Ksp's MEM / Sina / LEM

MEM-LEM-Max-Ksp.png?raw=true

Edited by 610yesnolovely
Link to comment
Share on other sites

On 5/31/2022 at 9:30 AM, JonnyOThan said:

Hey, I was poking around some old mods and I noticed that Apex and Kermantech mk3 cockpits are not supported by Reviva.  Would you mind adding them?
 

Ah, I forgot about doing this. I will do this soon(ish), even though you basically did all the hard work. :-D

Link to comment
Share on other sites

Hey, I appreciate you responding to my posts on the BDB forum. Basically when I installed MOARdV to add screens to Tundra Exploration's Crew Dragon pod, it caused other parts mods that used RPM for their monitors to no longer function. The panels still showed up, but the screens were blank and the buttons had no functionality anymore. The only fix I could find was to change the jsitomasupgrade.cfg file to jsitomasupgrade.nocfg. That fixed the issue with the pods with broken screens, but I'm pretty sure it prevents some IVA mods from showing up properly in parts switch via Reviva. Some IVA's show up just fine, but others look exactly like stock or are largely blank.

Again, not convinced your mod is the root problem, even though it's a "technically" related issue.

Link to comment
Share on other sites

16 minutes ago, Blufor878 said:

Hey, I appreciate you responding to my posts on the BDB forum. Basically when I installed MOARdV to add screens to Tundra Exploration's Crew Dragon pod, it caused other parts mods that used RPM for their monitors to no longer function. The panels still showed up, but the screens were blank and the buttons had no functionality anymore. The only fix I could find was to change the jsitomasupgrade.cfg file to jsitomasupgrade.nocfg. That fixed the issue with the pods with broken screens, but I'm pretty sure it prevents some IVA mods from showing up properly in parts switch via Reviva. Some IVA's show up just fine, but others look exactly like stock or are largely blank.

Again, not convinced your mod is the root problem, even though it's a "technically" related issue.

Do you have both RPM and MAS installed? If not, that might be why. I don't have Tundra Exploration (shockingly - I've still got about 30 mods to install that might include that), so I've not seen that issue yet. It might be that some MAS IVA assume that only MAS is needed, and without that update script those components won't work. If you have RPM, then it might be because unless an RPM computer module is added to the IVA, it won't work. You can have both RPM and MAS running, but the IVA has to specify that: the only one I can think of that does that is the UltimateShuttle IVA.

I'm not sure otherwise, without actually trying this out. I face similar kinds of weird issues all the time with 250+ mods installed at once.

Edited by 610yesnolovely
Link to comment
Share on other sites

12 hours ago, 610yesnolovely said:

Do you have both RPM and MAS installed? If not, that might be why. I don't have Tundra Exploration (shockingly - I've still got about 30 mods to install that might include that), so I've not seen that issue yet. It might be that some MAS IVA assume that only MAS is needed, and without that update script those components won't work. If you have RPM, then it might be because unless an RPM computer module is added to the IVA, it won't work. You can have both RPM and MAS running, but the IVA has to specify that: the only one I can think of that does that is the UltimateShuttle IVA.

I'm not sure otherwise, without actually trying this out. I face similar kinds of weird issues all the time with 250+ mods installed at once.

I'm dumb, I didn't realize the IVA file you had linked is technically a separate addon from the main MOARdV release. I didn't have that particular IVA installed to begin with. My bad.

On the plus side, I don't think the modified cfg file is the culprit of any major issues. So we're looking good over here for now.

Edited by Blufor878
Link to comment
Share on other sites

15 hours ago, 610yesnolovely said:

 You can have both RPM and MAS running, but the IVA has to specify that: the only one I can think of that does that is the UltimateShuttle IVA.

And with that mod, the Retro IVA CRTs still don't work correctly. I've been trying to fix it off and on for months when I have the inclination and spare time, and have only partially succeeded.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...