Jump to content
  • 0

Moving around Space centre delay


jack186k
 Share

Question

8 answers to this question

Recommended Posts

  • 0

Mine does that too. Though usually after I've had it running for a day or so. After it crashes, a restart brings things into line.

But delays in launching are proportional to the size of craft. My standing record is about an hour, on a 30 kilo-part monster.

Edited by steuben
Link to comment
Share on other sites

  • 0
On 2/5/2022 at 3:07 PM, steuben said:

Mine does that too. Though usually after I've had it running for a day or so. After it crashes, a restart brings things into line.

But delays in launching are proportional to the size of craft. My standing record is about an hour, on a 30 kilo-part monster.

Thanks steuben,   but I  see this ~30s with something with 5 parts. It improves slightly if I quit and reload but soon reverts. I wondered if any settings I may have altered would affect it. Otherwise the game runs fine, but with this delay, and the necessity to warp-to-dawn half the time it makes popping back and forth to tweak, say, reluctant de-couplersa bit more tedious than I'd like.

Link to comment
Share on other sites

  • 0

When you hit the "launch" button in the editor, colliders and rigid bodys have to be loaded for every part, the UI and the entire physics simulation stuff has to be loaded too. The game does a lot of work loading all this stuff which might take some time. Do you have a rather slow PC?

Link to comment
Share on other sites

  • 0
On 2/5/2022 at 7:12 AM, jack186k said:

Why does it take so long to get from anywhere to anywhere at the space centre, eg  spaceplane hanger to runway ~30 seconds ?

It also depends on how many mods you have installed.  Even with one part, if you have a large number of mods installed, it can take time to switch scenes

Knowing the following would help:

  • System specs, including memory, cpu, gpu
  • Version of the game
  • Number of mods installed

And, while not absolutely necessary, a log file (Player.log) to see if you are having any issues

Link to comment
Share on other sites

  • 0
On 2/7/2022 at 8:12 AM, jack186k said:

Thanks steuben,   but I  see this ~30s with something with 5 parts. It improves slightly if I quit and reload but soon reverts. I wondered if any settings I may have altered would affect it. Otherwise the game runs fine, but with this delay, and the necessity to warp-to-dawn half the time it makes popping back and forth to tweak, say, reluctant de-couplersa bit more tedious than I'd like.

That's common with 85-120 mods, especially those with a lot of parts, or those that change/add to a lot of game mechanics or need to (re)build a bunch of configuration on scene changes.

Link to comment
Share on other sites

  • 0

 Thanks for replies,

Here are some details.
zero mods. did have 'landing height' and 'wind tunnel' but removed them to see if... but it wasn't.
craft consisting of one part (staypunik)
time from VAB to launch pad 33 seconds
time from VAB to space centre 10 seconds
time from  space centre tracking station 10 seconds
time from space plane hanger to runway 31 seconds

some specs
Display Adapter Radeon RX550/550 Series
OS Microsoft Windows 10 Pro
Processor AMD Ryzen 5 3600 6-Core Processor, 3600 Mhz
Installed Physical Memory (RAM)    16.0 GB
C Drive ADATA SX6000PNP 512.1 GB

game version 1.12.3.3173
 

I'd just like to know if this delay is normal or whether I have a problem.

Link to comment
Share on other sites

  • 0

upon investigation  closing/opening ksp cuts vab to launch from 30+ seconds to 5 seconds.  I'd like to know why.  if I monitor the pc during these 30s it doesn't seem to be doing anything, cpu of gpu. 

Link to comment
Share on other sites

  • 0
3 hours ago, jack186k said:

upon investigation  closing/opening ksp cuts vab to launch from 30+ seconds to 5 seconds.  I'd like to know why.  if I monitor the pc during these 30s it doesn't seem to be doing anything, cpu of gpu. 

Antivirus/defender and/or remote drive (gdrive or such)?

 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...