Jump to content

[1.12.x] Artemis Construction Kit | Stockalike Orion & SLS | v1.4.0 | (Lockheed lander!)


benjee10
 Share

Recommended Posts

22 hours ago, Kuiper_Belt said:

These Parts are Fantastic! I've been on a bit of a delta blue craze!

1khsmQS.jpg2JgEyZf.jpgDQMHHth.jpgVjXaAxr.jpgYetmjUI.jpg75nhKGh.jpg

Then some classic Orange SOFI:

wgxZ5XO.jpgzKxgI6f.jpgtaVEQcx.jpg

Magnificent work!

Did you make the RO configs yourself or did you find them elsewhere? (If so please point me in that direction pretty plz)

Edited by Emperor of Ilve
Accidently posted 3 times
Link to comment
Share on other sites

1 hour ago, Tundra said:

I'm having a strange issue with the BDB parts.  The cfg and the .mu are named the same thing, so I've had to change the names to get the parts to work.

Odd, not having the same issue. Do you already have BDB installed or are you using the BDB parts included here on their own?

Link to comment
Share on other sites

18 hours ago, biohazard15 said:

Speaking of ReDIRECT: what is safe to delete and what isn't if I want to retain only SOCK-specific parts (ET and SRB parts), at least until replacement comes in?

 

Also, some notes after flying Artemis 1 in KSRSS-Reborn (I've used included craft file):

- Orion-IPCS stack is somewhat too heavy for it (KSRSS, not SLS), IMO. IPCS alone can't perform TLI even with most of monoprop and ablator unloaded in VAB - you need extra push from Orion itself.

- Had a close call with aforementioned Orion when returning to Earth - I had barely enough monoprop for the final correction burn (LF and Ox were used for orbital insertion and return burn).

- Despite being all red, Orion handles reentry quite well with 540 units of ablator (it ate up all of it, though). 

You can remove everything in the Phase 2 and Phase 3 folders as that is just the Orion & Ares I parts. 

As others have mentioned, make sure you are flying the proper flight plan. IRL the parking orbit after core stage sep is 30km x 1800 km. In KSP 2.5x scale I balanced for around an 80km x 1800km orbit, and you should have about 300 m/s left in the tank after that. From there I can easily get to a low lunar orbit with ICPS and return with Orion's ESM, which is beyond the capabilities of the real spacecraft, so there shouldn't be any shortfalls. 

Also make sure you are using the stretched ICPS variant of the ICPS stage part, and do a clean reinstall (delete and re download) of Benjee10_Orion and rebuild any craft files. This will ensure you don't have any stats lingering from previous versions. 

17 hours ago, Adam-Kerman said:

So it appears that when load or revert to VAB, the Core stage options for different colors/skins isn't there

but do show on a fresh new core stage

 

Appears that it doesn't even seem to save skins chosen between VAB and Launch Pad (Katniss LC-39B)

Like chose white with grey raceway and it shows on Launch pad Orange

I can't replicate this. Do you have any repaint mods that might interfere with this? Is B9PartSwitch up to date?

7 hours ago, GoldForest said:

Also, @benjee10 could we get the original SLS paint scheme? The white metal or at least striped white sofi?

Also also, am I crazy, or is there no decoupler for the SRBs included in the mod, making us rely on ReDIRECT's decoupler?

Unfortunately the UV doesn't allow for the black and white texture, but you can approximate it with the white version and some judicious use of Conformal Decals. 

As others have mentioned, the decoupler should be included. Try a reinstall and if that doesn't work I'd be interested to see your KSP.log files to try and figure what's broken. 

2 hours ago, Tundra said:

I'm having a strange issue with the BDB parts.  The cfg and the .mu are named the same thing, so I've had to change the names to get the parts to work.

There is a MM patch that will disable the parts added in ACK if BDB is detected. They have the same name so that you can install/uninstall BDB without affecting vessels in flight. Make sure you have module manager installed and up to date.

Edited by benjee10
Link to comment
Share on other sites

If I try to combine adapters together (3.125-3.2 and 3.2-3.75), the game for some reason freezes. It's definetely not the intended use of the adapters, I just like to make frankencrafts, but I don't think this should happen anyway.

Link to comment
Share on other sites

3 minutes ago, nothingSpecial said:

If I try to combine adapters together (3.125-3.2 and 3.2-3.75), the game for some reason freezes. It's definetely not the intended use of the adapters, I just like to make frankencrafts, but I don't think this should happen anyway.

Can confirm, but at least it's something very oddly specific.

Link to comment
Share on other sites

6 hours ago, nothingSpecial said:

If I try to combine adapters together (3.125-3.2 and 3.2-3.75), the game for some reason freezes. It's definetely not the intended use of the adapters, I just like to make frankencrafts, but I don't think this should happen anyway.

6 hours ago, Blufor878 said:

Can confirm, but at least it's something very oddly specific.

Wow. This might take the prize for weirdest issue I've encountered. No idea what is going on here but will look into it. 

Just pushed some minor updates to the GitHub code:

  • 2.5m adapter was broken due to a file path error
  • Adjusted node position for the SRBs, so hopefully they should line up with the fore attach point on the core stage without needing any offsetting now
  • Removed Restock FX patch that was causing some users to have silent, FX-less boosters
Link to comment
Share on other sites

11 hours ago, benjee10 said:

Unfortunately the UV doesn't allow for the black and white texture, but you can approximate it with the white version and some judicious use of Conformal Decals. 

As others have mentioned, the decoupler should be included. Try a reinstall and if that doesn't work I'd be interested to see your KSP.log files to try and figure what's broken. 

I figured it out. So I had deleted the booster folder because I have Photoncorp installed, so the booster folder wasn't needed. But, I had an older version of Photoncorp, one that didn't have the radial decoupler, but I have updated Photoncorp and have it now. 

Link to comment
Share on other sites

It would be great if you could rebalance the capsule and SM parts so that the SM has more monopropellant than the capsule. I think 400 units in the smaller SM would be good. The COM is pretty far forward on the Constellation variant of the spacecraft, so if you could add more mass to the smaller SM, I'd really appreciate it.

Link to comment
Share on other sites

21 minutes ago, ninthninja05 said:

It would be great if you could rebalance the capsule and SM parts so that the SM has more monopropellant than the capsule. I think 400 units in the smaller SM would be good. The COM is pretty far forward on the Constellation variant of the spacecraft, so if you could add more mass to the smaller SM, I'd really appreciate it.

There is no Constellation variant in ACK. The small SM is for Orion Lite, a LEO oriented Orion.  The launch vehicle would have been an Atlas V 402, kind of like the Starliner Atlas V, but without any solid strap-ons. 

Edited by GoldForest
Link to comment
Share on other sites

L8SWfDT.png

jG4E7pQ.png

TXnQckM.png

ThW7vxs.png

ekPsRnu.png

Delta IV M+ 4,4 launching Orion Lite. 

@benjee10 Orion Lite may need some more balancing. I wasn't able to launch it with an Atlas V N02, which was said would have been the launch vehicle of Orion Lite according to an article I found. I even tried N22 like Starliner, and still nothing. 

Speaking of which, would it be possible to get an adapter to go from Orion to Centaur?

Also, ninthninja05 is right, the COM is way too forward on the Lite. 

Edited by GoldForest
Link to comment
Share on other sites

22 minutes ago, GoldForest said:

 

@benjee10 Orion Lite may need some more balancing. I wasn't able to launch it with an Atlas V N02, which was said would have been the launch vehicle of Orion Lite according to an article I found. I even tried N22 like Starliner, and still nothing. 

Speaking of which, would it be possible to get an adapter to go from Orion to Centaur?

Also, ninthninja05 is right, the COM is way too forward on the Lite. 

Worth noting I wasn't specifically trying to replicate Orion Lite (which is a very vague proposal at best), just trying to provide additional build options. The half-length SM has half of the resources, mass etc. as the full-length SM IIRC. Orion Lite was going to have a stripped down heat shield for LEO reentry so perhaps this is the cause of the balance issues? 

What size adapter would be needed for Centaur? 

2 minutes ago, nothingSpecial said:

Using Orion Lite most of the time, I wanted to ask what's the best placement of solar panels without clipping them into adapter.

I think GoldForest has them in a good spot, doesn't seem like they clip. Would you need to switch off the panel mount points as these are sized for the full length SM so wouldn't fit. 

Link to comment
Share on other sites

 

26 minutes ago, benjee10 said:

Worth noting I wasn't specifically trying to replicate Orion Lite (which is a very vague proposal at best), just trying to provide additional build options. The half-length SM has half of the resources, mass etc. as the full-length SM IIRC. Orion Lite was going to have a stripped down heat shield for LEO reentry so perhaps this is the cause of the balance issues? 

What size adapter would be needed for Centaur? 

I think GoldForest has them in a good spot, doesn't seem like they clip. Would you need to switch off the panel mount points as these are sized for the full length SM so wouldn't fit. 

Ah, perhaps. I keep forgetting how heavy the shields are. Perhaps pulling the mono out of the CM will also help. 

As for the adapter, 1.875 meters. Though, since Lite never got approved, I'm not sure how it would look like. I think a straight 3.125 fairing ring with a 1.875m connector inside it would look best, think Starliner. Actually, now that I think about it, I do have Boring Company installed. It has the Starliner adapter, I'm going to check it out and see if it works well.

Edit: So the Boring adapter is too small, but here's a picture to give you an idea:

y4VWWwF.png

34 minutes ago, nothingSpecial said:

Using Orion Lite most of the time, I wanted to ask what's the best placement of solar panels without clipping them into adapter.

There's very minor clipping the way I have it, but unless Benjee10 gives us a shorter panel variant, I found this is the best placement. There's like a ring that goes around the bottom of the SM. Line the bottom of the panel connector with the ring's bottom edge/line. Also turn off the panel supports like Benjee10 said. Some images to help:

TAEZP4h.png

z9hcLNl.png

4OL6Aeo.png

Edited by GoldForest
Link to comment
Share on other sites

13 hours ago, GoldForest said:

L8SWfDT.png

jG4E7pQ.png

TXnQckM.png

ThW7vxs.png

ekPsRnu.png

Delta IV M+ 4,4 launching Orion Lite. 

@benjee10 Orion Lite may need some more balancing. I wasn't able to launch it with an Atlas V N02, which was said would have been the launch vehicle of Orion Lite according to an article I found. I even tried N22 like Starliner, and still nothing. 

Speaking of which, would it be possible to get an adapter to go from Orion to Centaur?

Also, ninthninja05 is right, the COM is way too forward on the Lite. 

Man-rate the Delta IV right this instant!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...