Jump to content

[1.12.x] Parallax - PBR Terrain and Surface Objects [2.0.2]


Gameslinx
 Share

Recommended Posts

23 minutes ago, Clamp-o-Tron said:

No. KSP 1.3.1 is incompatible and unsupported by basically every mod currently being developed, nor will it ever be. There is very little reason for ANY modder to continue supporting it, as any plugins would need large changes and many shaders simply won’t work. If you want to mod KSP or play it at all, I would HIGHLY recommend you upgrade to 1.9.1 or 1.11.0.

Oh ok thanks. I have purchased KSP 1.10.1, but it is very slow on my pc. It takes about 3-4 min. to load without any mod, where as ksp 1.3.1 takes only 3 min to load WITH mods.

Link to comment
Share on other sites

1 hour ago, theleg said:

Does this work for KSP 1.3.1?

No. This mod is only for KSP 1.9 to 1.11. Anything below KSP 1.9 doesn't run on DX11 and the shader won't work

As a general update to all, Parallax will now force Vsync off during the loading screen. This improved loading times for me from 60 seconds to just 12. Keep in mind that normally Vsync is off during the loading screen, but one of Parallax's dependencies breaks this and causes load times to increase

The reason why Vsync is responsible: Whoever designed the loading system did it horribly, so KSP only loads one item loads per frame. Vsync caps the framerate at your monitor refresh rate (likely 60fps) which causes loading to take a lot longer. 

 

Edited by Gameslinx
Link to comment
Share on other sites

39 minutes ago, Circassian Operator said:

Hello can someone help me use Parallax because it's not working and yes I do have the dependincies I'm also using AVP

https://imgur.com/a/oLKQyJ4

did you install the textures for Parallax?  Maybe try getting it to work by its self before adding another texture mod.  I doubt AVP is compatible. 

Edited by eberkain
Link to comment
Share on other sites

2 hours ago, Gameslinx said:

The reason why Vsync is responsible: Whoever designed the loading system did it horribly, so KSP only loads one item loads per frame. Vsync caps the framerate at your monitor refresh rate (likely 60fps) which causes loading to take a lot longer. 

Little bit offtopic, but how does ksp work with variable rate monitors? My display goes up to 240Hz but is GSynced. Or does it not matter in anyway?

Link to comment
Share on other sites

4 hours ago, Gameslinx said:

No, but I wish I knew how to. Parallax loads the textures only for the current main body (what you're orbiting or landed on) whereas in the stock game, all the planets are loaded at once

Is the terrain texture loading process dissimilar to part loading?  I was thinking something analogous to ReStock's blacklist/whitelist system, or a patch that directs the game to a low memory dummy file with the same name.  I've been wondering what the Tracking Station Map View is using if the Parallax textures aren't all loaded at the same time - some kind of separate "preview" texture?

Link to comment
Share on other sites

2 hours ago, lrd.Helmet said:

Little bit offtopic, but how does ksp work with variable rate monitors? My display goes up to 240Hz but is GSynced. Or does it not matter in anyway?

It uses the max refresh rate available.

Source : I use a monitor with variable rate (freesync not gsync but same thing).

Link to comment
Share on other sites

2 hours ago, lrd.Helmet said:

Little bit offtopic, but how does ksp work with variable rate monitors? My display goes up to 240Hz but is GSynced. Or does it not matter in anyway?

Then your max refresh is 240hz. Since something is forcing Vsync on during the loading screen, you will load 240 things a second (at a maximum). Gsync won't make a difference to that

2 hours ago, KSPrynk said:

Is the terrain texture loading process dissimilar to part loading?  I was thinking something analogous to ReStock's blacklist/whitelist system, or a patch that directs the game to a low memory dummy file with the same name.  I've been wondering what the Tracking Station Map View is using if the Parallax textures aren't all loaded at the same time - some kind of separate "preview" texture?

The terrain textures are loaded during the main loading screen. There is no way for me to unload these as far as I'm aware. The tracking station view shows the scaled version of the planet maps - Parallax doesn't change these, so they're the stock textures

 

Link to comment
Share on other sites

15 minutes ago, Lijazos said:

When are you expecting to have the new update with collisions ready?

Sorry if it sounds pushy, it's not my intention! But I'm really hyped about it :)

I am also hyped, but it seems the author is doing really amazing things in really fast tempo.  I am sure its going to be updated as soon as he can.

Link to comment
Share on other sites

On 9/20/2020 at 12:22 PM, Gameslinx said:

Why are lots of lights laggy?

  • For some reason, KSP uses Unity's "Forward Rendering" path instead of the "Deferred Rendering" path. This means that for every pixel light in the scene, the tessellation is re-calculated. With lots of lights, this can add up very quickly. Until KSP moves to the Deferred rendering path, there is nothing I can do about this.

Is this why the performance is so bad at Woomerang?  There are 3 spot lights built into the buildings there. 

Link to comment
Share on other sites

@Gameslinx, I'm getting a repeating "NullReferenceException: Object reference not set to an instance of an object" associated with "at ParallaxShader.Position.Update" and "at ParallaxShader.Shader5.Update" while in the orbits of multiple planets, including Jool and Eve.  This is on KSP 1.11.0 (w/o expansions) with Parallax 1.1.1 and KopernicusBE111 R53 on Win10Pro 20H2.  I've saved a logfile, which I can provide (I'm going to try and save a shorter run, since pastebin has a low free upload limit), but it should be easy enough to replicate. 

EDIT: FYI, this NRE doesn't seem to be immediately debilitating, aside from rapidly spamming up the log file, but I haven't let the game run for hours in orbit to see if memory use starts creeping up.

Edited by KSPrynk
correction: not using expansions
Link to comment
Share on other sites

19 minutes ago, KSPrynk said:

FYI, this NRE doesn't seem to be immediately debilitating, aside from rapidly spamming up the log file, but I haven't let the game run for hours in orbit to see if memory use starts creeping up.

Known issue, already fixed :)

There is no harm to the save or game done by this NRE - It's a check I forgot to guard against 

Link to comment
Share on other sites

43 minutes ago, TinsellyCone241 said:

Sorry if this is a dumb question (I'm new to KSP), but what is Kopernicus and how do I install that?

it is a mod that allows other mods to make alterations to planets.  Assuming you are using the new 1.11 version you can look here.  https://github.com/R-T-B/kopernicus/releases

Link to comment
Share on other sites

28 minutes ago, eberkain said:

it is a mod that allows other mods to make alterations to planets.  Assuming you are using the new 1.11 version you can look here.  https://github.com/R-T-B/kopernicus/releases

Ok - so I installed that but I have a problem. When I loaded the game with Kopernicus and the Paralax mod. I got an error that says "Kopernicus was not able to load the custom planetary system due to an exception in the loading process. Loading your saved game is NOT recommended, because the missing planets could corrupt it and delete your progress." What do I do about that? It says to include the KSP.log, ModuleManager.ConfigCache and the folder Logs/Kopernicus/. Here is all that.

Edit: I know the recommended specs say a Core i9-9900K. I have an i5-8400 right now but will be upgrading to an i9-10900K soon.

Edited by TinsellyCone241
Link to comment
Share on other sites

19 minutes ago, TinsellyCone241 said:

I know the recommended specs say a Core i9-9900K. I have an i5-8400 right now but will be upgrading to an i9-10900K soon.

Those are not recommended specs! These are:

  • CPU: Parallax does not have much of a CPU impact, you'll be fine
  • GPU: NVIDIA GT 970M (or AMD equivalent)
  • RAM: 6GB
  • Shader model 5.0

You're missing Parallax itself. Please download it from the github - You need it for the stock textures to work

Link to comment
Share on other sites

Just now, Gameslinx said:

Those are not recommended specs! These are:

  • CPU: Parallax does not have much of a CPU impact, you'll be fine
  • GPU: NVIDIA GT 970M (or AMD equivalent)
  • RAM: 6GB
  • Shader model 5.0

You're missing Parallax itself. Please download it from the github - You need it for the stock textures to work

Oh! I saw the specs that the trailer was recorded on. I just kind of glanced over the specs because I figured I should be fine once I upgrade my CPU soon. Sorry about that. As for the problem: I downloaded the file from the github page (The one for stock textures) and opened the GameData folder in the zip file. I just copied everything in there to the GameData folder in the KSP directory. Is that how I'm supposed to do it?

Link to comment
Share on other sites

1 hour ago, TinsellyCone241 said:

Ok - so I installed that but I have a problem. When I loaded the game with Kopernicus and the Paralax mod. I got an error that says "Kopernicus was not able to load the custom planetary system due to an exception in the loading process. Loading your saved game is NOT recommended, because the missing planets could corrupt it and delete your progress." What do I do about that? It says to include the KSP.log, ModuleManager.ConfigCache and the folder Logs/Kopernicus/. Here is all that.

Edit: I know the recommended specs say a Core i9-9900K. I have an i5-8400 right now but will be upgrading to an i9-10900K soon.

Your log is the second I've seen like that.  It aparently happens with Parralax, and it flips out over of all things, Moho.

Any other mods?  I've got a few users with this issue and I've been unable to replicate.  I'd like to narrow it down.

That being said, we should probably move this over to the Kopernicus thread:

EDIT:  Just noticed, it looks like you maybe missed downloading Parallax itself, and just downloaded the textures?  Try installing this:

https://github.com/Gameslinx/Tessellation/releases/download/1.1.1/Parallax.1.1.1.zip

Edited by R-T-B
Link to comment
Share on other sites

5 minutes ago, R-T-B said:

Your log is the second I've seen like that.  It aparently happens with Parralax, and it flips out over of all things, Moho.

Any other mods?  I've got a few users with this issue and I've been unable to replicate.  I'd like to narrow it down.

That being said, we should probably move this over to the Kopernicus thread:

 

I do have other mods installed - I put more info on the other thread:

I am not sure if my post is there yet because I created an account just for this so I have less than 5 posts. Posts have to be approved by a moderator first.

Edited by TinsellyCone241
Link to comment
Share on other sites

10 hours ago, R-T-B said:

Your log is the second I've seen like that.  It aparently happens with Parralax, and it flips out over of all things, Moho.

Any other mods?  I've got a few users with this issue and I've been unable to replicate.  I'd like to narrow it down.

That being said, we should probably move this over to the Kopernicus thread:

EDIT:  Just noticed, it looks like you maybe missed downloading Parallax itself, and just downloaded the textures?  Try installing this:

https://github.com/Gameslinx/Tessellation/releases/download/1.1.1/Parallax.1.1.1.zip

Just saw your edit - that fixed it. Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...