Jump to content

[1.12.x] Parallax - PBR Terrain and Surface Objects [2.0.2]


Gameslinx
 Share

Recommended Posts

On 1/17/2022 at 8:15 PM, Gameslinx said:

Here's some more progress on the scatter system I'm working on. Over the last month I managed to get large scale objects working properly on Kerbin. I added some roses, daisies and ferns to go with them :)

unknown.png

unknown.png

KSP 2 in KSP 1…this is absolutely incredible work! Hopefully development is going well. :D

Link to comment
Share on other sites

On 3/25/2022 at 5:19 PM, Gameslinx said:

I am having no issue on the current version but I'm investigating why some people are having issues. Could you upload your KSP.log and your ParallaxGlobal.cfg? I'm trying to find differences between people's installs that could cause this

Here's my logs. I posted before saying I had a long string of NRE's but my post was missed, I'm assuming that's my issue.

KSP.log: https://drive.google.com/file/d/1hJPiSZD2BCnJ6zvXJXpC1GNThRL1A1QH/view?usp=sharing

player.log: https://drive.google.com/file/d/1CFMvDR993akLk0ONKjcWx5kvH4EJ1my9/view?usp=sharing

ParallaxGlobal.cfg: https://drive.google.com/file/d/1o_CtyveY6O-IXr54NjQtp9EF9z_jCUQx/view?usp=sharing

EDIT: Wrong link

Edited by RyGuy_McFly
Link to comment
Share on other sites

Hey all, back with another small update on the next update, along with some things I'm looking into. First up, I've been working on creating alien flora for Laythe. I've not finished all the objects I want to yet, but this screenshot was too good to pass up on!

78fHrU9.png

Once the scatters are mostly done, I want to look into optimizing the tessellation performance - potentially moving some of it to a compute shader to free up some CPU speed and reduce how many times per frame the GPU needs to tessellate. I'll be posting more updates as development continues. As always, I'm really looking forward to being able to share this with you all when it's done :) 

 

Link to comment
Share on other sites

24 minutes ago, Gameslinx said:

Hey all, back with another small update on the next update, along with some things I'm looking into. First up, I've been working on creating alien flora for Laythe. I've not finished all the objects I want to yet, but this screenshot was too good to pass up on!

78fHrU9.png

Once the scatters are mostly done, I want to look into optimizing the tessellation performance - potentially moving some of it to a compute shader to free up some CPU speed and reduce how many times per frame the GPU needs to tessellate. I'll be posting more updates as development continues. As always, I'm really looking forward to being able to share this with you all when it's done :) 

 

This looks amazing. Nice work! :o 

Link to comment
Share on other sites

Posted (edited)
7 minutes ago, TheDicko said:

anyone have any info on this? cant get parallax to work

I can't find a specific reason why it isn't working, since your install looks right. There are, however, some exceptions coming from Kopernicus that I don't normally see. Can you try reinstalling Kopernicus?

Secondly, make sure your terrain shader quality is set to Ultra in the main menu.

If you are still having problems, please send your KSP.log instead of your player.log

Edited by Gameslinx
Link to comment
Share on other sites

6 hours ago, Gameslinx said:

I can't find a specific reason why it isn't working, since your install looks right. There are, however, some exceptions coming from Kopernicus that I don't normally see. Can you try reinstalling Kopernicus?

Secondly, make sure your terrain shader quality is set to Ultra in the main menu.

If you are still having problems, please send your KSP.log instead of your player.log

Hi, thanks for the reply

I have installed kopernicus again from here https://github.com/Kopernicus/Kopernicus/releases/download/release-87/Kopernicus-1.12.1-87.zip

My terrain shader quality is set to ultra in the main menu

Here is my KSP.log https://www.dropbox.com/s/uyn80uwqtc3euro/KSP.log?dl=0

Here also is my parallax config. https://www.dropbox.com/s/g6q0hmw93e2jomz/ParallaxGlobal.cfg?dl=0

Note that i have previously installed parallax correctly about a year ago. This is a brand new installation with minimal mods, but i cant seem to get it working. Non of the planet surfaces look changed.

Edited by TheDicko
Link to comment
Share on other sites

3 hours ago, TheDicko said:

Hi, thanks for the reply

I have installed kopernicus again from here https://github.com/Kopernicus/Kopernicus/releases/download/release-87/Kopernicus-1.12.1-87.zip

My terrain shader quality is set to ultra in the main menu

Here is my KSP.log https://www.dropbox.com/s/uyn80uwqtc3euro/KSP.log?dl=0

Here also is my parallax config. https://www.dropbox.com/s/g6q0hmw93e2jomz/ParallaxGlobal.cfg?dl=0

Note that i have previously installed parallax correctly about a year ago. This is a brand new installation with minimal mods, but i cant seem to get it working. Non of the planet surfaces look changed.

Looks like you're missing some files:

[ERR 20:31:48.606] Unable to open archive file: C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/Parallax/Shaders/Wireframe-windows.unity3d
[ERR 20:31:48.606] Failed to read data for the AssetBundle 'Wireframe-windows.unity3d'.

Delete the Parallax folder and try to do a clean install again?

Link to comment
Share on other sites

3 hours ago, TheDicko said:

Note that i have previously installed parallax correctly about a year ago. This is a brand new installation with minimal mods, but i cant seem to get it working. Non of the planet surfaces look changed.

Thanks for the updated log. As for the reply above, the Wireframe shader is something I accidentally left in with this release, along with the "incorrect version". Neither of these will affect your install or game.

I'm seeing a lot of 

[Parallax Advanced Subdivision] Exception: I can't find enough nearby vertices :(

in your log, which indicates that Parallax is having problems finding nearby vertices in the terrain and can't subdivide it. If this stage fails, I believe the shader is not applied.

I haven't seen this error before from anyone else's install, so I'll need some extra information.  Is your terrain quality (not terrain shader quality) set to high? I believe this might be required, since it affects the quality of the terrain mesh. If it is set to high, can you tell me your craft's latitude and longitude on Minmus? Cheers

Link to comment
Share on other sites

On 4/1/2022 at 10:45 PM, Gameslinx said:

Hey all, back with another small update on the next update, along with some things I'm looking into. First up, I've been working on creating alien flora for Laythe. I've not finished all the objects I want to yet, but this screenshot was too good to pass up on!

78fHrU9.png

Once the scatters are mostly done, I want to look into optimizing the tessellation performance - potentially moving some of it to a compute shader to free up some CPU speed and reduce how many times per frame the GPU needs to tessellate. I'll be posting more updates as development continues. As always, I'm really looking forward to being able to share this with you all when it's done :) 

 

Never seen Laythe look so alive, looks more like a beachy Pandora then a grey/brown mesh.

Link to comment
Share on other sites

10 hours ago, Gameslinx said:

Thanks for the updated log. As for the reply above, the Wireframe shader is something I accidentally left in with this release, along with the "incorrect version". Neither of these will affect your install or game.

I'm seeing a lot of 

[Parallax Advanced Subdivision] Exception: I can't find enough nearby vertices :(

in your log, which indicates that Parallax is having problems finding nearby vertices in the terrain and can't subdivide it. If this stage fails, I believe the shader is not applied.

I haven't seen this error before from anyone else's install, so I'll need some extra information.  Is your terrain quality (not terrain shader quality) set to high? I believe this might be required, since it affects the quality of the terrain mesh. If it is set to high, can you tell me your craft's latitude and longitude on Minmus? Cheers

Hi thanks for your reply. Here are my settings, they appear to be correct. https://imgur.com/d7FElAZ

Not sure which of these numbers is lat and long, so ill print them as they appear in game

0° 0' 2" S

178° 3' 38" E

Hope this is what you are looking for, and thanks again for helping with this issue.

Edited by TheDicko
Link to comment
Share on other sites

2 hours ago, TheDicko said:

Hi thanks for your reply. Here are my settings, they appear to be correct. https://imgur.com/d7FElAZ

Not sure which of these numbers is lat and long, so ill print them as they appear in game

0° 0' 2" S

178° 3' 38" E

Hope this is what you are looking for, and thanks again for helping with this issue.

So ive just uninstalled all my mods, and installed only parallax and the issue still persists. Ive also reset the game settings and same again. Only thing i can think of is that parallax doesnt support 30 series cards? ( I have a rtx 3070ti) Anyone here using one of these cards and had success? Like i said earlier i had a previous install on an old pc with a gtx 1060 , and parallax worked fine

Link to comment
Share on other sites

Posted (edited)
1 hour ago, TheDicko said:

So ive just uninstalled all my mods, and installed only parallax and the issue still persists

I've just been to Minmus at those coordinates and it's working fine for me. One thing to note is that there isn't any displacement on Minmus' flats because they're, well, flat. It should look like this:

vx19INc.png

You will see displacement on the slopes and the highlands. If you still have doubts, try going to Duna or even Pol, which has a significant change. I think this is what it might be - I probably could have saved you some time had I remembered this earlier ;) 

Edit: Having an RTX 30xx won't affect you. I've seen some people using those cards without issue

Edited by Gameslinx
Link to comment
Share on other sites

It certainly does support Ampere cards.

Why not completely delete all your KSP Steam directory, revalidate the integrity of your game cache to reacquire all the game files creating a fresh Vanilla copy of 1.12.3, then use CKAN to install Parallax on this fresh install and see if it works for you?

This should be the cleanest way to verify that it is working.

Link to comment
Share on other sites

1 hour ago, Gameslinx said:

I've just been to Minmus at those coordinates and it's working fine for me. One thing to note is that there isn't any displacement on Minmus' flats because they're, well, flat. It should look like this:

vx19INc.png

You will see displacement on the slopes and the highlands. If you still have doubts, try going to Duna or even Pol, which has a significant change. I think this is what it might be - I probably could have saved you some time had I remembered this earlier ;) 

Edit: Having an RTX 30xx won't affect you. I've seen some people using those cards without issue

Hi, I will try this when I get home. I compared what my minmus looks like to this video 

and mine does not look anything like it. 

Link to comment
Share on other sites

7 minutes ago, TheDicko said:

Hi, I will try this when I get home. I compared what my minmus looks like to this video 

The textures were changed since that video. Matt landed in the highlands, which right now uses a similar texture but is much more subtle. Parallax's Minmus looks the most like the Stock Minmus out of all the changed planets

Link to comment
Share on other sites

47 minutes ago, Gameslinx said:

The textures were changed since that video. Matt landed in the highlands, which right now uses a similar texture but is much more subtle. Parallax's Minmus looks the most like the Stock Minmus out of all the changed planets

Maybe this is what i was getting hung up on. Perhaps its been working after all but my mind is used to an earlier version. Apologies for wasting all this time, i appreciate all of the replies.

Link to comment
Share on other sites

Some more testing in regards to the FPS issue in 3440 x 1440 (now on a RX 6800 !), @Gameslinx

I'm not sure what setting it is, or whether all the graphical mods on top of Parallax are the cause for this, but as you rightly wrote some days ago, the vehicle lights are the final nail in the coffin for the FPS.

So I played around with the pixel light count:

 

PLC: 0 | FPS: 55
PLC: 1 | FPS: 50
PLC: 2 | FPS: 41
PLC: 3 | FPS: 34
PLC: 4 | FPS: 30
PLC: 5 | FPS: 25
PLC: 6 | FPS: 23
...
PLC: 64 | FPS: 21

 

At PLC 0 (equals lights off), I get 55 FPS with the GPU running at only 70-80%. So the FPS are CPU limited there.

As soon as I add more pixel light counts the FPS quite quickly goes down the drain.

Weirdly, beyond a PLC of 6 it doesn't seem to get any worse. Why is that?

Edited by FasterThanFlourite
Link to comment
Share on other sites

21 minutes ago, TheDicko said:

Maybe this is what i was getting hung up on. Perhaps its been working after all but my mind is used to an earlier version. Apologies for wasting all this time, i appreciate all of the replies.

Can confirm  i had it working all along, it was the textures that were different to what i was used to. Version 1.2.3 appears to still work on the latest version of KSP, so ill be using that. Many thanks gameslinx and others for help.

Link to comment
Share on other sites

Posted (edited)
8 minutes ago, FasterThanFlourite said:

beyond a PLC of 6 it doesn't seem to get any worse. Why is that?

You might only have 6 lights on your craft, so you won't see an impact of a higher pixel light count until you add more.

Pixel lights refer to lights that are picked up by the Pixel Shader which is a shader stage that runs for every pixel on the screen. You can have two types of lights - Vertex lights and Pixel lights. Vertex lights are cheap, but much lower quality as they can't use normal maps to create realistic looking surfaces. Pixel lights are much better quality, but because the pixel shader stage runs much more often than the vertex shader stage, they are much more detrimental to performance. 

KSP is an old game, so it uses the Forward Rendering pass in Unity - this means the scene is re-rendered for every light. There is another rendering pass called "Deferred Rendering" which has negligible performance impact for each additional light, but Squad didn't choose this route. This is why games like No Man's Sky or other AAA games can get away with massive amounts of lights, but KSP slows down when using a mere few.

Edited by Gameslinx
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...