Jump to content

[1.12.x] Parallax - PBR Terrain and Surface Objects [2.0.2]


Gameslinx
 Share

Recommended Posts

44 minutes ago, ShadowZone said:

I love this mod.

Together with Scatterer and EVE (thanks @blackrack for keeping the development going!!!) this is now part of my permanent modlist for KSP.

I agree!! Lovely stuff, works like a charm too!! Thanks to all involved!

 

May I ask the community here what EVE configs they use?? The stock (Boulder Co) lacks many goodies that I got used to! And Parallax clashes with the other eyecandy packages I like to run.

 

Long story short, looking for nice EVE configs, stand-alone would be nice.

 

 

Again, thanks to the creator(s)!! Appreciate your great work!

Link to comment
Share on other sites

2 hours ago, Dafni said:

May I ask the community here what EVE configs they use?? The stock (Boulder Co) lacks many goodies that I got used to! And Parallax clashes with the other eyecandy packages I like to run.

 

Long story short, looking for nice EVE configs, stand-alone would be nice.

Firstly, that’s  probably a better question for the EVE thread. 

Secondly, I love Astronomers Visual Pack, it never fails to look phenomenal. 

Link to comment
Share on other sites

2 hours ago, Dafni said:

And Parallax clashes with the other eyecandy packages I like to run.

Which visual mods are incompatible with Parallax?

Link to comment
Share on other sites

1 hour ago, Spaceman.Spiff said:

Firstly, that’s  probably a better question for the EVE thread. 

Secondly, I love Astronomers Visual Pack, it never fails to look phenomenal. 

I could not get to run AVP along Parallax for some reason...

 

1 hour ago, Forked Camphor said:

Which visual mods are incompatible with Parallax?

I found all the packages that include surface textures to make my Parallax stop working...

 

could also be my limited understanding of how mods and configs play together.

Link to comment
Share on other sites

I just landed on Eve on my freshly restarted career. Mind blown, jaw dropped. Well played sir ! This is amazing. I wont spoil the thing (went there without looking at the trailer or anything) so the surprise is intact - it's all worth the trouble.

Link to comment
Share on other sites

13 hours ago, Gameslinx said:

Trees don't have colliders because there are some Kerbal Konstructs launch sites that don't remove objects using a MapDecal, so crafts would end up spawning inside trees when trying to launch. That would be frustrating

Could you maybe make this an optional setting? Tree collisions would be pretty entertaining.

Excellent work btw. I can't wait to give this new version a try!

33 minutes ago, Dafni said:

I could not get to run AVP along Parallax for some reason...

AVP should work... IIRC all I had to do was remove the city lights textures included with AVP, as they fight with the Parallax ground scatters. With that said, I haven't had a chance to test the new Parallax version yet.

1 hour ago, Forked Camphor said:

Which visual mods are incompatible with Parallax?

In my experience it's mainly planet packs (and I think planet rescales) that break it. TUFX can cause some visual artifacts on terrain, but you can get rid of that by disabling ambient occlusion in the TUFX config. I can't recall having major issues with anything else...

Link to comment
Share on other sites

3 minutes ago, anakinsolo said:

Does anyone have this same issue with ground texture?

 

Hi, reinstalling Scatterer will fix this for you.

The setting that is affected is "mergeDepthPrePass" which needs to be set to false. You can do this manually in the scatterer config, but reinstalling is often easier

Link to comment
Share on other sites

2 hours ago, fleventeen said:

Could you maybe make this an optional setting? Tree collisions would be pretty entertaining.

You can enable them yourself by adding collideable=true (I think) to the tree configs. I did this the other day then proceeded to crash into a tree trying to takeoff from a random place on kerbin.

Edited by blackrack
Link to comment
Share on other sites

so im having issues with galaxies unbound and parallax. my game loads properly but then it just stuck on this sun orbiting planets loading screen.  i've heard that parallax doesnt work with most of the planet packs. Will there be support for GU and/or other planet packs? if so, can i do something with it? maybe like create a config file?

Link to comment
Share on other sites

1 hour ago, Dreamanchik said:

so im having issues with galaxies unbound and parallax. my game loads properly but then it just stuck on this sun orbiting planets loading screen.  i've heard that parallax doesnt work with most of the planet packs. Will there be support for GU and/or other planet packs? if so, can i do something with it? maybe like create a config file?

Can I see a ksp log? And whats your mod list?

Link to comment
Share on other sites

1 hour ago, Dreamanchik said:

so im having issues with galaxies unbound and parallax. my game loads properly but then it just stuck on this sun orbiting planets loading screen.  i've heard that parallax doesnt work with most of the planet packs. Will there be support for GU and/or other planet packs? if so, can i do something with it? maybe like create a config file?

It is on the planet pack authors to support Parallax, so I would keep an eye over on the GU thread for updates.

The current advice is to roll back to the previous version of Parallax, because the configs need to be redone for 2.0 (I assume you are trying to use 2.0).

Link to comment
Share on other sites

I'm loving Paralax 2.0! This will be one I can't live without from now on. I'm trying to figure out how to use it with 10x sigma dimensions. It's clear from the initial post that some values need to change but I'm not sure if I'm changing the right ones

On 9/20/2020 at 6:22 PM, Gameslinx said:

Does this work with Rescale / Sigma Dimensions?

  • Yes, but check for configs as some values must be adjusted for things to look correct.

I tried increasing the density but for 10x scale this would require 100x density. Anything above 10 runs very slowly (running out of ram I think). Interestingly the game starts running slow when a save is loaded from the main menu rather than when a flight scene is loaded (which is where I expected the lag to start).

I thought that maybe decreasing the range and/or LOD range might be able to compensate, but it didn't seem to make any difference.

Does anyone know what settings to change to get a dense look with 10x scale? Or is this just impossible (stop playing 10x you weirdo)? :P

 

Link to comment
Share on other sites

Just a friendly reminder that it has only been days since the release of these scatters.

If you think developers can just set aside their lives to create unique scatters for their 20+ body planet pack, think again.

Remember that we are people too, and that rushed products never turn out well.

Edited by ballisticfox0
Link to comment
Share on other sites

58 minutes ago, ballisticfox0 said:

Just a friendly reminder that it has only been days since the release of these scatters.

If you think developers can just set aside their lives to create unique scatters for their 20+ body planet pack, think again.

Remember that we are people too, and that rushed products never turn out well.

video game players when the unpaid mod maker can’t churn out features and fixes at every whim (coding isn’t that hard just get better) :o
 

Anyway, Bit sad that you have to remind people about basic human decency

Link to comment
Share on other sites

7 hours ago, blackrack said:

You can enable them yourself by adding collideable=true (I think) to the tree configs.

Where are these tree configs located? I messed around a bit, but to no effect. 

3 hours ago, Dahbakon said:

Just to clarrify, has the 2.0 Update resolved the situation with city lights in EVE or is it still an issue?

It appears to be the same situation as before, however, I didn't have to remove the city lights textures to avoid clipping. Not entirely sure why.

Link to comment
Share on other sites

1 hour ago, fleventeen said:

Where are these tree configs located? I messed around a bit, but to no effect. 

Trees don’t have colliders at the moment because of conflict with KerbalKonstructs. Your craft could accidentally spawn inside of a tree and explode. 

Link to comment
Share on other sites

20 minutes ago, Socowez said:

Trees don’t have colliders at the moment because of conflict with KerbalKonstructs. Your craft could accidentally spawn inside of a tree and explode. 

I get that, but I am not using KK atm. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...