Jump to content

[1.12.x] Parallax - PBR Terrain and Surface Objects [2.0.2]


Gameslinx
 Share

Recommended Posts

7 hours ago, JonnyOThan said:

KK has a MapDecal feature for removing scatters.  That should work for parallax too.

Oh, I see. Thanks for letting me know about this, but how do I implement this?

Edited by iterationAstro
I forgot to quote previous message
Link to comment
Share on other sites

I am playing stock ksp with a bunch of mods. Yesterday I had a strange torque where my vessel perfectly symetrical wanted to point in a different direction like it had a phantom force.
in the log of main KSP directory I had tons of these: maybe its related:
[EXC 00:19:47.454] NullReferenceException: Object reference not set to an instance of an object
    Grass.BodySwitchManager.Update () (at <9c0f8064d71048f18e0c652f62c72a2c>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
maybe not.

Edited by Agustin
Link to comment
Share on other sites

21 hours ago, Agustin said:

Yesterday I had a strange torque where my vessel perfectly symetrical wanted to point in a different direction like it had a phantom force

This isn't caused by Parallax, since it doesn't directly influence any forces on the craft. There are some cases where crafts will do this in a normal KSP install, or if SAS was off make sure you reset the trim using Alt + X and it should go away.

As for the exception, it just happens on a scene change (if it was happening all the time do let me know how you got this to happen). It's just Parallax checking to see if the dominant main body changed

Link to comment
Share on other sites

1 hour ago, Gameslinx said:

This isn't caused by Parallax, since it doesn't directly influence any forces on the craft. There are some cases where crafts will do this in a normal KSP install, or if SAS was off make sure you reset the trim using Alt + X and it should go away.

As for the exception, it just happens on a scene change (if it was happening all the time do let me know how you got this to happen). It's just Parallax checking to see if the dominant main body changed

yeah the phantom force surely was because of some part clipping I assume. About the spam.. All I can tell you I was going to Duna half way. So I was on solar orbit when that spam happened, not even close to a planet. so.. I don't know. Also I modified the config so the distance of tesseleation was 70 instead of 50. I go it back to 50 now in case that was causing the spam?

BTW, can I use kerbal wheel and foundries mod? or it isn't compatible with the physics on rocks thanks.

Edited by Agustin
Link to comment
Share on other sites

16 minutes ago, Agustin said:

All I can tell you I was going to Duna half way. So I was on solar orbit when that spam happened, not even close to a planet. so..

This is a bug that was fixed in an update shortly after release. Can you make sure you're using the latest version?

Link to comment
Share on other sites

7 hours ago, Gameslinx said:

This is a bug that was fixed in an update shortly after release. Can you make sure you're using the latest version?

Yes I am sure I am running the latest super cool version. Of course. I installed it a couple of days ago.
If I run the issue again I will provide the logs.

Edited by Agustin
Link to comment
Share on other sites

Are the positions of rocks consistent? or does the procedural nature of it makes it so that it changes the place when you unload.. load saves say... ?
I ask because a streamer said he couldn't install the mods because it would crash all their ships and I told him that he could load them with collisions off and then move everything is there are any rocks and re enable collisions. But he said the rocks would spam in different locations which I am sure is not the case.

Edited by Agustin
Link to comment
Share on other sites

2 hours ago, TaintedLion said:

Does anyone have a new Parallax config for RSS yet?

Several people have been working on it, and I have a complete config for all the base RSS CBs myself, but I'm not interested in releasing it.  If you really want configs, it's trivially easy to learn the mechanics behind the configs but a bit tedious to make configs for all the CBs.

Link to comment
Share on other sites

On 10/17/2022 at 4:12 PM, Agustin said:

Are the positions of rocks consistent? or does the procedural nature of it makes it so that it changes the place when you unload.. load saves say... ?
I ask because a streamer said he couldn't install the mods because it would crash all their ships and I told him that he could load them with collisions off and then move everything is there are any rocks and re enable collisions. But he said the rocks would spam in different locations which I am sure is not the case.

the big collidable ones are consistent, the smaller ones not.

Link to comment
Share on other sites

1 minute ago, SiCaRiO31 said:

the big collidable ones are consistent, the smaller ones not.

oh okay but those are not collidable, right?. so no problem.
BTW, I was asking before if there was a conflict with kspwheel mod and foundries wheels and all that. It seems to work good.

Edited by Agustin
Link to comment
Share on other sites

On 10/17/2022 at 2:56 AM, GianFrank said:

How can i find the best value for SigmaDimensions 10x Kerbin?

To get the same Density on a 10x scale you would need to set the density multiplier to ~100  but putting it that high will most likely cause your game to not load anymore, how far you can actually push it depends on how powerfull your PC is.  It seems 40-45 is about the highest multiplier some people get away with.

Dont forgett to reduce the multipliers for range and long range, at the same time as you turn up the density, it will help to reduce stress on your machine.

 

Finding the best compromise between density and playability is pretty much a matter of Try & Error

Link to comment
Share on other sites

Hi everyone,
At first, many thanks for this mod :)This mod is really nice!
But I have several graphics issues with shadows on this mod on linux machine (nvidia 3070 with opengp 4.6) and some error in KSP.log
Graphics issues are not reproduced when I run the windows version over steam-proton, but it's not playable for me (KSP works very bad over steam-proton)


[ERR 09:43:15.530] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.532] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreeLOD
[ERR 09:43:15.533] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.534] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreeLOD2
[ERR 09:43:15.535] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.537] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreeLOD3
[ERR 09:43:15.537] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.539] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreesmooth
[EXC 09:43:15.541] MissingFieldException: Field 'KSPParticleEmitter.pe' not found.
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[LOG 09:43:15.542] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreesmoothLOD
[ERR 09:43:15.543] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.544] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreesmoothLOD2
[ERR 09:43:15.545] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

[LOG 09:43:15.546] Load(Model): Parallax_StockTextures/_Scatters/Models/Kerbin/flattreesmoothLOD2Optimized
[ERR 09:43:15.547] Texture 'Parallax_StockTextures/_Scatters/Models/Kerbin/gray' not found!

h3yMch0.png4PE7OxO.pngq4tGCJw.pngKvwhbEd.jpg

Link to comment
Share on other sites

For everyone having this problem with Kopernicus and Parallax 2.0:

Failed to load Body: Squad/Moho: Value cannot be null.

Don't use CKAN. Download and install Parallax manually from GitHub. The CKAN build seems to be broken as of right now.

Link to comment
Share on other sites

On 10/22/2022 at 9:00 AM, JavaSaBr said:

But I have several graphics issues with shadows on this mod on linux machine (nvidia 3070 with opengp 4.6) and some error in KSP.log

Thanks for reporting this. Sadly, there's not a huge amount I can do with Linux support at the moment. There are a bunch of limitations on OpenGL and it handles shaders a little differently. I still need to do a lot of research into why this happens, so I can't guarantee a fix soon

2 hours ago, Vaeliar said:

Don't use CKAN. Download and install Parallax manually from GitHub. The CKAN build seems to be broken as of right now.

Are you making sure you download all three files? Parallax Stock Textures, Parallax Scatter Textures and Parallax (Core)? Their names might vary on CKAN

Link to comment
Share on other sites

1 hour ago, Gameslinx said:

Thanks for reporting this. Sadly, there's not a huge amount I can do with Linux support at the moment. There are a bunch of limitations on OpenGL and it handles shaders a little differently. I still need to do a lot of research into why this happens, so I can't guarantee a fix soon

Are you making sure you download all three files? Parallax Stock Textures, Parallax Scatter Textures and Parallax (Core)? Their names might vary on CKAN

Yes. Parallax, Parallax Stock Textures, and Scatter Textures. With Kopernicus v139. Tried everything, only manually installing the core finally helped.

// Edit

I compared both Parallax files and they seem to be the same. Maybe CKAN installs it incorrectly? I've tried to reproduce it on a clean game installation with only Parallax + Textures, Kopernicus, scatterer and ModuleManager and the issue persists. If I remove the Parallax folder and replace it manually then it works. Weird stuff.

Edited by Vaeliar
more info
Link to comment
Share on other sites

Congrats on getting v2.0 out! If I wasn't burnt out or annoyed with this wretched, ill-begotten spaghetti mound of a game I'd have gone ham with this in Strange New Worlds. An alternative to LandControl and its laggy tyranny is more than welcome. The stock package manages to make the stock system look intriguing which is a laudable feat. Nicely done.

Link to comment
Share on other sites

7 minutes ago, Zaffre said:

The stock package manages to make the stock system look intriguing which is a laudable feat

And it would be able to look so much better if I was any better at modelling and texturing :valsad:

 

also what on earth is this emoji :valawe:lmao

Link to comment
Share on other sites

49 minutes ago, Gameslinx said:

And it would be able to look so much better if I was any better at modelling and texturing :valsad:

 

also what on earth is this emoji :valawe:lmao

It's more than fine as it is! Going further would be unnecessary, though I totally understand the commitment to vision. I was unfortunately not able to reach completely what I wanted with my own project. Sometimes you've  got to know when to hold and when to fold, even if begrudgingly.

Mmm. The 'new' kerbal emojis feel awkward. Renders have never been prime material for emoticons. The 90s and 00s taught us that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...