Jump to content
  • 0

KSP 1.12.3 will not start on Mojave


jora
 Share

Question

I have downloaded the zip of 1.12.3 for OS X.  It is completely unmodifed.  When I open the KSP.app application, I get a black screen with a orange rectangle down near the bottom.

I'm running Mojave.  I find no KSP.log file in the KSP_osx directory.

I have tried chmod-ing the KSP_osx directory and removing the unity saved state file.  Neither of which helped.

KSP 1.7.2 runs just fine on my machine.  My kid wants to upgrade to 1.12.3 though.  :shrug:

Any ideas?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 1

Here’s what works for me:

  • Open the KSP folder in a finder window.
  • Locate the KSP app.  This is the file you click on to run, and has a Kerbal icon next to it.
  • Drag that app file to the desktop, and drop it on the desktop.
  • Next, drag the file from the desktop back to the folder where KSP is located.  (Right back to where you found it..)
  • Double click the app, it should start just fine now.

You only need to do that the first time you run a new download of KSP, after doing that procedure once you won’t need to do it again.  I have no idea why this works.

Link to comment
Share on other sites

  • 1

@jora welcome to the forum. Try a different way of opening it, such as right clicking ksp.app and select "show package contents" from the right-click menu, and open the Unix Executable File "ksp" using terminal located in "ksp.app"->"contents"->"MacOS"->"ksp". I might be wrong, but if you downloaded ksp as a zip file (not the installer thing), I think what you described (the "black screen with an orange rectangle at the bottom") is a result of directly clicking the "ksp.app" and not following the aforementioned procedure. To be fair, I have no idea why that needs to be done (I'm not a computer scientist) but it worked for me (after a lot of trial and error) when I first started playing ksp a long time ago. By the way, have you downloaded and opened ksp v1.12.3 in the same way as  you did in v1.7.2? Hope this helps!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...