Jump to content
  • 0

Catastrophic KSP Mod issue I am unable to fix despite my efforts


Bug Report

Alright so this issue really became a problem after my game crashed. Before all this mess, I was running at least 56 mods (or files, not all of them were full mods, maybe like integrity things but nonetheless 56 files) all in tandem and without issue on a world. I've played like this for a couple months (since it wasn't too long ago, mid-late 2022 at least) and hardly anything ever went wrong, I'd like to note that all these mods were installed manually without CKAN. The crash started when I was time-warping my LH2 rocket to the dark side of Kerbin, 5-8 times Time Warp to see the EC usage when all of a sudden the values of usage skyrocketed (no pun intended), the last value I saw was NaN and it crashed after freezing for a couple seconds.

I took a week long break from KSP after that but when I returned, the game wouldn't load past the Internal file of the Mobile Processing Lab, it was stuck for 7 hours nonstop (because I overslept while waiting). I found out that some of the mods I had installed were able to load the game but when working with some other mods I had before, would not load any further. Very rarely, it would even be unable to load certain aspects of a mod (real example; Heat Control Radiator not loading). So I ended up removing one mod at a time, if the added mod wasn't loading the game then I got rid of some of the files of that mod and introduce them one by one until I found the file that was the issue. This did seem to work but when I added a mod it, something happens and a mod that I haven't tampered with which either I already fixed or wasn't a problem, stopped loading.

This issue persisted for a week, without consulting anyone for advice yet, I've completely removed all the mods and resorted to CKAN to download what I needed. I tried with RSS and it worked so it proves that mods can still be used but when I tried creating a new world (Kerbol not RSS), it wouldn't get past the loading screen and it was only blackness.  


Before using CKAN I was using mods of old versions but the game did not report any issues with it, and before the crash, was able to use them in tandem very well. Some are 1.10, 1.11, and 1.12. Mods that were giving me a headache were mainly ScanSat and SSTU.

I've tried searching online for possible answers but I wasn't able to find anything, if anyone knows what's going on here, or by some miracle, a solution to revert it to normalcy, I'd greatly appreciate it, please, thank you. I'll try my best to supply more info.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this report...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...