• 3
Sign in to follow this  
sal_vager

The Linux compatibility thread!

Question

  • 0

Start KSP the right way with voidi's installation script, just click here!

(Direct link to script)

KSP for Linux from the Squad store comes as a zip file and can be unzipped to any folder in your home directory, it does not need root privileges but the binary files (KSP.x86 and KSP.x86_64) may need to be set as executable.

KSP for Linux from Steam is installed to the normal Steam games folder on your system.

Supported Systems

Officially, the Unity Game Engine supports Ubuntu from 12.04 onwards, older versions may fail to run KSP as they may be missing dependencies that they cannot install, and other flavours of Linux may also struggle a bit.

Please note that just because Unity (and KSP) do not support other distro's, does not mean KSP won't work, but also just because it works on Distro X doesn't mean it'll work on yours.

Using the ldd command I have this list of dependencies required by the KSP.x86 in Xubuntu 14.04:


linux-gate.so.1 => (0xf770f000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf75f8000)
libGLU.so.1 => /usr/lib/i386-linux-gnu/libGLU.so.1 (0xf7580000)
libGL.so.1 => /usr/lib32/nvidia-331/libGL.so.1 (0xf7478000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7340000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf7328000)
libXcursor.so.1 => /usr/lib/i386-linux-gnu/libXcursor.so.1 (0xf7318000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7310000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf72f0000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf72e0000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7298000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7278000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf70c8000)
/lib/ld-linux.so.2 (0xf7710000)
libnvidia-tls.so.331.38 => /usr/lib32/nvidia-331/tls/libnvidia-tls.so.331.38 (0xf70c0000)
libnvidia-glcore.so.331.38 => /usr/lib32/nvidia-331/libnvidia-glcore.so.331.38 (0xf4e78000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf4e50000)
libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xf4e40000)
libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xf4e38000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf4e30000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf4e28000)

And these for the KSP.x86_64

	linux-vdso.so.1 =>  (0x00007fffd9400000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f0f7b3d8000)
libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f0f7b168000)
libGL.so.1 => /usr/lib/nvidia-331/libGL.so.1 (0x00007f0f7ae30000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f0f7aaf8000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f0f7a8e0000)
libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f0f7a6d0000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f0f7a4c8000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f0f7a2a8000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f0f7a0a0000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f0f79d98000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f0f79b80000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f0f797b8000)
/lib64/ld-linux-x86-64.so.2 (0x00007f0f7b700000)
libnvidia-tls.so.331.38 => /usr/lib/nvidia-331/tls/libnvidia-tls.so.331.38 (0x00007f0f795b0000)
libnvidia-glcore.so.331.38 => /usr/lib/nvidia-331/libnvidia-glcore.so.331.38 (0x00007f0f76da0000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f0f76b80000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f0f76970000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f0f76768000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f0f76560000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f0f76358000)

If you are using a 64bit distro you may need the 32bit libraries, you can install them on a Debian based distro using ":i386" after the package name.

Here's an example for the Mesa driver "sudo apt-get install libgl1-mesa-glx:i386"

Edited by sal_vager

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Regex, you can enable verbose mode in the settings.cfg and that may add some more info, otherwise there should be something in the player.log as it's more complete then the ksp.log

player.log is what I'm looking at. I'll try verbose mode, but it doesn't seem to be a Unity or KSP problem.

Share this post


Link to post
Share on other sites
  • 0
MeCripp, can you post the full player.log after one of these crashes please?

Regex, you can enable verbose mode in the settings.cfg and that may add some more info, otherwise there should be something in the player.log as it's more complete then the ksp.log

This is the only log, I can fine https://dl.dropboxusercontent.com/u/72893034/KSP.log.zip

EDIT- Thats a install that, I test in it's all stock but MM and forgot 1 cfg and to clear MM save.

Edited by Mecripp2

Share this post


Link to post
Share on other sites
  • 0

There's a nullref near the end MeCripp, can you find your player.log? It's in "/home/user/.config/unity3d/Squad/Kerbal Space Program"

Share this post


Link to post
Share on other sites
  • 0
There's a nullref near the end MeCripp, can you find your player.log? It's in "/home/user/.config/unity3d/Squad/Kerbal Space Program"

I dont see that path anywhere, I have looked the 2 places that come close don't have .config

Share this post


Link to post
Share on other sites
  • 0
*Regex, you can enable verbose mode in the settings.cfg and that may add some more info, otherwise there should be something in the player.log as it's more complete then the ksp.log

Thanks for that. Happened right before the crash:

RenderTexture.Create failed: format unsupported.

Installed libtxc-dxtn-s2tc0, no help. This helped, though! Intel 4600 card, go figure.

Time to see how badly I can lag this machine out with my mod collection. Thanks for the help! Would rep again but ~these forums~

Share this post


Link to post
Share on other sites
  • 0
I dont see that path anywhere, I have looked the 2 places that come close don't have .config

files and directories starting with a dot are hidden per default on linux. Just copy "~/.config/unity3d/Squad/Kerbal Space Program" into whatever explorer-analogue you use. Or a shell. In the latter case, you will want to include the quotation marks, or it will break on the spaces.

Share this post


Link to post
Share on other sites
  • 0
files and directories starting with a dot are hidden per default on linux. Just copy "~/.config/unity3d/Squad/Kerbal Space Program" into whatever explorer-analogue you use. Or a shell. In the latter case, you will want to include the quotation marks, or it will break on the spaces.

Is there a setting that, I can change to show this files ? I need a Linux for Dummy Book.

EDIT- Thanks sal_vager but ALT+H brings up help but that did show me how lol CTRL+H will show hidden files next time, I launch will send log thanks again for the help, And Garek

Edited by Mecripp2

Share this post


Link to post
Share on other sites
  • 0

Regex, I'm just glad I could help :)

MeCripp, the log says you're using Ubuntu, so if that's true you can press alt+H to hide/unhide files if I remember correctly (Xfce user here, thunar not nautilus), otherwise there should be the option in the file viewer to show hidden files :)

Share this post


Link to post
Share on other sites
  • 0
Regex, I'm just glad I could help :)

MeCripp, the log says you're using Ubuntu, so if that's true you can press alt+H to hide/unhide files if I remember correctly (Xfce user here, thunar not nautilus), otherwise there should be the option in the file viewer to show hidden files :)

Found it, I think https://dl.dropboxusercontent.com/u/72893034/Player.log.zip

Share this post


Link to post
Share on other sites
  • 0

There's a segfault, it might be caused by the addons or the graphics card, Intel cards always seem to have problems with KSP.

Can you test with no addons at all, and if there's still trouble you could try the fix here, back up the binary first though.

Share this post


Link to post
Share on other sites
  • 0
There's a segfault, it might be caused by the addons or the graphics card, Intel cards always seem to have problems with KSP.

Can you test with no addons at all, and if there's still trouble you could try the fix here, back up the binary first though.

The only addon is ModuleManager.2.1.5 will take it out and see and see if, I can Dummy my way through that patch.

EDIT- Have notice that, I don't see the re-enter FX but thats about the time it shuts down.

Edited by Mecripp2

Share this post


Link to post
Share on other sites
  • 0

That's a good clue actually, Intel cards struggle with the re-entry shaders as the driver can't currently handle them, try disabling atmospheric effects in the settings screen :)

Share this post


Link to post
Share on other sites
  • 0
That's a good clue actually, Intel cards struggle with the re-entry shaders as the driver can't currently handle them, try disabling atmospheric effects in the settings screen :)

Not sure what that set is but must have got it there was a Fallback part shader was set false turned it to true and Aerodynamic FX turned it down to

Minimal and all works now Thanks for the help woohoo can land Kerbals again :D

EDIT- guessing it was ( Aerodynamic FX ) ?

Share this post


Link to post
Share on other sites
  • 0

Yeah it was most likely the aero fx, the hair shader used to render it is not available on all cards/drivers.

Share this post


Link to post
Share on other sites
  • 0

Unfortunately the Unity editor won't work in Linux or Wine, it only runs properly on Windows and OSX.

Share this post


Link to post
Share on other sites
  • 0

You can make parts in most 3D editor software, I like to use Blender but everyone has their own preferences :)

Share this post


Link to post
Share on other sites
  • 0
What's the new offset for version 0.24?

So far I have not needed the offset. Don't tell me it is fixed?!!

The modifier key has been changed to the Windoze standard Alt key. At first I thought this was mostly a good thing but I subsequently found that some Alt-key combinations clash with my window manager assignments (notably Alt-f5 which opens my system menu). I have now edited the settings.cfg file in the KSP folder to read...

MODIFIER_KEY
{
primary = LeftAlt
secondary = RightShift
group = 0
switchState = Any
}

Now I have the old right-shift key function back. Best of both worlds.

I cannot find a key assignment option for the modifier key in the in game settings for "input". Perhaps it could be added in 0.25 :)

Enjoying version 0.24 very much. Thank you Squad.

Share this post


Link to post
Share on other sites
  • 0
So far I have not needed the offset. Don't tell me it is fixed?!!

You mean the 'enable shadows'? It's not fixed for me :(

Going to try messing with the old fixes for enabling shadows and fx and see what happens.

Share this post


Link to post
Share on other sites
  • 0
What's the new offset for version 0.24?

If MikeAeronautLZ's signature from here (01 00 00 00 b8 01 00 00 00 c3 41 56 41 55 49) holds up, the new offsets are 0099F587 and 0099F58C.

Can someone who actually knows what he/she is doing double check that?

Share this post


Link to post
Share on other sites
  • 0

According to the changelog the re-entry effects shader was fixed for Linux.

As for the alt-keys clashing with your desktop manager, most desktop managers let you define exceptions for programs to not intercept their keys.

Share this post


Link to post
Share on other sites
  • 0

I've just copied the settings over from my .23.5 install, so I don't plan on even trying to use alt as the modifier. Why would you do that when practically every desktop environment on Linux uses it?

Edited by chrt

Share this post


Link to post
Share on other sites
  • 0
According to the changelog the re-entry effects shader was fixed for Linux.

It may not crash any longer on re-entry effects but they do not work like before. Now all I get is a red glow around the parts instead of the actual dynamic flames that used to appear :(

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this