Snjo

Firespitter propeller plane and helicopter parts v7.1 (May 5th) for KSP 1.0

Recommended Posts

So you are overriding it, but you're also not overriding it? I might try saving the current time of the clip (in AnimationState) with public override void OnSave() and then loading that with OnLoad() in conjunction with setting playAutomatically to false in OnStart; It should have a similar effect with less weirdness.

Edit:

Here's more reference pages:

Animation

AnimationState

Yeah, I 'm not touching the playAutomatically, but I'm also making it irrevlevat, I think. The fact that it was brought up means I may not have been successful.

Each update the current animation time and speed is saved to a persistent variable, so I don't have to handle the onsave and onload.

I have a question. What's the node on-top the K17 Flying House for?

For whatever you like. Maybe you have a nice gun to mount there. Maybe some science equipment. Maybe this guy:

66FogWc.png

Share this post


Link to post
Share on other sites
Yeah, I 'm not touching the playAutomatically, but I'm also making it irrevlevat, I think. The fact that it was brought up means I may not have been successful.

Each update the current animation time and speed is saved to a persistent variable, so I don't have to handle the onsave and onload.

I'll look at your code and see how it works in-game and then make a better judgement, but if you've got a persistent variable then it should be working fine... :confused:

I doubt I'll have time tomorrow but I can throw some code together for what I'm thinking and experiment with that along with yours.

Share this post


Link to post
Share on other sites

I see you still haven't got to work on the bomb bay and Lazor System did the RC thing.

Share this post


Link to post
Share on other sites
I see you still haven't got to work on the bomb bay and Lazor System did the RC thing.

Now that I've gotten my animation module up and running I can do the bomb bays right, with the option of opening it in the hangar for placing stuff inside, but having it closed on launch.

Share this post


Link to post
Share on other sites

There is a stock animation module. What do you think is the solar panels are for if they always closed.

Share this post


Link to post
Share on other sites

Are you planning on releasing any documentation for FSengineSounds? my coding knowledge is basically non-existant, so I can not really see how the innards work. Although I can get engine sounds to play, I can not get them to alter pitch based on thrust.

Share this post


Link to post
Share on other sites

I cant say yet what it is but it has to do with personalkerbal flight ;) But its complicated to make an controller where the kerbal can activate an engine in eva i think :/hmm just an idea :)

Mach, he is working on this alone so dont rush him , be grateful he is making it work for the latest version =) Im sure he has plans for that but modding takes time so just have patience =)

Hahaha that little guy, i think its from the movie caddyshack which is hilirarous hahaha

Share this post


Link to post
Share on other sites
There is a stock animation module. What do you think is the solar panels are for if they always closed.

The main reason Snjo is using his own animation module is to animate the propellors on the engines correctly– the stock animation modules can either change the current time of the animation based on throttle or use a context menu and action groups to toggle it and make it go between the beginning and end. Propellors don't do that, they constantly rotate as long as the engine is active and throttled up, so he has to create his own animator to make the animations work in that way.

Share this post


Link to post
Share on other sites

OK, so I was a moron and didn;t see the pitch adjustment in FSengineSounds. Is there a way to turn off the engine sounds at 0 throttle though?

Share this post


Link to post
Share on other sites
OK, so I was a moron and didn;t see the pitch adjustment in FSengineSounds. Is there a way to turn off the engine sounds at 0 throttle though?

Not all features are done yet for the engine sound module, but it will all work very soon. The silence at low thrust thing is going to be controlled by a cfg setting.

So the documetation is this:

MODULE

{

name = FSengineSounds

//the names of the sound in the game database. Open the alt+f12 debug menu/sounds to seea list of loaded ones:

// any unnamed sound will be disabled, so just comment out the lines for the sounds you don't use.

//the engine start sound

engage = Firespitter/Sounds/sound_fspropstart

//the constant thrust independent background hum of an engine (unimplemented)

running =

// the thrust based pitched main engine sound

power = Firespitter/Sounds/sound_fspropidle

// the engine shut down sound (unimplemented)

disengage =

// loss of fuel flameout sound (unimplemented)

flameout =

// engine overheat warning sound

warning = Firespitter/Sounds/sound_fsheatDing

// the default pitch of the engine power sound. 1 is the same pitch as the original sound file.

powerPitchBase = 1.0

// how much above the default pitch the power goes based on thrust. final pitch = powerPitchBase + (thrust * thrustAddedToPitch )

thrustAddedToPitch = 1.0

// how quickly the engine power sound volume ramps up from silent when started. set to 1 for immediate full volume. This value is added to the volume every 0.2 seconds until it reaches 1.

powerFadeInSpeed = 0.005

// how long the volume is off after starting the engine, to allow the engage sound to be heard

powerFadeInDelay = 0.5

// thrust values below this level will yield a silent engine sound (not implemented)

powerLowerThreshold = 0.0

// volume adjustment for the power sound

powerVolume = 1.0

// volume adjustment for the engage sound

engageVolume = 1.0

// normalized engine heat value at which the warning sound chimes. set above 1 to disable (or don't name the sound of course)

warningSoundThreshold = 0.8

// how often the warning sound can play in seconds

warningCooldownTime = 2.0

// random start dealy for the power sound, to make several engines not play in sync. makes for a better soundscape.

randomStartDelay = 1.0 //for playing engines slightly out of sync

}

The unimplemented things might spawn some more variables, but probably just volume settings.

Edited by Snjo

Share this post


Link to post
Share on other sites
The Kraken appears to have some sort of grudge on the sea-plane bits.

Whenever I put them into orbit (I was trying to make an electric seaplane for futzing around on eve), they very promptly spaz out, and start flailing all over the place and 'bending' (well, the parts on screen look like they've separated and started moving around with a gap between them, but then they come back together and it repeats) nonstop, which sends the ship tumbling out of control. The parts of the carrying vehicle tear off before they sea-plane bits break up, though.

Additionally, any vehicle that is based on the sea-plane pontoon wheels (I was trying to roll a rocket-powered catamaran thing into the ocean at the end of the runway) also seems to have a decent chance of just instantly spazzing out and flailing around as soon as it finishes loading when launched...

Is there any way to fix this, aside from just not using those parts? Smaller things work well, but as I've mentioned, larger ones cause kraken-related issues.

I just put a rocket with floats into orbit with no ill effects. Can you post a craft file for one that fails, and describe your flight path?

edit:

well, no Ill effects until shortly after this when I "landed" with no parachute

Zwvk7u5.jpg

Edited by Snjo

Share this post


Link to post
Share on other sites

I'm slowly filling out a document to, eh, document the various FS modules' cfg values. If you use my modules for your own parts, you might want to bookmark this.

Let me know if you need a specific module documented.

Firespitter Module Documentation

Share this post


Link to post
Share on other sites

New version on Spaceport

Download

v5.1

-Bomb Bay (open the doors by clicking the part in the action group editor, for easier payload placement. A popup menu will appear)

-Fuel drop Tank

-The Electric helicopter rotor can now start deployed (by using the action editor popup in the hangar)

-Engines with reverse thrust capabilities can now set default state in the hangar action editor

-FSanimateGeneric, replacement module for ModuleAnimateGeneric.

(EVA toggle, custom speed, set start state in hangar, multiple animations per part)

-Bug fix: Wheel colliders spamming errors on launch

-Bug fix: GUI parts spamming nullrefs when launching from main menu directly to runway

(The drop tank texture isn't done yet, but there were some bugs I felt I had to fix)

FINALLY A BOMB BAY!

IoVpH3i.jpg

Edited by Snjo
action group editor details

Share this post


Link to post
Share on other sites

Bomb bay :D Haha sweet beans

edit

"-FSanimateGeneric, replacement module for ModuleAnimateGeneric.

(EVA toggle, custom speed, set start state in hangar, multiple animations per part)" SWEET thanks for this animation support

Share this post


Link to post
Share on other sites
New version on Spaceport

Download

v5.1

-Bomb Bay (open the doors in the action editor for easier payload placement)

-Fuel drop Tank

-The Electric helicopter rotor can now start deployed (by using the action editor popup in the hangar)

-Engines with reverse thrust capabilities can now set default state in the hangar action editor

-FSanimateGeneric, replacement module for ModuleAnimateGeneric.

(EVA toggle, custom speed, set start state in hangar, multiple animations per part)

-Bug fix: Wheel colliders spamming errors on launch

-Bug fix: GUI parts spamming nullrefs when launching from main menu directly to runway

(The drop tank texture isn't done yet, but there were some bugs I felt I had to fix)

FINALLY A BOMB BAY!

What's the Action Editor you refer to?

Share this post


Link to post
Share on other sites

Click the gear icon on the top of the window in the hangar. You get to the window where you can edit action groups.

If you click on a part I've also added some pop up menu choices to that.

Share this post


Link to post
Share on other sites

Just curious... what's the "gunnery Module" for? or is that some super secret Black kerbal stuff we will never see

Share this post


Link to post
Share on other sites

I just installed this mod and seem to be having trouble loading the sample helicopters and/or building them in the SPH or VAB. My game becomes unresponsive and the parts screen dissapears. I am running a completely stock updated Steam version of the game. I cleared out my KSP directory and completely reinstalled with only Firespitter mod, but still having the same issues. I am running Win7 X64. Any suggestions? If this isn't the correct place to post issues, please let me know where to go. Thanks!

Share this post


Link to post
Share on other sites

Just curious....

Has anyone tried building a bi-plane? Had the thought today but all my tests have been way off....but im not so good at makin planes.

Share this post


Link to post
Share on other sites
I just installed this mod and seem to be having trouble loading the sample helicopters and/or building them in the SPH or VAB. My game becomes unresponsive and the parts screen dissapears. I am running a completely stock updated Steam version of the game. I cleared out my KSP directory and completely reinstalled with only Firespitter mod, but still having the same issues. I am running Win7 X64. Any suggestions? If this isn't the correct place to post issues, please let me know where to go. Thanks!

I encountered the exact same problem.

Share this post


Link to post
Share on other sites
I just installed this mod and seem to be having trouble loading the sample helicopters and/or building them in the SPH or VAB. My game becomes unresponsive and the parts screen dissapears. I am running a completely stock updated Steam version of the game. I cleared out my KSP directory and completely reinstalled with only Firespitter mod, but still having the same issues. I am running Win7 X64. Any suggestions? If this isn't the correct place to post issues, please let me know where to go. Thanks!

I get the same error. One of the parts is bugging out.

Looking into it, and I will upload a patch as soon as I can.

I've taken the mod to private mode on spaceport while I investigate

Edited by Snjo

Share this post


Link to post
Share on other sites

Ok, I fond the bug and uploaded v5.1.1

This was the error

[KSPField(guiActive = false, guiName = "partDistance", isPersistant = true)]

//private float partDistanceFromVessel = 0;

I had commented out a variable, but not the KSPField value!

gah! Hard to find.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.