TriggerAu

[1.6.x] Kerbal Alarm Clock v3.10.0.0 (Dec 31)

Recommended Posts

Can the Altitude alarm not do this already? set to the edge of atmosphere for the target, or am I thinking of something else?

The altitude alarm does not do it automatically. Imagine you've a ship heading to Jool with an aerobrake already on your trajectory. You have SOI alarms and Atmosphere alarms set up to automatically trigger. You're futzing around on your Minmus base and Ping! You get an alarm. Jool SOI encounter. You "Jump To" it and follow the ship through the SOI. The moment the ship goes through the SOI, you get a new alarm for the atmosphere encounter.

Will an altitude alarm work? Sure. This would just be more convenient and smooth.

Share this post


Link to post
Share on other sites
The altitude alarm does not do it automatically. Imagine you've a ship heading to Jool with an aerobrake already on your trajectory. You have SOI alarms and Atmosphere alarms set up to automatically trigger. You're futzing around on your Minmus base and Ping! You get an alarm. Jool SOI encounter. You "Jump To" it and follow the ship through the SOI. The moment the ship goes through the SOI, you get a new alarm for the atmosphere encounter.

Will an altitude alarm work? Sure. This would just be more convenient and smooth.

thanks, was missing that automatic step in my head. I'll have a fiddle here with adding auto alarms if the flight path intersects the atmosphere on a body

Share this post


Link to post
Share on other sites
thanks, was missing that automatic step in my head. I'll have a fiddle here with adding auto alarms if the flight path intersects the atmosphere on a body

Sweet! One potential problem, it'd trigger as you're rising from the surface and just cross the atmo boundary, unless you somehow limit it to only count when you're in space.

Share this post


Link to post
Share on other sites

Everything works great, but the alarm sounds don't seem to work for me. Ideas on troubleshooting?

Share this post


Link to post
Share on other sites
Sweet! One potential problem, it'd trigger as you're rising from the surface and just cross the atmo boundary, unless you somehow limit it to only count when you're in space.

hehe, good point, will keep that in mind

Everything works great, but the alarm sounds don't seem to work for me. Ideas on troubleshooting?

I'd suggest trying to play the sounds from the settings and checking the logs for any errors. Feel free to share your log file - if you need help locating it then there are somegood tips in this post - http://forum.kerbalspaceprogram.com/threads/92229-How-To-Get-Support-%28READ-FIRST%29?p=1380976&viewfull=1#post1380976

Share this post


Link to post
Share on other sites

Hello!

I'm having a problem with Kerbal Alarm Clock. Everything works fine and looks good but the warp option.

No matter how I configure it; the alarm goes off and a message appears, but no sound and---most importantly---the warp is not automatically stopped. This has caused my ships to miss some transfer windows. I already tried reinstalling and deleting the folder and installing again. I'm using the latest version. With previous one this did not happen, but I started to notice recently because of new savegame.

Could this be a bug? Thanks in advance!

Share this post


Link to post
Share on other sites

Hmm, any chance of getting a little x in the upper right corner of the KAC window to close it? Its annoying having to go back to the toolbar to click the icon to close it.

Share this post


Link to post
Share on other sites
Can the Altitude alarm not do this already? set to the edge of atmosphere for the target, or am I thinking of something else?

I didn't know there was an altitude alarm. And to figure out what it was, I had to Ctrl-F your OP, and it turns out it's "target distance"-alarm, which does not seem very obvious to me.

Is it possible to somehow make it more prominent?

Share this post


Link to post
Share on other sites

I just started using Kerbal Alarm Clock and already love it. Thx for making it! :)

Share this post


Link to post
Share on other sites

Hey - has anyone seen issues with KAC where only the first alarm counts down? This is driving me nuts right now.

I think it might be related to EPL build alarms that get automatically added and removed.

Share this post


Link to post
Share on other sites

Mod works great for me, except when I try to use it to calculate transfer windows to any of the planets contained in the outer planets mod (Sarnus, Urlum, Neidon, and Plock). All I get for each of them is a "no future model data" message under the "time to transfer" column. Anyone else experience this issue?

Share this post


Link to post
Share on other sites
So no bugs reported means this will just run fine under 1.0.5? :)

I haven't seen any issues.

Try it out and see if it works. If it doesn't, just uninstall it.

Share this post


Link to post
Share on other sites

Working fine for me.

Share this post


Link to post
Share on other sites

Seems like deleting KAC and trying to play 1.0.5 without it crashes the game a lot, so don't do that.

Share this post


Link to post
Share on other sites
Maybe I'll hold off a little before putting it into the gamedata folder then.

It should work fine. It's just that if you have a pre-1.0.5 save with KAC alarms, they might crash your game. It's silly but I think that's what is happening to me.

Share this post


Link to post
Share on other sites
It should work fine. It's just that if you have a pre-1.0.5 save with KAC alarms, they might crash your game. It's silly but I think that's what is happening to me.

Okay then.

Edit: I'm periodically getting this exception, looks like something related to VOID, which I don't have.



11/15/2015 4:54:09 PM,KerbalAlarmClock,Searching for VOID

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

11/15/2015 4:54:09 PM,KerbalAlarmClock-VOIDWrapper,Attempting to Grab VOID Types...

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

NullReferenceException: Object reference not set to an instance of an object
at KerbalAlarmClock.KerbalAlarmClock.UpdateDetails () [0x00000] in <filename unknown>:0

at KerbalAlarmClock.KerbalAlarmClock.RepeatingWorker () [0x00000] in <filename unknown>:0

at KSPPluginFramework.MonoBehaviourExtended.RepeatingWorkerWrapper () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at KerbalAlarmClock.KerbalAlarmClock.UpdateDetails () [0x00000] in <filename unknown>:0

at KerbalAlarmClock.KerbalAlarmClock.RepeatingWorker () [0x00000] in <filename unknown>:0

at KSPPluginFramework.MonoBehaviourExtended.RepeatingWorkerWrapper () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Edited by smjjames

Share this post


Link to post
Share on other sites
I'm working the KER issue atm, so will also check on that one too - I dont thnk its void related as thats all well wrapped with error handling, and not done in the UpdateDetails method. I assume its happening when you change scenes yes?

Also looking at the 1.0.5 stuff

Share this post


Link to post
Share on other sites
[quote name='TriggerAu']I'm working the KER issue atm, so will also check on that one too - I dont thnk its void related as thats all well wrapped with error handling, and not done in the UpdateDetails method. I assume its happening when you change scenes yes?

Also looking at the 1.0.5 stuff[/QUOTE]

Hi TriggerAu,

Love your mods. Looking forward to the pending KAC update. Have there been any other 1.0.5 issues reported, aside from trouble loading pre-1.0.5 savegames that have Kerbal Alarm Clock alarms set?

What's the KER issue? Something to do with Kerbal Engineering Redux?

Cheers!

Share this post


Link to post
Share on other sites
[quote name='TriggerAu']I'm working the KER issue atm, so will also check on that one too - I dont thnk its void related as thats all well wrapped with error handling, and not done in the UpdateDetails method. I assume its happening when you change scenes yes?

Also looking at the 1.0.5 stuff[/QUOTE]

It mostly happens when launching from the editor, and possibly launching from KSC view. So, yeah, some scene changes but not all.

Share this post


Link to post
Share on other sites
I hope the revision is going well. My program is lost without Kerbal Alarm Clock. Good luck; safe travels.

Share this post


Link to post
Share on other sites
[quote name='DunaticFringe']I had a contract to plant flag on the Mun. Already did it before, but contract came afterwards. No problem with the mission. It was the first time using a two-seat lander on the Mun. Nice compact design with at least 350dV after landing and returning to orbit. Was able to get around 550 science so I was able to unlock more parts.
[/QUOTE]

That's pretty cool, and nice screenshots, but what does it have to do with Kerbal Alarm Clock? Did you use it to plan your Munar injection burn?

Share this post


Link to post
Share on other sites
[quote name='Dweller_Benthos']That's pretty cool, and nice screenshots, but what does it have to do with Kerbal Alarm Clock? Did you use it to plan your Munar injection burn?[/QUOTE]

Oops!! I just noticed that I posted in the wrong thread. I wanted to post in the "What did you do in KSP today?" thread. Thanks for letting me know. Post moved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now