TriggerAu

[1.7.x] Kerbal Alarm Clock v3.11.0.0 (Sep 1)

Recommended Posts

Ok, so I upgraded from v2 to this latest release and Alarm Clock now disappears in-game. According to the log, it loads successfully. However, I can no longer find its icon in the toolbar so I can't enable it. What can I try?

Share this post


Link to post
Share on other sites
Congratulations TriggerAu on your new ( hopefully paid ) Squad position as Assistant QA Manager!

You're an asset.

Thanks Aethon, one day I hope to be paid for having fun :)

PS. some people leave the last couple of letters off asset

Is it in the stock toolbar?

What he said... thanks Master Tao

Share this post


Link to post
Share on other sites
Thanks Aethon, one day I hope to be paid for having fun :)...

Be careful what you wish for - it stops being fun after 10 years or so, then the only think you're left with is all that money :-(

(Spent 10 years being paid to bum-around on yachts after 20 years inventing software, after 5 years playing soldiers).

[Yeah, ok, so it isn't the worst thing that can happen!]

Congratulations :-)

Share this post


Link to post
Share on other sites
Be careful what you wish for - it stops being fun after 10 years or so, then the only think you're left with is all that money :-(

(Spent 10 years being paid to bum-around on yachts after 20 years inventing software, after 5 years playing soldiers).

[Yeah, ok, so it isn't the worst thing that can happen!]

Congratulations :-)

I'd be willing to give it a try I think :)

Thanks

Share this post


Link to post
Share on other sites
Found whats throwing that error and fixed it in Tarsier. The alarms seem to load OK in my game, but they didnt disappear every time before either -

Will look a bit more later. If you dont mind sharing a save file that has the problem with both mods installed that might help me test my pull request for updating Tarsier more (https://github.com/tobyb121/TarsierSpaceTechnology/pull/1 . )

I would but I've already wiped out all my previous saves when I was troubleshooting the issue so I don't have one to upload anymore. I do still have the original mod files that I downloaded and KSP hasn't been updated yet so I could try and replicate it again when I get some time.

Share this post


Link to post
Share on other sites
I would but I've already wiped out all my previous saves when I was troubleshooting the issue so I don't have one to upload anymore. I do still have the original mod files that I downloaded and KSP hasn't been updated yet so I could try and replicate it again when I get some time.

Noprobs, if it happens again then just worry about it then. Spare time should be spent playing KSP

Share this post


Link to post
Share on other sites

Something I've noticed about KAC since I started playing in 0.23 and it's a minor niggle, but a niggle nonetheless.

KSP: 0.25 Winx86

Problem: Interaction between KAC and F2 (hide GUI) prevents on-rails timewarp behaving as expected

Mods installed:

KAC 3.0.1.0

Reproduction steps (ignore the A, B, C, D and bold for now):

Set KAC to automatically create alarms for manoeuvre nodes (say, a 3 minute margin, like mine now). Make a node on your orbit several minutes or hours ahead. A, Increase timewarp until B, KAC slows it down to trigger the alarm. Alarm triggers, you can C, increase timewarp to the node, whether you click the OK button on the alarm or not and KAC won't slow it down again - in other words, first, A will happen, then B, then C. This is expected. What is not expected is what happens when you hide the GUI with F2 - a continual loop of B->C->B->C etc etc. KAC and the user fight over whether the game should be increasing timewarp towards the node or decreasing it because the alarm has triggered. This only happens when you hide the GUI with F2.

It can be a little niggle if you have a long alarm margin (say, the default of 15 mins) or are trying to get a nice cinematic screenshot just before your burn and don't want "Time Warp x2(3,4,3,2,1,2,3,4 etc)" plastered across the screen. Granted, if Squad could hide that (and all the Transmitting Science and [F] Board texts) along with the rest of the GUI, that'd alleviate the problem somewhat, but there's still the fact that the user and KAC fight over timewarp when the GUI is hidden.

This can be more easily reproduced without user interaction with MechJeb and the node execution autopilot, specifically the Autowarp feature of it. MJ will increase timewarp until KAC slows it down to display the alarm, MJ increases timewarp, KAC immediately slows it down, MJ speeds it up etc etc.. I'l repeat, the GUI must be hidden for this to occur.

Share this post


Link to post
Share on other sites

Apologies if this was reported before and/or elsewhere.

I found out that if I have an asteroid that's being tracked by the Tracking Station setup with an SOI transition alarm (SOI transition into Kerbin from Kerbol), I can use that alarm to "Jump to Ship" and as a result jump straight to the asteroid. As the Tracking Station does not allow "Flying" an asteroid all on its own, I am going to presume this is unintended behavior.

Edited by King Arthur
I derp. Tracking Station, not Tracking Center. :P

Share this post


Link to post
Share on other sites
Apologies if this was reported before and/or elsewhere.

I found out that if I have an asteroid that's being tracked by the Tracking Station setup with an SOI transition alarm (SOI transition into Kerbin from Kerbol), I can use that alarm to "Jump to Ship" and as a result jump straight to the asteroid. As the Tracking Station does not allow "Flying" an asteroid all on its own, I am going to presume this is unintended behavior.

Actually its an option - you can choose to allow or not this behaviour as some people wanted it and others didnt. You can find the setting for it in the general section as seen here - http://triggerau.github.io/KerbalAlarmClock/manual.html#Settings-General

PS. It was unintended originally, but when I went to remove it was asked if it could stay :)

Share this post


Link to post
Share on other sites

Ah, so I've learned. I guess I should've read the documentation more carefully, I've been using KAC since before asteroids were implemented so I'd missed that option it would seem.

My apologies as it seems I'd taken up your time on a moot issue. Thanks for the great work you've done for all of us, KAC is one of those essential mods we can't live without once we have it.

Share this post


Link to post
Share on other sites
@TriggerAu, could I please ask you to set the required KSP version information on kerbalstuff.com? This would make packaging your mod for the Comprehensive-Kerbal-Archive-Network much easier :)

Happy to do that, but checking Kerbalstuff I have filled out all the fields I can relating to versions, etc. Is there something specific missing?

Share this post


Link to post
Share on other sites

Just for clarification, I can keep the settings.cfg file while replacing everything else when upgrading KAC, right? I looked through the documentation, but unless I missed it there were no specific instructions or notes for upgrades.

I only noticed now that KAC was up to 3.0.4.0, goes to show I shouldn't just be glossing over thread titles. :P

Share this post


Link to post
Share on other sites
Happy to do that, but checking Kerbalstuff I have filled out all the fields I can relating to versions, etc. Is there something specific missing?

Good question actually, the only difference I notice in your listings is that you entered "KSP Version: 0.25.0" in the version fields ( see the output on https://kerbalstuff.com/api/mod/231 ) and other mods have only a "0.25" there ( see the output on https://kerbalstuff.com/api/mod/275 )

I have opened up a bug ticket in the CKAN project, but it might be better if you fix the metadata on your side as well. The same issue would hit the Alternate Resource Panel as well, I guess.

Share this post


Link to post
Share on other sites
Just for clarification, I can keep the settings.cfg file while replacing everything else when upgrading KAC, right? I looked through the documentation, but unless I missed it there were no specific instructions or notes for upgrades.

I only noticed now that KAC was up to 3.0.4.0, goes to show I shouldn't just be glossing over thread titles. :P

I should have that in the docuemntation somewhere really shouldnt I :). Yes you can keep the settings.cfg file, if you upgrade by overwriting the folder with the zip contents it should work fine as the zip has no settings.cfg.

Good question actually, the only difference I notice in your listings is that you entered "KSP Version: 0.25.0" in the version fields ( see the output on https://kerbalstuff.com/api/mod/231 ) and other mods have only a "0.25" there ( see the output on https://kerbalstuff.com/api/mod/275 )

I have opened up a bug ticket in the CKAN project, but it might be better if you fix the metadata on your side as well. The same issue would hit the Alternate Resource Panel as well, I guess.

All my releases are done via API, so there must be something wrong in the publish script. Theres no way to edit a previously entered number, but I did find a make my mod 0.25 compatible button, whoch I think has done what you need. I'll do it for ARP and TWP as well. I asked SirCmpwn about it a while ago, and I think you may have just twigged to it. Looks like the API for update mod doesnt sanitise the version string.

Let me know if the changes for KAC, ARp and TWP have resolved what you need, and if so I'll add an issue for SirCmpwn with the details for adjusting the APi - or look at the code myself maybe.

Share this post


Link to post
Share on other sites
Is it in the stock toolbar?

I re-installed the game and all the mods again. It's finally back and yes, it is in the stock toolbar. Great Must-have mod!

Share this post


Link to post
Share on other sites
Let me know if the changes for KAC, ARp and TWP have resolved what you need, and if so I'll add an issue for SirCmpwn with the details for adjusting the APi - or look at the code myself maybe.

ARP works, but KAC fails. Then again, if I look at the API dump https://kerbalstuff.com/api/mod/231 (for KAC) still has some "KSP Version x.yz" for older versions in it, but https://kerbalstuff.com/api/mod/195 for ARp is fine. So, this looks like a Smoking Rocket to me :D

Share this post


Link to post
Share on other sites
I re-installed the game and all the mods again. It's finally back and yes, it is in the stock toolbar. Great Must-have mod!

Excellent - like it when stuff works :)

ARP works, but KAC fails. Then again, if I look at the API dump https://kerbalstuff.com/api/mod/231 (for KAC) still has some "KSP Version x.yz" for older versions in it, but https://kerbalstuff.com/api/mod/195 for ARp is fine. So, this looks like a Smoking Rocket to me :D

And sadly I dont know how to edit the older ones - and I cant get to kerbalstuff now - there doesnt seem to be a way to edit the version number in the web site. If you know how I can give it a go - or I'll log an issue to ask the admins to do that for me

Share this post


Link to post
Share on other sites
And sadly I dont know how to edit the older ones - and I cant get to kerbalstuff now - there doesnt seem to be a way to edit the version number in the web site. If you know how I can give it a go - or I'll log an issue to ask the admins to do that for me

Me be sorry, too... I know kerbalstuff only from an user point of view. Which means that the admins would need to step in.

On the other hand, at least, we found a solution for the issue :)

Share this post


Link to post
Share on other sites

Does anyone have any experience getting this mod to cooperate with EPL? I can't find any estimated build time in the EPL interface to manually create an alarm, but it'd be nice if we could.

Share this post


Link to post
Share on other sites
Does anyone have any experience getting this mod to cooperate with EPL? I can't find any estimated build time in the EPL interface to manually create an alarm, but it'd be nice if we could.

Sorry kormer, I havent played with that in a while. If you mean an alarm that could be fired when a long running process completes like the KCT mod does then it would be possible to integrate that using the KAC API, but I dont believe it exists currently.

I'll keep an eye on it in a long term list if I get some other things finished.

Share this post


Link to post
Share on other sites

v3.0.5.0 Now Available - Download from GitHub or Download from Curse* or Download from Kerbal Stuff * Once it's approved

Basically a bBunch of fixes I've been slowing working through during breaks in test periods.

  • Added extra warp rate calcs for non standard values (Issue #71)
  • Added slider to configure weighting of transition periods
  • Added some instant transition fallbacks if alarm is too close to the game UT (Issue #72)
  • Fixed issue with Contract alarms in sandbox mode (Issue #78)
  • Fixed issue with warp fighting when GUI not displayed (Issue #76)
  • Double checked all input lock code

@Hakan - Hopefully the Kerbalstuff info flows through to CKAN properly this time - it sent emails as it should

Share this post


Link to post
Share on other sites

About CKAN, at this moment there is nothing that would kick the robot to re-index, I believe it still is a manual step to launch it.

Having said that, I ran the reindex locally on my machine, and it picks up the 3.0.5.0 release just fine :cool:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.