TriggerAu

[1.7.x] Kerbal Alarm Clock v3.11.0.0 (Sep 1)

Recommended Posts

3 hours ago, Friznit said:

It works fine in all 1.7.x versions

Well it works. But I'm pretty sure some buttons don't like to be pressed anymore :D. Though that might've been due to the UI scaling thing.. (couldn't get it to go back to the toolbar after checking stuff out even though I could navigate the minefield that was the scaled alarm drop-down succesfully).

Your mileage may vary :)

Edited by Jognt

Share this post


Link to post
Share on other sites

I'm about 200 hours into the game, and for the majority of that time have had virtually no unreasonable lag with the game on my PC.  However, over the last month or so (it maybe started after buying both expansions?) I've been getting extremely bad lag - transitions between ships / the space center took sometimes more than a minute to load, loading a ship after clicking "launch" from the VAB can pause for more than a minute, and the game itself would sometimes get unplayably laggy (even causing UI glitches) while working with ships in space. 

I have very few mods installed (Kerbal Engineer Redux 1.1.6.0, Kerbal Alarm Clock 3.10.0.0, and TriggerAU Flags 2.9.3.0; all installed via CKAN), but found a couple of old Reddit posts talking about lag and they mentioned that their only mods were with KER / KAC.

So I uninstalled KAC, and the lag went away entirely.  Reinstalled KAC, and after not much gameplay the lag was back (though not as bad).   Investigated logs, and sure enough: the pauses were occurring when KerbalAlarmClock is logging events.  See timestamp LOG 00:22:04.213 in this log, where the game pauses for more than a minute and a half between these two items:

Quote

[LOG 00:22:04.213] 7/16/2019 12:22:04 AM,KerbalAlarmClock,Initializing EjectAngle Render
[LOG 00:23:45.480] 7/16/2019 12:23:45 AM,KerbalAlarmClock,Active Vessel unreadable - resetting inqueue flag

Any thoughts on things I could do or check?   I can't play the game without KAC  ;.;

Share this post


Link to post
Share on other sites
6 hours ago, Quinquemaculata said:

I'm about 200 hours into the game, and for the majority of that time have had virtually no unreasonable lag with the game on my PC.  However, over the last month or so (it maybe started after buying both expansions?) I've been getting extremely bad lag - transitions between ships / the space center took sometimes more than a minute to load, loading a ship after clicking "launch" from the VAB can pause for more than a minute, and the game itself would sometimes get unplayably laggy (even causing UI glitches) while working with ships in space. 

I have very few mods installed (Kerbal Engineer Redux 1.1.6.0, Kerbal Alarm Clock 3.10.0.0, and TriggerAU Flags 2.9.3.0; all installed via CKAN), but found a couple of old Reddit posts talking about lag and they mentioned that their only mods were with KER / KAC.

So I uninstalled KAC, and the lag went away entirely.  Reinstalled KAC, and after not much gameplay the lag was back (though not as bad).   Investigated logs, and sure enough: the pauses were occurring when KerbalAlarmClock is logging events.  See timestamp LOG 00:22:04.213 in this log, where the game pauses for more than a minute and a half between these two items:

Any thoughts on things I could do or check?   I can't play the game without KAC  ;.;

Since it says "Active vessel unreadable" I'm wondering whether something snuck into your savefile that shouldn't have. I have no knowledge about the ins and outs of KAC except that I have not seen this type of behavior locally. Maybe worth a try to load your persistent save, then ALT+F5 to create a new named save, ALT+F9 to load that named save, and then doing another regular save over your persistent.sfs file? Make a backup of the persistent.sfs file just in case.

ps: Holy deployed-science batman that's a lot of log spam :o

Share this post


Link to post
Share on other sites

Hi, I installed the new version and now the font size is very large. How can I scale this down?

Share this post


Link to post
Share on other sites
On 7/20/2019 at 10:18 AM, Xd the great said:

Any plans for update to 1.7? Or is this mod dead? (Not pressing for updates, take your time.)

Im working on it today

Share this post


Link to post
Share on other sites

Ooooo - feature request - double click title bar to window shade it. :) just thought I'd ask!

thank you for this indispensable and wondrous mod!

Share this post


Link to post
Share on other sites
8 hours ago, TriggerAu said:

Im working on it today

Are there issues that havnt killed any of my kerbals yet? Worked fine for me so far.

Share this post


Link to post
Share on other sites

New version recompiled against 1.7.x with various fixes from helpful community peeps is now available

  • Recompiled for 1.7.3 (Issue #225)
  • Dont report missing vessel if there isnt one (Issue #222)  - Thanks ReeseGlidden
  • Fix Drop-dows and scaling (Issue #228) - Thanks Kerbas-Ad-Astra
  • update some urls/uris (Issue #229) - thanks zatricky and neilser

Download from GitHub or Download from Curse or Download from SpaceDock

Share this post


Link to post
Share on other sites

@TriggerAu: thank you for the update!

Any chance we can see something like KAC, even simplified, for example just for maneuver nodes and SOI, in KSP 1.8 ?

Playing career without KAC is almost impossible for me when I have more than two ships flying around.

Share this post


Link to post
Share on other sites
On 5/19/2016 at 2:27 PM, TriggerAu said:

Damn, its the little things that kill me :P

 

Thanks

Heya... you may STILL want to edit the ReadMe file coz it's still saying not to copy CONFIG.XML over... three years later. :)


INSTALLATION
******************* NOTE  ******************* NOTE ******************* NOTE *******************
IF YOU WANT TO MAINTAIN YOUR SETTINGS DO NOT COPY THE CONFIG.XML FILE OVER
******************* NOTE  ******************* NOTE ******************* NOTE *******************

Share this post


Link to post
Share on other sites

I love this mod, thank you very much for making it, it is on my short list of mods I refuse to play without.

saying that i have had a little problem with it for quite a while now back to maybe ksp1.4 where the scaling is a little strange, I don’t know if it’s something I’m doing or a bug. I know it goes away completely if I set the in game UI scale to 100%, but my monitors native resolution is 4k and the UI at 100% is too small for me to read (poor eye sight, glasses only help so much)

the problems i get, the KAC window starts a list at 2 alarms even though I have it set to the default 10, (all the settings in KAC are default with the exception that I have delete on close set to on) warp to markers are detached from the conic patching and sometimes just floating around nowhere near any lines and text gets split over several lines, sometimes even mid-word

I have linked a short YouTube video showing what I mean, less than 60seconds long

If anyone knows what I causing this or how to fix it without setting the UI scale smaller, i would really appreciate the help

Thanks again for a great mod and for your time.

https://www.youtube.com/watch?v=NCThbx1ho6U&feature=youtu.be

 

Share this post


Link to post
Share on other sites

I want to report an increased number of crashes when switching vessels using kerbal alarm clock. It's 3 crashes in the last 3 days now. I have been using this md for years, it never crashed that often.

 

Let me know wich files you need if you want to do a debug.

Share this post


Link to post
Share on other sites
11 hours ago, Nicky21 said:

I want to report an increased number of crashes when switching vessels using kerbal alarm clock. It's 3 crashes in the last 3 days now. I have been using this md for years, it never crashed that often.

Let me know wich files you need if you want to do a debug.

See my sig block for a topic about how to report problems and post a link to your log file.  If the game is crashing, there should also be a crash report somewhere (I've forgotten where).

Which version of KSP, KAC and other mods do you have installed?  Did you recently change the install with another mod or update?  How do you know it's KAC that's causing the problem?

I've not noticed this in my installs but your circumstances are probably different.  Your first troubleshooting step should be to install just KAC on a clean KSP install and see if the crashes still occur.

Edited by Brigadier
Spelling error

Share this post


Link to post
Share on other sites

Make sure you have the latest update for your version. I have ran across this before they just updated KAC.  if that doesn't work reload the game I know its kind of a hassle but this usually works. I just put everything in Gamedata in folder on my desktop uninstall and Download. this gets rid of any catches that tend to hang on regardless of what you do Hopefully this will all be gone when Kerbal 2 comes out. 

Share this post


Link to post
Share on other sites
4 hours ago, flekota said:

 Hopefully this will all be gone when Kerbal 2 comes out. 

Well, nice sentiment but KSP 2 is at least 6 months away so don't wait for that to solve the problem.  Neither will it be error-free on release and it'll come with its own set of issues which will take more time to sort out.

4 hours ago, flekota said:

I just put everything in Gamedata in folder on my desktop

Remember that there is a Squad folder under GameData that might also be updated in a new KSP versions which you could overwrite when you copy your GameData back into your new install.

Edited by Brigadier

Share this post


Link to post
Share on other sites

Kerbal Alarm Clock (for KSP v1.7.9) just worked for me in KSP v1.8.0.

Share this post


Link to post
Share on other sites
On 10/19/2019 at 2:38 AM, SteveD80 said:

Kerbal Alarm Clock seems to have a bug setting ascending and descending node  alarms in 1.8

But beyond this bug, do you think the mod is ok in 1.8.1 ? I have tested several mods but not this one yet :/

Share this post


Link to post
Share on other sites
On 10/31/2019 at 4:25 AM, DarkNounours said:

But beyond this bug, do you think the mod is ok in 1.8.1 ? I have tested several mods but not this one yet :/

Has anyone checked behavioral conflicts with the the new warp to maneuver node feature in 1.8.x?

I know that MechJeb has had issues with similar feature conflicts as well, and this very well could be a nasty sticking point.

 

Edited by Ruedii

Share this post


Link to post
Share on other sites

@TriggerAu just an FYI - there's no compiled .zip on GitHub; just source code.  SpaceDock was fine - I just wanted to let you know. :)

Share this post


Link to post
Share on other sites
21 hours ago, TriggerAu said:

still getting over the 1.8.1 rush

Just out of curiosity: what do you mean by that? Rush, because the version is so good? Or because it came out so soon after 1.8.0?

Many thanks for the update anyhow :)

Edited by avalancha

Share this post


Link to post
Share on other sites

I'm kinda new to all this and I found this mod to be useful to me, but I don't see it updated on CKAN. Does it take a while to transfer there? My other mods all updated on there to 1.8.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.