TriggerAu

[1.9.x] Kerbal Alarm Clock v3.13.0.0 (April 26)

Recommended Posts

2 minutes ago, Nightside said:

Sounds like a question for the CKAN thread?

Only if CKAN was supposed to be aware. Though I'm assuming TriggerAU is also managing the netkan file, which may not be the case.

Share this post


Link to post
Share on other sites
1 hour ago, Jognt said:

Much appreciated.

Was CKAN supposed to be aware of 1.8.1 compatibility or was this just an oversight? Wondering because this is the third time recently that CKAN was unaware of a compatible update.

The version file in v3.13 specifically states that 1.9.0 is the min version hence why CKAN is not picking it up as compatible with 1.8.1, as per JPLRepo's post.

Share this post


Link to post
Share on other sites
2 hours ago, Poodmund said:

The version file in v3.13 specifically states that 1.9.0 is the min version hence why CKAN is not picking it up as compatible with 1.8.1, as per JPLRepo's post.

Cheers. Guess I could've/should've checked the netkan myself. Apologies.

Share this post


Link to post
Share on other sites
Posted (edited)

I could need some help in understanding in chosing transfer windows. I am playing in JNSQ. When I plot a transfer window and look in the same menu several days before launch the same target has a nother transfer date. Why is this? I always wondered why my transfers are that much off and are not Hohmann ones.

Is there something I can do about "No future model data"?

Edited by New Horizons

Share this post


Link to post
Share on other sites

@TriggerAu I play on a 4K monitor at 3840x2160 and the game's UI Scale set at 140%.  If the KAC window is open in map view the Warp To arrows are wildly misplaced. With the window closed you can see them near the SOI change and Pe marker at the center of the screen.  With the window open the arrows jump to the bottom right.

RUsD0js.gifIt's been like this for years. Today I finally figured out it coincided with the KAC window being open.  I normally just leave the KAC window open since I use it so much.  Today I accidentally closed it while in the map and saw the arrows jump.

Share this post


Link to post
Share on other sites

@TriggerAu I looked through the code last night while watching TV and found the error I was seeing.  Tested this morning and it works, so I submitted a PR for my problem.

Share this post


Link to post
Share on other sites

@Tonka Crash Wow. Never occurred to me that the weird position of some of the arrows had anything to do with KAC. I've just been ignoring it for ages, as it's not a big deal to me - just a distraction. I use KAC a *LOT*, as I tend to have a dozen or two active missions going on simultaneously. Heck, I even use it for some things that aren't even really alarms. I find it handy as a menu of craft that I might want to do something with, even if they don't have a particular alarm time. I'll just set a manual "alarm" for 5 years or so in the future just so that a link to the craft is in the KAC window. That's handier than pawing through the much larger list of craft in the tracking station. So yes, I pretty much always have the KAC window up.

Share this post


Link to post
Share on other sites

@rmaine I use KAC pretty much the same way you do, which was why it took me so long to figure out the glitch was coming from KAC and I've used KAC from almost the first day I started playing.  It just seemed like one of KSP's quirks. 

Share this post


Link to post
Share on other sites

@TriggerAu I'm perfectly aware that this mod is not supposed to work with 1.9.1, but I tried it regardless and encountered a problem that I wanna share. If a alarm is set and I enter VAB (not SPH interestingly), the game crashes to desktop without any error message. It's definitely KAC causing it as removing the set alarm removed the persistent crash issue.

Share this post


Link to post
Share on other sites
9 hours ago, WearyJoe said:

@TriggerAu I'm perfectly aware that this mod is not supposed to work with 1.9.1, but I tried it regardless and encountered a problem that I wanna share. If a alarm is set and I enter VAB (not SPH interestingly), the game crashes to desktop without any error message. It's definitely KAC causing it as removing the set alarm removed the persistent crash issue.

I see this is your first post on the forums. Welcome.

I'm using KAC with 1.9.1 and haven't had any crashes. Someone may be able to help you resolve the problem if you post log files (see link below). Your crashes might be caused by interference from another mod or maybe there's some KSP setting to bypass the issue.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.