Jump to content

[1.9.x] Kerbal Alarm Clock v3.13.0.0 (April 26)


Recommended Posts

Sounds good - thanks! No more crashes since deleting MiniAVC, but only a couple hours of run time since then, so we'll see - hopefully that was it.

Link to post
Share on other sites
  • 2 weeks later...

Thanks, I have ZeroMiniAVC installed now. Still seeing random crashes, but not too frequent, and I don't think KAC is involved at this point.

However -- a "how to use this" question, since I'm fairly new to it; it seems like it doesn't play all that well with Mechjeb's ability to "execute next node" or worse, "execute all nodes" -- which is very handy, except when an alarm pops up in the middle of the process. KAC kills the warp as requested, but if I'm not really on my toes, Mechjeb says "auto-warp checked? Yes! Fire it up again boys!" and suddently I'm five days past my maneuver node. I don't blame KAC for this; having more than one mod trying to manage the state of warp (or anything else) at the same time is bound to be problematic.

How to deal with this?

It seems like I have two options, but open to suggestions. One, as soon as an alarm comes up, disable auto-warp in the most convenient MJ window (but be fast enough!). Or two, as soon as the option shows up in KAC, "jump to ship" (which I assume kills the execution of all remaining nodes for the ship that just lost focus? Not 100% sure about that.) but remember where you came from and what you were in the middle of so you don't forget to come back to it. :)

Tips? (I apologize if this has been covered before; there are 103 pages of posts in this thread to go through...)

Thanks!!

 

Link to post
Share on other sites
7 hours ago, chd said:

How to deal with this?

I play with KAC and MechJeb.  In KAC I use "Pause Game" for all alarms with a 10 minute lead.  This stops everything when the alarm pops up and gives me time to deal with it before continuing warp.  The 10 minute lead time is so I can decide if I can continue or need to abort my current ship's next maneuver node or go deal with an alarm.  It's not too uncommon for me to end up with maneuver nodes for different ships to fall within minutes or seconds of each other.  

Link to post
Share on other sites
  • 4 weeks later...

Why is it not possible to enter a raw time value?

Is Kronometer the issue?

For example, now it is:

2y 286d 3h 43m 31s

I want to enter the year, so I highlight the whole number using Shift and cursor-right and type "316".

After that the input fields say:

3y 47d 1h 1m 7s

I cannot enter anything useful this way.

After trying to type into this one input field this is logged once:

NullReferenceException: Object reference not set to an instance of an object
  at KerbalAlarmClock.KerbalAlarmClock.FillAlarmWindow (System.Int32 windowID) [0x0004c] in <6351bed726c440a59309c6dba3c6ef51>:0 
  at UnityEngine.GUILayout+LayoutedWindow.DoWindow (System.Int32 windowID) [0x00077] in <fa6f9762ac624af092525d37c9d516c4>:0 
  at UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) [0x00077] in <fa6f9762ac624af092525d37c9d516c4>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 

 

Link to post
Share on other sites
  • 2 weeks later...

This may not be a KAC specific question but I'm not sure.  It happened with KAC so I'll ask here.  Some how during GUI lag and trying to drag the KAC popup window I managed to elongate/resize it to an overkill width that takes up most of the screen.  I can't figure out how to get it back to normal size.  It is only oversized for the ship that was active at the time I ganked it.  I was incorrect, it is oversized everywhere now. bleah

Edited by darthgently
Link to post
Share on other sites

@darthgently: GameData/TriggerTech/KerbalAlarmClock/PluginData/settings.cfg

First, make a backup (always), then remove or edit the relevant WindowPos* node.

eg

        WindowPositionStored
        {
                x = 0
                y = 146
                width = 340
                height = 345
        }

 

Link to post
Share on other sites
5 hours ago, taniwha said:

@darthgently: GameData/TriggerTech/KerbalAlarmClock/PluginData/settings.cfg

First, make a backup (always), then remove or edit the relevant WindowPos* node.

eg

        WindowPositionStored
        {
                x = 0
                y = 146
                width = 340
                height = 345
        }

 

Will do, thanks!

Link to post
Share on other sites
  • 2 weeks later...

I've recently had trouble trying to load Kerbal Alarm Clock. I first started playing KSP a few weeks ago with no expansions. Kerbal Alarm Clock was one of the first mods I tried and it was working great. I recently bought and installed the expansion packs and noticed that the Kerbal Alarm Clock wasn't loading anymore. Is it because of the expansions? Or are there other common mods that aren't compatible with KAC?

Link to post
Share on other sites
2 hours ago, TigerScuba said:

I've recently had trouble trying to load Kerbal Alarm Clock. I first started playing KSP a few weeks ago with no expansions. Kerbal Alarm Clock was one of the first mods I tried and it was working great. I recently bought and installed the expansion packs and noticed that the Kerbal Alarm Clock wasn't loading anymore. Is it because of the expansions? Or are there other common mods that aren't compatible with KAC?

Which versions of KSP and KAC are you using?

Link to post
Share on other sites
1 hour ago, Brigadier said:

Which versions of KSP and KAC are you using?

For KSP, I'm running 1.10.1 and for KAC, I'm running 3.13. And in looking at this, I just realized my issue: The KAC mod is updated for KSP version 1.9.1. Thank you helping me realize my own mistake! :P

Link to post
Share on other sites
4 hours ago, TigerScuba said:

For KSP, I'm running 1.10.1 and for KAC, I'm running 3.13. And in looking at this, I just realized my issue: The KAC mod is updated for KSP version 1.9.1. Thank you helping me realize my own mistake! :P

I am also running KAC 3.13.0.0 with version 1.10.1 and both DLC's, and have had no problems... Please note, I installed KAC after having both DLC's.
Maybe one thing to try would be removing KAC, launching the game, closing it and then reinstalling KAC?

Edited by alartor
Link to post
Share on other sites
3 hours ago, alartor said:

I am also running KAC 3.13.0.0 with version 1.10.1 and both DLC's, and have had no problems... Please note, I installed KAC after having both DLC's.
Maybe one thing to try would be removing KAC, launching the game, closing it and then reinstalling KAC?

Hi all. Maybe another thing to try is to delete the "ModuleManager.ConfigCache in the GameData folder. It will be rebuild in the next launch. It resolve some issue with mod for me.

Link to post
Share on other sites
18 hours ago, alartor said:

I am also running KAC 3.13.0.0 with version 1.10.1 and both DLC's, and have had no problems... Please note, I installed KAC after having both DLC's.
Maybe one thing to try would be removing KAC, launching the game, closing it and then reinstalling KAC?

This solved my problem. KAC is working like a charm now! Thank you!

Link to post
Share on other sites
14 hours ago, LTQ90 said:

Hi all. Maybe another thing to try is to delete the "ModuleManager.ConfigCache in the GameData folder. It will be rebuild in the next launch. It resolve some issue with mod for me.

I didn't have a chance to try this, since I tried alartor's recommendation first and it solved my issue. So it's possible this could work too. Thanks for the suggestion!

Link to post
Share on other sites
  • 5 weeks later...

Hello @TriggerAu Thanks for making this essential mod. I was having unknown mod problems and just nuked my whole install and started fresh. I'm trying to be strict about the KSP version compatibility now. Any concerns about KSP 1.10.1 ? Can you update CKAN?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...