Jump to content

[1.9.x] Kerbal Alarm Clock v3.13.0.0 (April 26)


TriggerAu
 Share

Recommended Posts

Some things are clearly not working though. It consistently missed SOI change alarms for me several times in a row now.

It could be because the configuration got screwed up in the noise, though, let me doublecheck...

P.S. Well, my configs are certainly intact and are in fact copied between PluginData and Plugins\PluginData, so that's not it.

Edited by Mihara
Link to comment
Share on other sites

Some things are clearly not working though. It consistently missed SOI change alarms for me several times in a row now.

It could be because the configuration got screwed up in the noise, though, let me doublecheck...

P.S. Well, my configs are certainly intact and are in fact copied between PluginData and Plugins\PluginData, so that's not it.

Thanks Mihara, I do certainly need to rework and retest all of it for 0.20 due to the significant changes in the plugin loader and other code. v1.4.1.0 was simply to get it loading in 0.20 - now comes the "fun" part :(.

Link to comment
Share on other sites

Well that sucks a bit more. Playing without this mod makes me realize how much I depended on the maneuver node restoration functions, as well as the apsides notifications.

I do hope you don't lose patience in updating this mod. I can't speak for others, but I'll have patience in this. You haven't pushed out a bad release so far, so I'm confident you'll be able to give 0.20 a good kick in the pants in due time.

Link to comment
Share on other sites

Well that sucks a bit more. Playing without this mod makes me realize how much I depended on the maneuver node restoration functions, as well as the apsides notifications.

I do hope you don't lose patience in updating this mod. I can't speak for others, but I'll have patience in this. You haven't pushed out a bad release so far, so I'm confident you'll be able to give 0.20 a good kick in the pants in due time.

Have you tried 1.4.1.0 RPharazon? I kludged an interim version while I try and work out the gamedatabase and plugin stuff.

Link to comment
Share on other sites

Yeah, but I ran into much the same problems as Mihara. The plugin tends to overshoot or entirely miss set alarms about one in four times or so.

The maneuver node restoration works, but I'm getting a few errors that change projected apsides and inclination a bit. Probably just floating point errors or some wonkiness from the game itself, so nothing too big to worry about. The error margins themselves tend to be on the order of a km or two, sometimes more, sometimes less, depending on the scale of the maneuver and projected orbits. Manageable, but I didn't get it with 1.4.0.0 and 0.19.

Link to comment
Share on other sites

Yeah, but I ran into much the same problems as Mihara. The plugin tends to overshoot or entirely miss set alarms about one in four times or so.

The maneuver node restoration works, but I'm getting a few errors that change projected apsides and inclination a bit. Probably just floating point errors or some wonkiness from the game itself, so nothing too big to worry about. The error margins themselves tend to be on the order of a km or two, sometimes more, sometimes less, depending on the scale of the maneuver and projected orbits. Manageable, but I didn't get it with 1.4.0.0 and 0.19.

OK, Thanks, I guess its not really usable yet then. Thanks RPharazon

Link to comment
Share on other sites

What's with the added part?

Looks like the way they've changed the loader means that one of the methods for a plugin loading seems to create a psuedo part. No need to add it to the ship, and I'm working on the real v20 version today. The bits that seem out of whack are:

  • The funny part.
  • The recalculation of Flight plan nodes seems to be off by a little - thus the missing of times every now and then.

I'm putting some time into it today

Link to comment
Share on other sites

v2.0.0.0 Is now on Spaceport

The following has been updated and changed:

  • Rebuild and rewrite for 0.20 Game Database Loading Structure
  • Also fixes for - only recalc alarms when under Physwarp or nowarp - stops creep at high warp
  • Reset Defaults for autocalc to prevent creep
  • Reset Defaults for Transfer Mode
  • Added position of icon to config.xml so people can move it around as needed

Man that took more than I thought :(

Now, back to a form of distance based alarm, and remembering an alarms target...

Link to comment
Share on other sites

Tested it out and everything looks pretty great. Things are a bit slower to react to being clicked on, but otherwise the plugin isn't overshooting or missing its time-warp stops. It does tend to come out of time warp rather faster than before, so it freaked me out the first few times.

I haven't encountered the slight maneuver-node restoration errors too, so that's definitely a plus!

Thanks a bunch for all your effort and for your upkeep of this mod.

Link to comment
Share on other sites

Thanks! About to attempt some planned concurrent missions, so will be a real help. Especially as my original lander, the prototype recovery and now the upgraded version are all on Moho recovering the stranded crew. As they have 1 lander each, I've decided to give them a race back to kerbin! :D

Link to comment
Share on other sites

For some reason, the new version seems to have the fuzzy filter turned on.

Previously:

shot1u.png

New version:

shot2f.png

The only difference between the two is the mod version. It's still useable, just not so nice on the eyes anymore.

Link to comment
Share on other sites

For some reason, the new version seems to have the fuzzy filter turned on.

The only difference between the two is the mod version. It's still useable, just not so nice on the eyes anymore.

Amusingly, I can reproduce this. It's not really the mod's fault, but the game's fault. If you set texture sizes to anything below Full Res, you get those blurry icons, probably because the game applies the texture resolution settings to everything in the GameData folder. At Eighth Res the icons become solid blocks of colour.

Link to comment
Share on other sites

It's not really the mod's fault, but the game's fault. If you set texture sizes to anything below Full Res, you get those blurry icons...

I figured that might have something to do with it.

Curse my old computer!

Link to comment
Share on other sites

Amusingly, I can reproduce this....
I figured that might have something to do with it....

Can I get you guys to let me know which graphical setting(s) seems to be doing it - I've tried a bunch and it seems to stay unblurred - I'm testing on Windows.

Link to comment
Share on other sites

Can I get you guys to let me know which graphical setting(s) seems to be doing it - I've tried a bunch and it seems to stay unblurred - I'm testing on Windows.

Running Windows, 1152x864, windowed, half-res, and fastest rendering.

Edit:

Changed it to full res, and that does fix it.

Link to comment
Share on other sites

Running Windows, 1152x864, windowed, half-res, and fastest rendering.

Edit:

Changed it to full res, and that does fix it.

I can replicate it now, no issues - have no idea why I couldn't do that before :P.

Will see if there's a way to mark those textures as always full res, or some alternative. Some of the screen obviously is not affected.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...