Sign in to follow this  
khyperia

HyperEdit - taken over by Ezriilc, this thread is dead

Recommended Posts

Sweet, now I have a new feature - MechJeb completely goes crazy if / when I hyperedit something into orbit. All my windows disappear for that vessel and reverts to default. Hmm.

Frostiken,

I did a test with all the latest versions of KSP, MechJeb2 and HyperEdit, and everything went fine; I was able to set a Kerbin orbit without losing MechJeb or anything that I noticed. So, I need some more info.

  • Have you tried a different ship?
  • Which versions of everything are you using, Windows, KSP, MechJeb, HyperEdit, other plugins etc.?
  • Are you having any other problems with KSP, other plugins, or that computer in general?
  • Please PM me with a copy of the relevant portions of your KSP.log file from a time when it happened.
  • Please PM me with a copy of your .craft file so I can test your ship.

Share this post


Link to post
Share on other sites
Now that I feel more up to speed on this, I don't mind taking the lead on this project if you all are OK with that. I think I have the resources and time needed to maintain it, but with all the help being provided, I feel there won't be any problems there.

So, if you all wish it, and khyperia approves, I volunteer to take over the HyperEdit project.

It's official. Big thanks to khyperia for the excellent HyperEdit plugin, and for being so generous with its legacy. I promise to do my best at keeping it awesome.

My first order of business is to very carefully NOT screw it up. I have some ideas, but I'm interested in what the whole community wants HyperEdit to be. While MechJeb is the go-to plugin for ship operations and real-world-style automation (not really cheating IMO), HyperEdit is - as khyperia put it - like God mode for the universe itself (clearly cheating, and in the most bad-ass way possible). So, I figure that HyperEdit should cement itself as the OTHER must-have plugin, for when reality (and gravity) is getting you down.

And awaaaay, we go!

Share this post


Link to post
Share on other sites

Yay! I'm very happy to see someone working on this again; and I totally agree with you, expand it's functionality until it becomes the MechJeb of cheating! Awesome!

Now as you're asking for ideas... Complex orbit mode could use a little clean-up

I would like to see Hyperedit use less SI prefixes. 2.50u is more legible than 0.0000025, but 0.70da instead of 7 is just silly. The rounding to only three significant figures can be a problem too. Jool has a SMA of 68,773 Mm. In hyperedit it gets rounded to 0.07Tm. That leads to a large error. I need to put in SMA manually to keep Jool in the same place.

I think the h, da, d, and c prefixes should go and numbers in this range should just display directly. All numbers should show at least six sig figs.

Epoch is a special case. It gets rounded to, say 0.30M, which means the error might be 5,000 seconds. That makes setting my mEp pretty much guesswork. It needs to be displayed to the second. Even better would be a button to just use the current time for Epoch. I can't see any reason to use an Epoch other than 0 or the current time.

Share this post


Link to post
Share on other sites
Yay! I'm very happy to see someone working on this again; and I totally agree with you, expand it's functionality until it becomes the MechJeb of cheating! Awesome!

Thanks for the encouragement! It means a lot.

Now as you're asking for ideas... Complex orbit mode could use a little clean-up

I plan to clean up everything. I'm pretty picky about presentation. Another thing is the fact that focus is not taken off of a number field when a GUI button is clicked, so right after hitting LAND, I often proceed to type a thousand "t"s into the Altitude box trying to toggle SAS, because I forgot to click outside the box to regain control of the ship - then the Lander box won't shrink back down until a restart. That lack of losing focus bothers me in MechJeb too, so I'm wondering if there's even a way around that - strike that, there must be.

I would like to see Hyperedit use less SI prefixes. 2.50u is more legible than 0.0000025, but 0.70da instead of 7 is just silly. The rounding to only three significant figures can be a problem too. Jool has a SMA of 68,773 Mm. In hyperedit it gets rounded to 0.07Tm. That leads to a large error. I need to put in SMA manually to keep Jool in the same place.

I think the h, da, d, and c prefixes should go and numbers in this range should just display directly. All numbers should show at least six sig figs.

Epoch is a special case. It gets rounded to, say 0.30M, which means the error might be 5,000 seconds. That makes setting my mEp pretty much guesswork. It needs to be displayed to the second. Even better would be a button to just use the current time for Epoch. I can't see any reason to use an Epoch other than 0 or the current time.

Oh yes, for sure. Units and ranges and whatnot are something I tripped over, and a 10 year-old pointed out to me, so it's also on the list. +1 noted!

Thanks for the input, TonboIV! It helps immensely. Currently, sirkut is working on updating our code to the latest API, and then we want to do some serious QA work to flush out as many bugs we can before proceeding with go-fasters.

I'm currently working on our brand-new, ultra-Kool website (:cool:), but it's not quite ready, so I'm not going to publish just yet - maybe tomorrow, or Monday. It will soon include a support ticket system and suggestion box to make all this much more efficient; I'll be sure to add your comments to it.

EDIT: Can't forget SolarLiner, he's been a huge help with setting up our development repository/version control system. It's done, but we're not sure if it's going to stay as it is, so it's still a bit up in the air. No matter; all in good time.

Edited by Ezriilc
Fixed TonboIV's name.

Share this post


Link to post
Share on other sites
It's official. Big thanks to khyperia for the excellent HyperEdit plugin, and for being so generous with its legacy. I promise to do my best at keeping it awesome.

My first order of business is to very carefully NOT screw it up. I have some ideas, but I'm interested in what the whole community wants HyperEdit to be. While MechJeb is the go-to plugin for ship operations and real-world-style automation (not really cheating IMO), HyperEdit is - as khyperia put it - like God mode for the universe itself (clearly cheating, and in the most bad-ass way possible). So, I figure that HyperEdit should cement itself as the OTHER must-have plugin, for when reality (and gravity) is getting you down.

And awaaaay, we go!

I'd like a new way (its apparently possible now but I've never found a way to do it) way to change the AP And PE to specific values.

Share this post


Link to post
Share on other sites
I'd like a new way (its apparently possible now but I've never found a way to do it) way to change the AP And PE to specific values.

I believe that's been suggested before, so that's a +2 for that. Good one!

Share this post


Link to post
Share on other sites

When I try to hyperedit my ship from launch pad to orbit, my ship either goes into water or explodes in space...what am I doing wrong? Help anyone?

Share this post


Link to post
Share on other sites

You're probably using the wrong units for your input. By default it's in meters (you can use 'k' and 'M' for kilometer and million meters respectively.)

Share this post


Link to post
Share on other sites

^What theSpeare said.

Are you simply editing YOUR ship's orbit, using the simple method ? That gives you a nice circular orbit.

Share this post


Link to post
Share on other sites
You're probably using the wrong units for your input. By default it's in meters (you can use 'k' and 'M' for kilometer and million meters respectively.)

We're going to make that more intuitive and flexible... someday.

Share this post


Link to post
Share on other sites
When I try to hyperedit my ship from launch pad to orbit, my ship either goes into water or explodes in space...what am I doing wrong? Help anyone?

That does happen to me at times as well, when editing an orbit and when "landing". All I can offer at this point is to try restarting the game, and try a different ship or orbit. Some ships seem to have more trouble than others, and it only happens sometimes.

"Exploding on teleport" is +1 on our list.

Share this post


Link to post
Share on other sites

Exploding on teleport? Interesting. I don't think that's ever happened to me. I have blown up a lot of ships this way, but usually I can trace it to something I did. Wrong unit for altitude in simple mode. Wrong mEp for an elliptical orbit with Pe below ground. Orbiting the wrong (larger) body. That kind of thing. Mind you, the current design does make errors of the type rather easy to make. Kind of fun even, but good to know you guys have had the same problems and want to see it fixed. Count on me for bug testing!

Share this post


Link to post
Share on other sites

Heyas Ezriilc, I am really glad you have stepped up to maintain this PlugIn :)

I've been lurking in the thread and am looking forward to the things your planning on doing. I would like to make a suggestion of splitting the resource refill button back to separate resources instead of a fill all when clicked. I don't remember exactly when previous version had this. I do recall however that it was nice to be able to choose which one to refill. I used the refill option to simulate in flight refueling as a "role-play" idea more or less heh...kinda lame I know, but as long as I'm having fun in my game doesn't really matter does it :D

Anyway keep on keeping on mate :) and once again thanks for your efforts.

Share this post


Link to post
Share on other sites
Exploding on teleport? Interesting. I don't think that's ever happened to me. I have blown up a lot of ships this way, but usually I can trace it to something I did. Wrong unit for altitude in simple mode. Wrong mEp for an elliptical orbit with Pe below ground. Orbiting the wrong (larger) body. That kind of thing. Mind you, the current design does make errors of the type rather easy to make. Kind of fun even, but good to know you guys have had the same problems and want to see it fixed. Count on me for bug testing!

That actually answers some questions for me.

Heyas Ezriilc, I am really glad you have stepped up to maintain this PlugIn :)

I've been lurking in the thread and am looking forward to the things your planning on doing. I would like to make a suggestion of splitting the resource refill button back to separate resources instead of a fill all when clicked. I don't remember exactly when previous version had this. I do recall however that it was nice to be able to choose which one to refill. I used the refill option to simulate in flight refueling as a "role-play" idea more or less heh...kinda lame I know, but as long as I'm having fun in my game doesn't really matter does it :D

Anyway keep on keeping on mate :) and once again thanks for your efforts.

Thanks for the encouragement, and for the suggestion (good one! +1). I was also thinking about trying to make the refill process happen over a few seconds instead of instantly. I've had a few watercraft bite the big one from the sudden added weight.

This thread is closed, so find us at our new site:

http://www.KerbaltekAerospace.com

Edited by Ezriilc

Share this post


Link to post
Share on other sites
My ship, when I teleport, just spins in a way that all parts except the command pod fling outwards and explode, even at reasonable altitudes. Any suggestions?

Please read the OP (or at least the title) before necro-ing a thread like this. The mod is now maintained at www.kerbaltekaerospace.com, try submitting your bug there.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this