frizzank

[1.0.5] FASA 5.44

Recommended Posts

Has anyone figured out how to use Mechjeb with the Explorer? There doesn't seem to be a Limit Velocity option, just limit acceleration and limit throttle.

Share this post


Link to post
Share on other sites
Has anyone figured out how to use Mechjeb with the Explorer? There doesn't seem to be a Limit Velocity option, just limit acceleration and limit throttle.

mechjeb is having issues with fasa or other rockets that come with the game. I recently couldn't get the rocket to make the gravity turn and when I staged off the first section, I would just uncontrollably flip.

Share this post


Link to post
Share on other sites
Gentlemen.

Anybody else having trouble with the Gemini docking port nose cone? It' always suddenly starting to rapidly overheat (on altitudes about 40-55 km and still on nonorbital speed), despite all other parts are ok ....

yes, i'm using Re-entry heating rebalance (made harder), but it ok with other FASA parts and other mods.

any solution?

I briefely tried the Re-Entry heating rebalance mod. I had issues with several parts overheating from many mods when they shouldn't. I quickly removed the mod and have not had issues since. Likewise specificly with the FASA Gemini nose cones, you can't use the mod Tweak Everything either.

- - - Updated - - -

mechjeb is having issues with fasa or other rockets that come with the game. I recently couldn't get the rocket to make the gravity turn and when I staged off the first section, I would just uncontrollably flip.

I have never had an issue with MJ and FASA (or any other mod for that matter,) unless I combined it with FAR. I will say this, you can't start your gravity turn until you are at about 10K meters with most of the Rockets in game. And you must start with a SLOW turn.

- - - Updated - - -

Has anyone figured out how to use Mechjeb with the Explorer? There doesn't seem to be a Limit Velocity option, just limit acceleration and limit throttle.

Depends on what you want to use it for. I modded my CFG to add basic MJ Ascent guidance to the Explorer core (and the pioneer core and most obviously,the Agena core.) I have not had major issues with the latest dev release of MJ. I know the previous MJ 1.0.2 release was having issues. Have you tried the latest release as of 5 days ago?

Edited by Pappystein

Share this post


Link to post
Share on other sites
I'm having a hard time with the latest update making the engines fit within the stock game and feel like the actual launches. Please be patient and as always I am open to suggestions as well...

I thought it was ready for 1.0. It said on main page where I wait to see if it's ready. http://forum.kerbalspaceprogram.com/threads/55401-Community-Mods-and-Plugins-Library

When it says 1.0. I get them thinking its' ready.

Maybe keeping it saying .90 for now would be ok.

All the others are still saying .90 so I wait.

(Even though KSP 1.anything in it's self is not ready for 1.0.)

Share this post


Link to post
Share on other sites

Apollo 11 is the one that went to the moon? there should be one in the craft files that came with Fasa. that has the Saturn 5 with the Apollo Capsule and CSM as well as the LEM

Share this post


Link to post
Share on other sites
Hello, I am thinking of downloading this mod! Does it replace anything in game, or just add to it? Thanks!

This mod does not replace anything. It is a pretty awesome parts mod to boot. Not quite life-like but as the Mod Creator/maintainer Frizzank will tell you, he wanted a Kerbal Space program that was similar to NASAs space program. NOT NASA's space program. Ie he wanted it to be fun, not realistic.

The only time I don't use 100% of this mod is when I am doing a SSTO space plane career. The Gemini capsule is my GOTO capsule for almost everything. I even use Gemini on most of my Saturn Launches!

- - - Updated - - -

Anyone else having problems with the pre-built Apollo 11 rocket shaking itself apart on launch?

If you leave the side attaching launch clamps on the rocket, this often happens. I had a Saturn II INT-17 break up at less than 1500m when I used the side clamps. Once I switched to the under engine (Redstone 1.25 and Redstone 2.5m clamps) most of my exploding issues went away. This is a known KSP bug and not caused by FASA itself.

Edited by Pappystein
Fixed gramatical error

Share this post


Link to post
Share on other sites

Hello there i want to report a little bug:

version: 5.34 it was download from CKAN & kerbalstuff for duble check arhive

[WRN 10:11:51.708] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Apollo\ApolloCSM\ColorRed.dds'

[WRN 10:11:51.712] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Apollo\ApolloCSM\ColorWhite.dds'

[WRN 10:11:51.724] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Apollo\ApolloCSM\ColorWhiteDark.dds'

[WRN 10:11:51.739] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Apollo\ApolloCSM\ColorYellow.dds'

[WRN 10:11:55.275] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\ASETindicators\model000.dds'

[WRN 10:11:55.386] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\Bolt\BoltCap.dds'

[WRN 10:11:55.400] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\Bolt\BoltCap_NRM.dds'

[WRN 10:11:55.904] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\LM_FuelIndicatorSE\FuelIndicatorInd.dds'

[WRN 10:11:55.910] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\LM_FuelIndSE\FuelIndicatorInd.dds'

[WRN 10:11:56.129] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\LM_Mirror\screen-emissive.dds'

[WRN 10:11:56.133] Texture load error in 'D:\Games\Kerbal Space Program\GameData\FASA\Props\LM_Mirror\screen.dds'

[ERR 10:13:13.308] Texture 'FASA/Apollo/ApolloCSM/FoilWhite' not found!

[ERR 10:13:13.309] Texture 'FASA/Apollo/ApolloCSM/FoilGold' not found!

[ERR 10:13:13.345] Texture 'FASA/Apollo/ApolloCSM/FoilWhite' not found!

[ERR 10:13:13.346] Texture 'FASA/Apollo/ApolloCSM/FoilGold' not found!

[ERR 10:13:13.347] Texture 'FASA/Apollo/ApolloCSM/FoilBlack' not found!

[ERR 10:13:13.348] Texture 'FASA/Apollo/ApolloCSM/ColorYellow' not found!

[ERR 10:13:13.362] Texture 'FASA/Apollo/ApolloCSM/FoilWhite' not found!

[ERR 10:13:13.363] Texture 'FASA/Apollo/ApolloCSM/wall1_DIFFUSE' not found!

[ERR 10:13:13.363] Texture 'FASA/Apollo/ApolloCSM/wall1_nrm' not found!

[ERR 10:13:13.381] Texture 'FASA/Apollo/ApolloCSM/RCS_box_NRM' not found!

[ERR 10:13:13.382] Texture 'FASA/Apollo/ApolloCSM/ColorYellow' not found!

[ERR 10:13:13.383] Texture 'FASA/Apollo/ApolloCSM/rusty' not found!

[ERR 10:13:15.256] Texture 'FASA/Gemini2/FASA_Gemini_Engine_Fuel2/Gemini_RCSFuel_Pack' not found!

[ERR 10:13:15.536] Texture 'FASA/Gemini2/FASA_Gemini_LFT_Ext_Sm/LFT_Ext_SmH2' not found!

[ERR 10:13:15.573] Texture 'FASA/Gemini2/FASA_Gemini_LFT_Ext_Sm/LFT_Ext_SmO2' not found!

[ERR 10:13:17.779] Texture 'FASA/Props/ASETindicators/model000' not found!

[ERR 10:13:17.884] Texture 'FASA/Props/Bolt/BoltCap' not found!

[ERR 10:13:17.885] Texture 'FASA/Props/Bolt/BoltCap_NRM' not found!

[ERR 10:13:18.245] Texture 'FASA/Props/LM_FuelIndicatorSE/FuelIndicatorInd' not found!

[ERR 10:13:18.251] Texture 'FASA/Props/LM_FuelIndSE/FuelIndicatorInd' not found!

[ERR 10:13:18.417] Texture 'FASA/Props/LM_Mirror/screen' not found!

[ERR 10:13:18.418] Texture 'FASA/Props/LM_Mirror/screen-emissive' not found!

most dds file what are report like warning are in corect place but it seams they are damaged or broke with very low size betwin 2-6 kb

houpe it help & cya around

Share this post


Link to post
Share on other sites

If you leave the side attaching launch clamps on the rocket, this often happens. I had a Saturn II INT-17 break up at less than 1500m when I used the side clamps. Once I switched to the under engine (Redstone 1.25 and Redstone 2.5m clamps) most of my exploding issues went away. This is a known KSP bug and not caused by FASA itself.

Is this the same bug that's spawning the clamps as debris mid flight?

Share this post


Link to post
Share on other sites

I believe so. Although at this point 1.0.2 has too many little bugs to be 100% certain.

Share this post


Link to post
Share on other sites
I thought it was ready for 1.0. It said on main page where I wait to see if it's ready. http://forum.kerbalspaceprogram.com/threads/55401-Community-Mods-and-Plugins-Library

When it says 1.0. I get them thinking its' ready.

Maybe keeping it saying .90 for now would be ok.

All the others are still saying .90 so I wait.

(Even though KSP 1.anything in it's self is not ready for 1.0.)

Working, yes, balanced and bug free, no....

As I said before just wanted to get a version up that worked with 1.0 as the previous version did not work at all.

Share this post


Link to post
Share on other sites

I can make it to orbit with RS mercury long tank. Use FS swamp fans, and a light LFO engine. Put explorer on top with fairing nosecone. Add panels if you want.

Share this post


Link to post
Share on other sites

Love the mod. However, 5.34 kills my game without fail to the point where removing the mod STILL crashes the game. I don't understand it, but I am building a new install; I cannot install a version of this mod now without a test that it won't screw up a previous save. I don't know why this should be, all I DO lnow is that 5.34 screwed my last game over to the point that reverting to the last version meant re-installing the game.

- - - Updated - - -

Where can I get 5.33?

Share this post


Link to post
Share on other sites

Gemini Atlas Agena is flipping constantly, cannot get it into orbit. Gravity turn: 10 deg north at 100 m/s. Turn off SAS, let gravity turn it till 25 Km, then parallel. Flips at 4k.

Share this post


Link to post
Share on other sites
Gemini Atlas Agena is flipping constantly, cannot get it into orbit. Gravity turn: 10 deg north at 100 m/s. Turn off SAS, let gravity turn it till 25 Km, then parallel. Flips at 4k.

Yeah the Atlas does have issues unless you use a lot of the control engines or add an SAS module to it. (or some god awful looking fins)

Something you may want to try is to not let the rocket gravity turn on its own. Keep SAS on and drag prograde down very, very slowly. I typically find for most of the FASA rockets that hitting about halfway to 45 degrees @~15km apoapsis will ensure a smooth flight.

Edited by G'th

Share this post


Link to post
Share on other sites

Turning off SAS only works if the rocket is statically stable. Most real life ones aren't, and I'd expect the same for these. Instead of turning SAS off, switch SAS to follow-prograde mode.

Share this post


Link to post
Share on other sites
Turning off SAS only works if the rocket is statically stable. Most real life ones aren't, and I'd expect the same for these. Instead of turning SAS off, switch SAS to follow-prograde mode.

That can also be cause for failure if the rocket doesn't work perfectly, which the FASA one's don't because they're not quite balanced to the stock aero as of yet. You'll either end up a way higher orbit than you necessarily wanted or your turn will be too fast.

But anyway, frizz, I was wondering if you ever planning on giving reflections to the LM ascent stage? While the LM wasn't as shiny as the CSM, parts of it were shiny to some degree.

Share this post


Link to post
Share on other sites

FASAGeminiLanderInt is erroneous and inappropriate, especially russian (in fact Turkmenian) bad word on the panel, at bottom left :-\

Also, its 4-way legs are throwing

[EXC 14:54:44.702] NullReferenceException: Object reference not set to an instance of an object
ModuleLandingLeg.StateUpdate ()
ModuleLandingLeg.FixedUpdate ()

like mad, even (opened and then) closed.

As a second thought, writing F-word on stuff, incl. planets & asteroids, is sooo russian. It's the essence of their characteristic mentality, so to speak: "we can't improve it and won't leave it, so we'll write F-word and move along, and everyone who'll come after us will know - russkie was there!".

Edited by cipherpunks

Share this post


Link to post
Share on other sites

If you go to kerbalstuff find the FASA Page then the changelog Tab the different versions are there for download

Share this post


Link to post
Share on other sites
FASAGeminiLanderInt is erroneous and inappropriate, especially russian (in fact Turkmenian) bad word on the panel, at bottom left :-\

Also, its 4-way legs are throwing

[EXC 14:54:44.702] NullReferenceException: Object reference not set to an instance of an object
ModuleLandingLeg.StateUpdate ()
ModuleLandingLeg.FixedUpdate ()

like mad, even (opened and then) closed.

As a second thought, writing F-word on stuff, incl. planets & asteroids, is sooo russian. It's the essence of their characteristic mentality, so to speak: "we can't improve it and won't leave it, so we'll write F-word and move along, and everyone who'll come after us will know - russkie was there!".

I apologize for this, I thought it said XYZ, had no idea it was russian. I will put a post it note over it.

As for the landing leg, I have no idea...

Share this post


Link to post
Share on other sites

Since the soviet pack has yet to be updated, would you consider making an N1?

Share this post


Link to post
Share on other sites

Hello frizzank!

In testing the FASA parts and fine-tuning them for RO in 1.02 I found that the LEM engine does not gimbal. NathanKell suggested I change the gimbal transform used, and it works with this line added:

gimbalTransformName = thrustTransform

Your current config uses:

gimbalTransformName = Engine_Nozzle

which appears to be a non-existent transform for this part.

You always deserve more thanks than you get for developing and continuing to work on FASA, thank you so much for the work Frizzank.

Share this post


Link to post
Share on other sites

If you've got the Unity source, it'd be great if you could make the engine actually gimbal; using just thrust transform will only gimbal the exhaust (AFAIK). But at least it'll work, so nm. :)

Speaking of--does SPS have a gimbal transform?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.