Jump to content

[0.22] B9 Aerospace Pack / R4.0c / New pods, IVAs, engines, fuselages & structures


bac9
 Share

Recommended Posts

Quick question, tried to spot it in this threadnaught but after reading about 20 pages, I didn't find anything.

-When I use the B9 lights, if I timewarp with them on while in orbit, they will lightup the entire planet! Is there anything to fix that? I am not sure but it seemed to happen only with the b9 lights, could be wrong tho.

-On the same note, I doubt this can be fixed as its probably hard coded in the animation, still maybe not. Is it possible to have the lights not flicker when you turn them on or off? I don't know, not quite fond of that effect. Just a personal taste here and defenatly not going crazy about it but if it can be changed, it would be nice.

Thanks!

I think it might be possible to use a different animation, maybe? Check this out (in the A1-White.cfg for the B9 A1_Utility_Light_A)


MODULE
{
name = ModuleLight
lightName = Spotlight
useAnimationDim = true
lightBrightenSpeed = 1
lightDimSpeed = 1
resourceAmount = 0.015
[B][COLOR=#b22222] animationName = light_array_toggle[/COLOR][/B]
useResources = true
}

Now reference the same segment in the vanilla lights


MODULE
{
name = ModuleLight
lightName = spotlight
useAnimationDim = true
lightBrightenSpeed = 2.5
lightDimSpeed = 2.5
resourceAmount = 0.04
[B][COLOR=#b22222]animationName = LightAnimation[/COLOR][/B]
useResources = true
}

Try swapping out the animation name? Also don't forget to set the BrightenSpeed and DimSpeed to 2.5 to match the vanilla lights as well. I'll give this a try when I'm back in front of my system, but I'm not going to be around it for another three days.

Link to comment
Share on other sites

I think it might be possible to use a different animation, maybe? Check this out (in the A1-White.cfg for the B9 A1_Utility_Light_A)


MODULE
{
name = ModuleLight
lightName = Spotlight
useAnimationDim = true
lightBrightenSpeed = 1
lightDimSpeed = 1
resourceAmount = 0.015
[B][COLOR=#b22222] animationName = light_array_toggle[/COLOR][/B]
useResources = true
}

Now reference the same segment in the vanilla lights


MODULE
{
name = ModuleLight
lightName = spotlight
useAnimationDim = true
lightBrightenSpeed = 2.5
lightDimSpeed = 2.5
resourceAmount = 0.04
[B][COLOR=#b22222]animationName = LightAnimation[/COLOR][/B]
useResources = true
}

Try swapping out the animation name? Also don't forget to set the BrightenSpeed and DimSpeed to 2.5 to match the vanilla lights as well. I'll give this a try when I'm back in front of my system, but I'm not going to be around it for another three days.

Remember that the model has to have an animation by that name for the config to be able to tell it what to do. If you wanted to make this fix work, you would have to get the animation out of the model.mu of the vanilla lights and transfer it to the model.mu of the B9 lights as well as making these changes to the part.cfg.

Seems like that's a lot of work to go thru to fix such a tiny bug. That doesn't mean it wouldn't work, but personally I don't think the result is worth the effort.

Link to comment
Share on other sites

Cmon the B9 forum is a bit of threadnought but you should at least put some effort to reading through some of the previous posts and if you cant find what you looking for then ask its not like the question hasnt been answered on every second page since .23 came out I am with deadweasil on this one

Link to comment
Share on other sites

And cheers for elitism and segregation!

Dafuq? All he was saying was, that he should check the last few pages, where it has been answered multiple times already. His response had NOTHING to do with discriminating due to post count.

Link to comment
Share on other sites

i'm going to post that link on the top of every new page from now on so people stop asking...

Won't always work. There aren't a lot of people who will change the number of posts per page in their settings (like me), but those that do won't see it at the top.

Link to comment
Share on other sites

http://forum.kerbalspaceprogram.com/threads/66020-B9-0-23-fixes

anyone looking for fixes please use link above....

(i told ya i'd post it on every new page...)

As people explained to you already - what you see as "new page" is not new page for many many people. Everyone uses different settings.

On the contrary, for me, for example, your post is about the 20th post on page 104.

And this thread is now redundant. All discussion regarding the mod can go in the fixed mods thread.

Everything I've read in the last few pages is just ridiculously offtopic and I wonder why do the mods tolerate this.

Each time I see it updated in my Subscriptions page I get the idea Bac9 posted something and people are talking about it.

However I soon found out all that is posted is useless banter and disputes.

I am reporting the thread. Hopefully I won't be alone in this and it will only be unlocked as per Bac9's request, not some 14 year old wanting to generate forum posts.

Link to comment
Share on other sites

actually before you do that i have a question...

any news on decouplers to fit the werid shaped pieces of this mod pack?

if not how would i go about doing this?

also there is as much clutter here as any other post... and really between the ramblings and the arguments we do sorta help out other people... when they ask for the tenth time...

Edited by AntiMatter001
Link to comment
Share on other sites

In the future, please pay attention to the rules. I see a lot of off topic posting as well as reaction images. This thread is not for either.

Also refrain from speculating about bac9's life. He is not obligated to log in nor update the mod. Do not violate any licenses involving this mod either.

FORUM

RULES

I should have edited this months ago, but visit the new official thread by bac9 here

Edited by shadowsutekh
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...