Kreuzung

[1.0]Vanguard Technologies | EVA parachutes | still works

Recommended Posts

I have to agree with this one guys, its kinda dangerous to have 6 guys bail out of a cockpit and then only "half" deploy......:confused:

Dren

Share this post


Link to post
Share on other sites

>ArkaelDren

I once had a part with a wrong internal setup and it didn't really work on that one, but I'm quite sure I've ejected from an internal-less part. Try removing the INTERNAL nodes from the part.cfg's.

>Smurfalot

I originally wanted it to be fully manually, but I am considering automatic deployment now. Also, if you use space+f below 100m you directly go to full mode. Landing in half-deployed mode works fine too, at least on Kerbin.

Share this post


Link to post
Share on other sites

I feel almost certain that you can punch [space]+F again and it will cause the parachute to fully deploy automatically whenever it reaches altitude, but I may just be crazy.

On the subject of possible changes, I'd like to see a part that you could put on your ship that automatically gives kerbals parachutes as they exit. This means you still need then with you, but are more likely to survive as your plane collapses on you.

Like an automatic parachute box? Kind of clever. Maybe you could make it such that the parachute count goes back up whenever a kerbal with one on enters the craft? That would be one way around the parachutes being destroyed when you re-enter.

Share this post


Link to post
Share on other sites

Nope bud, I have tried this now on several attempts and builds, remove the internal space for the Pod/cockpit, and it no longer functions. But the new version of KSP 0.20.2 requires you to remove the line in the cfg for the internals even to function correctly. So, if you remove all your internals, then you have to remove the internals line in the cfg for every part that requires them, or you get strange glitches of the displays. Just try it, remove the internal and the internal line from a cfg, and your mod no longer functions. I am not saying you have to fix this, but for those of us that don't need internals, then were left with not being able to use your Mod, and I love this Mod...

Thx for your work and time.

Dren

Share this post


Link to post
Share on other sites
-snip- Maybe you could make it such that the parachute count goes back up whenever a kerbal with one on enters the craft? That would be one way around the parachutes being destroyed when you re-enter.

That sounds like an idea! And that could save Kreuzung from needing to create a mechanism that saves parachutes with non-eva'd kerbals.

Maybe it'd be good to have it work for kerbals on external sets, they get a parachute whenever they leave, and give it up when they sit.

Share this post


Link to post
Share on other sites

Mod doesn't work at all for me. No other mods installed. Just this and the vanguard all, I can equip a parachute from the box and then I can click deploy in mid air but neither button actually causes anything to be deployed and my kerbal falls to his death

Share this post


Link to post
Share on other sites

>Smurfalot

I originally wanted it to be fully manually, but I am considering automatic deployment now. Also, if you use space+f below 100m you directly go to full mode. Landing in half-deployed mode works fine too, at least on Kerbin.

I am ok with still needing to trigger the deploy manually, but I think the semi- to full deployment should happen automatically. I would basically work like a pod chute does.

Share this post


Link to post
Share on other sites
-snip-, I can equip a parachute from the box and then I can click deploy in mid air but neither button actually causes anything to be deployed and my kerbal falls to his death

I had a problem like this earlier, that was fixed my making sure the mod was installed with exactly the file structure it came with. Maybe that could be what's happened here.

Doesn't make for happy kerbals...

xjD0InX.jpg

Share this post


Link to post
Share on other sites

>6677

As already said, check your file structure. If that doesn't work, please check the debug log after trying to deploy.

Share this post


Link to post
Share on other sites

Yes. Models will be redone for the next update, whenever that happens.

Share this post


Link to post
Share on other sites
I really want to use this mod, but is there any chance a model and/or texture update is coming?

I am working on them atm, here you can see current status (its just basic diffuse maps, without any spec, diff and any shaders yet):

Screenshot_1136.jpg

Screenshot_1141.jpg

Screenshot_1146.jpg

Screenshot_1161.jpg

Screenshot_1174.jpg

Made according to Kreuzung-chan's blueprints ^^

It's not final, btw - everything could be changed.

Edited by quadro7f

Share this post


Link to post
Share on other sites

So Kreuzung, are you going to ignore this bug, or are you choosing to work on it?

Stock KSP game, add in the Parachute Mod, remove the internals, and the cfg line for the internals, and the Mod no longer functions.

Its cool if this is how you want it, but I cant see why you would be happy with the Mod not functioning with out the internals line or files. Because that space is precious for those of us that enjoy being part whores.

Share this post


Link to post
Share on other sites

You've been slightly aggressive when writing that post, right? :P

I have absolutely no idea why the whole mod should break without the internals removed, and you never provided me any other information other than "doesn't work", which can really mean everything.

I found some useless line in the ejection module code which might screw up without internals, but as said, I'll rewrite the whole mod so I'm not gonna put out another version with just that line removed, sorry. If you wanna recompile it yourself, just remove line 33, "print(kerbal.KerbalRef.InPart.name);", from ModuleEjectCrew.cs, not sure if that is the problem but it's worth a try.

Share this post


Link to post
Share on other sites

You just made a friend here for sure bud. OK, that sounded a bit lame, but its true...... I love you man....lol :D

Share this post


Link to post
Share on other sites

Just saying that this mod seems to work fine in .21 ;)

Still didn't start working on 2.0 though.

Share this post


Link to post
Share on other sites
Just saying that this mod seems to work fine in .21 ;)

Excellent! Your technology has saved many a test pilot's life, and all my production aircraft have been equipped with ejection seats for longer than I can remember ;)

EDIT:

PS.: I had to rename VNG_Parachutebox/Textures to ./textures (lowercase), and VNG_Eject/textures/EjectionModule.png to ./ejectionmodule.png (also lowercase) to fix two warnings and get the textures to load properly.

This is likely an issue with Linux only (maybe MacOS as well, since they both use a similar foundation) and (guessing only) the way you have set up texture names in the Unity editor. Path and file names are case sensitive on those systems.

I understand you have new models and eventually an overall new version in the making, so maybe a release just to fix this is unwarranted; but if you do an interim release, I'd suggest either renaming those files/folders, or changing the texture names within the editor, to reflect actual case.

Edited by Corax

Share this post


Link to post
Share on other sites

At first I couldn't get this mod to work (resulting in much anguish, since it looked so cool) - then I came on here and it was cleared up in about five minutes. I don't know what to be more thrilled about - that you're great at supporting your mods, or that I can bust out all Baumgartner now. THANK YOU!!!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.