Sign in to follow this  
Followers 0
Iannic-ann-od

[0.24] Chatterer v.0.5.9.4

659 posts in this topic

Thanks for feedback guys, unfortunately I can't reproduce any of these issues (weird noise/Crashes), neither in 32 bits nor 64 bits.

Log files might help, also give a latest Mechjeb dev version x.288 a try to see if it helps.

@Stephanie, nice sound set, I will give it a try ingame to see how it goes. ;)

Share this post


Link to post
Share on other sites
I re-installed chatterer 0.5.9.4_x64 alongside the latest MechJeb 2.3.1.0 from curse, the crash folder in a zip file is here:

https://owncloud.dominiquestender.de/public.php?service=files&t=77fe02cd272b666836259fd34fd4ff0f

Happy debugging ;)

Thanks a lot for your log files.

This sounds like a memorie access violation that definitely shouldn't be there...

Can you please try the following :

- use latest Mechjeb dev version x.294 here : http://jenkins.mumech.com/job/MechJeb2/

- use latest Modulemanager dev version 2.2.3 here : http://forum.kerbalspaceprogram.com/threads/55219-Module-Manager-2-2-1-%28August-3%29-The-pony-is-not-here-yet-edition?p=1359136&viewfull=1#post1359136

- use latest Chatterer dev version 0.5.9.6405 (compiled against 0.24.2) here : https://www.dropbox.com/sh/9rgvtv62m5d20ym/AAA6zaXrDxhpULIkmWyPZypia

Also check if you don't have multiple modulemanager dll files inside your mods folder, it seems, from your log files, it applies at least 3 times.

Finally can you try with 32bits KSP version just to see if it is just a x64 related issue.

Thanks ;)

Share this post


Link to post
Share on other sites
@Stephanie, nice sound set, I will give it a try ingame to see how it goes.

You're welcome. I was thinking of making some more actually, and of perhaps figuring out how to muffle the sounds and merge them more seamlessly with your originals. The issue of course is that my versions sound more like a modern communication with much less degradation (preserves echo and reverb), while yours are more nostalgic.

Share this post


Link to post
Share on other sites

Can the plugin be updated to use the built-in toolbars in latest KSP?

Share this post


Link to post
Share on other sites
Can the plugin be updated to use the built-in toolbars in latest KSP?

Yep, it is just around the corner ;)

1 person likes this

Share this post


Link to post
Share on other sites
You're welcome. I was thinking of making some more actually, and of perhaps figuring out how to muffle the sounds and merge them more seamlessly with your originals. The issue of course is that my versions sound more like a modern communication with much less degradation (preserves echo and reverb), while yours are more nostalgic.

Can you tell us how to set your sounds up, please?

The chatters are easy enough, but how about the beeps and background sounds? Somehow I can only play two background sounds and they keep looping, which kinda makes having a whole variety pointless. Am I missing something?

Share this post


Link to post
Share on other sites

I believe that two background sounds is the maximum. Simply pick a sound that is appropriate to your vessel, and lay a different one over the top with a different volume setting for the second selection. These ambient sounds loop because it would make no sense for a ship to suddenly have a different base hum. For the beeps, you need to set them up manually. Go to the Beeps section of the chatterer GUI, and you can 'add' beeps. By changing the timer from 'no beep' to a certain time or time range (I choose random on various lengths so they don't loop that often) and by selecting a volume you can set up a variety of different beeps with different loop times and volumes. To change the actual beep being played for that particular setup, simply click the name of the beep in the window. I think the default one is 'beep33' or something. Add more beeps by clicking the 'add' button. I had over 30 different beeps being played at different volumes and intervals alongside the chatter. I did not disable beeps while the comms are active because it adds more to the randomness and it would not make sense for the instrument sounds in the background to stop simply because comms are active, but it is your choice.

A quick way to set up beeps, is to set one up and then duplicate it. All you have to do then is shift one or two of the sliders and pick a new sound + repeat.

Edited by Stephanie the Viking

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0