Sign in to follow this  
Followers 0
Iannic-ann-od

[0.24] Chatterer v.0.5.9.4

659 posts in this topic

Why not? You would get more feedback and maybe someone would find the cause of the problem.

Share this post


Link to post
Share on other sites
Bad news is that I can no longer get the audio to reliably play 100% of the time in 0.20. The clips always play but under certain conditions they play completely garbled up and warbly and generally sound like ****.

I'm not sure if it is a bug or if I am not doing something right?

It's feature, now it simulate poor communication and radio interference.

Share this post


Link to post
Share on other sites

The only cause I can think of is for some (silly) reason, you are losing processing power due to Textures of the planet being loaded?

that is the only thing that would seem to be common amonst all celestial body's - as the resolution of the maps change per your altitude.

Personally, I have the .19.1 version hacked into my ksp v.20 so I am good untill the new one becomes stable.

Share this post


Link to post
Share on other sites

I wouldn't mind playing with it i would just say theres a crazy messed up solar interaction with the planets magnetosphere that causes garbled communications at those altitudes :P

Share this post


Link to post
Share on other sites
Chatterer 0.4 for KSP 0.20 is released! !yojnE

And the people cheered!

My flights have been extremely too quiet lately. Amazing how a little thing that really doesn't have a use makes the game so much more alive.

Share this post


Link to post
Share on other sites

I agree :) Adds an nice immersion, thanks for enabling own sets =D cheers

Share this post


Link to post
Share on other sites

My 0.02 kerbal monetary units:


@PART[longAntenna]
{
@MODULE[ModuleAnimateGeneric] {
@isOneShot = false
}
MODULE
{
name = rbr_chatterer
}
}

@PART[commDish]
{
@MODULE[ModuleAnimateGeneric] {
@isOneShot = false
}
MODULE
{
name = rbr_chatterer
}
}

Put that in a file named something like "part-antenna-patch.cfg" somewhere in GameData and install ModuleManager into the mix, and you have Chatterer functionality in stock antennas. :)

Share this post


Link to post
Share on other sites
Chatterer 0.4 for KSP 0.20 is released! !yojnE

oooo rushes off to spaceport to download..

Thank you very much for the update, my kerbals love chattering away when I am sending them into unknown space :)

Share this post


Link to post
Share on other sites
My 0.02 kerbal monetary units:

...code...

Put that in a file named something like "part-antenna-patch.cfg" somewhere in GameData and install ModuleManager into the mix, and you have Chatterer functionality in stock antennas. :)

That is really cool. I am going to sneak that into the .zip file real fast.I am going to add capsules and probes to that and include it.

Edited by Iannic-ann-od

Share this post


Link to post
Share on other sites

I still hear chattering when sending an empty habitation module all the way to Jool.

That was pretty disconcerting. :)

Share this post


Link to post
Share on other sites

Now with the new version of Chatterer out, I, or possibly somebody else could work on adding lines from moon base alpha. I think that would be rather high-larious.

Share this post


Link to post
Share on other sites

can get the part to show up but and the functionality windows are there but i just cant get it to play sounds ...

guess ill wait for space port release ;.;

correction i am an idiot got it to work just fine if i did not use mod manager

Edited by hawk_za

Share this post


Link to post
Share on other sites
I still hear chattering when sending an empty habitation module all the way to Jool.

That was pretty disconcerting. :)

Are you saying that you are hallucinating from too much KSP or there is a bug? :) It shouldn't make any chatter on an empty crewable vessel.

Share this post


Link to post
Share on other sites

I can't get it to work :( I've put everything in Game Data, icon shows up, menu is accessible but there is no sound. Apollo and ISS chatter sets show 0 bytes in menu. Any advice?

Share this post


Link to post
Share on other sites
My 0.02 kerbal monetary units:


@PART[longAntenna]
{
@MODULE[ModuleAnimateGeneric] {
@isOneShot = false
}
MODULE
{
name = rbr_chatterer
}
}

@PART[commDish]
{
@MODULE[ModuleAnimateGeneric] {
@isOneShot = false
}
MODULE
{
name = rbr_chatterer
}
}

Put that in a file named something like "part-antenna-patch.cfg" somewhere in GameData and install ModuleManager into the mix, and you have Chatterer functionality in stock antennas. :)

Perfect! Thank you!

Share this post


Link to post
Share on other sites

wrong thread lol

Edited by comham
whoops

Share this post


Link to post
Share on other sites
I know they're a lot more work, but it'd be cool to see an IVA for the station can. With your texturing skills it could be the best looking mod space station internals, even if it was just cupboards and a sleeping bag.

Alternatively, maybe togglable window lights.

Yeah, it would be great if we could make kerbals sleep in the chatterer. Totally agree.

Share this post


Link to post
Share on other sites
I can't get it to work :( I've put everything in Game Data, icon shows up, menu is accessible but there is no sound. Apollo and ISS chatter sets show 0 bytes in menu. Any advice?

Did you copy the entire folders structure from the .zip?

Make sure the sound files are where they need to be. Apollo 11 clips need to be in GameData\RBR\Sounds\rbr_chatterer\apollo11. STS-1 clips need to be in GameData\RBR\Sounds\rbr_chatterer\sts1. These are case sensitive so double check if you created them manually.

Windows, OSX, Linux? Steam?

I know they're a lot more work, but it'd be cool to see an IVA for the station can. With your texturing skills it could be the best looking mod space station internals, even if it was just cupboards and a sleeping bag.

Alternatively, maybe togglable window lights.

My texturing skills are non-existant. I can only write code and barely that.

The two Chatterer parts were created by Spartan190 and baalzebob. Send a message to them about your idea; I would be hopeless at it.

Edited by Iannic-ann-od

Share this post


Link to post
Share on other sites
My texturing skills are non-existant. I can only write code and barely that.

The two Chatterer parts were created by Spartan190 and baalzebob. Send a message to them about your idea; I would be hopeless at it.

Herp, sorry, posted in the wrong thread. Meant to post it here

Share this post


Link to post
Share on other sites
I can't get it to work :( I've put everything in Game Data, icon shows up, menu is accessible but there is no sound. Apollo and ISS chatter sets show 0 bytes in menu. Any advice?

I'm having the same problem as the quote above. How can I fix this?

Edited by DreadZombie

Share this post


Link to post
Share on other sites
I still hear chattering when sending an empty habitation module all the way to Jool.

That was pretty disconcerting. :)

its the ghost in the shell =P

Share this post


Link to post
Share on other sites

I got a strange issue with this mod + BobCat's soyuz - when I added chatter module to Soyuz TMA Descent Module part.cfg, it broke - the ship was frozen over a single point on surface and the orbital speed gauge showed 0 m/s. Anyone knows what could cause such behaviour?

Also how does this mod realize wheather a craft is a probe or manned ship? Bc when I added radio to Progress I heard regular chatter instead of beeps.

Share this post


Link to post
Share on other sites
I got a strange issue with this mod + BobCat's soyuz - when I added chatter module to Soyuz TMA Descent Module part.cfg, it broke - the ship was frozen over a single point on surface and the orbital speed gauge showed 0 m/s. Anyone knows what could cause such behaviour?

Also how does this mod realize wheather a craft is a probe or manned ship? Bc when I added radio to Progress I heard regular chatter instead of beeps.

Check the debug log (Alt-F12). It will often tell you why something is going wrong.

To decide whether to play beeps or chatter, the plugin only checks for Crew Capacity. If it's zero, it'll beep. If it's > 0, it'll chatter. I don't know why some mods are causing this but I will work around it. I could add a button to switch between beep and chatter menu? I kind of like that.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0