Sign in to follow this  
Followers 0
Iannic-ann-od

[0.24] Chatterer v.0.5.9.4

659 posts in this topic

Personally, I think the SSTV should only be transmitted by a command. They're loud, frightening, and long. I wouldn't want that to happen randomly every five minutes.

Also those pictures are quite lovely.

And would it be possible to have some kind of built-in decoder?

Edited by mushroomman

Share this post


Link to post
Share on other sites

My 0.02 kerbal monetary units:

  • SSTV should only be transmitted by probes, it can be presumed manned ships have superior means of image transmission - after all, we see their portraits, don't we.
  • SSTV should be transmitted infrequently, not more often than once per 10 minutes of gameplay.
  • SSTV signal should be realistic, which means it probably has to be longish. So that it's not too jarring, it needs to be quieter than the other noises.

Share this post


Link to post
Share on other sites

Just a little change to the chatterer-part-patch.cfg, the "Mk1-2Pod" is called "Mark1-2Pod" so it should be changed to

@PART[Mark1-2Pod]

Share this post


Link to post
Share on other sites
SSTV should only be transmitted by probes, it can be presumed manned ships have superior means of image transmission - after all, we see their portraits, don't we.

Manned missions can also use SSTV:

Apollo_11_first_step.jpg

Also, the portraits aren't necessarily video feed to the ground. They're just there to let us see our Kerbals' reactions.

Share this post


Link to post
Share on other sites

Can, sure. Did a lot at some point in history, even. The point is, overuse of SSTV in randomly bleeping messages will quickly get annoying.

Share this post


Link to post
Share on other sites

Somebody told me to ask you for help on this, so I'll just copy and paste it over.

I just recently installed chatterer (link incoming!) http://kerbalspaceprogram.com/chatterer/

It worked great for a day or two, then I staged a mission to Pol, sent my lander down, came back up, then realized there was no "chattering".

I tried my insta-chatter key, but it didn't work either.

Could anyone help me with this?

Thanks in advance.

Share this post


Link to post
Share on other sites

...

And would it be possible to have some kind of built-in decoder?

It may be possible (MMSSTV has a .dll that can be used by other apps), but also well beyond my current abilities to implement. :) Unless I can find a savvy coder to help with that, you will have to use an external decoder if you want to see the images. Thanks for the input!

My 0.02 kerbal monetary units:

  • SSTV should only be transmitted by probes, it can be presumed manned ships have superior means of image transmission - after all, we see their portraits, don't we.
  • SSTV should be transmitted infrequently, not more often than once per 10 minutes of gameplay.
  • SSTV signal should be realistic, which means it probably has to be longish. So that it's not too jarring, it needs to be quieter than the other noises.

Suggestions noted and considered, thanks!

Just a little change to the chatterer-part-patch.cfg, the "Mk1-2Pod" is called "Mark1-2Pod" so it should be changed to

@PART[Mark1-2Pod]

Thanks! Edited and re-uploaded.

Somebody told me to ask you for help on this, so I'll just copy and paste it over.

I just recently installed chatterer (link incoming!) http://kerbalspaceprogram.com/chatterer/

It worked great for a day or two, then I staged a mission to Pol, sent my lander down, came back up, then realized there was no "chattering".

I tried my insta-chatter key, but it didn't work either.

Could anyone help me with this?

Thanks in advance.

Is it only sounds that aren't playing or did the entire window and icon disappear?

Are you using any Bobcat parts on that vessel? Chatterer 0.4.1 can cause issues with the Bobcat Soyuz lander and there is a temporary patch in this post.

Be sure that all the Chatterer files are in the right place and didn't get deleted or moved. See the Manual.txt file in the download for a list showing all the files and where they need to be located.

Do you see any errors in the Debug window (Alt-F2 or Alt-F11) when trying Insta-Chatter, ie NullRefException? If so, you can find detailed information about the error in /KSP/KSP_Data/output_log.txt. It will look something like this:

NullReferenceException
at (wrapper managed-to-native) UnityEngine.GameObject:set_active (bool)
at PQSMod_LandClassScatterQuad.Destroy () [0x00000] in <filename unknown>:0
at PQSLandControl+LandClassScatter.DestroyQuad (.PQSMod_LandClassScatterQuad q) [0x00000] in <filename unknown>:0
at PQSMod_LandClassScatterQuad.OnQuadDestroy (.PQ quad) [0x00000] in <filename unknown>:0

If you see an error like this that shows 'Chatterer' in it, copy the lines and post them here for me.

Share this post


Link to post
Share on other sites

Thanks for the mod I feel lost when chatterer is not on a ship :)

Share this post


Link to post
Share on other sites

hi there i was just wondering if i add the chatterer functionality to the capsules will it still draw a separate amount of electricity and if so will it be shown on the module

i.e command module alone draw 3.0 electricity/min

command module + inbuilt chatterer draw 4.0 electricity/ min

Share this post


Link to post
Share on other sites
hi there i was just wondering if i add the chatterer functionality to the capsules will it still draw a separate amount of electricity and if so will it be shown on the module

i.e command module alone draw 3.0 electricity/min

command module + inbuilt chatterer draw 4.0 electricity/ min

Yes, Chatterer will draw its own ElectricCharge when included in the capsules. The amount is shown in the VAB when hovering over a part with Chatterer.

Edited by Iannic-ann-od

Share this post


Link to post
Share on other sites

How about a chatterer that doesn't use parts but is just incorporated into the command pods and probe cores?

Share this post


Link to post
Share on other sites
How about a chatterer that doesn't use parts but is just incorporated into the command pods and probe cores?

Please read the first post. It tells you how.

Share this post


Link to post
Share on other sites

Thank you for this mod, it made my recent Mun landing simply epic. Plus, my wife finds it creepy.

Share this post


Link to post
Share on other sites

hi !

i didnt hear any apollo message,, its all gitterish..

Share this post


Link to post
Share on other sites

What, you speak kerbin?

Share this post


Link to post
Share on other sites

Alright, so I spent some time last night trying to figure out how to disable the power usage on this mod but couldn't find it. How would I go about doing this?

Share this post


Link to post
Share on other sites

I was wondering if there is a way to disable the power usage on this mod? I spent some time last night but just couldn't figure it out.

Share this post


Link to post
Share on other sites
I was wondering if there is a way to disable the power usage on this mod? I spent some time last night but just couldn't figure it out.

Find the consume_resources() function:


private void consume_resources()
{
if (TimeWarp.deltaTime == 0) return; //no power draw when paused
if (vessel.vesselType == VesselType.EVA) power_available = true; //power always available and no drain
else if (chatter_freq > 0 || beep_manager[0].imprecise_freq > -1 || beep_manager[1].imprecise_freq > -1 || beep_manager[2].imprecise_freq > -1)
{
float recvd_amount = vessel.rootPart.RequestResource("ElectricCharge", 0.01f * TimeWarp.deltaTime);
if (recvd_amount > 0) power_available = true; // doesn't always send 100% of demand so as long as it sends something
else power_available = false;
}
}

Change it to this:


private void consume_resources()
{
power_available = true; //power always available and no drain
}

Share this post


Link to post
Share on other sites

I have a probe that's using RemoteTech, which was originally connected to a manned vessel. The probe has the chatterer part, the launch vessel did not. I didn't switch to probe mode before release, and after release it no longer seems possible to switch it to probe mode... So I'm not able to select any probe options. "RemoteTech integration" is checked, though I'm not sure what it does.

Share this post


Link to post
Share on other sites

Ignore my last message, I was able to figure it out, thanks a bunch!

Share this post


Link to post
Share on other sites

Please make this randomly throw in a 'nominal' every now and then... That would be gold. In fact, if radio chatter is in the full game, frequent 'nominals' are a must-have. Except when things aren't nominal. But those times don't matter.

Edited by Vostok

Share this post


Link to post
Share on other sites
Please make this randomly throw in a 'nominal' every now and then... That would be gold. In fact, if radio chatter is in the full game, frequent 'nominals' are a must-have. Except when things aren't nominal. But those times don't matter.

Ohh... my laughbox!

Share this post


Link to post
Share on other sites
I have a probe that's using RemoteTech, which was originally connected to a manned vessel. The probe has the chatterer part, the launch vessel did not. I didn't switch to probe mode before release, and after release it no longer seems possible to switch it to probe mode... So I'm not able to select any probe options. "RemoteTech integration" is checked, though I'm not sure what it does.

Thanks for bringing this to my attention. I was able to duplicate the problem and I'll be sure to have it corrected in the next version.

RemoteTech Integration does a couple things: 1) If you are not connected to the RT network, you get no chatter from Control. Crew will still call out in vain but receive no replies until reconnected. 2) Chatter from Control is delayed by the same amount of time as RT delays ship controls. Get far away from Kerbin and it will take quite a while for Control to reply.

Please make this randomly throw in a 'nominal' every now and then... That would be gold. In fact, if radio chatter is in the full game, frequent 'nominals' are a must-have. Except when things aren't nominal. But those times don't matter.

If I add it, it's going to be backwards like everything else. :)

You will be able to do this in the next version with new loosely timed beeps. Instead of beeping every x seconds, you can instead choose have the beeps timed like chatter is timed, e.g. 1-5secs, 5-15secs, 15-30secs, and so on. Rename your audio file as beep_11.ogg or so, copy it into /Sounds, and you can listen to "nominal" until you're convinced it's not really a word.

Edit: almost done

NnTaISz.png

Edited by Iannic-ann-od

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0