Jump to content

TUTORIAL: Getting Started With Unity [BACK FROM THE DEAD!]


Recommended Posts

This tutorial will assume you have basic knowledge of modeling and texturing, if you don't, stop reading this now and watch some tutorials on youtube.

To get started: You need Unity: http://unity3d.com/unity/download/

And the KSP Parttools: http://kerbalspaceprogram.com/files/...rttools-18.zip

Then you open unity with the parttools package loaded up.

Drag in the model.

1nudm

Drag the texture into the "Materials" folder. (I prefer to keep textures and materials separate.)

1nuf3

Open the material your part is using.

1nugv

Change it to a material under the "KSP" prefix.

.......KSP Specular for shiny stuff

.......KSP Diffuse for basicl textures

.......KSP Bumped for if you have a "normal" map.

.......KSP Emissive for glowing and engine heat effects, wonderful tutorial by CardboardBox here: http://forum.kerbalspaceprogram.com/showthread.php/25023-Emissive-tutorial

1numw

Now that you have your material set, just drag in your texture.

1nunk

Now you need to make a new empty Gameobject.

1nuog

Drag the part tools script into it.

1nuoM

It should look like this:

1nupl

Drag your model into the gameobject.

1nurd

Make sure everything is located at 0,0,0

1nurS

ADD A COLLIDER MESH. I forget to do this often, it doesn't work right without a collider mesh

1nuv1

Set it to "convex"

1nuvE

Name your object and name the folder to export to. Just don't change the last field, keep it as "Model".

1nuwO

Hit "write" and you're done!

Give it cfg file, set attachment nodes, and you should have a working part!

If you need any more help here's a video tutorial by the best dev: C7.

Edited by DuoDex
fixed img tags for VERY important part
Link to post
Share on other sites
  • 1 month later...

I'm going to guess that the Part Tools do not work for 0.20. My textures are all off now. I get an error when I attempt to load the Part Tools saying that there are not enough renderers. Any suggestions?

Update: The issue was that I still had a reference to a texture in my .cfg file. Removing that caused the .mu files and their textures to load correctly.

Edited by Hooligan Labs
Link to post
Share on other sites

I am a newbie just starting to create some models and textures.

to start, I will try editing existing model.mu, model000.mbm files, can Unity edit those or what program should I use? Also the part tools link is broken

EDIT: never mind, found this http://wiki.kerbalspaceprogram.com/wiki/Editing_MBM_Textures#Converting_Textures_in_to_.PNG_Images_and_making_.MU_Model_to_load_them

Edited by lyndonguitar
Link to post
Share on other sites

How can I open an existing .mu model in Unity? I have a set of old, animated landing gear which don't work as actual wheels, I'd like to try and fix that.

Link to post
Share on other sites
  • 3 months later...
  • 5 months later...
  • 3 months later...
  • 8 months later...
  • 2 months later...

KSP is still being published on Unity 4.6.x but the version you use to export parts doesn't need to match that, its better to use a version most compatible with the KSP Part Tools script (last version was 0.23) and that is still 4.2.2. Newer versions will probably work, with some issues to work around. But if you don't need a newer version for other projects, then 4.2.2 is the best bet for part-making.

You can download older versions here: https://unity3d.com/get-unity/download/archive

Link to post
Share on other sites
  • 1 month later...
  • 5 weeks later...
KSP is still being published on Unity 4.6.x but the version you use to export parts doesn't need to match that, its better to use a version most compatible with the KSP Part Tools script (last version was 0.23) and that is still 4.2.2. Newer versions will probably work, with some issues to work around. But if you don't need a newer version for other projects, then 4.2.2 is the best bet for part-making.

You can download older versions here: https://unity3d.com/get-unity/download/archive

I am having problems getting Unity to work with Parttools .23. I first tried downloading the latest Unity, but that gave me an error when trying to attach the KSP script to the game object. After looking at this forum I saw the advice was to download 4.2.2 Unity.

However, now when I run Unity and I setup a part I do not see the 'write' button when I attach the KSP script to the game object.

I downloaded the tools from this link: http://forum.kerbalspaceprogram.com/threads/65356-0-23-PartTools?p=2018633&viewfull=1#post2018633

here is a link to the screenshot... https://drive.google.com/file/d/0B3eEt53vmN9kSUVEOENnSE85cTA/view?usp=sharing

Edited by alienspacepirate
Link to post
Share on other sites

Looks ok like I answered my own question. After downloading several unity versions I found the part tools package I downloaded from this link was corrupt. I ended up with unity 4.3.2 and part tools .23 tat I downloaded from the curse link. Just FYI for anyone interested in knowing what unity versions work with part tools.

I am having problems getting Unity to work with Parttools .23. I first tried downloading the latest Unity, but that gave me an error when trying to attach the KSP script to the game object. After looking at this forum I saw the advice was to download 4.2.2 Unity.

However, now when I run Unity and I setup a part I do not see the 'write' button when I attach the KSP script to the game object.

I downloaded the tools from this link: http://forum.kerbalspaceprogram.com/threads/65356-0-23-PartTools?p=2018633&viewfull=1#post2018633

here is a link to the screenshot... https://drive.google.com/file/d/0B3eEt53vmN9kSUVEOENnSE85cTA/view?usp=sharing

Link to post
Share on other sites

Part Tools .23 works just fine with 4.2.2. Which is the version you should be using. Installing it, such as it is, is just a case of unzipping into the assets folder inside the project directory Unity creates when you first start and create a project. This will usually be inside Documents\Unity IIRC

Link to post
Share on other sites
  • 9 months later...

Hello, hope this thread is still being watched. I'm trying to get some  new parts in unity (4.2.2) and some of my models aren't creating a material when I load them into unity. I've found out how to make materials but can't assign them to the objects that are missing materials, and I can't make the hierarchy window appear either (by clicking in the menu or pressing ctrl+4).

I did just upgrade to windows 10 and haven't reinstalled unity, not sure if I need to or not. I also think there may be some issue with my UVs, when I assign my texture to the default material sometimes it displays my textures properly and sometimes it displays it like I have no UVs, and sometimes when I duplicate my model in Maya it loses its UVs for some reason.  The googling I've done so far makes me think that Unity only creates a material for a model if it has a UV set so so far I think this may be part of the issue.

Anyone have any advice on how to get materials assigned to models?

 

 

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 3 months later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...