Jump to content

[0.21.1] KAS v0.4.3 - Struts, pipes, part storage, containers, merged winches & more


Recommended Posts

Hmm for some reason, whenever I have the GUI open and I eject, or release or do anything with a winch with a grapple on it, the GUI just goes blank and then none of the buttons or controls for the winch work.

May be another bug.... As I didn't use a lot the GUI myself, it's possible I miss it. I will check this.

My solution to aiming the grapple (that I haven't actually tried yet): Clampotron jr sitting next to the winch, using the lazor docking camera. Gets you a nice crosshair (but with a bit of offset). Maybe KAS can offer something like this built in in the future. Without the cam it'll still work like what winn75 suggested when you use 'control from here'.

I didn't use lazor cam, but maybe it's possible to add the docking cam module to the grapple in the part.cfg ?

A stand alone camera module usable on any part will be nice for modularity. But I will not do it as I know nothing about camera coding.

Yeah, I'm having this issue too. It also slows the game down a lot by flooding the debug console with an error

That doesn't let me pick it back up, the rover and skycrane are unmanned so I can't swap out the part connector for an electromagnet. (Unless I'm missing something)

I'm not sure to understand your problem, but you can't use the electromagnet to pick and lock a part under the winch. Only the connector>port can.

Don't hesitate to post a screenshot of the configuration you made, it can help me to understand.

Edited by KospY
Link to post
Share on other sites

Hmm, weird thing happened to me today. Using the same ship with radially attached winch\grapple configuration i went to Mun's orbit. There i wanted to try using cable as safety line for EVA'ing Kerbal. I went outside, floated to the winch and right clicked it, choosing Grab option. In next moment, my Kerbonaut was violently smashed into solar array, knocked it off and started tumbling towards Mun's surface in tangled mess. It took a bit of frantic control keys mashing, but luckily i managed to disentangle from the panel, stabilise flight and burn into stable-ish orbit before poor Ronley became a Mun-stain. So - what happened? Did i trigger Eject option trying to grab the grapple? Was it supposed to happen? It does not make for a good "safety line if touching the contraption threatens to catapult hapless Kerbal into solar orbit (and knocks parts of the ship off too) :wink:

Link to post
Share on other sites

Hey there. Awesome mod however, when I try to grab the magnet, I'm not given the option to actually grab it. I get the option to disconnect it though. I have actually built a truck where it lets me grab the hook, but I also made to more truck using the same hook setup and the option is not there. Is this a glitch?

Link to post
Share on other sites

Ok dudes I did some more testing. The problem of the connector turning into debris and disappearing has indeed been solved from what I can tell.

Things I have learned so far.

1. Mass Matters!! I have found just grabbing things and dragging them around is usually OK. However, when switching to docking mode, things can get ugly quick. Make sure you aren't hooking up something that is really light to something that is really heavy. This obviously has exceptions but it kept spontaneously eviscerating my drilling vessel until I actually filled it with kethane.

2. Placement Matters! Try to get the connectors on top or on the bottom of your vehicles. Kinda like a docking port. Radially attaching does work. Just not as well. On the bottom or top, and you'll be way less likely to have a mass destruction event.

YMMV.

Link to post
Share on other sites

Im having problems to transfer fuel, oxidizer, monopropellant,... from one ship to other. When i set the port to dock mode i cant transfer with alt + mouse.

Edit: The problem is about clip connector correctly :) now solved.

Edited by Cuerdas
Solved
Link to post
Share on other sites

KospY - thanks for a really nice update!

However, I just built something that produces a bunch of NullException messages in the debug log (and keeps the retracting sound playing in a loop).

Here is the thing (the issue starts when I hit the "Winch: Extend ([1])" option). Note also that I did not use the connector - I am not sure if it's even supposed to work without one, but the GUI said connector is pre-attached so I suppose - it should.

5hSXe3f.jpg

Link to post
Share on other sites

Well, since you asked for it, here it is:

HW2Ocho.png

One picture of me hauling a piece of my colony across the Munar Surface after a botched landing. With the wide base on it, it was easy to get going and then accelerate time to help cross the 900 meters that separated it's landing and the colony site.

Thank you again! Without this mod, I'd be spending most of my time relaunching the same mission to fix landing spots!

Link to post
Share on other sites

this has got to be one of the best mods ever.

managed to land my massive rover on the mun and start building a base.

screenshot1ly.png

screenshot10pi.png

screenshot15a.png

also loving the new update with the docking and fuel transfer stuff, now building a fuel dump in mun orbit as a refuelling station.

Link to post
Share on other sites

Here's my niftiest creation so far. The screenshots were taken during a prototype stage, I've done a few test/change iterations since the screenshots were taken, but the basic idea remains the same.

It's a good old fashioned crane. The real invention is using grapples to lock it to the ground, rather than ballast or stabilizers. Using Damned Robotics the arm can rotate 360, turn about 60 degrees down from vertical (120 if I add another hinge) and extend to a good bit extra length. It's very flexible too (though it looks glitched under load), so the arm is not limited by weight pretty much at all. Especially not at mun where I intend to use it. Grappled the ground with the crane to see what would break first - the core flipped even under its restraints, crashing the boom into the ground. It being uneven, it hit the boom in the middle.

The one thing this crane won't be able to do is pick up a heavy object and move it a long distance, but that's the job of a heavier vehicle. The latest iteration is approximately 7.2t, and I will try cutting down a bit more.

Big images though.

6AD21937A09C84DE89AA1ACB9581D99B932873E5

F6A11D68ED4FE0E88BC296F8FBFA89D6E31C7B67

Bugs

1) Have a winch with connector and grappling hook (built or attached, doesn't matter)

2) Extend or attach grappling hook

3) Quicksave, quickload

4) Hook is no longer connected.

Presumably it has something to do with the hooks not being docked - or even dockable. To preserve it across a reload requires releasing whatever is held and pulling it all the way in to lock it.

Also, another save/load cycle took it out of the world for me. (And I'm supposed to be on infinite debris.)

Haven't tried reproducing it a second time, though.

1) Eject

2) Retract

3) Eject

4) Try to retract - it won't react.

There's an easy workaround in pressing the extend button before retracting it again. Presumably the underlying code thinks it's still locked in the winch. Not sure if this also happens with release instead of eject.

Link to post
Share on other sites

Bugs

1) Have a winch with connector and grappling hook (built or attached, doesn't matter)

2) Extend or attach grappling hook

3) Quicksave, quickload

4) Hook is no longer connected.

Presumably it has something to do with the hooks not being docked - or even dockable. To preserve it across a reload requires releasing whatever is held and pulling it all the way in to lock it.

Also, another save/load cycle took it out of the world for me. (And I'm supposed to be on infinite debris.)

Haven't tried reproducing it a second time, though.

1) Eject

2) Retract

3) Eject

4) Try to retract - it won't react.

There's an easy workaround in pressing the extend button before retracting it again. Presumably the underlying code thinks it's still locked in the winch. Not sure if this also happens with release instead of eject.

These two I can confirm, have been using the grappling hooks as airship anchors with aforementioned results. The retracting thing was hella annoying until I figured out the workaround.

Link to post
Share on other sites
Hmm, weird thing happened to me today. Using the same ship with radially attached winch\grapple configuration i went to Mun's orbit. There i wanted to try using cable as safety line for EVA'ing Kerbal. I went outside, floated to the winch and right clicked it, choosing Grab option. In next moment, my Kerbonaut was violently smashed into solar array, knocked it off and started tumbling towards Mun's surface in tangled mess. It took a bit of frantic control keys mashing, but luckily i managed to disentangle from the panel, stabilise flight and burn into stable-ish orbit before poor Ronley became a Mun-stain. So - what happened? Did i trigger Eject option trying to grab the grapple? Was it supposed to happen? It does not make for a good "safety line if touching the contraption threatens to catapult hapless Kerbal into solar orbit (and knocks parts of the ship off too) :wink:

Nothing is safe in the kerbal universe :)

Need to take a look at this, I will send a space ship in munar orbit to check it. It can be the Kraken.

Good Idea but ...

Maybe there is a parameter to set the direction in the module ? If not maybe Romfarer can add one ?

Hey there. Awesome mod however, when I try to grab the magnet, I'm not given the option to actually grab it. I get the option to disconnect it though. I have actually built a truck where it lets me grab the hook, but I also made to more truck using the same hook setup and the option is not there. Is this a glitch?

Strange, can you try to save/load and tell me if the option come back ?

Ok dudes I did some more testing. The problem of the connector turning into debris and disappearing has indeed been solved from what I can tell.

Things I have learned so far.

1. Mass Matters!! I have found just grabbing things and dragging them around is usually OK. However, when switching to docking mode, things can get ugly quick. Make sure you aren't hooking up something that is really light to something that is really heavy. This obviously has exceptions but it kept spontaneously eviscerating my drilling vessel until I actually filled it with kethane.

2. Placement Matters! Try to get the connectors on top or on the bottom of your vehicles. Kinda like a docking port. Radially attaching does work. Just not as well. On the bottom or top, and you'll be way less likely to have a mass destruction event.

YMMV.

Have you tried the latest version of KAS (v0.2.1) ?

KospY - thanks for a really nice update!

However, I just built something that produces a bunch of NullException messages in the debug log (and keeps the retracting sound playing in a loop).

Here is the thing (the issue starts when I hit the "Winch: Extend ([1])" option). Note also that I did not use the connector - I am not sure if it's even supposed to work without one, but the GUI said connector is pre-attached so I suppose - it should.

This configuration is not supported, you need to use the connector, without it it can't work. I will try to see how disable the winch in this case (port and connector share the same module, and I only check if a connector module is attached, my mistake...)

Thank you again! Without this mod, I'd be spending most of my time relaunching the same mission to fix landing spots!

Nice ! I'm glad to know this mod can even help to fix a bad landing :)

this has got to be one of the best mods ever.

managed to land my massive rover on the mun and start building a base.

also loving the new update with the docking and fuel transfer stuff, now building a fuel dump in mun orbit as a refuelling station.

I must say my crane are a lot smaller. This crane is pretty huge :-o

These two I can confirm, have been using the grappling hooks as airship anchors with aforementioned results. The retracting thing was hella annoying until I figured out the workaround.

Retract stuck after eject are a known issue. You can effectively use extend button as a workaround. I will fix this for the next update.

About the grappling hook problem, I will take a look.

Edited by KospY
Link to post
Share on other sites

I can't say enough things to make my feelings about this mod clear to you guys.

Just a few points why I think this is easily at the top 5 of all mods:

- It doesn't contain too much parts (and therefore spamming your editor)

- It enhances the usefullness (and FUN) of EVA in such incredible ways it's just untrue

- It fits so perfectly in the game you don't notice it's a mod any more (style of the parts feels first-hand-like)

- It's cleverly balanced within the resource system of the game (you actually have to watch that your energy doesn't run out while using the magnet, etc.)

- It offers so much new fun solutions for everyday KSP problems one has to wonder why this wasn't there earlier

- Now winches and hooks are modular, making it even more useful (exchangeable hooks)

- There is no reason not to use it, in the sense that it doesn't feel like 'cheating' in any way

- Very good visual documentation with big pictures so you don't even need to speak english to understand it

- Probably much more I can't think of right now...

A BIG THANKS to KospY for your hard work, also those new models by Winn75 are great (I can't wait for the next update)! :D

Happy greetings,

BigNose

Link to post
Share on other sites

I tried saving and reloading but it still doesn't work. I have screens of one that works and one that doesn't.

This one works:

KAIM2cM.jpg

3yCXH2c.jpg

This one does not work. (No option to grab, hotkey "G" doesn't work either)

9NuJxO5.jpg

Wxpqk5z.jpg

Also when bringing up the GUI it drops my framerate significantly.

Edited by Stealth2668
Link to post
Share on other sites
This one does not work. (No option to grab, hotkey "G" doesn't work either)

It seems you attached the connector back to front. Flip it and the problem should be solve (tiny arrows on the model's texture have to point out from the winch).

1XJQWbJ.jpg

Link to post
Share on other sites

Quick question - is there any way of slowing down the reel-in rate of the cable? I've been trying to use the KAS setup to grab a kethane harvesting unit from Kerbal orbit behind my towing ship - the issue I'm having is that the cable pulls in so rapidly that it's smashing parts off the harvester, when it's not flailing the whole lot around like.... well a flail :P Also having a bit of an issue where the attached harvester isn't sitting straight compared to the towing rig, instead locking at about a 15 degree angle from straight which throws the whole center of balance of the ship off.

I'm sure it's just me doing something wrong but it's proving much more difficult to use than just docking the parts together with docking ports, which is kind of what I was trying to avoid. Tow-ropes are much cooler and better for multipurpose stuff :D I'm using winch + connector on the towing rig, with a stack connector port on top of the kethane harvesting rig if that helps at all. I can probably post pics sometime tomorrow when I relaunch everything.

Link to post
Share on other sites

For some reason, no matter the configuration, I'm unable to bring up the context menu by right clicking on the winch part, EVA or no. I have tried every possible position for the connector and have gotten to the point of bumping into the winch in EVA in an attempt to get close.

Link to post
Share on other sites
I can't say enough things to make my feelings about this mod clear to you guys.

Just a few points why I think this is easily at the top 5 of all mods:

- It doesn't contain too much parts (and therefore spamming your editor)

- It enhances the usefullness (and FUN) of EVA in such incredible ways it's just untrue

- It fits so perfectly in the game you don't notice it's a mod any more (style of the parts feels first-hand-like)

- It's cleverly balanced within the resource system of the game (you actually have to watch that your energy doesn't run out while using the magnet, etc.)

- It offers so much new fun solutions for everyday KSP problems one has to wonder why this wasn't there earlier

- Now winches and hooks are modular, making it even more useful (exchangeable hooks)

- There is no reason not to use it, in the sense that it doesn't feel like 'cheating' in any way

- Very good visual documentation with big pictures so you don't even need to speak english to understand it

- Probably much more I can't think of right now...

A BIG THANKS to KospY for your hard work, also those new models by Winn75 are great (I can't wait for the next update)! :D

Happy greetings,

BigNose

Thanks for the support, It's always very rewarding :)

It funny cause your explainations matches what we discussed about evolution of the mod. Its nice to see we took the right direction.

Kospy worked very hard on coding to make a even more "player-friendly" gameplay for this release. I think he really have the hard part here cause i'm no so good with coding.

On my side, I still have much to do to improve models. There are still many placeholders I have to update to make KAS unnoticeable as a mod.

(It actually took me much time to study stock parts and understand how they were modeled and especially textured but it was worth it).

We're glad to share this release for KSP community but we're not done yet: more is coming :wink:

Link to post
Share on other sites

Whenever I try to add this mod to my game it breaks my part loading. It'll get to about half of my parts and then the game will stop loading parts and stay there forever. I've tested it with a completely clean install from Steam and a download from the Space Port. Any help?

Link to post
Share on other sites

that happens to me once in a wile, i install to many mods one happens to get broken some how during its install and then i have to reinstall the game because of it. Did you extract the fill and "move" it to the appropriate file or did you "copy" it. in my experience the copy option sometimes breaks the mod at leased it did in 0.16 haven't tried copying sens then

hope this helped

Link to post
Share on other sites
Thanks for the support, It's always very rewarding :)

It funny cause your explainations matches what we discussed about evolution of the mod. Its nice to see we took the right direction.

Kospy worked very hard on coding to make a even more "player-friendly" gameplay for this release. I think he really have the hard part here cause i'm no so good with coding.

On my side, I still have much to do to improve models. There are still many placeholders I have to update to make KAS unnoticeable as a mod.

(It actually took me much time to study stock parts and understand how they were modeled and especially textured but it was worth it).

We're glad to share this release for KSP community but we're not done yet: more is coming :wink:

Yes, you two made definitly the right decisions on the future of this mod.

When you guys updated KAS to a point where you are happy with it, I would really love to see this getting implemented in the vanilla game.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...