Jump to content

Orion aka "Ol' Boom-boom"


nyrath
 Share

Recommended Posts

I see what you did there Rulib. I'm aiming at being able to get things working without resorting to tweakscale etc, but yeah, you definitely can make fully working craft out of Nyrath's work, with, or without things like tweakscale.

As far as internal pulse unit storage is concerned, I think I just need to work out how I want it to work now. It's a choice between how much the player is forced into reality vs just advising them of realistic limits etc. The internal, "doesn't take space" solution, leaves the system open to player abuse. But other options essentially ignore that there should be some internal storage.

I've decided to concentrate on the rest of the mod until that's more sensibly workable, then come back to this.

Link to comment
Share on other sites

Basic parts almost done. I think a couple more parts and I'll start texturing stuff.

Gotta add the escape vehicle bunk room, a workshop/lab/storage/whatever section for the lower spine, and redo the escape rocket fairings (I pretty much destroyed the design redesigning the bottom of the escape vehicle).

Then, once all that's textured I'll have another look at the various possible solutions for internal bomb storage.

Anyway, test orbiter picture. All in current design parts without thick edges.

E7539D5E53F492D8D2782E1A673B0C71A5E68FFE

Link to comment
Share on other sites

This looks neat! Wish there was a stock-like 3.75m version, are you going to build one at some point?

For stock-like, just use the 3.75m parts from the engine to the 7.2m parts. Then probably 2.5m after up to the capsule. At the moment, I don't really have any plans to make 3.75m parts, or to do specifically stock-like parts. There's not really any need considering mods that let you scale parts how you want.

I do intend to add in some adapters though. So you can add stock parts. The only adapter at the moment is the 3m to 2.5m emergency supply part with a shallow hollow at the top to take the navigation system. You'd find it in the Utility section. But I intend to make plain adapters with no other function, for the closest sizes above and below each of the part sizes I've been making. So, 3m to 2.5m or 3.75m and ditto for 3.2m. Maybe a 7.2m to 7.5m and 7.2m to 3.75m

Alternatively you can skip all my stuff and just start building on top of Nyrath's engines and use some mod to rescale parts to be suitable.

Link to comment
Share on other sites

Lord_Chappington, when you right-click on a magazine, does the pop-up menu say it is "feeding?"

Did you try firing off bombs by both using the Z key and using the throttle? Neither worked?

Link to comment
Share on other sites

  • 1 month later...
I noticed in a post and link that there is a fix for the 1.0 issue? I'm not sure where to put the new .dll files.

That'll be the fix for v0.90, wherein unpatched, it would cause all the space centre to be destroyed.

Sorry, but I don't think Nyrath's updated the dll just yet. When he does, there'll be a post in this thread. If you have 0.90 saved somewhere, the dll goes with the other dlls.

- - - Updated - - -

Rats, bombs won't go off in v1.0. Am looking into it.

I found the debug thingy! Some temperature field thingy has changed. Probably not surprising that things like that changed. Annoying, but not surprising. :-(

Curiously, bombs still fire out, but stop before passing the pusher plate. This pic isn't a moment in time frozen by the screen capture, it's the steady state after triggering the engine. The dlls control the bomb and pusher movement, so my guess is it gets to read or write that temperature and stops. With the frozen bomb. Now, if it was all written in bash or perl, I'd have a go at debugging further. Unfortunately, people don't much game-code in perl. Which is probably good for games. (sentence carefully crafted to say, not a lot, because I'm sure some bloody minded individuals would have done game coding in perl, cos perl people)

DHf5Ahl.jpg

Link to comment
Share on other sites

  • 2 weeks later...

Has anyone got this to work with 1.0.2? I can only make it drop one nuke that gives no propulsion and then it stops.

Edit: I tried it with 0.90 and it works, I think the problem in 1.0 is because of the bottom attachment nodes of the magazines. In 1.0, I have to use non-strict attachment in the f12 menu to get them to attach and it doesn't work, in 0.90 the attachment and the engine works.

I'm starting to understand why they thought it was too powerful, I made a 665t ship with the biggest bombs and 12 bombs later my apoapsis was beyond Eeloo :P

Edited by Michaelo90
Link to comment
Share on other sites

I'm trying to get a fixed package together for this week. The nodes have to be flipped, temperature hook changed, needs a place in the tech tree, and the new source code added to the package. Sorry I'm taking so long.

Link to comment
Share on other sites

I'm trying to get a fixed package together for this week. The nodes have to be flipped, temperature hook changed, needs a place in the tech tree, and the new source code added to the package. Sorry I'm taking so long.

I would recommend using Community Tech Tree and putting it in the Efficient Nuclear Propulsion Technode.

Link to comment
Share on other sites

I'm trying to get a fixed package together for this week. The nodes have to be flipped, temperature hook changed, needs a place in the tech tree, and the new source code added to the package. Sorry I'm taking so long.

Taking a long time? How am I going to get the Nexus finished in time???? Slow down!! :-)

Link to comment
Share on other sites

I need help. For some reason all the pieces in the mod wont connect to each other. So that means I cant connect the nuclear bombs to the pulse engine.

Stack nodes in pre1.0 and post 1.0 are different (slightly), which is why it doesn't connect. BUT, even if you could join them (it's a pretty simple text cfg edit) the module to make the nukes work isn't functioning yet. This is not yet 1.x compatible.

Link to comment
Share on other sites

Stack nodes in pre1.0 and post 1.0 are different (slightly), which is why it doesn't connect. BUT, even if you could join them (it's a pretty simple text cfg edit) the module to make the nukes work isn't functioning yet. This is not yet 1.x compatible.

Ok thanks, I will try to use an early version.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...