Xeldrak

What did you do in KSP today?

Recommended Posts

Posted (edited)

Ok. It's bug. It's a Unity glitch on a MacMini 2011 with shared memory GPU, that probably has a glitch too.

So both glitches renders this bug. I totally understand it.

But yet... THIS IS FUN AS HELL. I really need to learn how to do it on purpose!!! :D:D

22_KSP170-Unity-MacOS-Bug.jpg

— — — POST EDIT — — — 

I found the source of the glitch! :D 

It's something on Facebook, that "3D Photos" new thing. if I open facebook with KSP running, the 3D photos became a complete madness, with some other window's graphics being used as textures. And then KSP got some weird texturing too! :) 

Edited by Lisias
Post edit

Share this post


Link to post
Share on other sites

I guess the guy on the Mun is just checking that all his parts are where they should be.

Or he's thinking "look at the hands, never at the sky, look at the hands."

Share this post


Link to post
Share on other sites
On 4/20/2019 at 11:17 AM, Pthigrivi said:

I've read most of the other Culture books but I always liked the names in Excession best. I guess Player of Games is probably the better book? My wife has never read them (not big into sci-fi) but I almost convinced her by reading that Wikipedia list out to her. 

I love Banks and have read almost all of both his sci-fi and non sci-fi novels.  I have not found another Sci Fi author that scratches the same itch.  I read Excession first and it is a favourite, but "Use of Weapons" was pretty amazing as well. Have you read his non sci-fi?  

Share this post


Link to post
Share on other sites

I've been cleaning out the clutter in the SPH and uploading  to KerbalX a backlog of aircraft etc that have been sitting in various saves and are actually worth saving.

 

Five down, about 13 to go:

R7kzWFR.png

lp2BcSV.png

ySrkQHT.png

I2OHLzl.png

LiuFWnQ.png

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Valentina takes a spin in a brand new aerobat

Since this video, I've beefed up the ailerons to bring them up to speed with the elevators.  A real hoot to fly, especially "crop-dusting" and buzzing the peaks & valleys in the mountains to the west of the KSC...
 

Edited by Hotel26

Share this post


Link to post
Share on other sites

So I work from home right. I've been trying to land on the moon instead of working haha. 

Share this post


Link to post
Share on other sites
5 hours ago, Klapaucius said:

I've been cleaning out the clutter in the SPH and uploading  to KerbalX a backlog of aircraft etc that have been sitting in various saves and are actually worth saving.

Damn dude. I love asymmetrical too, but yeesh. Nice aircraft.

Share this post


Link to post
Share on other sites

Yesterday, I built a KSP clone of the cancelled TKS spacecraft. 

But who wants who know what I did yesterday?

Today I was pretty much messing about in KSP, trying to make a Tsar Bomba without BDarmory (and putting it on top of a Proton, which I then put in a missile silo), messing with TAC self-destruct and the abort key (you can actually set TAC self destruct on the abort keybinding!) and taking a look at stuff littered around the Kerbol System.

I jumped to a particular asteroid named Comet Halley that I HE'd into a high elliptical orbit 10 years ago reaching past the orbit of Plock. (That gives me something to be excited about when it comes back every few decades.) And then the planets of the Kerbol System, all of them except Plock, were lined up, ready for a photo shoot.

And so I got a Voyager-style Solar System family shoot!

FecaiP1.png

In the remote outskirts of the Kerbol System, the Kerbol System poses for a family pic.

(And yes, Dres is there. It's about three pixels in area. Try zooming in.)

Share this post


Link to post
Share on other sites
12 hours ago, Lisias said:

22_KSP170-Unity-MacOS-Bug.jpg

This looks a lot like datamoshing!

Share this post


Link to post
Share on other sites
2 hours ago, Delay said:

This looks a lot like datamoshing!

Perhaps a new feature on MacOS? GPU with automatic datamoshing! :D 

It appears to be related to something on Safari - only certains sites when opened triggers this. And it only affects 1.7.0, 1.6.1 and older are glitch free.

Well… It's probably some bug on memory management on the MacOS X's OpenGL. Sometimes, the image being displayed is something from the browser. :D 

Share this post


Link to post
Share on other sites
11 minutes ago, Lisias said:

GPU with automatic datamoshing!

I'd gladly buy that!

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Attempted my first (simulated) launch to orbit using my homebrew accent guidance system in my RO playthrough. It did not go well.

The guidance computer went haywire when the first stage detached and crashed, at which point the rocket nose dived to the floor.

Some more work needed I feel.

 

Share this post


Link to post
Share on other sites
23 hours ago, Fearless Son said:

Is that a modded part?  Because I've been waiting for Squad to add a two-seater Mk1 inline cockpit for a while now.

That is a modded part. It comes from Airplane Plus I believe. 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Flibble said:

Attempted my first (simulated) launch to orbit using my homebrew accent guidance system in my RO playthrough. It did not go well.

The guidance computer went haywire when the first stage detached and crashed, at which point the rocket nose dived to the floor.

Some more work needed I feel.

 

Don't be too hard on yourself .... many (many) RL launch guidance engineers had similar problems.. At least you don't have to worry about installing your gyros upside down  :)  

Can't wait to see how your work progresses. Handling staging seems like the biggest challenge for Gravity Turn.

Edited by Tyko

Share this post


Link to post
Share on other sites

Today, coming home from work in my new roadster. :cool:

dPjVj3H.png

R7Bjvi8.png

hHK8S7g.png

cJyEiam.png

Now, let's go and bomb it. :ph34r:

lQ3g4pc.png

I love this game. :lol:

 

Share this post


Link to post
Share on other sites

Soooo....I've been working on Minmus operations for about a month.  Building a few drilling rigs, adding a few rovers, an ore processor, and finally a larger fuel storage craft.  Currently I have the following

  • 3 satellites in geosync orbit around Kerbin
  • 1 resource satellite around Minmus
  • 1 relay satellite around Minmus, to help prevent signal outage zones
  • 2 ore drilling rigs on the surface of Minmus (first two craft put on Minmus)
  • 1 rover mainly for transporting ore from drillers to ore processor (3rd craft on Minmus)
  • 1 ore processing craft
  • 1 additional rover, just for moving fuel from ore processor to fuel storage rig

Today, I finished building my fuel storage vessel, tested out the alignment of the docking port for transferring fuel to/from rovers, and launched the craft to Minmus.  Landed great, BUUUUUUUT......big problem.....2 of my craft are no longer on the surface of Minmus.  They are nowhere.  They are gone.  Not on the surface, not in the tracking station.  No little pieces....just completely....GONE!  :mad:

1 of my mining rigs, and my 1st rover  used for fuel, ore, and monoprop moving, are both missing.  AAAAAANNNNND, I was going to take a screenshot for this post, so I loaded KSP to my last save, went back to Minmus annnnnnd.....another vessel is missing, my second rover just for fuel is now gone.  Thinking I'm not liking 1.7 very much.  Very few mods loaded (KER, RCS Build Aid, X Science,  & Surface Lights).  Never seen anything like this before.

Here's what is left now:

Mig3uOu.png

 

 I reloaded my save as I was coming in for final landing with my Fuel Station craft (already missing a rover and ore rig).  It almost seems like KSP 1.7 can't keep track of more than 10 objects, including craft and debris.  At least, that appears to be what I am seeing so far.

 

Share this post


Link to post
Share on other sites

Full story at 11.

50dscreenshot325.png

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, djr5899 said:

can't keep track of more than 10 objects

Can't say for sure this is 1.7 because I think it (would have) happened in my Orbit world [1.6.1], BUT: I've noticed that if you use [, ] keys to cycle rapidly between nearby (physics range) craft, you may hear a Poof! in the background and a head count shows a missing ship.  (I'm running World Stabilizer in my 1.6.1 mix, so that's a complication.)  I've gotten OK at recovering the missing ship from a persistent.sfs (before it gets auto-saved over; or from a quick save) and splicing it back in to the current world.

Sometimes I lay awake at night in my bunk thinking about a futuristic AI-based mod that just rides shotgun on KSP and thinks, "Naaaaah!  No way.  That should NOT have happened.  Doesn't make any damn sense whatsoever!  OK, I will step in and Fix That."  You would perhaps hear an Unpoof sound and see a cheery caption at the bottom of the screen, fading out after a couple of seconds, "Don't Panic".

I haven't yet concluded whether the mod should be called Fix That or Don't Panic...

Serious take-away: don't cycle between ships rapidly, if that's what you are doing.

Edited by Hotel26

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Tyko said:

Don't be too hard on yourself .... many (many) RL launch guidance engineers had similar problems.. At least you don't have to worry about installing your gyros upside down  :)  

Can't wait to see how your work progresses. Handling staging seems like the biggest challenge for Gravity Turn.

I know what the issue is, my code calculates stage mass to work out an estimated burn time, but I'm not getting everything assigned to the right stage. So it thought the second stage would burn for around 30 minutes, rather than 130 seconds.

Edited by Flibble

Share this post


Link to post
Share on other sites

It's not 11, but full story.

Tried out the in-flight abort roughly 3 seconds after liftoff.  The cabin ejected perfectly fine, and I got to watch the rest of the contraption tumble and fall (No SSs :( ).

I think FMRS killed the SSMEs when I ejected.  However, what's really strange, was the thing tumbled back down to the ground, basically landed on its tail, and the SRBs shut off when it touched the ground.

 

Then the capsule touched down.  And the SRBs RELIT!

I really wish I had more screenies.  I should really get another, like, 2TB drive and dedicate it just to screenshots with that auto screenshot mod running like every second.

b78screenshot321.pngd5dscreenshot322.pnged5screenshot323.png

ecbscreenshot324.png768screenshot326.pngscreenshot327.png

screenshot328.png1c1screenshot329.pngscreenshot330.png

 

I tried to recreate it, but no dice.  The rest of the vessel exploded on contact with the ground, and the capsule ended up destroying the flagpole by landing on it.

screenshot337.png

 

Share this post


Link to post
Share on other sites

Not much progress on my orbital flight. Still having issues getting the stage masses calculated correctly (turns out to be some weirdness between the engine I'm using and kOS).

It flies the early ascent phase beautifully though:

y4mX8rGDC-jTvOj6g9Z9XMD3ln1cX_0Fb4Zjs919UdHPB6VSOxgTK5niP2mjEF-DHSQzWGcqb87jeV5RhxCEuJRzvZNgbVJAPGhIhJ7pi1ynFrSlM52eceHa2PoQT1IzbIbhYKKsVepuLM4pTn_z6LYgHCuv1MZOe5mbUytfoPnmjcydNtf2Ue9XlpVXT_kRaWIcV6Xd1ZOLKcSqJBIAn_JJw?width=660&height=413&cropmode=none  y4mLGSGLIAk4NoPl1dvtUkvTb-F6gq_9SfT2VVXVd1ycLnVS6_cJ29TpEgqzB3ToO1SUV_1W3-jFMCPovMUDBOsrkYnQBVU-MPbfmKN2OSBEkNMdW60V-GcvxFq0Lf20Ar3owa2UyatKzINop6Wqa9qjWXqsmfHaqfcZFhAFebJb9uHOa8a7Scvz9tgvGktQM3-AqA2oSrSzeQQn25NAu9ETg?width=660&height=413&cropmode=none

Share this post


Link to post
Share on other sites
Posted (edited)

(1.6.1) Howdy, y'all. Hadn't fallen off the face of the Earth, just haven't had a great deal of time to play this past week. Missus went to the hospital on Monday and had to have a cholecystectomy yesterday, so I have a bonafide excuse for not playing much...RL kicked my butt over the weekend also, just not quite so hard. Took some time to go into work today so I figured I'd use the opportunity to tell y'all about what little has happened.

On Friday, got a signal from engineer Ceri Kerman aboard LSV House Atreides orbiting Eve. After seven days of working hardly, she had finished the construction of the Hellhound 7a rover/skycrane. The nascent rover was fueled up and released from Atreides's drydock.

Z5O06iZ.png
Hellhound 7a rover, take two.

After clearing the drydock, the rover was lowered into a 100-kilometer, 3-degree inclined orbit, burning for a landing point in the Midlands upon reaching the target coordinates. Here the mission hit a hiccup - I misjudged the timing of the burn and wound up fairly far off target.

gBBH9V6.png
At least this time I was able to get the damn heat shield jettisoned without destroying the whole damn thing in the process...

The rover finally settled gently to the ground intact about 140 kilometers east of the target zone in the Shallows, on land.

vgrveTK.png
Phew.

After releasing the rover, I went ahead and terminated the skycrane itself in the Tracking Station. I consider this action a cheat - the skycrane didn't have sufficient thrust for liftoff and it turned out that it was too tightly wrapped to the rover to allow it to slip out from underneath. At least at this point I have an intact rover on Eve. Still have yet to initiate its primary mission of attempting to locate a flat enough zone in the Midlands or Lowlands suitable for the establishment of a ground base. Got a 130 kilometer rove ahead. Here's hoping I don't bust any tires in the process...

Nothing to report for Saturday as usual, but I did do a little Sunday drive flight with the Bad Idea 4. The plane was modified to haul up two Wheesley engines each stuck to a piece of structural fuselage and a parachute, which in turn was cobbled onto the wingtips via structural pylons. Pilot Kardon Kerman took the modified craft up to 11,000 m for a quick parts test; after that was done, the extra engines were jettisoned at the plane proceeded to do a 5-point high-altitude temperature survey just under a thousand klicks southeast of KSC


SOjuBrp.png
I don't use the Whiplash engine for much of anything, so I still get excited about stupid things like shock rings...

Survey complete, Kardon returned the plane intact to KSC 27.

Things are largely on hold at the moment until my wife gets out of the hospital. I've still got the Eve mission coming up and the science team is just about done with their experiments aboard space station Dunaport, so that will probably be getting started sooner rather than later. Got a rove to do as well, and I have a couple of small contracts that I could knock out relatively fast; I'll probably wind up doing those today just so I can feel like I accomplished something.

 

Edited by capi3101
fixed some grammar/formatting.

Share this post


Link to post
Share on other sites
Posted (edited)

Todaydreaming

X3L8gTS.png

daImCQF.png

Edited by Triop

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.