Sign in to follow this  
katyjsst

Is 0.20 faster?

Is 0.20 faster than 0.19?  

1 member has voted

  1. 1. Is 0.20 faster than 0.19?

    • Yes! Very significant change
      78
    • Yes! Slight improvement
      111
    • No change.
      53
    • Performed worse.
      34


Recommended Posts

Ever since I play 0.20 my loading times have decreased and my lag has reduced significantly. I sympathize with the people who are having problems though, I know how it feels when you're favorite game is letting you down... but I'm having zero problems with the new release.

Edited by Peenvogel

Share this post


Link to post
Share on other sites

Loading times stayed the same, overall FPS decreased by more than 50%, i could play fine with 45-60 before, now I don't go over 25 no matter if it is a single mk1 pod or a 100 part ship. I can change the graphics option from low to high with anti-alias and it stays the same.

3.2Ghz AMD Phenon II CPU, AMD HD4870 GPU, 32GB of ram, 40GB X-25V Intel SSD.

Share this post


Link to post
Share on other sites

I think people should be more accurate, both in asking this question and in answering it:

I, for example, have noticed the game running faster, but only as long as I don't "look" at the ground.

I get horrible lag when the camera view includes Kerbin's terrain, while there is a definite improvement in loading times, and especially in launching ships with high part count.

we all seem to agree on the fact that the new terrain textures have caused problems to a lot of people, so "is 0.20 faster than 0.19" cannot be really answered.

Share this post


Link to post
Share on other sites

0.19 orbiting kerbin around 20fps 0.20 orbiting kerbin 1 to 10 fps. my PC is kinda bad but it ran 0.19 decently enough

Share this post


Link to post
Share on other sites

On my main ~400 part mun lander launch vehicle I've gone from a solid 20fps on the pad, down to 5 or 6 fps, with the same settings. Also loading from the VAB/SPH or into a flight from the tracking station takes longer, though map view does load faster as does the initial game load. I'm running a 2.8GHz Phenom II X6 1055T with an HD5870 and 8GB of RAM. Additionally with that same ship I used to get a good 30fps in space, now it's around about 8 at best, at least until I've detached my rovers.

Share this post


Link to post
Share on other sites

It seems to perform - differently. Can't really say it's faster, but it feels different.

The biggest concern for me right now though is that the kracken seem to be back X(. Have to be careful to switch craft via the tracking station rather than using "[" and "]".

Share this post


Link to post
Share on other sites
Guest trolling trains

the only thing faster for me in the load times

Share this post


Link to post
Share on other sites

Loading time are way longer for me, maybe twice what they were in 0.19. On the flip side, that annoying "crash on second launch" memory/ram issue has vanished so I'm actually pretty happy :D

Share this post


Link to post
Share on other sites

This type of question is kind of pointless without knowing what everyone's pc specs are too. i5 3570k@4.5ghz gtx 670 FTW, 16 gb's ram

I haven't noticed any difference at all, and I would expect anyone with a higher mid range- high end specced pc likely wouldn't notice a difference either, or much of one at any rate.

Edited by _Aramchek_

Share this post


Link to post
Share on other sites

AMD Phenom II x4 955 BE, 12gb ram, GTX 570.

I got an across the board performance boost with 0.20. And I also apparently don't suffer from the 'kerbin lag' like others do. I've had pretty much zero performance issues with .20 so far.

In .19.1 pretty much everything I did caused physics slowdown (mission timer in yellow) and I see very little of it now in .20 dealing with the exact same ships.

The only problem i've encountered at all so far is apparently the Mun grew by about 50m.. since my .19.1 munbase, and everything else on Mun, ended up underground and unresponsive in .20.

Edited by Qumefox

Share this post


Link to post
Share on other sites

On my big computer there was no difference. It was running max settings full speed and it is still in .20.

On my notebook however, it was a slide show in .19 at lowest settings and now I have over 30 FPS. Thank you Squad, this helped a lot.

Share this post


Link to post
Share on other sites

It feels faster in 0.20. Higher part count ships in particular seem like they don't have the same game-time slowdown they used to. I haven't actually measured or loaded up any of my biggest ships from prior to 0.20 though.

On the other hand, the framerate whenever Kerbin is on-screen seems to be worse. Or more accurately, Kerbin's horizon. On the launchpad, if I look straight down, the framerate will be good, as it will if I look straight up after launch. But any time I can see the horizon, including once I'm in space, my framerate drops. My guess is something's up with the shaders that do the atmospheric effects, but that's just a guess.

Anyway though, the game-time slowdown was always a bigger issue for me than the framerate. I'd be alright with down to about 4FPS on huge ships if the simulation ran full speed. It didn't used to, it might now.

Share this post


Link to post
Share on other sites

I feel a dramatically more significant change after 0.20 compared to 0.19, but that may be because of all of the mods I had in 0.19. Regardless, the game doesn't guzzle my memory any more so that's a plus.

Share this post


Link to post
Share on other sites

Seems the same to me once I fixed my mods.

Core i7 2600K @ 4.5GHZ, Radeon 6970, 8GB RAM. OS is on an SSD but I have KSP running on a conventional HDD.

Share this post


Link to post
Share on other sites

much faster yes. sound stutters are almost gone but no totaly. A ship with 200 parts is easy to launch without being unplayable, before it would be a massive struggle.

Share this post


Link to post
Share on other sites

Mine's faster, but probably because I don't have so many addons (used to have KW and NovaPunch)

Although before I installed addons, it was faster than stock 0.19

Edited by last_user

Share this post


Link to post
Share on other sites

Performance is still bad when looking at kerbin maybe even worse for me. Loading parts at the beginning seems slower. Ram usage has lowered but performance isn't better. Specs are Intel i3-2100 3.1GHz. 8GB DDR3 ram, Radeon HD 5570 graphics card. Windows 7 Home Premium 64-Bit.

Share this post


Link to post
Share on other sites

Somewhere I read that unity runs not so well if you have an Intel Celeron core, so that could be some peoples problem.

0.20 for me has been amazing, I get 40-50fps and no more random game crashes when I try to launch a rocket!

happy landings :)

Share this post


Link to post
Share on other sites

Based on how the graph is showing, I think it follows a good pattern, if we were to replace the keys:

significant: Low to mid end computer users

Slight: Mid to high end computer users

No change: Those Alienware or Razer type setups, or other "hot-rod" souped-up PCs with all the goodies in them.

Performed worse: various reasons (v0.19 mods, O/S issues, some not updated drivers, etc.)

this is just my opinion/observation/prediction

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this