m4v

[1.2] RCS Build Aid v0.9.1

Recommended Posts

Maybe I am using this wrong but when I open the CoM and press the buttons, the CoM disappears for a split second and the arrows appear then disappear under the rocket.

tried with B9, Nova, mechjeb. then with just stock same behavior

If the CoM disappears then maybe is because RCS are already balanced? Or you don't have any RCS in place?

Could you make the red darker than that? It's difficult to tell them apart at first glance.
I'm not very inclined to do it so. Yellow and red look very contrasting to me.

Share this post


Link to post
Share on other sites

I just thought I'd post a positive response for you (since most people only hit the forums when they have a problem ;) ). Your mod is dead easy to install and works perfectly for me. I detach the final part of my ships and adjust with this to get them perfect or as close as it goes - the difference is amazing. My ships are so much easier to dock and land, thanks and please keep updating this as KSP develops.

Share this post


Link to post
Share on other sites

Great idea for a useful mod! I like the new idea of being able to see Empty as well as full tank CoM. I kinda wish there was a mod to test multi-tank fuel flow balance (Especially for space planes)... where you would want to know where the CoM is throughout the fuel draining process.

Share this post


Link to post
Share on other sites

More good feedback for you. I had no idea what I was missing without this mod. A million and one thank you's!!!!!!

I refuse to build another payload without this!

Share this post


Link to post
Share on other sites

I got the same problem than Charles Darwin. Re-installed a few times, with and withoud other mods, and the only thing i get is a flickering CoM when I press the translation keys. I can't understand where the problem lies, and it's driving me mad. It seems to work according to other's comments. So why?

Share this post


Link to post
Share on other sites

Are you holding down on one of the ijkl keys or just pressing once? Just one press makes the arrows show up, if you press again it restores the "normal" com display. So if your holding down the button you would be turning the display off and on at the input rate of your keyboard and that would cause flickering.

Just a thought.

Share this post


Link to post
Share on other sites

Thanks for your thought, but nope. Holding or pressing once does the same thing. Besides, it flickers (I apologize for any misuse of this verb) only once.

Edited by Initar

Share this post


Link to post
Share on other sites
I got the same problem than Charles Darwin. Re-installed a few times, with and withoud other mods, and the only thing i get is a flickering CoM when I press the translation keys. I can't understand where the problem lies, and it's driving me mad. It seems to work according to other's comments. So why?
damn, I don't know what could it be. It might be an issue with the keyboard shortcuts but I don't know why. The next version will have a bit of rewriting and I plan to add a GUI interface after that. Maybe with a good deal of blind luck we can strike that bug down.

Share this post


Link to post
Share on other sites

Dunno either, i set my keyboard from azerty to qwerty, but no luck again. I had this mod for a while, and you realize how useful it is when it does'nt work. I'll have to wait for the next version!

:)

Edited by Initar

Share this post


Link to post
Share on other sites

Hey, just curious -

Whatever you're calling to present the arrows - Is that call-able outside the VAB?

For that matter, are the stock indicators for center of thrust / center of lift presentable outside the VAB?

It would be kind of awesome for debugging craft in-flight, or designing variable geometry craft.

I've always wanted to build a 'dock-bot,' like a separate RCS platform that grabbed station components for assembly, for example.

Being able to see this information live and in-flight could be super useful.

Share this post


Link to post
Share on other sites
Hey, just curious -

Whatever you're calling to present the arrows - Is that call-able outside the VAB?

For that matter, are the stock indicators for center of thrust / center of lift presentable outside the VAB?

It would be kind of awesome for debugging craft in-flight, or designing variable geometry craft.

I've always wanted to build a 'dock-bot,' like a separate RCS platform that grabbed station components for assembly, for example.

Being able to see this information live and in-flight could be super useful.

There aren't any technical reasons (at least I can't think any) for argue that this can't be done in flight. But there are some assumptions I make in VAB that make my life easier that I couldn't do in flight, you know how the devil is in the details, there are a lot more forces affecting your vessel in flight and some mods like to replace stock modules during that time.

The question isn't "can it be done?", but "should I bother?" and "is it worth it?" for the time being I'm not going to, limiting the scope of a project is a good way of keeping it simple and maintainable and right now the scope is "VAB/SPH only".

Share this post


Link to post
Share on other sites

bumping v0.3 update, features:

* Dry center of mass.

* Fancy new circular arrow for display torque.

* Reworked the display of arrows so there's no need of shrinking CoMs.

Share this post


Link to post
Share on other sites

This is one sweet tool. It should really be stock someday. Great work! :D

Share this post


Link to post
Share on other sites

Outstanding improvements!

There's a minor problem for me: The the dry mass marker shows up when I toggle the mass indicator (Yay!) but does not reappear if I then toggle the mass indicator off and then on again (Boo). Reopening the craft brings it back. I haven't tested thoroughly yet and my game is not stock, so could be another mod hurting it.

Sweet mod regardless! Has become a "must-have" for my game.

Share this post


Link to post
Share on other sites

There's a minor problem for me: The the dry mass marker shows up when I toggle the mass indicator (Yay!) but does not reappear if I then toggle the mass indicator off and then on again (Boo).

is a bug, thanks. Will fix tomorrow.

Share this post


Link to post
Share on other sites

fixed, sorry about that.

Share this post


Link to post
Share on other sites

Thanks for making this mod. It makes adding RCS fun and easy now! Would it be possible to adapt it to also show torque from main engine thrust vectors as well? I'd love to be able to make some asymmetrical ships. At least if torque was low enough then thrust vectoring could take care of the rest. (it would be even more amazing if there was an indicator that would tell you if thrust vectoring was enough to keep the ship flying straight or not, but that would just be a bonus).

In any case, thanks again for this mod. :)

Share this post


Link to post
Share on other sites
Would it be possible to adapt it to also show torque from main engine thrust vectors as well? I'd love to be able to make some asymmetrical ships.
yes, there's already some work done for that, it works but It doesn't care about stages yet, so is like all the engines are ignited. Edited by m4v

Share this post


Link to post
Share on other sites

Amazing, i gonna try it now!

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now