m4v

[1.2] RCS Build Aid v0.9.1

Recommended Posts

RCS thrusters are engaging for some reason, but not all the time. My vectors are fine in the balancer, but as soon as I engage RCS (sometimes) I get a small thrust in one direction that won't stop.

You might have some trim set - hit Alt+X (Mod+X) to clear trim.

Share this post


Link to post
Share on other sites
RCS thrusters are engaging for some reason, but not all the time. My vectors are fine in the balancer, but as soon as I engage RCS (sometimes) I get a small thrust in one direction that won't stop.

Mmh, not sure what could it be, if there's nothing estrange in the editor then the problem is either modded RCS or something else completely unrelated. Sorry that I can't be of much help.

Anyone tested this on 0.24.2 x64?

well, the current version was build for 0.23.5 but it was reported to work perfectly in 0.24, so I don't see any reason for not working in 0.24.2. The only thing I would have to check is the math change that Squad did to RCS in 0.24.1

Crash aswell.. on 0.24.2 x64

Crashes are never a mod issue, blame the 64bit build.

Share this post


Link to post
Share on other sites
Crashes are never a mod issue, blame the 64bit build.

False. What's going on is x64 isn't catching some exceptions, so now if your mod throws in OnGUI, the whole program CTDs. So it may be both issues, and you can't know that without seeing the log.

Share this post


Link to post
Share on other sites
False. What's going on is x64 isn't catching some exceptions, so now if your mod throws in OnGUI, the whole program CTDs. So it may be both issues, and you can't know that without seeing the log.

Which is an issue with KSP/Unity, it shouldn't crash because a mod throws an exception, no matter the kind. And I did briefly test RCS Build Aid in both 32 and 64bits (linux) and there weren't any exceptions nor crashes.

In short, crashes aren't my problem, don't report them here.

Share this post


Link to post
Share on other sites

Just installed and tested for myself and very pleased with this mod! Very useful.

Please, if you can, support the KSP AVC mod with a .version file in your mod. It means every time I boot the game up, it tells me if you've released a new version.

Share this post


Link to post
Share on other sites

Please, if you can, support the KSP AVC mod with a .version file in your mod. It means every time I boot the game up, it tells me if you've released a new version.

yes, I will do that.

Share this post


Link to post
Share on other sites
RealFuels support for this would be great!

I don't use RealFuels and I know better than supporting something that I don't use.

What is broken anyway? at first glance it doesn't look like RealFuels adds their own modules or something like that.

Share this post


Link to post
Share on other sites
I don't use RealFuels and I know better than supporting something that I don't use.

What is broken anyway?

It mostly works, but it seems that RCS Build Aid doesn't recognize any of the RealFuels resources when it's calculating the dry CoM; It's always in exactly the same place as your regular CoM.

dCoM is useful, but the mod is still insanely awesome without that functionality.

Share this post


Link to post
Share on other sites

you're right. There is thrust displayed but no delta-V or other exact readings.

Share this post


Link to post
Share on other sites

On the Mass tab, you can choose what resources count when determining DCoM.

The only incompatibility with RF is that "RCS Delta V" assumes MonoPropellant is the propellant, which is already false for stock, so you needn't be using RF to have it not work. :)

Share this post


Link to post
Share on other sites
It mostly works, but it seems that RCS Build Aid doesn't recognize any of the RealFuels resources when it's calculating the dry CoM; It's always in exactly the same place as your regular CoM.

dCoM is useful, but the mod is still insanely awesome without that functionality.

Deactivate the resources from the mass tab, RCSBA defaults to adding the mass of unknown resources to the DCoM, the setting will be remembered so you have to do it once per resource. I'll change the default in next release.

you're right. There is thrust displayed but no delta-V or other exact readings.

the delta-v reading it very dumb and only works for a corner case, mainly for single stage vessels with stock RCS using monopropellant, and is probably broken for the new bipropellant RCS that Squad introduced, but I think that is fixable.

Share this post


Link to post
Share on other sites

Version 0.5
-----------

* GUI revamp.
* Disable plugin when editing crew/actions.
* Editor CoM toggle button now toggles all markers (when using the toolbar).
* Update RCS math (changed in 0.24.1).
* Added .version file.
* Readme rewrite.

Known issues:

delta v readout will only show for monopropellant RCS, doesn't work for the new Vernor RCS.

Share this post


Link to post
Share on other sites
Version 0.5
-----------

* GUI revamp.
* Disable plugin when editing crew/actions.
* Editor CoM toggle button now toggles all markers (when using the toolbar).
* Update RCS math (changed in 0.24.1).
[B]* Added .version file.[/B]
* Readme rewrite.

Known issues:

delta v readout will only show for monopropellant RCS, doesn't work for the new Vernor RCS.

Wonderful, thank you so much!

Share this post


Link to post
Share on other sites

First up: thank you thank you thank you. This mod has saved me endless hassle when docking my spaceplanes; they're a right sod to balance by eyeball and trial and error.

Is there any way to separate the analysis of Vernors vs conventional RCS? I tend to use linear thrusters on my spaceplanes for docking (so I want those balanced) and Vernors for in-flight vectored thrust trickery (and these work best when placed in a totally unbalanced fashion; it's all about yanking the nose around).

At the moment I'm just aligning the RCS thrusters before I put the Vernors on, but it's a right nuisance having to remove all the Vernors again any time I change anything that requires a rebalance. A toggle that lets you view Monoprop and Vernor thrusters separately would be wonderful.

Share this post


Link to post
Share on other sites

Is there any way to separate the analysis of Vernors vs conventional RCS? I tend to use linear thrusters on my spaceplanes for docking (so I want those balanced) and Vernors for in-flight vectored thrust trickery (and these work best when placed in a totally unbalanced fashion; it's all about yanking the nose around).

Not sure if I want to, Vernors and monopropellant RCS are pretty much the same thing, the difference being that one has higher thrust than the other, distinguishing each would probably be hacky.

Share this post


Link to post
Share on other sites

I have a major problem of not being able to make this mod to work. My issue is that when i enter the VAB, build a vessel (i place RCS thrusters and RCS fuel), I enable the CoM button, press any of the translation buttons but no indication arrows of the RCS build help appear, also the mod's menu does not appear at all. I tried enabling this mod with and without the toolbar but with no success, also at the toolbar there is no icon for the mod. The path i installed the mod is c:\games\KSP\Gamedata\RCSBuildAid\ (at the RCSBuildAid folder are the mod's files) and also tried c:\games\KSP\Gamedata\RCSBuildAid-master\ (it's the zip's file name when i download from github). Finally i tried this mod without any mods installed and i had the same issue and it is the 32 bit version of KSP.

Share this post


Link to post
Share on other sites

small update, i installed the 0.4.5 version and it works fine. Is it possible that it is a compilation problem of the new version? i checked the files at the new version and there are some extra files that are not at 0.4.5

Share this post


Link to post
Share on other sites
I have a major problem of not being able to make this mod to work. My issue is that when i enter the VAB, build a vessel (i place RCS thrusters and RCS fuel), I enable the CoM button, press any of the translation buttons but no indication arrows of the RCS build help appear, also the mod's menu does not appear at all. I tried enabling this mod with and without the toolbar but with no success, also at the toolbar there is no icon for the mod. The path i installed the mod is c:\games\KSP\Gamedata\RCSBuildAid\ (at the RCSBuildAid folder are the mod's files) and also tried c:\games\KSP\Gamedata\RCSBuildAid-master\ (it's the zip's file name when i download from github). Finally i tried this mod without any mods installed and i had the same issue and it is the 32 bit version of KSP.

I don't do GitHub releases, the zip from github only has sources. Get the binary from curse, see the original post of this thread for a link.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.