m4v

[1.2] RCS Build Aid v0.9.1

Recommended Posts

9 hours ago, NJC2 said:

It showed up on CKAN, so you either fixed it or didn't need to do anything.

My mod can't be automatically indexed, so somebody has to. In the past It was me, now the CKAN crew seems to have taken up the task, which is awesome.

Share this post


Link to post
Share on other sites

Rendered everything in the KSC unclickable right after installing this via CKAN. v0.8. My mod list is pretty huge already though, so a conflict with one is likely very hard to track down, and since it appears nobody else has brought this up here yet, I should probably assume that's the case.

I don't have a log file... Not sure how to obtain information that helps with that. 

Share this post


Link to post
Share on other sites

@charliepryor Removing RCSBA fixed it though?

2 minutes ago, charliepryor said:

I don't have a log file... Not sure how to obtain information that helps with that. 

In this thread

You will find this

Quote
  1. The Logs
    These are text files that the game spits out for debugging purposes as it runs; if something broke horribly in-game, there will be something in here about it. You should upload the entire log as a file (i.e. not to pastebin); you can use dropbox or an equivalent host to upload the file. Make sure the entire file gets uploaded; you may have to zip it first, as logs can be very long. Here is where you can find the log:
    • Windows: KSP_win\KSP_Data\output_log.txt (32bit) or KSP_win64\KSP_x64_Data\output_log.txt (64bit)
    • Mac OS X: Open Console, on the left side of the window there is a menu that says 'files'. Scroll down the list and find the Unity drop down, under Unity there will be Player.log ( Files>~/Library/Logs>Unity>Player.log )
    • Linux: ~/.config/unity3d/Squad/Kerbal\ Space\ Program/Player.log

 

NOTE: These logs are not the same as KSP.log, which lacks valuable data. Do not upload KSP.log; do upload output_log.txt / Player.log

 

 

Share this post


Link to post
Share on other sites
6 minutes ago, m4v said:

@charliepryor Removing RCSBA fixed it though?

In this thread

You will find this

 

 

Yes, I'll look into that and get back with you... removing RCSBA didn't exactly solve it right away, but I reverted the KSP folder to a version from before installing (hence why my logs are likely not there now) and everything went back to normal with no noticeable errors. This was a couple days ago.

I'll replicate the steps I did before and see about getting you a log here. Thanks.

Share this post


Link to post
Share on other sites

Sorry I responded to a post and didn't look at the date. My response couldn't be what their issue was. 

But I will report that it appears this mod is working in 1.13.  I had to start a new game though because it seems old saves have been messed up for me.

the vab window comes up. In sandbox the markers all seemed to function and change as I moved rcs. I just didn't actually test to see if any craft was actually balanced under rcs during flight yet though, but all appears to be working as expected so far.

Edited by Hevak

Share this post


Link to post
Share on other sites

So as my previous post says it appears rcs build aid is functioning still in 1.13. But I do have a bug report.

i know previously this bug had popped up, I think it got fixed at one time but I'm not sure. When you first enter the VAB and start to build a craft, if you go to action groups or crew mode then back to build mode it will pop up the CoL/CoM marker from RCSBA. If you then open and close the RCSBA these go away. As long as you don't leave the VAB you can switch to action groups or crew mode and back to build mode without these popping up again. But this will happen again if you leave the VAB and then come back in.. So it's only the first time you switch modes.

not a big issue, but just wanted to report it.  

Share this post


Link to post
Share on other sites
34 minutes ago, Hevak said:

not a big issue, but just wanted to report it.

Noted. Next time I can play KSP I'll look into it.

Share this post


Link to post
Share on other sites

Sorry, but the same thing is happening still in KSP 1.1.3 with this plugin. Everything is fine when installed, but when I come back and load the game again the next day, it's all messed up. None of the UI works at the space center. It doesn't even show me the whole place... it's just all the way zoomed in, and the camera is not controllable either. Only way to 'fix' is to alt-tab out and force the application to quit, and then remove the mod.

I've attached the log file here this time as instructed above. When I remove RCS Build Aid, everything returns to normal and operates as expected.

Share this post


Link to post
Share on other sites

@m4v Thanks for the update!  I haven't tested it yet but quick question, did you by any chance integrate anything similar to my fix (just a few lines of code, borrowed from @linuxgurugamer) to prevent the RCS Build Aid hotkey handlers from responding when you are typing into input boxes such as the part search textbox?

 

 

Share this post


Link to post
Share on other sites
On 10/7/2016 at 9:28 PM, charliepryor said:

Sorry, but the same thing is happening still in KSP 1.1.3 with this plugin. Everything is fine when installed, but when I come back and load the game again the next day, it's all messed up. None of the UI works at the space center. It doesn't even show me the whole place... it's just all the way zoomed in, and the camera is not controllable either. Only way to 'fix' is to alt-tab out and force the application to quit, and then remove the mod.

I've attached the log file here this time as instructed above. When I remove RCS Build Aid, everything returns to normal and operates as expected.

At glance I can't get any clue from the logs, there's a bunch of exceptions but I can't see how RCSBA could trigger them. Perhaps in the weekend I can look further.

18 hours ago, Fwiffo said:

@m4v Thanks for the update!  I haven't tested it yet but quick question, did you by any chance integrate anything similar to my fix (just a few lines of code, borrowed from @linuxgurugamer) to prevent the RCS Build Aid hotkey handlers from responding when you are typing into input boxes such as the part search textbox?

 

yep.

Share this post


Link to post
Share on other sites

Hello there,

since 1.1.2 or 1.1.3 I have a strange issue with this great tool: The center seems to be much too small / too far "inside" of the rocket. The red arrows indicating the actual translation are often "hidden" in the rocket. I am using this mod with RealismOverhaul. I tried reinstalling it (also cleaning the mods folder and reinstalling RealismOverhaul/RSS and the dependencies from scratch).

Is there any way I can fix this via config, or do I need to provide further info?

Thanks!

Share this post


Link to post
Share on other sites
11 hours ago, garthako said:

Hello there,

since 1.1.2 or 1.1.3 I have a strange issue with this great tool: The center seems to be much too small / too far "inside" of the rocket. The red arrows indicating the actual translation are often "hidden" in the rocket. I am using this mod with RealismOverhaul. I tried reinstalling it (also cleaning the mods folder and reinstalling RealismOverhaul/RSS and the dependencies from scratch).

Is there any way I can fix this via config, or do I need to provide further info?

Thanks!

Thanks for the report, since I'm not playing KSP anymore I didn't notice that issue.

Version 0.8.1
-------------

* Fix vectors rendering behind rocket parts.

 

Edited by m4v

Share this post


Link to post
Share on other sites
4 hours ago, m4v said:

Thanks for the report, since I'm not playing KSP anymore I didn't notice that issue.


Version 0.8.1
-------------

* Fix vectors rendering behind rocket parts.

 

What a shame, your mod changed my KSP life forever! Hope you will not completely abandon this, this is a great piece of code, thank you so much!

Share this post


Link to post
Share on other sites
5 hours ago, m4v said:

Thanks for the report, since I'm not playing KSP anymore I didn't notice that issue.


Version 0.8.1
-------------

* Fix vectors rendering behind rocket parts.

 

Alright, I can confirm that the new version is working again. Thank you so much for your effort, not playing a game but still supporting your mod is awesome and deserves a medal. And since I don't have medals, I will try out your donor button :-) Thank you very much, you saved my Kerbal gaming experience!!!

Share this post


Link to post
Share on other sites

I've submitted a pull request to update CKAN to the latest version.

RCSBuildAid is awesome, BTW.  I consider it essential.

Share this post


Link to post
Share on other sites

Say, how straightforward would it be to implement a balancing tool for reaction wheels? RCS Build Aid is an essential, of course, but I'm rather thrown off by having to balance reaction wheels manually with all of the awesome instrumentation for RCS thrusters. For all I know it might be as simple as having it snap to the CoM.

Share this post


Link to post
Share on other sites

Can you explain a little further what you mean by 'balancing reaction wheels?' Perhaps a case where you have wanted to do that?

Share this post


Link to post
Share on other sites
1 hour ago, fourfa said:

Can you explain a little further what you mean by 'balancing reaction wheels?' Perhaps a case where you have wanted to do that?

Simply put, a torque readout for reaction wheels instead of RCS thrusters. Reaction wheels are most effective near the Centre of Mass, so "balancing" them would mean positioning them at the CoM.

Share this post


Link to post
Share on other sites

Ah, I was wondering if that was the issue.  Have a look at some threads on the subject:

 

Share this post


Link to post
Share on other sites
9 hours ago, SingABrightSong said:

Say, how straightforward would it be to implement a balancing tool for reaction wheels? RCS Build Aid is an essential, of course, but I'm rather thrown off by having to balance reaction wheels manually with all of the awesome instrumentation for RCS thrusters. For all I know it might be as simple as having it snap to the CoM.

There's cases where you put a reaction wheel in an odd position that makes the vessel rotate in two axes, instead of just the one you wanted, so some vector math will be necessary. If is straightforward or not I will not know until I attempt to implement it, at the very least I know that it isn't just Total_Torque += rotation_axis * reaction_wheel_torque_magnitude for each reaction wheel.

Edited by m4v

Share this post


Link to post
Share on other sites

Can somebody point me to a helpful video or guide on fixing placement and reading/interpreting what these arrows say? I dontreally understand and no matter where I place RCS I get the big red arrows.

Share this post


Link to post
Share on other sites

Could you please remind whether this mod can display distance in meters between dry and wet center of mass? I totally remember that some mod did it (quite useful for total fine tuning of stuff like VTOL when not using throttle controlled avoinics), but can't remember which one and kinda suspect RCS build aid :) 

Share this post


Link to post
Share on other sites
1 hour ago, Mystique said:

Could you please remind whether this mod can display distance in meters between dry and wet center of mass? I totally remember that some mod did it (quite useful for total fine tuning of stuff like VTOL when not using throttle controlled avoinics), but can't remember which one and kinda suspect RCS build aid :) 

RCSBA did at some point but I removed it for save UI space. Placing the DCoM marker inside the CoM marker is good enough for zeroing their distance. Reducing the size of the markers will help.

Edited by m4v

Share this post


Link to post
Share on other sites

I don't suppose you could put that back in at some point...knowing the exact distance between the CoM and DCoM was occasionally a really useful piece of data (particularly when designing VTOLs).

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.