m4v

[1.2] RCS Build Aid v0.9.1

Recommended Posts

Stupid question but doesn't fine controls negate the need for perfect placement of RCS thrusters?

Nope. Even with fine controls, if your RCS thrusters are not placed well enough you can still cause rotations.

Share this post


Link to post
Share on other sites

I just made a little hotfix. It replaces the deprecated functions. Nothing more, nothing less. Since the license allows it, I'd like to share it with you until there is an official patch.

Source is included. License stays as is.

https://dl.dropboxusercontent.com/u/65236705/RCSBuildAid/RCSBuildAid_v0.4_HOTFIX.zip

Oh and this is my first post on the forum so... Hi everybody. ^^

Share this post


Link to post
Share on other sites

Version 0.4.1
-------------

* KSP 0.23 fixes.
* Account tweakables in fuel tanks and engines.
* Ignore the mass of landing gear and launch clamps, in both DCoM and CoM.
* Dynamic list of resources in mass window.

Besides of fixes for 0.23, I pushed some changes that I had already in git for some time. The plugin will ignore RAPIER engines since it uses a different PartModule and supporting it will demand more time than the couple of hours I used today.

Big thanks to RadarManFromTheMoon for the hotfix, if this release causes issues (I didn't test it much) revert to RadarMan's version.

Share this post


Link to post
Share on other sites
Version 0.4.1
-------------

* KSP 0.23 fixes.
* Account tweakables in fuel tanks and engines.
* Ignore the mass of landing gear and launch clamps, in both DCoM and CoM.
* Dynamic list of resources in mass window.

Besides of fixes for 0.23, I pushed some changes that I had already in git for some time. The plugin will ignore RAPIER engines since it uses a different PartModule and supporting it will demand more time than the couple of hours I used today.

Big thanks to RadarManFromTheMoon for the hotfix, if this release causes issues (I didn't test it much) revert to RadarMan's version.

Thank you sir, you are a legend. Merry Xmas

Share this post


Link to post
Share on other sites

Cool stuff, but when there is electric charge in an engine it causes the mod to stop working and the centre of mass disappears,unless you change the electric charge to 0. Although this may just be a bug with ksp

Share this post


Link to post
Share on other sites
Cool stuff, but when there is electric charge in an engine it causes the mod to stop working and the centre of mass disappears,unless you change the electric charge to 0. Although this may just be a bug with ksp

I experienced that bug only once and I wasn't sure what caused it, thanks for the info. Looking a bit further I can say that only non-stock engines trigger it, like KW ones, not sure why they have an electric charge setting.

Edited by m4v

Share this post


Link to post
Share on other sites

I heard there's some module that needs to be changed with the engines alternators. Because those engines aren't 0.23 updated they have an electric charge issue

Share this post


Link to post
Share on other sites

Unfortunately...

MissingMethodException: Method not found: 'EditorLogic.SetSoftLock'.

at RCSBuildAid.Window.OnGUI () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

... logged every few milliseconds

Share this post


Link to post
Share on other sites
Unfortunately...

MissingMethodException: Method not found: 'EditorLogic.SetSoftLock'.

at RCSBuildAid.Window.OnGUI () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

... logged every few milliseconds

Latest update fixed that, you are likely still using the old dll.

Share this post


Link to post
Share on other sites
Latest update fixed that, you are likely still using the old dll.

Sorry, perhaps I should have made it more clear.. that was with your latest release. The version from RadarManFromTheMoon was fine, however.

Share this post


Link to post
Share on other sites

oh man, don't tell me I shipped the wrong dll ...

edit: reuploaded, sorry.

Edited by m4v

Share this post


Link to post
Share on other sites

***** happens :) Thanks, it's a super useful tool, way better than my old ruler against the screen and hope for the best method.

Share this post


Link to post
Share on other sites
oh man, don't tell me I shipped the wrong dll ...

edit: reuploaded, sorry.

Thanks for that fix, (and the reupload) I was starting to worry that I would have to sift through al my mods to find the cause.

Share this post


Link to post
Share on other sites

Hopefully this time around I zipped the correct dll.

Version 0.4.2
-------------

* RAPIER support.
* Delta V and burn time readout for RCS (because I could).
* TWR readout for engines.
* Added slider for change the scale of CoM markers.
* Set to ignore all ladders as they incorrectly show mass in the editor, much
like landing gears.

Share this post


Link to post
Share on other sites
Hopefully this time around I zipped the correct dll.

Version 0.4.2
-------------

* RAPIER support.
* Delta V and burn time readout for RCS (because I could).
* TWR readout for engines.
* Added slider for change the scale of CoM markers.
* Set to ignore all ladders as they incorrectly show mass in the editor, much
like landing gears.

Thank you for the update.

Share this post


Link to post
Share on other sites
Cool!

....Please tell me dV/burntime respects resourceName for RCS :)

You mean for modded RCS? in that case then the readout it will be all wrong I'm afraid. The plugin assumes all RCS use MonoPropellant because I didn't want to complicate things much.

Edited by m4v

Share this post


Link to post
Share on other sites

Finally!! Now I can start building stations again!

This mod ruined my KSP life. I can't truly play the game with out it!

Share this post


Link to post
Share on other sites

Version 0.4.3
-------------

* Support for blizzy78's toolbar.
* Hide dV readout when it isn't accurate (like with modded RCS).
* FIX: torque calculation in rotation mode wasn't correct.

This update adds a new .dll file called RCSBuildAidToolbar.dll, you can remove this file if you aren't interested in using the toolbar.

Share this post


Link to post
Share on other sites

Hello all. :)

I've encountered a minor issue with the newest update:

When activated with the Toolbar button, the Build Aid displays engine thrust vector and torque as normal, but won't show RCS translation info at all when using translation controls. However, I discovered that if I activate the in- game CoM marker, as needed to be done before, THEN it will show RCS translation vectors just fine. And, it still shows engine thrust data as usual.

This isn't a terrible problem, it's just an extra step to have to take, but I'm pretty sure that that's not intended behavior, so I thought I'd mention it.

I use parts of many mods, but the only ones I have that are active in editor mode would be:

Toolbar (duh)

Editor Extensions

Active Memory Reduction v2-10 Basic

MechJeb 2.1.1-159

I think that's it. I'd love to have UbioZur's Welding Tool, but it still REALLY doesn't play nice with this mod, it's too bad no one seems to be very interested in doing anything about that.

Anyway, there you go, FYI. :)

Share this post


Link to post
Share on other sites
Hello all. :)

I've encountered a minor issue with the newest update:

When activated with the Toolbar button, the Build Aid displays engine thrust vector and torque as normal, but won't show RCS translation info at all when using translation controls. However, I discovered that if I activate the in- game CoM marker, as needed to be done before, THEN it will show RCS translation vectors just fine. And, it still shows engine thrust data as usual.

This isn't a terrible problem, it's just an extra step to have to take, but I'm pretty sure that that's not intended behavior, so I thought I'd mention it.

I cannot reproduce it, but check if the CoM visibility toggle is enabled in the Mass tab, if it's on then the CoM should be visible while the plugin is enabled. If you still get that issue then can you give me a step-by-step guide (from the moment you enter the VAB) so I can try to reproduce from my end?

I think that's it. I'd love to have UbioZur's Welding Tool, but it still REALLY doesn't play nice with this mod, it's too bad no one seems to be very interested in doing anything about that.

Well I wasn't aware of that conflict, and after looking in UbioZur's thread is kind of bizarre since RCSBuildAid doesn't touch the vessel name text field.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.