Jump to content

[1.11] HyperEdit [v1.5.8, July 10, 2018] - Cheat, Teleporter, Orbit/Planet Editor, & More


Recommended Posts

thanks to fast update

Were glad to do it, of course. Just don't get too used to getting updates so quickly. :P This time was an easy fix, but there's no guarantee it will always be.

Edited by Ezriilc
included quote
Link to post
Share on other sites

After a question from a user, I've updated our website to include previous versions of HyperEdit and other stuff, so that anyone who hasn't updated KSP can still get the compatible one.

For those still using KSP v0.20.x, HyperEdit v1.2.1 is now on our website.

I also plan to add pages for our developers to house their own stuff, and even for users to submit theirs. So send us your screenshots, ship .craft files, or anything else you'd like to make available. Don't worry, you'll get full credit and retain copyright and ownership of your submissions.

Edited by Ezriilc
Link to post
Share on other sites

Looks like lastest HE are broking the game. On a fresh install with only HyperEdit mod, when I try to build manouver for Mun transfer game just dont want to show Mun SOI intersect. Removing HyperEdit fixes the problem ...so that's it.

Link to post
Share on other sites

I'm sorry ya'all are having trouble. I'll do what I can.

tek_604 said:
Website is down for me....Not for everyone. ;.;

Seems the DNS provided by your host is somehow not available everywhere.

Are you referring to KerbaltekAerospace.com (now Kerbaltek.com)? !!:0.0:!! There shouldn't be any problems for anyone, and if so, I need to get it fixed.

  • What error do you get?
  • What country are you in?
  • Has it ever worked for you?
  • Are you on a direct internet connection or through a LAN?
ZobrAA said:
Looks like lastest HE are broking the game. On a fresh install with only HyperEdit mod, when I try to build manouver for Mun transfer game just dont want to show Mun SOI intersect. Removing HyperEdit fixes the problem ...so that's it.

I believe it was working fine for me, but I will attempt to replicate your issue again. When you say Mun transfer, do you mean to Mun orbit from a lower Kerbin orbit? Sorry, I'm not completely up on the terminology.

This is a rather major problem, so I will see what I can figure out right away.

Edited by Ezriilc
Link to post
Share on other sites
Looks like lastest HE are broking the game. On a fresh install with only HyperEdit mod, when I try to build manouver for Mun transfer game just dont want to show Mun SOI intersect. Removing HyperEdit fixes the problem ...so that's it.

This is what I think you mean. Please let me know if it's correct.

I used HyperEdit to put me in a circular orbit of Kerbin @ 6 million meters, and then created a maneuver node to hit Mun, and it did what I expected.

Mun-Transfer.jpg

Link to post
Share on other sites

I did some more testing, and I was able to complete a transfer to Mun with maneuvers while HyperEdit is installed and working.

However, the maneuver editor GUI is... twitchy, to say the least. I find it quite difficult at times to finely edit maneuvers in the orbit view, but that's KSP, and isn't affected by HyperEdit. Even with it jumping all over and randomly deleting my nodes, I was able to make a "landing" on Mun (Kerbs would have walked away, but not returned).

In other words, I'm not able to replicate your issue. If you discover anything else to add, let us know. I'm curious to see what is causing it.

Just a hunch (his hunches are good):

Is your MET clock counting up properly, or perhaps counting down? If you've edited the time with HyperEdit, then you may have the clock bug I found which seems to wreak havoc with the SAS toggle, and who knows what else. Something worth checking. [shrug]

Sorry I'm not more help.

Link to post
Share on other sites
I believe it was working fine for me, but I will attempt to replicate your issue again. When you say Mun transfer, do you mean to Mun orbit from a lower Kerbin orbit?

Yes, I meant from 80km LKO to the Mun.

But...

This is strange but when I reinstall HE today it seems to work just fine and I wasn't able to replicate that strange glitch... Maybe problem was in sysfiles and rebooting helped...

Only one thing worries me now - how to disable opening HE menu on F11? Earlier I was accustomed to assign a screenshot on this key...

Anyway thanks for your work! I use this plugin for testing landers, and (almost) can't play without it. ^_^

Edited by ZobrAA
Link to post
Share on other sites
Are you referring to KerbaltekAerospace.com? !!:0.0:!! There shouldn't be any problems for anyone, and if so, I need to get it fixed.

Yes, KerbaltekAerospace.com.

[*]What error do you get?

Couldn't resolve the domain name. That is when I used a "isitdownforyou" or whatever, which reported it was up. So, definately a DNS issue.

[*]What country are you in?

Germany.

[*]Has it ever worked for you?

Yes, I used an earlier version of HE, so I must have been to the site once in the past. Don't ask when. I don't know :sticktongue:

[*]Are you on a direct internet connection or through a LAN?

We have a small LAN at home. Everything else was resolving fine at the time.

The good news is, the next day, I was able to get to your site fine. You just might want to chase up your hosting provider to see if they had DNS problems on Saturday.

Link to post
Share on other sites
Yes, I used an earlier version of HE, so I must have been to the site once in the past. Don't ask when. I don't know :sticktongue:
Actually, Our website is new, and you may have downloaded from the Space Port.
The good news is, the next day, I was able to get to your site fine. You just might want to chase up your hosting provider to see if they had DNS problems on Saturday.
Thanks for the heads-up. DNS hiccups do happen, and it could have been caused by anything between you and our site, from your PC's NIC or OS, to your router, cable-modem, ISP, their equipment, or even the 'net itself. So long as you're able to see it now, I'm happy! :D

Re: Germany: :cool:. I've always wanted to visit.

- Sure, I might fly with MechJeb. But, I don't HyperEdit bad designs into orbit :sticktongue:"
Awesome.

...

Only one thing worries me now - how to disable opening HE menu on F11? Earlier I was accustomed to assign a screenshot on this key...
I plan to remove the F11 hotkey in the next release. I didn't just chop it out already because I wanted to be sure everyone approves of this change.
Anyway thanks for your work! I use this plugin for testing landers, and (almost) can't play without it. ^_^
You're always very welcome, but I'm not The Creator, and I haven't really done anything beyond packaging and presenting other people's work. Also, I agree. I use HyperEdit to position my Water Speed crafts for racing, and many other awesome tasks.
Link to post
Share on other sites
Actually, Our website is new, and you may have downloaded from the Space Port.

Thanks for the heads-up. DNS hiccups do happen, and it could have been caused by anything between you and our site, from your PC's NIC or OS, to your router, cable-modem, ISP, their equipment, or even the 'net itself. So long as you're able to see it now, I'm happy! :D

Re: Germany: :cool:. I've always wanted to visit.

Awesome.

...

I plan to remove the F11 hotkey in the next release. I didn't just chop it out already because I wanted to be sure everyone approves of this change.

You're always very welcome, but I'm not The Creator, and I haven't really done anything beyond packaging and presenting other people's work. Also, I agree. I use HyperEdit to position my Water Speed crafts for racing, and many other awesome tasks.

I removed it from my version of the dll because I use F11 for Fraps. I don't think it would hurt people's feelings to remove it considering it still has alt-h.

Link to post
Share on other sites
Just in case anyone was wondering why I have HyperEdit... I use it for testing my mod. :sticktongue:

Yea, sure. Whatever helps you sleep at night. :wink:

...

About removing the F11 key. I was hoping to hear from Devo, but it's pretty clear that nobody wants it left in, so I'll make sure it gets removed. Is it important enough to make this change now and do another release?

Link to post
Share on other sites

I have a little bit of a weird problem. I have 0.21 installed, and hyperedit for 0.21. I unzipped it into te right spot which is the main ksp folder. Now everything works, BUT i have my rocket on the launchpad, I try t launch it by spacebar and w/e to throttle up, it doesnt work, the throttle, the spacebar all of that. I even waited there for a good 10-15 minutes seeing if it would work but doesnt. Any idea what I might be doing wrong? Also I edited orbits before actually getting into flying.

Link to post
Share on other sites
How do i get my rover to teleport to the surface of the Mun? each time i try it says i colided with the surface, what figures do i need for the surface?

Unless you know the exact location to teleport to, you will most likely crash every single time too.

Instead of completely cheating, try and select and orbit a planet first, then select the land option, rather than trying to teleport directly to another planets surface.

Link to post
Share on other sites
Ok, thanks i'll do that. It'll be funny to see a five ton rover floating over the surface of the Mun. Probably.

no problem, Pressing land in hyperedit sort of disables most of the KSP physics, so just land say 250 meters above the surface and glide down, your asas should keep you level for landing. It sets touchdown speed to like 2ms so no matter how heavy the craft it will set down at the same rate, no thrusters required.

This i find a tad boring tho.. if you say press land and land at 5000m and then press land again to disable it you can practice your entry then.

Link to post
Share on other sites
I have a little bit of a weird problem. I have 0.21 installed, and hyperedit for 0.21. I unzipped it into te right spot which is the main ksp folder. Now everything works, BUT i have my rocket on the launchpad, I try t launch it by spacebar and w/e to throttle up, it doesnt work, the throttle, the spacebar all of that. I even waited there for a good 10-15 minutes seeing if it would work but doesnt. Any idea what I might be doing wrong? Also I edited orbits before actually getting into flying.

It sounds like you've left your cursor in an input box, and/or your mouse is pointing at the stages stack on the left, or another interface box, instead of the background, or your rocket. Make sure you have clicked on the grass or something near your ship, and that your mouse isn't pointing at any boxes.

Also, make sure your ship has electrical power, and/or a pilot to drive it.

I hope this helps!

EDIT: I plan to someday make the HyperEdit interface more intelligent, like MechJeb has gotten. Invalid characters being typed should not register in HyperEdit, and clicking a button should send focus back to the scene. I still forget to click the scene background and end up putting a string of "t"s in a box, from trying to toggle SAS. DOH! :huh:

Edited by Ezriilc
Added anecdote.
Link to post
Share on other sites

Yeah I tried to change that, but it seems to be a bit more complicated than what I though.

I also work on the "selection by map", MechJeb style for the HyperLander. And to work with DMS coords as they are more user-friendly and used than boring degrees numbers.

Link to post
Share on other sites
It sounds like you've left your cursor in an input box, and/or your mouse is pointing at the stages stack on the left, or another interface box, instead of the background, or your rocket. Make sure you have clicked on the grass or something near your ship, and that your mouse isn't pointing at any boxes.

Also, make sure your ship has electrical power, and/or a pilot to drive it.

I hope this helps!

EDIT: I plan to someday make the HyperEdit interface more intelligent, like MechJeb has gotten. Invalid characters being typed should not register in HyperEdit, and clicking a button should send focus back to the scene. I still forget to click the scene background and end up putting a string of "t"s in a box, from trying to toggle SAS. DOH! :huh:

This didn't work, ill explain in detail what it's doing. Ill make my rocket, I set it on the launch pad, and it doesnt want to take off, it has solar panels and whatever, its a satellite, its unmanned. but for example i try to right click and see the resources or something, that doesnt work, none of the buttons decide to work. But I take out the mod, everything is back to normal. :/

EDIT: Ahah!!! I found it! The save file I made had another file besides persistence, which was out of the ordinary which made things a bit uneven I guess? I took it out and its working now, woohoo :P sorry for that, I didn't look before I posted :L

Edited by big bear
Found it
Link to post
Share on other sites

HyperEdit v1.2.3

I've made some minor changes to the code, and re-created the repo after screwing it up again (really hating Git right now). I'd like to get everyone's feedback.

  • I've removed the "messy UnitTest" and replaced it with "KSPAddon", and included Majiir's, "KSPAddonFixed".
  • I've also added some more descriptive info about the SI units in the Help window,
  • and removed the F11 hotkey, as promised.

https://github.com/Ezriilc/HyperEdit

Barring any objections, I plan to release this new version in the next couple of days.

UnitTest vs. KSPAddon

Someone on IRC asked why I'd remove UnitTest, and the reason is because I thought KSPAddon is preferred for a plugin to load w/o a part. If anyone knows why we should or shouldn't make this change, please let me know.

big bear, I'm glad! What was the "extra" file that you removed named?

SolarLiner/HyperEdit v1.3, I'm learning more and understanding the code a little better now. Let's you and I hammer out a solid plan for what to include in the next version. I can meet you on IRC #kspmodders. A more intuitive interface should be at the top of our list, I think.

I think the DMS conversion is well within our ability, but I'd like to include both options. The coords system actually makes some sense when you take out the SI Metric multiplier suffixes, which I think are throwing a lot of users. Those SI suffixes may be more trouble than they're worth. If every box were straight Meters or kMeters, or whatever, then it would be far simpler and perhaps easier to grasp. I mean, NOBODY is going to use Yatta to add 24 zeros to anything they're likely to enter into HyperEdit.

But most importantly, and I see this throughout the plugin, we need to make things more user-friendly. If a value the user entered is being changed in the code - like reverting to a minimum or maximum, or whatever - it should warn the user and possibly offer options, as I believe this is where a lot of confusion arises. I realize this makes for more complex code, but I think it's worth the effort to provide a truly professional grade product.

Edited by Ezriilc
Fixing broken links.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...