Jump to content

[1.11] HyperEdit [v1.5.8, July 10, 2018] - Cheat, Teleporter, Orbit/Planet Editor, & More


Recommended Posts

On 8/10/2020 at 2:20 PM, Drupegod02 said:

I cant seem to use the ship lander button while playing on KSRSS.

I'm afraid I won't be much help with regard to other mods - sorry.  But I'm hoping that someone else here will.

 

Edited by Ezriilc
typo
Link to post
Share on other sites
12 hours ago, GayNASA said:

The Kerbaltek website seamed to have diapered. It just shows a site not found error. Is hyper edit available from a different place? 

Sorry about that!  I'm in the processing of changing my hosting provider.

The site is back up now, so please let me know if you have any issues from here on.

EDIT:  "diapered", lol.  I'm beginning to feel my age, but I'm not quite there just yet.  :D

EDIT-2:  @GayNASA, welcome to the forums!  I love your avatar.  It's always nice to have some color around.

Edited by Ezriilc
for the lulz
Link to post
Share on other sites
  • 2 weeks later...
7 hours ago, Nooby_dud said:

I wonna do real reusability rocket stages but this ia cheat? 

Sorry i am gonna use cheats im alerdy good but it will be nice like refuling really

I mean... technically depends on how you use it?

HyperEdit is a utility that lets you edit orbits and ships. Sometimes, this lets you get out of situations that are more "bug" than "I failed"

Examples where I've used it:

  • Finish a landing on a regular planet, and the moment you touch down stuff starts going boom for some reason. Crap. Load up your quicksave, edit your craft back to orbit, readd your fuel, and try again in a different spot. I'm not talking about a rough landing here, or a landing on a hill - I'm talking about the sort of landing when you do a perfect touchdown at 1m/s on flat ground, and your legs explode anyway.
  • Take a craft into orbit, then find out that one of your landing legs is wobbling violently for some reason (in orbit, mind you - and it's not overlapping anything.) If you can't revert, hit the "land" button so you can recover it and figure out what the hell it's doing and why (in this particular case, the landing legs would go stupid if I edited any part of the ship after placing the landing legs - no clue why still...)
  • Testing an interplanetary ship - I'd tested getting to orbit, but testing the warp drive (sort of) requires you to be around Minmus' orbit. I could plot a transfer and time warp through the 15-day trip... or I could just edit my orbit up there and get started on testing.
  • Why is my engine suddenly burning and messing up my orbit? (answer: hit the time warp key too fast before the residual thrust from the KSPI-E engines wore off.)

Three of those four examples - in my opinion - would be considered problems with the game engine (or mods) rather than cheats. The last is just testing, and I'm doing a revert afterwards.

What's considered cheating is kind of fluid in KSP anyway - some people consider MJ cheating, some people consider any mod cheating. Be clear in what you're using and your methods, let people decide for themselves, and ignore them. As long as you are having fun with the game and haven't misrepresented how you're doing it (i.e. saying you reloaded your rocket fuel after landing with HyperEdit,) that's what counts.

Side note - if you're interested in reusable rockets, you might want to look at Kerbal Construction Time and ScrapYard as a combination.

Link to post
Share on other sites
  • 2 weeks later...

@Ezriilc - okay, here's an interesting bug for you:

It seems that the ship lander will not work correctly with RSS. I don't recall having issues like this with resized stock, so I'm assuming RSS is the issue.

In orbit, I don't have any ships in the pick list for the ship lander, other than the single one I have already landed (it's a rover, specifically, and it's technically in pre-launch state since I used Bon Voyage to move it - I'll give it a nudge and see if that causes it to disappear from the list, but I digress...)

Even after landing on Earth (on the ocean, which seems solid? Methinks there's another issue at play here... (oh, maybe I touched down too gently, and I got a perfect float going or something? Hitting at 2m/s blows everything up...)) the ship doesn't show up on the ship list as valid for landing.

If this isn't enough info, I'll see if I can get a minimal install reproduction for you - with that said, RSS is more than a few KSP versions behind, so if this isn't a known bug this probably isn't a valid report in the first place.

Link to post
Share on other sites

@etmoonshade,

I'm very sorry, but I just don't know.  I don't use other mods and I'm not familiar with the code enough to be of much help (I didn't create HyperEdit).

I recommend checking with the devs of those other mods, and/or hope that someone here can help.

I wish you the best of luck, and please let us know if you get it fixed or learn anything more.

Link to post
Share on other sites
On 8/4/2020 at 12:02 PM, Drupegod02 said:

I cant seem to use the ship lander button while playing on beyond home on 1.9.1 or 1.10.1. It only allows me to use "land here".

 

On 8/10/2020 at 1:20 PM, Drupegod02 said:

I cant seem to use the ship lander button while playing on KSRSS.

 

On 9/4/2020 at 12:26 PM, etmoonshade said:

@Ezriilc - okay, here's an interesting bug for you:

It seems that the ship lander will not work correctly with RSS. I don't recall having issues like this with resized stock, so I'm assuming RSS is the issue.

In orbit, I don't have any ships in the pick list for the ship lander, other than the single one I have already landed (it's a rover, specifically, and it's technically in pre-launch state since I used Bon Voyage to move it - I'll give it a nudge and see if that causes it to disappear from the list, but I digress...)

Even after landing on Earth (on the ocean, which seems solid? Methinks there's another issue at play here... (oh, maybe I touched down too gently, and I got a perfect float going or something? Hitting at 2m/s blows everything up...)) the ship doesn't show up on the ship list as valid for landing.

If this isn't enough info, I'll see if I can get a minimal install reproduction for you - with that said, RSS is more than a few KSP versions behind, so if this isn't a known bug this probably isn't a valid report in the first place.

I just put two and two together, realized I was probably reporting the same bug as @Drupegod02 and...

I wonder - is HyperEdit having a problem when the "home" planet is replaced? That seems to be the common thread here - RSS and Beyond Home are both system replacers, and while RSS uses a .dll for resizing, Beyond Home does not (it has an install checker .dll, but nothing else.)

I sort of wonder if a player of GPP or something else that replaces the stock system would have a similar issue.

I'd also be interested to see if someone with something like OPM has trouble using the ship lander on a non-stock planet/moon. I'll see if I can test some of these scenarios at some point this weekend, but it'll require me to build out a test install again. >_<

Edited by etmoonshade
weird wording
Link to post
Share on other sites
  • 4 weeks later...
On 6/10/2020 at 5:09 PM, Ezriilc said:

I'll be honest.  I just don't know.  I'll have my crew of testers (a "technically adult" kid) that will attempt to determine the possibilities, if any.

Kerbin has an atmosphere that gradually increases in density as one descends for a landing. When I use the HyperEdit button to add an atmosphere to a planet or moon that does not come with one, it suddenly kicks in at sea level pressure when I reach the altitude I enter into HyperEdit. There's no gradual change like Kerbin.  The instant change to sea level pressure suddenly destroys the craft.

Has there been any progress on fixing this as mentioned in a message here on the Forum in June? Any ideas how I might do a work-around with some other setting or something?

This causes me to wonder about the purpose of the "has atmosphere" button. It seems like the only reason, would be to remove an existing atmosphere, right?   Thanks for answering in advance.

Link to post
Share on other sites
  • 1 month later...
13 hours ago, OrbitalManeuvers said:

Hello, I am hoping some kind hyperediter might be able to answer this. Can this tool help with cheating a craft into a position where it will encounter the SOI of a specific planet? I'm attempting to streaming the planning/practicing/filming of planetary approaches if possible. Thanks!

I'm not sure.  Of course you can put a vessel in orbit around any planet, but I've never tried to put it on a certain path before.  I suppose you could put yourself into a very high orbit of a nearby planet and then do legit burns to encounter anything, really.

I'd bet someone else here has better input than I.

Link to post
Share on other sites
11 hours ago, Ezriilc said:

I'm not sure.  Of course you can put a vessel in orbit around any planet, but I've never tried to put it on a certain path before.  I suppose you could put yourself into a very high orbit of a nearby planet and then do legit burns to encounter anything, really.

I'd bet someone else here has better input than I.

Yeah there are ways to get close with just regular cheat to orbit if you just do a maneuver that points you into the planet and then you gain enough speed to simulate what your approach velocity would really be. I don't think the angles would be quite right but it might be good enough for cinematics. It's not a simple task so I was just hoping there was something automated. Thanks for the reply!

Link to post
Share on other sites
2 minutes ago, OrbitalManeuvers said:

Yeah there are ways to get close with just regular cheat to orbit if you just do a maneuver that points you into the planet and then you gain enough speed to simulate what your approach velocity would really be. I don't think the angles would be quite right but it might be good enough for cinematics. It's not a simple task so I was just hoping there was something automated. Thanks for the reply!

Best of luck, and feel free to come back and tell us how you do! :)

Link to post
Share on other sites
  • 1 month later...
  • 4 weeks later...

Hi, I would like to edit my orbit to be suborbital but the GUI won't allow it either graphically or via complex tab. Here are my elements I want to set...

INC: 148.756

ECC: 0.2

SMA: 5833184

LAN: 44.06

ArgOfPeri: 289.62

MNA: -157.17

Maybe I need a different epoch time such that the craft isn't already under the surface?

Oh, I'm using RSS so these are Earth elements.

Thanks

Edited by Racalac
clarification
Link to post
Share on other sites

  

58 minutes ago, Racalac said:

Hi, I would like to edit my orbit to be suborbital but the GUI won't allow it either graphically or via complex tab. Here are my elements I want to set...

[snipped]

Maybe I need a different epoch time such that the craft isn't already under the surface?

Oh, I'm using RSS so these are Earth elements.

Thanks

I'm sorry, but I honestly don't know.  Let's hope that someone here does.

Edited by Ezriilc
Link to post
Share on other sites
9 hours ago, Jestersage said:

Question: Is the "beta-1" newer, but untested?

It is a bit newer, but has been tested pretty well.  I need to make that BETA-1 into a full release.

Link to post
Share on other sites
  • 1 month later...
15 hours ago, Jaz3001 said:

I seem to be running into an issue with entering timewarp after I started using this mod. Here's a video, If anyone has run into and/or knows how to fix it, help would be greatly appreciated.

This might be related to that old bug.  I think if you save and load the game and/or change the scene from flight and back, it fixes it.

EDIT:  Oops!  Here's that issue: https://github.com/Ezriilc/HyperEdit/issues/14

Edited by Ezriilc
Link to post
Share on other sites
20 minutes ago, therealcrow999 said:

Did you ever get around to making the Beta a full release?

No.  I'm sorry.  I've run into a problem where I try to build the current (BETA) code, and it fails in a way that I don't understand.  I use MS Visual Studio 2019 Community, but I barely know what I'm doing in that, but it seems related to the newer versions of the KSP API.  I'm also not fluent in GIT, so, yeah.

Any input is welcome.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...