Ezriilc

[1.7] HyperEdit [v1.5.8, July 10, 2018] - Cheat, Teleporter, Orbit/Planet Editor, & More

Recommended Posts

Hi @Jirokoh

I'm curious why you're still running 1.2.2?

Other than trying an earlier version of HyperEdit I can't really offer a solution as we're now on KSP version 1.4.1 and I know some things have changed since the version you're choosing to use.

Have you tried using the mods in their relevant latest KSP builds?

Edited by fronbow
Referenced wrong user.

Share this post


Link to post
Share on other sites
11 minutes ago, The Dunatian said:

When will this be updated to 1.4.1? 

I'm sorry, but we will almost never have a good answer to that.  It's just a matter of whenever we get the changes and/or testing done.

But actually, you could help us a great deal by testing our latest BETA build against 1.4.1 and report back to us.  Thanks in advance!

Share this post


Link to post
Share on other sites
10 minutes ago, Ezriilc said:

I'm sorry, but we will almost never have a good answer to that.  It's just a matter of whenever we get the changes and/or testing done.

But actually, you could help us a great deal by testing our latest BETA build against 1.4.1 and report back to us.  Thanks in advance!

I'd be happy to help, but it won't eat my game will it?

Share this post


Link to post
Share on other sites
Just now, The Dunatian said:

I'd be happy to help, but it won't eat my game will it?

It may well at that, but probably won't.  :cool:  ALWAYS back up your stuff.  Please note the disclaimer on our site.

Share this post


Link to post
Share on other sites
On 12/25/2017 at 2:34 PM, BaelRathLian said:

Thanks.  Google search only went here.

 

I am getting forbidden when trying to access? site down?

Share this post


Link to post
Share on other sites
34 minutes ago, t12213roy said:

I am getting forbidden when trying to access? site down?

The site is fine.

What else does the error say?

Share this post


Link to post
Share on other sites

"403 Forbidden! "  when using Firefox, Edge and Internet Explorer. Can you check the logs and see why im getting 403.

 

I would like the beta can some one post a link other than the www.kerbaltek.com, thanks

 

Edited by t12213roy

Share this post


Link to post
Share on other sites
3 hours ago, t12213roy said:

"403 Forbidden! "  when using Firefox, Edge and Internet Explorer. Can you check the logs and see why im getting 403.

 

I would like the beta can some one post a link other than the www.kerbaltek.com, thanks

 

There is most assuredly more to that error message than that.  Please tell us the entire message.

Share this post


Link to post
Share on other sites
2 hours ago, t12213roy said:

That is the entire error. top left "403 Forbidden" and the rest is all blank.

I'm sorry you're still having trouble, but the site is working fine and I have no other reports.  :blush:

If you want me to look into it further, please contact me directly via PM here.

Share this post


Link to post
Share on other sites
Just now, Ezriilc said:

I'm sorry you're still having trouble, but the site is working fine and I have no other reports.  :blush:

If you want me to look into it further, please contact me directly via PM here.

I am unable to pm, or post without moderation. not sure the post count need to enable pm'img and posting without moderation.

 

I am using Firefox 59.1 with no addons, not using any proxies, I work for my ISP and checking our firewall rules, there is no blocking enabled for clients. Maybe search your apache/nginx access/error logs to see what is going on.

 

Thanks

Share this post


Link to post
Share on other sites
58 minutes ago, t12213roy said:

I am unable to pm, or post without moderation. not sure the post count need to enable pm'img and posting without moderation.

 

I am using Firefox 59.1 with no addons, not using any proxies, I work for my ISP and checking our firewall rules, there is no blocking enabled for clients. Maybe search your apache/nginx access/error logs to see what is going on.

 

Thanks

I would need your IP address to find you in the logs.

Share this post


Link to post
Share on other sites

Hey @Ezriilc

The http error is only on the file download - IIRC (It was a few hours ago when I tried) 429: Too many requests - the site's fine, just whichever download I chose seemed to be getting a lot of hits?

On a separate note, I will recompile for 1.4.1 at some point in the next few days, I'm just hunting down a bug that may or may not be HyperEdit related!

Share this post


Link to post
Share on other sites
On 18/03/2018 at 2:36 PM, fronbow said:

Hi @Jirokoh

I'm curious why you're still running 1.2.2?

Other than trying an earlier version of HyperEdit I can't really offer a solution as we're now on KSP version 1.4.1 and I know some things have changed since the version you're choosing to use.

Have you tried using the mods in their relevant latest KSP builds?

Because I am running RSS and RO, and for some reason one of mods was only updated to 1.2.2
And I would like to have HE on my RSS / RO version

Share this post


Link to post
Share on other sites
5 hours ago, fronbow said:

Hey @Ezriilc

The http error is only on the file download - IIRC (It was a few hours ago when I tried) 429: Too many requests - the site's fine, just whichever download I chose seemed to be getting a lot of hits?


Yep, just hit that error myself...  the beta downloaded fine, the 1.3.1 version aborted with the error screen.  A couple of minutes later it worked.

Share this post


Link to post
Share on other sites
1 hour ago, Fireheart318 said:

I was able to get the beta so I Dropboxed the .ZIP - https://www.dropbox.com/s/aemq7g3ah5pryjl/HyperEdit_BETA-1.zip?dl=0

@Ezriilc , if you have a problem with this, just tell me and I'll get rid of the link as soon as I can (probably within a few hours)

 

Edit - It's not working. I did all the things the site told me to - copied the Kerbaltek folder and replaced the .dll. Do I need the flags folder?

No.  You don't need the Flags folder.  Just make sure the Kerbaltek folder is inside your GameData folder.

Share this post


Link to post
Share on other sites

If it's any help, the beta seems to be playing nice for me in 1.4.1.  I haven't been real crazy with it yet, but I can put things into orbit, and then modify the orbit. Great mod! Hyper-Edit has been at the core of my flight test program for a long time! :)

Share this post


Link to post
Share on other sites
12 minutes ago, Lindy said:

If it's any help, the beta seems to be playing nice for me in 1.4.1.  I haven't been real crazy with it yet, but I can put things into orbit, and then modify the orbit. Great mod! Hyper-Edit has been at the core of my flight test program for a long time! :)

Yes, that is helpful!  Thanks for the report.

And on that note... Good news, everyone!  I've published a new BETA-3 version for KSP 1.4.1, with all the latest fixes and improvements that @fronbow has been working on.  If that version is good, then we'll make it a full release.

http://www.Kerbaltek.com/hyperedit

Share this post


Link to post
Share on other sites
32 minutes ago, Ezriilc said:

Yes, that is helpful!  Thanks for the report.

And on that note... Good news, everyone!  I've published a new BETA-3 version for KSP 1.4.1, with all the latest fixes and improvements that @fronbow has been working on.  If that version is good, then we'll make it a full release.

http://www.Kerbaltek.com/hyperedit

Great job as always, initial testing is good. Will post detailed results once I return home for the evening.

Share this post


Link to post
Share on other sites
48 minutes ago, Ezriilc said:

Yes, that is helpful!  Thanks for the report.

And on that note... Good news, everyone!  I've published a new BETA-3 version for KSP 1.4.1, with all the latest fixes and improvements that @fronbow has been working on.  If that version is good, then we'll make it a full release.

http://www.Kerbaltek.com/hyperedit

Oh, fantastic!!! Thank you so much for all your hard work!!!

Share this post


Link to post
Share on other sites
4 hours ago, Ezriilc said:

Yes, that is helpful!  Thanks for the report.

And on that note... Good news, everyone!  I've published a new BETA-3 version for KSP 1.4.1, with all the latest fixes and improvements that @fronbow has been working on.  If that version is good, then we'll make it a full release.

http://www.Kerbaltek.com/hyperedit

Thank You!!

Share this post


Link to post
Share on other sites

Good luck!I hope it makes it to full release soon!

Edited by Boyster

Share this post


Link to post
Share on other sites

Just used the BETA version to get a mission done that id already had a chance to do but didnt click accept for it. By far the scariest most unstable thing ive ever used but it got the job done. Holy crap that BETA needs some work. I was sitting on the edge of my seat while my ships were flinging around in orbit after I had just set them up to rendezvous together. Im scarred for life. :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.