Sign in to follow this  
UbioZur

[0.22] UbioZur Welding Ltd. 2.0 Dev STOPPED

Recommended Posts

It is possible to weld one part to another, but without effect the collision mesh of the first one? so the welded part would be like a part that not interact with the world.

Share this post


Link to post
Share on other sites
It is possible to weld one part to another, but without effect the collision mesh of the first one? so the welded part would be like a part that not interact with the world.

I'm not sure I understand you correctly...

Did you mean something like this? If yes, then change PhysicsSignificance to 0. But there will be some side

like this

EDIT: I was totally wrong! I had in mind "change to 1" to make part physicsless :blush:

Edited by girka2k

Share this post


Link to post
Share on other sites

almost. I want to be able to pass thru the attached part, like if it were a ghost.

like it happens with the strut strings.

As if it had no mesh collision.

like chance the model but retain the original collision mesh

Edited by Locob

Share this post


Link to post
Share on other sites

Apparently trying to weld up 14 Antimatter collectors from the KSP Interstellar Mod destroyed my science program and made everything un-researched... and nothing able to be researched. Of course, this is using the TechManager to work the tech tree with KSPI since TreeLoader is not supported for 0.25.

Sucks, I really want to reduce part count on my Antimatter Farm Station.

Interesting bug.

~Steve

EDIT:

Apparently I have to Alt-F4 after I went something... it saves the weld.

EDIT2:

So I gave it the college try again... and it still doesn't work. 14x AM Collecters still only collect AM as if they were one. Oh well. And here I thought I'd be able to reduce my AM Farm Station from 190 parts down to 72.

Edited by NeoAcario

Share this post


Link to post
Share on other sites

If I weld several RCS ports to other parts, will the RCS ports still function correctly?

Also, has anybody tried welding procedural parts together? Will that work, or does Kerbin explode or something?

Edited by White Owl

Share this post


Link to post
Share on other sites
Apparently trying to weld up 14 Antimatter collectors from the KSP Interstellar Mod

.....

14x AM Collecters still only collect AM as if they were one. Oh well. And here I thought I'd be able to reduce my AM Farm Station from 190 parts down to 72.

If I weld several RCS ports to other parts, will the RCS ports still function correctly?

I recommend see carefully "Known Issues" on OP. For example "Don't use Merged RCS for rotation, the game doesn't allow it." line.

Actually, from personal experience, I strongly would not recommend to include in the welded part more than one part containing specific modules.

For example, welding together several engines, RCS, animated (ladders, expandable antennas) or light producing (illuminators) parts would/must lead problems

Edited by girka2k

Share this post


Link to post
Share on other sites

Returning to the subject of growing parts in VAB (post, post)

It turns out that this bug was introduced in KSP 0.23 (link) and there is working solution for it.

By the way, I would strongly recommend to read this for those who haven't read it before - it was very useful for me.

Share this post


Link to post
Share on other sites
Apparently trying to weld up 14 Antimatter collectors from the KSP Interstellar Mod destroyed my science program and made everything un-researched... and nothing able to be researched. Of course, this is using the TechManager to work the tech tree with KSPI since TreeLoader is not supported for 0.25.

Sucks, I really want to reduce part count on my Antimatter Farm Station.

Interesting bug.

~Steve

EDIT:

Apparently I have to Alt-F4 after I went something... it saves the weld.

EDIT2:

So I gave it the college try again... and it still doesn't work. 14x AM Collecters still only collect AM as if they were one. Oh well. And here I thought I'd be able to reduce my AM Farm Station from 190 parts down to 72.

Do you use the latest unofficial version that was released by Girka2k?

I changed the merging of modules so that such a case should be covered. As Interstellar fan I know this pain. Do you use light or full Interstellar?

Share this post


Link to post
Share on other sites
I changed the merging of modules so that such a case should be covered. As Interstellar fan I know this pain. Do you use light or full Interstellar?

I didn't take this into account.

In any case, many of the modules (for example, stock ModuleAnimateGeneric, ModuleLandingLeg, ModuleRCS, ModuleLight, ModuleDeployableSolarPanel and non-stock ModuleDockingNodeController, ModuleDockingNodeNamed) will not work correctly, if the welded part contains several of the same models (i.e. four landing legs welded in one part will not work anyway).

Some don't have this problem - for example, it's ModuleDockingNode which works fine while there are preserved attach nodes associated with the docking ports

Edited by girka2k

Share this post


Link to post
Share on other sites
I didn't take this into account.

In any case, many of the modules (for example, stock ModuleAnimateGeneric, ModuleLandingLeg, ModuleRCS, ModuleLight, ModuleDeployableSolarPanel and non-stock ModuleDockingNodeController, ModuleDockingNodeNamed) will not work correctly, if the welded part contains several of the same models (i.e. four landing legs welded in one part will not work anyway).

Some don't have this problem - for example, it's ModuleDockingNode which works fine while there are preserved attach nodes associated with the docking ports

Animated Modules will always run into problems, as they reference certain transforms or meshes.

ModuleRCS as example works in half, the translation is ok but rotation is broken with welded parts.

My ModuleMerger should no matter which module still merge all the values. I don't know the Interstellar Modules inside out, but the antimatter collector might be have its own value for generating particles or it has some kind of modifier, otherwise it is filled and controlled by Interstellar code itself. I will have to look at the part when I'm home.

The easiest way to avoid problems would be to add the modules, we know of that they are broken in welded parts, to the Ignorelist.

Share this post


Link to post
Share on other sites
The easiest way to avoid problems would be to add the modules, we know of that they are broken in welded parts, to the Ignorelist.

I guess it would be better to improve the mechanism for alerts. Now for some of these modules provides alerts about possible problems, but they are written in debug log only. The user does not see them, unfortunately.

EDIT: just created an issue

Edited by girka2k

Share this post


Link to post
Share on other sites
I guess it would be better to improve the mechanism for alerts. Now for some of these modules provides alerts about possible problems, but they are written in debug log only. The user does not see them, unfortunately.

EDIT: just created an issue

Yeah Ok, that should also be not too difficult to do.

Share this post


Link to post
Share on other sites
Do you use the latest unofficial version that was released by Girka2k?

I changed the merging of modules so that such a case should be covered. As Interstellar fan I know this pain. Do you use light or full Interstellar?

I was trying the latest unofficial release of the Welder

I am using the latest official release of KSPI

I am using TechManager with KSPI since TreeLoader is not supported for 0.25. This means that my tech tree crashes whenever I weld a part... but it saves the part when I alt-f4 and restart the game. I don't mind having to force quit twice to reduce a station by 120 parts.

I honestly don't know what I need to do to make my 14 stack of Antimatter collectors work like a stack of 14. It was only working as a singular AM collector. I also had my core of 15x 3.75m AM cans working just fine. The ONLY problem (which I am more than willing to accept) is that as soon as it gets any AM at all you have to instantly pay full MJ resource as if all 15 AM cans had a little AM in them. Goes from 3MJ to 6MJ. Hardly an issue and nothing worth even mentioning.. so why the hell did I?

If you are able to tell me how to edit the 14x AM collect stack part to be recognized as 14... I'd love you forever. It's a very simple part.


PART
{
name = 14x-AM-Collector
module = Part
author = UbioZurWeldingLtd
rescaleFactor = 1
PhysicsSignificance = -1
node_stack_topAntimatterCollector0 = 0,12.09254,1E-05,0,1,0,2
node_stack_bottomAntimatterCollector13 = 0,-12.10698,0,0,1,0,2
node_attach = 0,0,0,0,0,0,0
CrewCapacity = 0
TechRequired = interstellarTechAccelerator
entryCost = 280000
cost = 140
category = Utility
subcategory = 0
title = 14x AM Collector
manufacturer = UbioZur Welding Ltd
description = Warranty void during re-entry.
attachRules = 1,1,1,1,0,0,0
mass = 56
dragModelType = default
maximum_drag = 0.19999
minimum_drag = 0.19999
angularDrag = 1.99988
crashTolerance = 7
breakingForce = 200
breakingTorque = 200
maxTemp = 3000
fuelCrossFeed = True
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,11.23542,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,9.5069,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,7.77837,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,6.04986,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,4.32133,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,2.59283,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,0.86426,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-0.86426,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-2.59278,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-4.32129,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-6.04983,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-7.77834,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-9.50688,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-11.23558,0
scale = 2,2,2
rotation = 0,1,0
}
MODULE
{
name = AntimatterCollector
}
}

~Steve

EDIT:

Wait a sec... do I just add

MODULE

{

name = AntimatterCollector

}

13 more times?

Edited by NeoAcario

Share this post


Link to post
Share on other sites
I was trying the latest unofficial release of the Welder

I am using the latest official release of KSPI

I am using TechManager with KSPI since TreeLoader is not supported for 0.25. This means that my tech tree crashes whenever I weld a part... but it saves the part when I alt-f4 and restart the game. I don't mind having to force quit twice to reduce a station by 120 parts.

I honestly don't know what I need to do to make my 14 stack of Antimatter collectors work like a stack of 14. It was only working as a singular AM collector. I also had my core of 15x 3.75m AM cans working just fine. The ONLY problem (which I am more than willing to accept) is that as soon as it gets any AM at all you have to instantly pay full MJ resource as if all 15 AM cans had a little AM in them. Goes from 3MJ to 6MJ. Hardly an issue and nothing worth even mentioning.. so why the hell did I?

If you are able to tell me how to edit the 14x AM collect stack part to be recognized as 14... I'd love you forever. It's a very simple part.


PART
{
name = 14x-AM-Collector
module = Part
author = UbioZurWeldingLtd
rescaleFactor = 1
PhysicsSignificance = -1
node_stack_topAntimatterCollector0 = 0,12.09254,1E-05,0,1,0,2
node_stack_bottomAntimatterCollector13 = 0,-12.10698,0,0,1,0,2
node_attach = 0,0,0,0,0,0,0
CrewCapacity = 0
TechRequired = interstellarTechAccelerator
entryCost = 280000
cost = 140
category = Utility
subcategory = 0
title = 14x AM Collector
manufacturer = UbioZur Welding Ltd
description = Warranty void during re-entry.
attachRules = 1,1,1,1,0,0,0
mass = 56
dragModelType = default
maximum_drag = 0.19999
minimum_drag = 0.19999
angularDrag = 1.99988
crashTolerance = 7
breakingForce = 200
breakingTorque = 200
maxTemp = 3000
fuelCrossFeed = True
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,11.23542,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,9.5069,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,7.77837,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,6.04986,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,4.32133,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,2.59283,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,0.86426,1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-0.86426,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-2.59278,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-4.32129,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-6.04983,-1E-05
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-7.77834,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-9.50688,0
scale = 2,2,2
rotation = 0,1,0
}
MODEL
{
model = WarpPlugin/Parts/Electrical/AntimatterCollector/model
position = 0,-11.23558,0
scale = 2,2,2
rotation = 0,1,0
}
MODULE
{
name = AntimatterCollector
}
}

~Steve

EDIT:

Wait a sec... do I just add

MODULE

{

name = AntimatterCollector

}

13 more times?

Thanks for all the info that is really helpful.

If you add the Module 13 times, that would make the game think there would be 14 am collectors and make the context menu unusable large. try at own risk.

Unfortunately as the module has only the name it will be completely controlled and filled from the Interstellar DLL. You could ask Fractal_UK for more input, but welding the collectors wouldn't help you at all it will always be getting the input as it would be a single collector.

But you can still weld the rest of your station to reduce the part count.

Share this post


Link to post
Share on other sites
Thanks for all the info that is really helpful.

If you add the Module 13 times, that would make the game think there would be 14 am collectors and make the context menu unusable large. try at own risk.

Unfortunately as the module has only the name it will be completely controlled and filled from the Interstellar DLL. You could ask Fractal_UK for more input, but welding the collectors wouldn't help you at all it will always be getting the input as it would be a single collector.

But you can still weld the rest of your station to reduce the part count.

The station is only a mountain of AM collectors, a 15 stack of cans... struts.. and docking ports. No need to even have the welder mod installed if it can't reduce my AM collector count from 112 to 8. Yes, I use 8 stacks of 14 AM collectors in my Jool station. So, I'd rather have one less mod installed if I can't get it to work with the only part I use multiple of on a single vessel.

~Steve

EDIT:

Wait.. you DID just say adding the module 13 more times would work? The AM Collectors' context menu only lists it's collection rate of AM. There's no need to even LOOK at the AM collector context menu... I know I never do. Just watch the resource tab for the ship as a whole.

Maybe I'll give it another try with the part edit.

Edited by NeoAcario

Share this post


Link to post
Share on other sites
The station is only a mountain of AM collectors, a 15 stack of cans... struts.. and docking ports. No need to even have the welder mod installed if it can't reduce my AM collector count from 112 to 8. Yes, I use 8 stacks of 14 AM collectors in my Jool station. So, I'd rather have one less mod installed if I can't get it to work with the only part I use multiple of on a single vessel.

~Steve

EDIT:

Wait.. you DID just say adding the module 13 more times would work? The AM Collectors' context menu only lists it's collection rate of AM. There's no need to even LOOK at the AM collector context menu... I know I never do. Just watch the resource tab for the ship as a whole.

Maybe I'll give it another try with the part edit.

It might work, but there is no guarantee.

Share this post


Link to post
Share on other sites
It might work, but there is no guarantee.

Works perfectly... and the context menu isn't even that bad.

screenshot13.png

Obviously, if it were an interactive part, you wouldn't want to do this. With AM collectors? I see no problem at all. As I said, I normally never even click on them for context... I just use the main resource window for the vessel.

Verdict? Welder is staying and I think I'll try and make an even more ridiculous AM harvester. I would use it for other applications, but people have issues with multiple resources in a single welded part. KSPI is notorious for several resources per part.

~Steve

Share this post


Link to post
Share on other sites
... but people have issues with multiple resources in a single welded part. KSPI is notorious for several resources per part.

If you about this problem:

...in VAB ... they start to grow when i mouseover them till they fill up the whole screen...

then I have good news for you.

I had not heard about any other problems with multiple resources...

@Alewx: It seems that there is replenishment for moduleAttributeList.xml?

Edited by girka2k

Share this post


Link to post
Share on other sites
If you about this problem:

then I have good news for you.

I had not heard about any other problems with multiple resources...

@Alewx: It seems that there is replenishment for moduleAttributeList.xml?

@Girka2k: Yep, indeed it looks like it, but the current one was just some basics I threw in there, to make it work and provide examples for everything.

A new list for modules that should be added multiple times, or what do you think?

I would prefer that it would contain somekind of multiplier that could be merged by the weldingtool, but Fractal might not be happy about such a suggestion.

@NeoAcario: I can also not report any problems with x(number you like but bigger 3) resources in welded parts, my biggest one hat 8 resources in one part.

Edited by Alewx
typo

Share this post


Link to post
Share on other sites

the only problems I have found is:

  • Using this when you have tweakscale installed, the welding plugin seems to disable tweakscale when it rebuilds the catalog so if you go from one save to another or try to load up a ship with tweakscaled parts it will either make existing ships unload (in event of changing game saves) or tell you that the ship contains invalid parts (in event of trying to load crafts with tweakscaled parts in the VAB/SPH).
  • I don't dare weld parts that have been tweakscalled but i gather it would be bad.
  • Welding Universal Storage parts results in problems:- loss of fuctionallity(alkaline fuel cell/Electrolizer), not being connected to connection nodes on launch(Octocore module).
  • Landing legs:- when welding landing legs in symmetry, new part only opens the root of the symmetry rather than all parts.

*note*

I am using the forum version of the welding mod, ksp 0.25 and mod list can be found on my stream channel page.

Share this post


Link to post
Share on other sites
Welding Universal Storage parts results in problems:- loss of fuctionallity(alkaline fuel cell/Electrolizer), not being connected to connection nodes on launch(Octocore module).

This happens with many mods that add complex functionality and use plugins for this. Just do it by trial and error.

Landing legs:- when welding landing legs in symmetry, new part only opens the root of the symmetry rather than all parts.

Actually, from personal experience, I strongly would not recommend to include in the welded part more than one part containing specific modules.

For example, welding together several engines, RCS, animated (ladders, expandable antennas) or light producing (illuminators) parts would/must lead problems

...and unfortunately, landing legs are included in this list.

EDIT:

Using this when you have tweakscale installed, the welding plugin seems to disable tweakscale when it rebuilds the catalog so if you go from one save to another or try to load up a ship with tweakscaled parts it will either make existing ships unload (in event of changing game saves) or tell you that the ship contains invalid parts (in event of trying to load crafts with tweakscaled parts in the VAB/SPH).

And yes, integrated reloading of database is incompatible with a lot of mods. Unfortunately, significant improvements here are not expected. You will have to restart the game after welding.

I don't dare weld parts that have been tweakscalled but i gather it would be bad.

Support of TweakScale was announced in the latest versions!

Edited by girka2k

Share this post


Link to post
Share on other sites

Also, has anybody tried welding procedural parts together? Will that work, or does Kerbin explode or something?

I tried that, every part reverts to it's original texture, angle and form.

Until Procedural Parts has support, I don't have a single use for it.

Share this post


Link to post
Share on other sites

Can some wane help mi. I have welded part and its fast overheating:


PART
{
name = Part-1
module = Part
author = UbioZurWeldingLtd
rescaleFactor = 1
PhysicsSignificance = -1
node_stack_topfuelTankSmall0 = 0,2.005974,0,0,0.125,0,1
node_attach = 0.62625,0,0,0.125,0,0,1
sound_rocket_hard = running
sound_explosion_low = flameout
sound_vent_medium = engage
sound_vent_soft = disengage
fx_exhaustSparks_flameout = 0, -2.433444, 0, 0, 1, 0, flameout
sound_explosion_low = thruster_flameout
sound_vent_medium = thruster_engage
sound_vent_soft = thruster_disengage
fx_exhaustFlame_blue = 0, -2.433444, 0, 0, 1, 0, running
fx_smokeTrail_light = 0, -2.433444, 0, 0, 1, 0, running
sound_rocket_hard = thruster_running
fx_exhaustSparks_flameout = 0, -2.433444, 0, 0, 1, 0, flameout
fx_exhaustFlame_blue = 0, -2.433444, 0, 0, 1, 0, running
fx_smokeTrail_light = 0, -2.433444, 0, 0, 1, 0, running
CrewCapacity = 0
TechRequired = start
entryCost = 43600
cost = 5125
category = Propulsion
subcategory = 0
title = My welded part
manufacturer = UbioZur Welding Ltd
description = Warranty void during re-entry.
attachRules = 1,1,1,1,0,0,0
mass = 1.875
dragModelType = default
maximum_drag = 0.175
minimum_drag = 0.2125
angularDrag = 1.75
crashTolerance = 17.2
breakingForce = 27.6
breakingTorque = 27.6
maxTemp = 1106.667
fuelCrossFeed = True
MODEL
{
model = Squad/Parts/FuelTank/fuelTankT200/model
position = 0,1.450724,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
MODEL
{
model = Squad/Parts/FuelTank/fuelTankT400/model
position = 0,-0.07021558,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
MODEL
{
model = Squad/Parts/Engine/liquidEngineAerospike/model
position = 0,-0.9827198,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
RESOURCE
{
name = LiquidFuel
amount = 270
maxAmount = 270
}
RESOURCE
{
name = Oxidizer
amount = 330
maxAmount = 330
}
MODULE
{
name = ModuleEngines
thrustVectorTransformName = thrustTransform
exhaustDamage = True
ignitionThreshold = 0.1
minThrust = 0
maxThrust = 175
heatProduction = 550
fxOffset = 0, 0, 0.25
PROPELLANT
{
name = LiquidFuel
ratio = 0.9
DrawGauge = True
}
PROPELLANT
{
name = Oxidizer
ratio = 1.1
}
atmosphereCurve
{
key = 0 390
key = 1 388
}
}
MODULE
{
name = ModuleAnimateHeat
}
MODULE
{
name = ModuleAlternator
RESOURCE
{
name = ElectricCharge
rate = 5.0
}
}
MODULE
{
name = ModuleTestSubject
environments = 15
useStaging = True
useEvent = True
}
}

Share this post


Link to post
Share on other sites
Can some wane help mi. I have welded part and its fast overheating:


PART
{
name = Part-1
module = Part
author = UbioZurWeldingLtd
rescaleFactor = 1
PhysicsSignificance = -1
node_stack_topfuelTankSmall0 = 0,2.005974,0,0,0.125,0,1
node_attach = 0.62625,0,0,0.125,0,0,1
sound_rocket_hard = running
sound_explosion_low = flameout
sound_vent_medium = engage
sound_vent_soft = disengage
fx_exhaustSparks_flameout = 0, -2.433444, 0, 0, 1, 0, flameout
sound_explosion_low = thruster_flameout
sound_vent_medium = thruster_engage
sound_vent_soft = thruster_disengage
fx_exhaustFlame_blue = 0, -2.433444, 0, 0, 1, 0, running
fx_smokeTrail_light = 0, -2.433444, 0, 0, 1, 0, running
sound_rocket_hard = thruster_running
fx_exhaustSparks_flameout = 0, -2.433444, 0, 0, 1, 0, flameout
fx_exhaustFlame_blue = 0, -2.433444, 0, 0, 1, 0, running
fx_smokeTrail_light = 0, -2.433444, 0, 0, 1, 0, running
CrewCapacity = 0
TechRequired = start
entryCost = 43600
cost = 5125
category = Propulsion
subcategory = 0
title = My welded part
manufacturer = UbioZur Welding Ltd
description = Warranty void during re-entry.
attachRules = 1,1,1,1,0,0,0
mass = 1.875
dragModelType = default
maximum_drag = 0.175
minimum_drag = 0.2125
angularDrag = 1.75
crashTolerance = 17.2
breakingForce = 27.6
breakingTorque = 27.6
maxTemp = 1106.667
fuelCrossFeed = True
MODEL
{
model = Squad/Parts/FuelTank/fuelTankT200/model
position = 0,1.450724,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
MODEL
{
model = Squad/Parts/FuelTank/fuelTankT400/model
position = 0,-0.07021558,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
MODEL
{
model = Squad/Parts/Engine/liquidEngineAerospike/model
position = 0,-0.9827198,0
scale = 1.25,1.25,1.25
rotation = 0,0,0
}
RESOURCE
{
name = LiquidFuel
amount = 270
maxAmount = 270
}
RESOURCE
{
name = Oxidizer
amount = 330
maxAmount = 330
}
MODULE
{
name = ModuleEngines
thrustVectorTransformName = thrustTransform
exhaustDamage = True
ignitionThreshold = 0.1
minThrust = 0
maxThrust = 175
heatProduction = 550
fxOffset = 0, 0, 0.25
PROPELLANT
{
name = LiquidFuel
ratio = 0.9
DrawGauge = True
}
PROPELLANT
{
name = Oxidizer
ratio = 1.1
}
atmosphereCurve
{
key = 0 390
key = 1 388
}
}
MODULE
{
name = ModuleAnimateHeat
}
MODULE
{
name = ModuleAlternator
RESOURCE
{
name = ElectricCharge
rate = 5.0
}
}
MODULE
{
name = ModuleTestSubject
environments = 15
useStaging = True
useEvent = True
}
}

Welding engines is always a bad idea!

That feature is so broken I don't even know where it produces all the broken stuff and adds the same attributes multiple times.

    maxTemp = 1106.667

Is a little bit low for an engine if you ask me.

Share this post


Link to post
Share on other sites

May I recommend a new thread for your version, referenced from here to there and with this one essentially getting killed? I have fans who are being introduced to welding on my YT channel but when they come looking for it they don't realize the top post is not the correct DL link. A new thread that you could maintain and keep up to date with proper links would help new fans of welding a lot. :)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this